New Build - 05/24/2024 - r56490

Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 5775

PostPosted: Fri May 24, 2024 15:05    Post subject: New Build - 05/24/2024 - r56490 Reply with quote
Welcome to Marvell r56490 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
List router model & version or revision, operating & wireless modes & exact filename/firmware image flashed.


CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp) 'write {file} linux' then 'reboot'.

Downloads: HTTPS, FTP

Trac SVN: repository since last build 56478 (mirror)

OpenVPN 2.6.10: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips, scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Adv, PBR, KS, tips, scripts. Thanks BS egc & eibgrad!

Notes:
... r55799 r55819 r56029 r56119 r56182 r56237 r56326 r56359 r56380 r56409 r56472 r56478 r56490

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs, logs: syslog klog 'dmesg' 'cat /tmp/var/log/messages' nvram set console_debug=1, serial.
• Firewall NAT: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' & 'cat /tmp/.ipt'. Debug Analyze: strace tcpdump.
• Gremlins: reboot. cold boot. Reset & reconfigure not restore backup. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, SB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 462

PostPosted: Fri May 24, 2024 22:54    Post subject: Reply with quote
Router/Version: Linksys WRT1200ac v1
File/Kernel: r56490 Linux 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l
Previous/Reset: r56478 No reset
Mode/Status: Gateway,VPN,Stable
Issues/Errors: None
Lemonhard
DD-WRT Novice


Joined: 16 Feb 2023
Posts: 1

PostPosted: Sat May 25, 2024 7:29    Post subject: Reply with quote
Router/Version: Linksys WRT1900acs v2
File/Kernel: r56490 Linux wrt1900acs 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l DD-WRT
Previous/Reset: r51679 No reset
Mode/Status: Seems ok with that old nvram conf - All services ok so far
Issues/Errors: NONE (keep testing)

❤ Thanks @blkt
TedCheeze
DD-WRT User


Joined: 01 Feb 2016
Posts: 56
Location: Oregon, U.S.

PostPosted: Sat May 25, 2024 9:43    Post subject: Reply with quote
Router/Version: Linksys WRT1900AC v1
File: DD-WRT v3.0-r56490 std (05/24/24) / ddwrt-linksys-wrt1900ac-webflash.bin
Kernel: Linux 6.1.91-rt28 #219 SMP Fri May 24 06:20:00 +07 2024 armv7l
Previous/Reset: R53633 - No Reset
Mode/Status: Gateway device, NO SFE, four SSIDs(2 Private, 2 unbridged Guests), 4TB HDD connected via eSATA for NAS using FTP & Samba, OpenVPN Server, DNSCrypt, & EntWare
Issues/Errors: Both USB1 & USB2 are non-functional, however eSATA functions as expected.


Other than no USB support after R53633 I am having no issues. SAMBA is working normally.
FYI - Both USB ports function normally using OEM firmware and versions prior to r53662.
saphirely
DD-WRT User


Joined: 13 Dec 2020
Posts: 280

PostPosted: Sat May 25, 2024 14:17    Post subject: Reply with quote
Linksys WRT1900ACS
DD-WRT v3.0-r56490 std (05/24/24)
Linux 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l

Works stable for me.

There is a bug that Disable on "Web UI Access" for wlan1 [2.4 GHz] - MWL88W8864 not works.
ewo32
DD-WRT Novice


Joined: 11 Nov 2023
Posts: 47

PostPosted: Sun May 26, 2024 12:10    Post subject: Reply with quote
Router: Linksys WRT32X
Firmware: DD-WRT v3.0-r56490 std (05/24/24)
File: ddwrt-linksys-wrt32x-webflash.bin
Kernel: Linux 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l
Previous/Reset: DD-WRT v3.0-r56478 std (05/23/24) / No
Mode/Status: Gateway (PPPOE, ignore WAN DNS, non-default router IP, SFE disabled), WAN to ONT, AP, wlan0 5GHz AC-only VHT80 WPA2-Personal-CCMP, wlan1 2.4Ghz N-only HT40 WPA2-Personal-CCMP, wlan2 disabled, DDNS (SSL), encrypt DNS (DNSSEC, check unsigned DNS replies), virtual interface wlan1.1 (2.4GHz, unbridged, AP isolation, net isolation, DHCPD, web UI disabled), ssh (non-default port, public key, password login disabled), telnet disabled, wireguard server (non-default port, preshared key) / Stable (uptime 24hrs)
Issues/Errors: None.
NetAlien
DD-WRT Novice


Joined: 18 Mar 2013
Posts: 22
Location: Sanford, NC

PostPosted: Tue May 28, 2024 14:51    Post subject: r56490 issues -- FYI: will not continue with this version Reply with quote
Having been previously told to report here first; doing so.
No need to reply as I will be backing out this version.

Issues after about 30 hours:
After upgrade to r56490, initial boot did not start WiFi; required reboot. No reproducing possible without reverting and re-installing.

WiFi occasionally drops connected clients -- wrote script for clients that monitors for disconnect and restarts connection asap.

This morning at 09:18 DNS got royally hosed:
- would not resolve any address
- worse, it interfered with responses from remote DNS servers
- using: "dig @<IP> domain.tld" from Linux client, all responses were stripped of ANSWER; like this:

$ dig @174.128.246.100 pfortin.com (also tried 1.1.1.1, 8.8.8.8, 9.9.9.9 -- identical responses)

; <<>> DiG 9.18.24 <<>> @174.128.246.100 xxxxxx.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 26003
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; EDE: 14 (Not Ready)
;; QUESTION SECTION:
;xxxxxx.com. IN A

;; Query time: 0 msec
;; SERVER: 174.128.246.100#53(174.128.246.100) (UDP)
;; WHEN: Tue May 28 09:51:04 EDT 2024
;; MSG SIZE rcvd: 46

Power cycle reboot resolved for now; will revert to previously installed r53469 asap.

Not looking for a response; simply reporting and dropping this version.
Zyxx
DD-WRT Guru


Joined: 28 Dec 2018
Posts: 754

PostPosted: Wed May 29, 2024 7:25    Post subject: Reply with quote
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r56490 std (05/24/24)
Kernel: Linux 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l
Mode: Gateway, SFE disabled, QoS in use, Wifi disabled, Wireguard for external access, WAN to Fiber Modem, samba to access USB3-ext4 SSD, Keep Alive reboot 5:00 in the morning, using my own local NTP
Reset: No
Status: Installed at release, had one random reboot yesterday.
The very moment I opened Steam the device rebooted. Unfortunately no Logs. Now everything wired and log is running, trying to provoke it again.
PavelVD
DD-WRT User


Joined: 26 Jul 2019
Posts: 115

PostPosted: Fri May 31, 2024 4:16    Post subject: Reply with quote
Router: Linksys WRT1900ACSv2
Firmware: DD-WRT v3.0-r56490 std (05/24/24).
Kernel: Linux 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l
Reset: Yes.
Mode/Status: Ignore WAN DNS; SFE Enable; Use dnsmasq for DNS; DHCP-Authoritative; SmartDNS Resolve.
Wi-Fi: wlan0 - AP,AC/N-Mix,VHT80; wlan1 - AP,N-Only,HT40. Support 802.11r,v,k Band-Steering.
USB Storage Support: --- /dev/sda - Block device, size 931.5 GiB,Ext4; --- /dev/sdb - Block device, size 223.6 GiB, Ext4; --- /dev/sdb - Block device, size 931.5 GiB, Ext4.
NAS: Samba Protocol 2.10\3.11; NFS Server - Enable;
Issues/Errors:
I observed strange behavior of the SMB client (Win10): on a network drive in the Z:/Temp folder (conditional name) there is a Thumbnails folder, in which there are about 15 subfolders, and in total they contain about 100,000 small files. When entering Z:/Temp, the Thumbnails folder suddenly disappears after about 1-2 seconds. You go to Temp - it’s there, a second later it’s gone! After 3-5 minutes of inactivity, Thumbnails stops disappearing, and you can make manipulations: copy, move, etc.
Now a little about something else: I always thought that the Services-->NAS-->Share Configuration section is intended only for organizing access via SMB. I needed a separate SSD for the NFS clients, and I expected to provide access through the Network File System Server (NFS) section (Fig2.png). I had to spend some time trying to do this without success! - The resource was always unavailable. The failures ended after adding the disk to the SMB section (Fig1.png). This looked strange to me.
(Perhaps this should have been posted in the Advanced Networking section?)

_________________
Linksys WRT1900ACSv2
Automatically adjustable temperature, always within the range of 48-53°С.
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 828
Location: Pittsburgh, PA USA

PostPosted: Fri May 31, 2024 10:04    Post subject: Reply with quote
TedCheeze wrote:
Other than no USB support after R53633 I am having no issues. SAMBA is working normally.
FYI - Both USB ports function normally using OEM firmware and versions prior to r53662.

I found that USB 3.0 devices don't work, but USB 2.0 devices seem to be fine in the USB1 port. If you have an old USB 2.0 hub, you could try putting that between the device and the router. Obviously, that will slow the access, but at least it should work.

USB2 port seems to be non-functional as well.

_________________
__________________________
Netgear R7800
DD-WRT v3.0 STD
Linksys WRT1900AC
DD-WRT v3.0 STD
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 828
Location: Pittsburgh, PA USA

PostPosted: Fri May 31, 2024 10:07    Post subject: Reply with quote
Router/Version: Linksys WRT1900AC v1 x 3
File/Kernel: DD-WRT v3.0-r56490 std (05/24/24)
Previous/Reset: DD-WRT v3.0-r56478 std (05/23/24), last reset at r56182
Mode/Status: Gateway (SFE enabled), Access Point (2.4GHz, 5GHZ, WPA2/WPA3, 802.11r/v/k), IPV6 (DHCP6 w/ prefix delegation), Entware, DOT via SmartDNS/DNSMasq, OpenVPN server, Wireguard Server + 2 wired access points (2.4GHz, 5GHZ, WPA2/WPA3, 802.11r/v/k)

Up 8 hours. USB 2.0 working properly on USB1 for Entware and "jffs" partitions, USB 3.0 not functional, nor is the USB2 port. Wireguard and OpenVPN servers working as expected and throughput sufficient to open video files on network shares. Speed (tested via nPerf.com) is very close to published, both wired and wireless, which is equal or favorable to the ISP router.

Thank you Brainslayer.

_________________
__________________________
Netgear R7800
DD-WRT v3.0 STD
Linksys WRT1900AC
DD-WRT v3.0 STD
Zyxx
DD-WRT Guru


Joined: 28 Dec 2018
Posts: 754

PostPosted: Fri May 31, 2024 10:56    Post subject: Reply with quote
Another random reboot.

Unfortunately no log -.- (again).
Was reading a newssite. Had quite a few tabs opened + twitch running.

Just the usual load, as every day.
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 828
Location: Pittsburgh, PA USA

PostPosted: Fri May 31, 2024 13:00    Post subject: Reply with quote
Same here. I went as long as 60 hours and as short as 30 minutes. No unusual load. Does not seem to affect my wired access points, only the gateway. SFE is off. I'd love to get a serial log but considering the randomness, I don't have a spare workstation to dedicate to log collection.
_________________
__________________________
Netgear R7800
DD-WRT v3.0 STD
Linksys WRT1900AC
DD-WRT v3.0 STD
mikesal57
DD-WRT User


Joined: 27 Aug 2007
Posts: 237

PostPosted: Sun Jun 02, 2024 18:00    Post subject: Reply with quote
Did testing and new builds stop?

Been waiting in the wings to see something with no issues

WRT3200ACM here
greenphantom61
DD-WRT Novice


Joined: 29 Mar 2011
Posts: 6

PostPosted: Tue Jun 04, 2024 20:06    Post subject: Reply with quote
Router/Version: Linksys WRT3200ACM
File/Kernel: r56490/Linux 6.1.91-rt28 #469 SMP Fri May 24 06:00:09 +07 2024 armv7l
Previous/Reset: r56029 No reset
Mode/Status: Gateway,No VPN, Stable
Issues/Errors: None

Thank you!
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum