[SPLIT] Edgerouter Lite and DDWRT

Post new topic   Reply to topic    DD-WRT Forum Index -> Ubiquiti Devices
Author Message
neftv
DD-WRT Novice


Joined: 29 Nov 2009
Posts: 22

PostPosted: Sat Jun 29, 2019 23:34    Post subject: [SPLIT] Edgerouter Lite and DDWRT Reply with quote
I flashed the latest image on a different Flash Drive and inserted in the router. It booted up fine but what do I need to get the activation code? It seems the login to these forums wont work at the Activation center from the top right corner of this page I am on now too.

Mod note 03.27.24: Split from original device support thread:

Any DD-WRT Interest in ubiquiti Edgerouter Lite ?
Sponsor
neftv
DD-WRT Novice


Joined: 29 Nov 2009
Posts: 22

PostPosted: Sun Jun 30, 2019 22:22    Post subject: Re: Edgerouter Lite and DDWRT Reply with quote
neftv wrote:
I flashed the latest image on a different Flash Drive and inserted in the router. It booted up fine but what do I need to get the activation code? It seems the login to these forums wont work at the Activation center from the top right corner of this page I am on now too.


Just wanted to add when DDWRT loads up and I go to 192.68.1.1 in IE I get a beautiful login prompt to change the login/password to the router. SO I do that then the screen goes away and nothing. I even step away for 10 min and still browser is spinning. I do a reset on the Edgerouter lite I get the prompt for log in change and instead of doing that I go to services to try to customize DHCP and WAN. Services tab will not come up on the screen I just get the spinning in the tab I am on waiting on the router. I guess it not meant for the general public this firmware. The log in page is pretty though, so what comes next?
I did not overwrite the original USB I used a new USB I made fit with out cheap plastic casing,
cdzo72
DD-WRT Novice


Joined: 16 Dec 2013
Posts: 14
Location: Heredia, Costa Rica

PostPosted: Mon Mar 04, 2024 22:37    Post subject: Reply with quote
Is the Edge Router Lite 3 still being supported by DD-WRT? I can't seem to find the image file.
dale_gribble39
DD-WRT Guru


Joined: 11 Jun 2022
Posts: 1921

PostPosted: Tue Mar 05, 2024 0:45    Post subject: Reply with quote
Current release as of this post:

https://ftp.dd-wrt.com/dd-wrtv2/downloads/betas/2024/03-03-2024-r55262/ubnt-edgerouter-lite/

_________________
"The woods are lovely, dark and deep,
But I have promises to keep,
And miles to go before I sleep,
And miles to go before I sleep." - Robert Frost

"I am one of the noticeable ones - notice me" - Dale Frances McKenzie Bozzio

<fact>code knows no gender</fact>

This is me, knowing I've ruffled your feathers, and not giving a ****
Some people are still hard-headed.

--------------------------------------
Mac Pro (Mid 2012) - Two 2.4GHz 6-Core Intel Xeon E5645 processors 64GB 1333MHz DDR3 ECC SDRAM OpenSUSE Leap 15.5
leo_bsb
DD-WRT Novice


Joined: 10 Jul 2014
Posts: 17

PostPosted: Tue Mar 12, 2024 0:00    Post subject: Reply with quote
the last version bricked my edgerouter lite.
I tried to DD write the image using rufus and still does not work. I think there is maybe a problem with the configuration and different features on the new version. On console the boot hangs reading the usb drive. I tried a new usb drive and wrote the image again, same error.

Any suggestions? Should I recover to stock and than try DD-WRT again?
lexridge
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1046
Location: WV, USA

PostPosted: Wed Mar 27, 2024 22:18    Post subject: Reply with quote
leo_bsb wrote:
the last version bricked my edgerouter lite.

Have you tried going back a few versions to figure out which build this problems starts with? Also, this really should have been a new thread instead of posting to one created several years ago. It might get more attention.

_________________
Linksys EA8500 (Internet Gateway, AP/VAP) - DD-WRT r53562
Features in use: WDS-AP, Multiple VLANs, Samba, WireGuard, Entware: mqtt, mlocate
Wireless 5ghz only

Netgear R7800 (WDS-AP, WAP, VAP) - DD-WRT r53562
Features in use: multiple VLANs over single trunk port

Linksys EA8500 WDS Station x2 - DD-WRT r55779

Netgear R6400v2 WAP, VAP 2.4ghz only w/VLANs over single trunk port. DD-WRT r55779

OSes: Fedora 38, 9 RPis (2,3,4,5), 20 ESP8266s: Straight from Amiga to Linux in '94, never having owned a Windows PC.

Forum member #248
leo_bsb
DD-WRT Novice


Joined: 10 Jul 2014
Posts: 17

PostPosted: Wed Mar 27, 2024 23:17    Post subject: Reply with quote
lexridge wrote:
leo_bsb wrote:
the last version bricked my edgerouter lite.

Have you tried going back a few versions to figure out which build this problems starts with? Also, this really should have been a new thread instead of posting to one created several years ago. It might get more attention.


Thanks for your reply.

I tried several versions, after dozens of tries the last one that works fine is DD-WRT v3.0-r54248 std (11/29/23), writing the .image straight to the OS USB drive.

The failsafe from a bad flash using the web browser update is also broken. Anything past this version returns a boot loop kernel panic. It used to return to the last working version after a few tries and power cycle.

I tried resetting the config with the same error. First I thought there should be something new added because there is file size increase on version r54637, but I could not update to the versions over r54248 and that one.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 14197
Location: Texas, USA

PostPosted: Thu Mar 28, 2024 2:27    Post subject: Reply with quote
Topic split. Again, serial console logs of broken firmware would help the developer find and solve the problem. Also, your tangent in the other thread has been split out as I had forewarned:

[SPLIT] Edgerouter Lite Issues on latest releases

Pick a thread, or not. At this point, I've done what I can with this mess.
lexridge
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 1046
Location: WV, USA

PostPosted: Thu Mar 28, 2024 3:40    Post subject: Reply with quote
leo_bsb wrote:
The failsafe from a bad flash using the web browser update is also broken. Anything past this version returns a boot loop kernel panic. It used to return to the last working version after a few tries and power cycle.


So the USB drive is set up with dual boot partitions? Interesting if so. I know absolutely NOTHING about these routers. So please take my questions and comments with a grain of salt.

In this case, the similarities between this and EA8500 draw closer (and potentially even the old WRT54GL w/k2.4), even though the kernels are nowhere even close to the same. That could mean a NVRAM issue rather than a kernel issue, which I have posted about suspecting in the EA8500 thread.
Quote:

I tried resetting the config with the same error. First I thought there should be something new added because there is file size increase on version r54637, but I could not update to the versions over r54248 and that one.

Version r54248 is much later than we are able to boot on the EA8500. I use the word "boot" loosely, as it can boot (but only to partition 2) but it takes like 35 minutes and always erases all NVRAM settings. Are you experiencing anything like this?

...and PLEASE learn how to create a serial log!!

_________________
Linksys EA8500 (Internet Gateway, AP/VAP) - DD-WRT r53562
Features in use: WDS-AP, Multiple VLANs, Samba, WireGuard, Entware: mqtt, mlocate
Wireless 5ghz only

Netgear R7800 (WDS-AP, WAP, VAP) - DD-WRT r53562
Features in use: multiple VLANs over single trunk port

Linksys EA8500 WDS Station x2 - DD-WRT r55779

Netgear R6400v2 WAP, VAP 2.4ghz only w/VLANs over single trunk port. DD-WRT r55779

OSes: Fedora 38, 9 RPis (2,3,4,5), 20 ESP8266s: Straight from Amiga to Linux in '94, never having owned a Windows PC.

Forum member #248
leo_bsb
DD-WRT Novice


Joined: 10 Jul 2014
Posts: 17

PostPosted: Fri Mar 29, 2024 20:04    Post subject: Reply with quote
I'll get all logs next week.
I will have to install everything on my desk at night. I'll post the resulta ASAP.

thanks,


lexridge wrote:
leo_bsb wrote:
The failsafe from a bad flash using the web browser update is also broken. Anything past this version returns a boot loop kernel panic. It used to return to the last working version after a few tries and power cycle.


So the USB drive is set up with dual boot partitions? Interesting if so. I know absolutely NOTHING about these routers. So please take my questions and comments with a grain of salt.

In this case, the similarities between this and EA8500 draw closer (and potentially even the old WRT54GL w/k2.4), even though the kernels are nowhere even close to the same. That could mean a NVRAM issue rather than a kernel issue, which I have posted about suspecting in the EA8500 thread.
Quote:

I tried resetting the config with the same error. First I thought there should be something new added because there is file size increase on version r54637, but I could not update to the versions over r54248 and that one.

Version r54248 is much later than we are able to boot on the EA8500. I use the word "boot" loosely, as it can boot (but only to partition 2) but it takes like 35 minutes and always erases all NVRAM settings. Are you experiencing anything like this?

...and PLEASE learn how to create a serial log!!
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Ubiquiti Devices All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum