hostapd did not acknowledge auth response

Post new topic   Reply to topic    DD-WRT Forum Index -> Ralink SoC based Hardware
Author Message
snaky69
DD-WRT Novice


Joined: 08 Jan 2024
Posts: 7

PostPosted: Sun Feb 25, 2024 14:52    Post subject: hostapd did not acknowledge auth response Reply with quote
Good day,

I run DD-WRT on a Netgear R6350. It is used to broadcast an isolated IoT 2.4Ghz network. Everything is nice and stable except 1 thing.

I have one particular client that can remain stable for hours, sometimes days on end, then it starts constantly disconnecting with

Code:
hostapd did not acknowledge auth response


messages, and will only stay connected in legacy mode without acknowledging it authenticated. Power cycling the router sometimes brings it back, power cycling the AC usually works, changing the wireless channel sometimes works as well.

It is a Gree AC, with a known finicky wireless module. Is there anything I can do on the router side to mitigate this?

If there is any part of my configuration someone needs to look at, kindly let me know and I'll post some screenshots.

So far disabling short gi and preamble, and WMM, as well as raising the groupkey interval seem to help for keeping it connected, but once it starts to disconnect there's no rhyme or reason to it.

https://imgur.com/a/7Aav7FJ
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 14577
Location: Texas, USA

PostPosted: Sun Feb 25, 2024 19:46    Post subject: Reply with quote
Connect it to the 2.4 band if it isn't already and under advanced settings disable LDPC (Disable for ESP8266), save and reboot.
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
DD-WRT Releases 2023 (PolitePol)
DD-WRT Releases 2023 (RSS Everything)

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
snaky69
DD-WRT Novice


Joined: 08 Jan 2024
Posts: 7

PostPosted: Sun Feb 25, 2024 20:24    Post subject: Reply with quote
kernel-panic69 wrote:
Connect it to the 2.4 band if it isn't already and under advanced settings disable LDPC (Disable for ESP8266), save and reboot.


The router has no 5ghz network active. LDPC is not visible?
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 14577
Location: Texas, USA

PostPosted: Mon Feb 26, 2024 1:45    Post subject: Reply with quote
Did you click the box for "Advanced Settings"? I don't think that's just for Marvell, but I could be wrong. I would have to pull out my WNDR3700 v5 to verify.
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
DD-WRT Releases 2023 (PolitePol)
DD-WRT Releases 2023 (RSS Everything)

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
snaky69
DD-WRT Novice


Joined: 08 Jan 2024
Posts: 7

PostPosted: Mon Feb 26, 2024 23:49    Post subject: Reply with quote
kernel-panic69 wrote:
Did you click the box for "Advanced Settings"? I don't think that's just for Marvell, but I could be wrong. I would have to pull out my WNDR3700 v5 to verify.


That setting does not exist in advanced setting on my router.

Here is the full error:
eb 26 16:47:17 R6350 daemon.notice hostapd: wlan1.1: STA f4:91:1e:46:67:51 IEEE 802.11: did not acknowledge authentication response
snaky69
DD-WRT Novice


Joined: 08 Jan 2024
Posts: 7

PostPosted: Tue Feb 27, 2024 2:40    Post subject: Reply with quote
kernel-panic69 wrote:
Did you click the box for "Advanced Settings"? I don't think that's just for Marvell, but I could be wrong. I would have to pull out my WNDR3700 v5 to verify.


I did end up finding the LDPC setting in advanced settings under the 5ghz radio. I disabled it but since that radio is OFF I'm not sure that it'll do anything.
snaky69
DD-WRT Novice


Joined: 08 Jan 2024
Posts: 7

PostPosted: Mon Apr 01, 2024 21:37    Post subject: Reply with quote
Still having issues with this, only on this one client.

Is there any way to get the router to wait longer? This is driving me nuts. The connection can be stable for days and then will drop constantly lasting barely minutes.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Ralink SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum