New Build - 02/09/2024 - r55109

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 5620

PostPosted: Fri Feb 09, 2024 6:31    Post subject: New Build - 02/09/2024 - r55109 Reply with quote
Welcome to Broadcom r55109 beta release thread for reporting, feedback to developers & community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
List router model & version or revision, operating & wireless modes & exact filename/firmware image flashed.


CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp) 'write {file} linux' then 'reboot'.

Downloads: HTTPS, FTP

Trac SVN: repository since last build 55052 (mirror)

OpenVPN 2.6.8: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Adv, PBR, KS, tips & scripts. Thanks BS egc & eibgrad!

Notes:
r54203 r54248 r54420 r54475 r54517 r54545 r54569 r54604 r54637 r54652 r54682 r54905 r54914 r55003 r55009 r55033
r55052 r55109

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs, logs: syslog klog 'dmesg' 'cat /tmp/var/log/messages' nvram set console_debug=1, serial.
• Firewall NAT: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' & 'cat /tmp/.ipt'. Debug Analyze: strace tcpdump.
• Gremlins: reboot. cold boot. Reset & reconfigure not restore backup. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, SB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
KACTET
DD-WRT User


Joined: 01 May 2022
Posts: 217

PostPosted: Fri Feb 09, 2024 10:13    Post subject: Reply with quote
Router/Version: Asus RT-AC87U R
Update method: WebUpgrade
File/Kernel: asus_rt-ac87u-firmware.trx_r55109 std / Linux 4.4.302-st48 #10993 SMP Fri Feb 9 04:29:17 +06 2024 armv7l
Previous/Reset: r55052 / no
Mode/Status: Gateway / Up and running for 2:05 hours
CPU Temperature: CPU 63.6 °C / WL0 40.5 °C / WL1 0.0 °C (ambient temperature 17.0 °C)
Issues/Errors: Nothing significant

As always, the Quantenna chip has its own quirks. This is a closed source chipset
There is no way to install a channel. Crying or Very sad
But you can disable 5.0 GHz. @mpgalaxy hack "If you set the radio mode to station bridge and disable the network mode, the 5GHz device will turn off completely even after reboot." Wink

The fact is that the router is connected to the Internet (to the Internet provider). And it reports an error, the red WAN indicator flashes (the icon in the form of a planet). The internet works, I just think it's a glitch.
But this does not affect the work.
Just relax
Cool

CPU temperature is not displayed correctly.
CPU temperature readings started changing after one second from 62.5 - 63.5 °C

Thank you BS and gurus!

_________________
Atheros
Netgear XR500 Nighthawk - DD-WRT 54545
Tp-Link TL-WDR4900 v1.3 - DD-WRT 53133
TP-Link WR1043ND v4 - DD-WRT 51838
TP-Link WR1043ND v2 - Gargoyle OS 1.13.0
TP-Link WR841ND v11 - DD-WRT 55109
Broadcom
Asus RT-AC87U R - DD-WRT 55109
Asus RT-N66U - DD-WRT 55109
Linksys WRT54GL v1.1 - DD-WRT 54517M
Linksys WRT54GL v1.1 - FreshTomato 2023.4_MIPS_K26
Linksys WRT54GL v1.1 - Gargoyle OS 1.6.2
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12772
Location: Netherlands

PostPosted: Sat Feb 10, 2024 12:16    Post subject: Reply with quote
Router Model: Linksys EA6900 (XVortex CFE)

Firmware Version: DD-WRT v3.0-r55109M Community Build (02/09/24)
Kernel Version: Linux 4.4.302-st48 #1 SMP Fri Feb 9 11:59:38 CET 2024 armv7l

Upgraded from DD-WRT v3.0-r54905M Community Build (01/12/24)via telnet (update via GUI not possible because nvram is placed on linux partition and not linux2 partition due to Xvortex CFE)

Reset: No not this time.

Configuration: Default gateway mode, 2,4GHz wireless running with unbridged VAP, 5GHz running, some static leases and some port range forwarding.
Four WireGuard tunnels running, one Server, one site-to-site and two clients in Fail-over group to Mullvad (of course with PBR to allow the WG server to use the WAN).
OpenVPN client with PBR running.
DDNS (dynv6) working.
IPv6 working.
NAS and ksmbd working.
SmartDNS is working both with DoT and DoH
NVRAM size 56K (NVRAM size should not be a problem with the Xvortex CFE)

Status: Up and stable for 8 hours

Errors: none so far

Thanks BS!!

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 1809
Location: Hung Hom, Hong Kong

PostPosted: Sun Feb 11, 2024 8:07    Post subject: Reply with quote
KACTET wrote:
But you can disable 5.0 GHz. @mpgalaxy hack "If you set the radio mode to station bridge and disable the network mode, the 5GHz device will turn off completely even after reboot."

I have been wondering:

This method does make Status->Wireless show "TX Power: Inactive", and "Radio Status: Inactive".

But was the router's radio really NOT sending out any signal (2.4 GHz & 5 GHz)?

Did you test it with some kinds of EMF (WiFi) meters from Amazon? Smile

_________________
Router: Asus RT-N18U (rev. A1)

Drink, Blink, Stretch! Live long and prosper! May the Force and farces be with you!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
GitHub: https://github.com/changmw/changmw
Aar
DD-WRT User


Joined: 25 Aug 2020
Posts: 56
Location: New York, USA

PostPosted: Sun Feb 11, 2024 23:44    Post subject: Reply with quote
Router/Version: R7000
File/Kernel: netgear-r7000-webflash.bin
Previous/Reset: r55033, no
Mode/Status: Router, Secondary AP only
Issues/Errors: 5GHz suddenly became inaccessible

5GHz signal was visible but became unconnectable after around 1 day 23:39 uptime. This issue has persisted with pretty much every build I've used on my R7000 for the past several months unfortunately. The previous build I tried on this device dropped 5GHz after around 1 day's worth of uptime (r55033), and the one before that held out for around 4 days.

_________________
HP EliteDesk 800 G2 Mini PC [i3-6100T] (WAN, DHCP, QoS)
NETGEAR R7000 (AP)
NETGEAR WNDR4300 (Switch)
wabe
DD-WRT Guru


Joined: 17 Jun 2006
Posts: 888

PostPosted: Mon Feb 12, 2024 8:21    Post subject: Reply with quote
Aar wrote:
Router/Version: R7000
File/Kernel: netgear-r7000-webflash.bin
Previous/Reset: r55033, no
Mode/Status: Router, Secondary AP only
Issues/Errors: 5GHz suddenly became inaccessible

5GHz signal was visible but became unconnectable after around 1 day 23:39 uptime. This issue has persisted with pretty much every build I've used on my R7000 for the past several months unfortunately. The previous build I tried on this device dropped 5GHz after around 1 day's worth of uptime (r55033), and the one before that held out for around 4 days.

Seems like a hardware error or a bad power supply. Works flawless for me with all, good, builds including this one.

_________________
Netgear R7000 on Build 55109
Asus AC-AC68U rev. C1 (AP) on Build 55109
Asus AC-68U rev. A1 on Build 54604
Asus AC-68U rev. A1 on Build 53339
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 6338
Location: UK, London, just across the river..

PostPosted: Mon Feb 12, 2024 8:47    Post subject: Reply with quote
Router Model Netgear R7000
Firmware Version DD-WRT v3.0-r55109 std (02/09/24)
Kernel Version Linux 4.4.302-st48 #10985 SMP Thu Feb 8 08:17:31 +06 2024 armv7l

update: CLI r55052 > r55109
reset: NO
mode: Gateway/DoH via SmartDNS, AD-Block(via script),Firewall (Iptables and IPset rules),Forced DNS,AP&Net Isolation,x4VLAN,VPN client(PBR),40 HT 2.4Ghz only
status: Operational 72h+
errors: Nothing new, yet...Thanks BS and Team !

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 55009 WAP
TP-Link WR1043NDv2 -DD-WRT 55109 Gateway/DoT,Forced DNS,AP Isolation,Ad-Block,Firewall,VPN,x1VLAN
TP-Link WR1043NDv2 -DD-WRT 55052 Gateway/DoT,Forced DNS,Ad-Block,Firewall,x4VLAN,VPN
TP-Link WR1043NDv2 -Gargoyle OS 1.15.x AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 55109 Gateway/DoT,AD-Block,Forced DNS,AP&Net Isolation,x3VLAN,Firewall,Vanilla
Netgear R9000 --DD-WRT 55052 Gateway/DoT,AD-Block,AP Isolation,Firewall,Forced DNS,x2VLAN,Vanilla
Broadcom
Netgear R7000 --DD-WRT 55109 Gateway/SmartDNS/DoH,AD-Block,Firewall,Forced DNS,x3VLAN,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby DNS over TLS I DNSCrypt v2 by mac913
KACTET
DD-WRT User


Joined: 01 May 2022
Posts: 217

PostPosted: Mon Feb 12, 2024 14:36    Post subject: Reply with quote
Router/Version: Asus RT-N66U
Update method: WebUpgrade
File/Kernel: dd-wrt.v24-r55109_NEWD-2_K3.x-big-RT-N66U.trx / Linux 4.4.302-st48 #28555 Fri Feb 9 05:23:51 +06 2024 mips
Previous/Reset: r55052 / no
Mode/Status: Gateway / Up and running for 3 days, 5:19
CPU Temperature: WL0 48.5 °C (ambient temperature 20.3 °C)
Issues/Errors: Nothing significant

Thank you BS and gurus!

_________________
Atheros
Netgear XR500 Nighthawk - DD-WRT 54545
Tp-Link TL-WDR4900 v1.3 - DD-WRT 53133
TP-Link WR1043ND v4 - DD-WRT 51838
TP-Link WR1043ND v2 - Gargoyle OS 1.13.0
TP-Link WR841ND v11 - DD-WRT 55109
Broadcom
Asus RT-AC87U R - DD-WRT 55109
Asus RT-N66U - DD-WRT 55109
Linksys WRT54GL v1.1 - DD-WRT 54517M
Linksys WRT54GL v1.1 - FreshTomato 2023.4_MIPS_K26
Linksys WRT54GL v1.1 - Gargoyle OS 1.6.2
KACTET
DD-WRT User


Joined: 01 May 2022
Posts: 217

PostPosted: Mon Feb 12, 2024 15:19    Post subject: Reply with quote
mwchang wrote:

I have been wondering:

This method does make Status->Wireless show "TX Power: Inactive", and "Radio Status: Inactive".

But was the router's radio really NOT sending out any signal (2.4 GHz & 5 GHz)?

Did you test it with some kinds of EMF (WiFi) meters from Amazon? Smile


Unfortunately I don't have such devices.
I simply used household devices, a smartphone, a laptop, to search for disconnected 5 GHz Rolling Eyes

_________________
Atheros
Netgear XR500 Nighthawk - DD-WRT 54545
Tp-Link TL-WDR4900 v1.3 - DD-WRT 53133
TP-Link WR1043ND v4 - DD-WRT 51838
TP-Link WR1043ND v2 - Gargoyle OS 1.13.0
TP-Link WR841ND v11 - DD-WRT 55109
Broadcom
Asus RT-AC87U R - DD-WRT 55109
Asus RT-N66U - DD-WRT 55109
Linksys WRT54GL v1.1 - DD-WRT 54517M
Linksys WRT54GL v1.1 - FreshTomato 2023.4_MIPS_K26
Linksys WRT54GL v1.1 - Gargoyle OS 1.6.2
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 1809
Location: Hung Hom, Hong Kong

PostPosted: Mon Feb 12, 2024 15:30    Post subject: Reply with quote
egc wrote:
Router Model: Linksys EA6900 (XVortex CFE)

Firmware Version: DD-WRT v3.0-r55109M Community Build (02/09/24)
....
NAS and ksmbd working.

May I ask whether ksmbd in this build 55109 really would NOT stall 50 seconds after being started/init?

In previous three 55xxx builds, ksmbd stalled after a while, making it unusable. And you could not "service samba3 stop". Even the command itself stalled. There were also other stability problems, including USB.

Update:

ksmbd still stalled about 50 seconds after init. It's still impossible to stop ksmb, not even by the init process. At least reboot worked fine. WAN, Wired LAN and WLAN (wifi) were working OK, including Dropbear sessions. USB was auto-mounted properly.
Code:
# ps | grep smb
 2809 root     [ksmbd:50031]
 2896 root     sh -c echo hard > /sys/class/ksmbd-control/kill_server
 4542 root     grep smb

On 2nd (or is it the 3rd) reboot, all connections to DD-WRT build 55109 was lost. Needed to cold boot the router to fix it. This strangeness might become a security exploit?? Related to ksmbd changes?

Rolling back to 54682 because of ksmbd issue.

_________________
Router: Asus RT-N18U (rev. A1)

Drink, Blink, Stretch! Live long and prosper! May the Force and farces be with you!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
GitHub: https://github.com/changmw/changmw


Last edited by mwchang on Thu Feb 22, 2024 11:34; edited 10 times in total
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 1809
Location: Hung Hom, Hong Kong

PostPosted: Mon Feb 12, 2024 15:33    Post subject: Reply with quote
KACTET wrote:
Unfortunately I don't have such devices.
I simply used household devices, a smartphone, a laptop, to search for disconnected 5 GHz Rolling Eyes

Understood. Thanks!

_________________
Router: Asus RT-N18U (rev. A1)

Drink, Blink, Stretch! Live long and prosper! May the Force and farces be with you!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
GitHub: https://github.com/changmw/changmw
IONK
DD-WRT Guru


Joined: 19 Aug 2011
Posts: 934

PostPosted: Tue Feb 13, 2024 17:52    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin (r55109) / Linux 4.4.302-st48 #10985 SMP Thu Feb 8 08:17:31 +06 2024 armv7l
Previous/Reset: DD-WRT v3.0-r55033 std (01/29/24) / no
Mode/Status: Repeater Bridge on 5GHz AC/N-Mixed (wl0 is purposely turned off) + CTF & FA + SSH (public key) + DDNS (Dynu.com) + high-speed USB Storage (guide by egc) + WireGuard server + Cron / working
Issues/Errors: none



dmesg_messages_Dlink-DIR868L-RB_r55109_2024-02-14_01-13-30.tgz
 Description:

Download
 Filename:  dmesg_messages_Dlink-DIR868L-RB_r55109_2024-02-14_01-13-30.tgz
 Filesize:  19.19 KB
 Downloaded:  13 Time(s)


_________________
▫ RSS feed for DD-WRT releases (2024): https://rsseverything.com/feed/7d36ab68-7733-46c3-bd8a-9c54c5cef08c.xml
easyddup - A simple upgrade/downgrade utility by yoyoma2 --- as featured in 📌 Reference Links, stickies retired back to forum (Moderator's Pick 🌟)
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 408

PostPosted: Tue Feb 13, 2024 19:06    Post subject: Reply with quote
Router/Version: R6400 V2 (board id=U12H332T30_NETGEAR)
Firmware: DD-WRT v3.0-r55109 std (02/09/24)
Kernel: Linux 4.4.302-st48 #10985 SMP Thu Feb 8 08:17:31 +06 2024 armv7l
Previous: DD-WRT v3.0-r54682 std (01/02/24)
Update Method: SSH / CLI using PuTTY
Mode/Status: Repeater Bridge 5Ghz (AC / N Mixed) /OK
Reset: No
Setup:
2.4 GHz N/G Mixed 20 MHz WPA2-PSK (AES)
Issues/Errors: None / Thanks B.S.

_________________
Netgear XR500, R7800
Asus AC87Ua1
Repeater Bridge
Netgear R6400v2otp
stillaround2024
DD-WRT Novice


Joined: 25 Jan 2024
Posts: 7

PostPosted: Tue Feb 13, 2024 23:16    Post subject: DNScrypt rt-ac68u vA Reply with quote
Sorry long hiatus with Fresh Tomato truly there is So Much More Help with DD-WRT!
Unable to setup DNSCrypt Resolver using TLS errors. Have tried on a few different verisons same result.

Feb 13 13:18:00 DD-WRT user.err smartdns: create icmp socket failed, Address family not supported by protocol
Feb 13 13:18:00 DD-WRT user.info : [smartdns] : successfully started
Feb 13 13:18:00 DD-WRT daemon.crit dnsmasq[2335]: bad option at line 21 of /tmp/dnsmasq.conf (this is log failure)
Feb 13 13:18:00 DD-WRT daemon.crit dnsmasq[2335]: FAILED to start up
Feb 13 13:18:00 DD-WRT user.info : [dnsmasq] : Error on startup, returncode 1

router ver RT-AC68U var
fw ver - DD-WRT v3.0-r55109 std (02/09/24)
kernel - Linux 4.4.302-st48 #10985 SMP Thu Feb 8 08:17:31 +06 2024 armv7l
Previous ver r54682 "same results"
mode - gateway router - Vlan 3/br1, Vlan 4/br2 (dhcp working) wlan 2.4 N only and no 5 ghz devices being used
jffs on defualt - usb never worked on this router and the v3 replacement is buggy across the board so it will hold samba
Update Method - default settings first reboot - then hard reset - pw change reboot -
stillaround2024
DD-WRT Novice


Joined: 25 Jan 2024
Posts: 7

PostPosted: Tue Feb 13, 2024 23:19    Post subject: no attachments being posted Reply with quote
missing 7zip file with logs and conf files...it did upload...
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum