New Build - 10/18/2023 - r53694

Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 5630

PostPosted: Wed Oct 18, 2023 7:20    Post subject: New Build - 10/18/2023 - r53694 Reply with quote
Welcome to Marvell r53694 beta release thread for reporting, feedback to developers and community benefit.
Please do not flash builds until installation is understood, risks involved and device specific recovery methods.
Avoid discussions, create threads for questions, general problems or use search; this thread is not for support.
List router model & version or revision, operating & wireless modes & exact filename/firmware image flashed.


CLI Flash: 'cd /tmp' then 'wget {file URL}' (http only) or 'curl -O {file URL}' (http, https, ftp) 'write {file} linux' then 'reboot'.

Downloads: HTTPS, FTP

Trac SVN: repository since last build 53662 (mirror)

OpenVPN 2.6.6: Changelog, Guides, Server, PBR, DNS, Kill Switch, Watchdog, Reverse PBR, Client, Multiple, tips & scripts.
WireGuard 1.0.20211208/Tools: Changelog, Guides, Client, Server, Adv, PBR, KS, tips & scripts. Thanks BS egc & eibgrad!

Notes:
Transmission x86 Zabbix terminfo 6.1 ZFS DC ZFS DC WG SmartDNS cURL 6.1 PHP 4.14 DC base smb3 6.1 irqbalance 6.1
ZFS EtherIP PPP SmartDNS nf_conntrack_helper USB 6.1

Issues, observations, and/or workarounds reported:
WebUI: Clear history or use a portable. Temporary cache bypass: Ctrl+F5, Cmd+Shift+R or new private window/incognito.
Please report findings with steps needed to reproduce, configuration, clients, output, logs and important information below!

Important:
Detail issues & relevant configs, logs: syslog klog 'dmesg' 'cat /tmp/var/log/messages' nvram set console_debug=1, serial.
• Firewall NAT: 'iptables -vnL' 'iptables -t nat -vnL' 'iptables -t mangle -vnL' & 'cat /tmp/.ipt'. Debug Analyze: strace tcpdump.
• Gremlins: reboot. cold boot. Reset & reconfigure not restore backup. Search Trac & discuss in forum before opening tickets.
• Include operating & wireless modes (e.g. Gateway, Router, AP, SB, WDS, Mesh) and applicable configurations to reproduce.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 433

PostPosted: Wed Oct 18, 2023 9:01    Post subject: Reply with quote
Router/Version: Linksys WRT1200ac v1
File/Kernel: r53694 Linux 6.1.58 #33 SMP Wed Oct 18 01:18:36 +07 2023 arm
Previous/Reset: r53633 No reset
Mode/Status: Gateway,VPN, Stable
Issues/Errors: None
Zyxx
DD-WRT Guru


Joined: 28 Dec 2018
Posts: 729

PostPosted: Wed Oct 18, 2023 10:20    Post subject: Reply with quote
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r53694 std (10/18/23)
Kernel: Linux 6.1.58 #33 SMP Wed Oct 18 01:18:36 +07 2023 arm
Mode: Gateway, SFE enabled, Wifi disabled, Wireguard for external access, WAN to DSL Modem, samba to access USB3-ext4 SSD, Keep Alive reboot 5:00 in the morning
Reset: No
Status: Installed an hour ago, everything except Wireguard seems fine. Will monitor it closely.
Wireguard itself cannot be accessed with any client, neither WAN nor LAN. Was working in release with old kernel. Sent bytes in Wireguard app on mobile just increase over time, but received stays at 0B.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Wed Oct 18, 2023 10:33    Post subject: Reply with quote
@Zyxx, can you simply restart wireguard with:
Code:
sh /usr/bin/wireguard-restart.sh 2>/dev/null
to see if that helps.

If not and if you can spare the time, can you PM me the output of:
Quote:
wg
wg showconf oet1
ip route show
iptables -vnL FORWARD | grep oet
iptables -vnL INPUT
iptables -vnL -t nat
iptables -vnL -t raw
grep -E -i 'oet|wireguard|eop' /var/log/messages
nvram get wan_gateway
get_wanface
ifconfig

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Zyxx
DD-WRT Guru


Joined: 28 Dec 2018
Posts: 729

PostPosted: Wed Oct 18, 2023 12:21    Post subject: Reply with quote
@egc, requested information are in your inbox.

Unfortunately the restart command did not solve the issue.

If anything else is needed, let me know!

regards!
Wizo
DD-WRT User


Joined: 08 Jun 2023
Posts: 60
Location: Essex. England.

PostPosted: Wed Oct 18, 2023 13:02    Post subject: Reply with quote
Zyxx wrote:
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r53694 std (10/18/23)
Kernel: Linux 6.1.58 #33 SMP Wed Oct 18 01:18:36 +07 2023 arm
Mode: Gateway, SFE enabled, Wifi disabled, Wireguard for external access, WAN to DSL Modem, samba to access USB3-ext4 SSD, Keep Alive reboot 5:00 in the morning
Reset: No
Status: Installed an hour ago, everything except Wireguard seems fine. Will monitor it closely.
Wireguard itself cannot be accessed with any client, neither WAN nor LAN. Was working in release with old kernel. Sent bytes in Wireguard app on mobile just increase over time, but received stays at 0B.


Same for me, Wireguard is not working.
I have syslog and wireguard output if needed.


Last edited by Wizo on Wed Oct 18, 2023 13:21; edited 1 time in total
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Wed Oct 18, 2023 13:21    Post subject: Reply with quote
Wizo wrote:
Zyxx wrote:
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r53694 std (10/18/23)
Kernel: Linux 6.1.58 #33 SMP Wed Oct 18 01:18:36 +07 2023 arm
Mode: Gateway, SFE enabled, Wifi disabled, Wireguard for external access, WAN to DSL Modem, samba to access USB3-ext4 SSD, Keep Alive reboot 5:00 in the morning
Reset: No
Status: Installed an hour ago, everything except Wireguard seems fine. Will monitor it closely.
Wireguard itself cannot be accessed with any client, neither WAN nor LAN. Was working in release with old kernel. Sent bytes in Wireguard app on mobile just increase over time, but received stays at 0B.


Same for me, Wireguard is not working.


Can you PM me the output of:
Code:
nvram get wan_gateway
get_wanface
ip route | awk '/^default/{print $NF}'
nvram get wan_iface


TIA

_________________
Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Wizo
DD-WRT User


Joined: 08 Jun 2023
Posts: 60
Location: Essex. England.

PostPosted: Wed Oct 18, 2023 13:23    Post subject: Reply with quote
yes give me 5 mins "Done"
oliver44
DD-WRT Guru


Joined: 01 Jun 2016
Posts: 504

PostPosted: Wed Oct 18, 2023 13:55    Post subject: Reply with quote
Router Model Linksys WRT1900ACS v2
Firmware Version DD-WRT v3.0-r53694 std (10/18/23)
Kernel Version Linux 6.1.58 #33 SMP Wed Oct 18 01:18:36 +07 2023 arm
Current Time Wed, 18 Oct 2023 16:50:39
Uptime 4 min


update-browser waterfox, I switched from -53675 without keeping the settings, all ok

connection Type PPPoE - IPv6 Type DHCPv6 with Prefix Delegation 1Gbps
IPv6 Type DHCPv6 with Prefix Delegation-On - all Ok

Operating Mode Gateway/AP
Shortcut Forwarding Engine-On
Schedule Reboot-On,
Web Access Protocol - HTTPS,
SSH (public key)-all ok
Encrypt DNS Enable
Validate DNS Replies (DNSSEC)-all ok
Port Forwarding - all Ok,
USB - System Log -all Ok
Schedule Reboot - At a Set Time - On



Wireless Interface 5GHz-Wireless Mode AP-Wireless Network Mode-AC/N, Width VHT 80 Mhz-Wireless Channel-36,Extension Channel UU,RTS Threshold 2346, Short GI, Short Preamble, Radio Scheduling, TX Power-30dBm ,TX Antenna Chains-1+2+3+4, RX Antenna Chains-1+2+3+4, Enable-WPA2 - WPA3 Personal / SAE-CCMP-128 (AES), Regulatory Domain Romania, all-ok

Wireless Interface 2.4GHz-Wireless Mode AP-Wireless Network Mode-N, Width VHT 40 Mhz-Wireless Channel-11, Extension Channel Lower,RTS Threshold 2346, Short Preamble, Short GI, Radio Scheduling,TX Power-30dBm ,TX Antenna Chains-1+2+3+4, RX Antenna Chains1+2+3+4, Enable-WPA2 - WPA3 Personal / SAE-CCMP-128 (AES) all-ok!


Thanks to everyone who contributed to the move to Linux 6.1.58, it's a big step for DDWRT Exclamation Cool


I will publish some information with the system logs, I think there is little information that I receive, I have set the following: Syslogd, Klogd, and the usb configuration is as follows, please tell me if there is something wrong!

_________________
Internet provider https://en.wikipedia.org/wiki/RCS_%26_RDS 1Gbps
WDR3600 rev.1.5 - DD-Wrt
Linksys WRT1900ACS v.2 DD-Wrt/-OpenWrt



https://ipv6.chappell-family.com/ipv6tcptest/
https://en.internet.nl/connection/e91f490fe1c54cb2b78145c0ab0d2b5a/results
http://www.dnssec-or-not.com/
https://dnscheck.tools/#results


Last edited by oliver44 on Mon Oct 23, 2023 21:17; edited 1 time in total
AlexGT
DD-WRT Novice


Joined: 16 Oct 2023
Posts: 3
Location: Kyiv, Ukraine

PostPosted: Wed Oct 18, 2023 19:00    Post subject: Reply with quote
Using WRT1200ac v1 for Wi-Fi 5Ghz and couple of lan connections, all good.
One thing I noted is that my CPU temrperature dropped from 71C to 60C during the same use case, don't know is that a result of moving onto linux 6.1 but it looks great.
P.S. yes I know that high temperatures for that proccessors isn't a problem Smile

_________________
Linksys WRT1200ac(v1)
Ivo_K
DD-WRT Novice


Joined: 12 Jan 2018
Posts: 37

PostPosted: Thu Oct 19, 2023 11:41    Post subject: DDNS seems to fail with Namecheap Reply with quote
Router/Version: Linksys WRT1200AC v1
File: ddwrt-linksys-wrt1200ac-webflash.bin
Kernel: Linux 6.1.58 #33 SMP Wed Oct 18 01:18:36 +07 2023 arm
Previous/Reset: r53633/No Reset
Mode: Gateway
Issues/Errors: All seems to work fine except DDNS. It was set up as custom in accordance with the instructions at https://www.namecheap.com/support/knowledgebase/article.aspx/9356/11/how-to-configure-a-ddwrt-router/ and has worked fine for a very long time. The host field contains the following: @ -a *

Now I get the following response:

Oct 19 13:28:44 DD-WRT user.warn inadyn[1927]: Failed resolving hostname @: Name does not resolve
Oct 19 13:28:49 DD-WRT user.warn inadyn[1927]: Failed resolving hostname -a: Try again
Oct 19 13:28:49 DD-WRT user.warn inadyn[1927]: Failed resolving hostname *: Name does not resolve
Oct 19 13:28:49 DD-WRT user.notice inadyn[1927]: Update forced for alias @, new IP# xxx.xxx.xxx.xxx
Oct 19 13:28:49 DD-WRT user.notice inadyn[1927]: Update forced for alias -a, new IP# xxx.xxx.xxx.xxx
Oct 19 13:28:49 DD-WRT user.notice inadyn[1927]: Update forced for alias *, new IP# xxx.xxx.xxx.xxx
Oct 19 13:28:50 DD-WRT user.notice inadyn[1927]: Updating IPv4 cache for @
Oct 19 13:28:50 DD-WRT user.notice inadyn[1927]: Updating IPv4 cache for -a
Oct 19 13:28:50 DD-WRT user.notice inadyn[1927]: Updating IPv4 cache for *

I have also tried, instead of the Custom option, to use the DD-WRT menu option Namecheap and got this:

Oct 19 13:34:16 DD-WRT user.notice inadyn[2425]: In-a-dyn version 2.12.0-dev -- Dynamic DNS update client.
Oct 19 13:34:16 DD-WRT user.warn inadyn[2425]: Failed resolving hostname @: Name does not resolve
Oct 19 13:34:21 DD-WRT user.warn inadyn[2425]: Failed resolving hostname -a: Try again
Oct 19 13:34:21 DD-WRT user.warn inadyn[2425]: Failed resolving hostname *: Name does not resolve
Oct 19 13:34:21 DD-WRT user.notice inadyn[2425]: Update forced for alias @, new IP# xxx.xxx.xxx.xxx
Oct 19 13:34:21 DD-WRT user.notice inadyn[2425]: Update forced for alias -a, new IP# xxx.xxx.xxx.xxx
Oct 19 13:34:21 DD-WRT user.notice inadyn[2425]: Update forced for alias *, new IP# xxx.xxx.xxx.xxx
Oct 19 13:34:22 DD-WRT user.warn inadyn[2425]: Fatal error in DDNS server response: DDNS server response not OK
Oct 19 13:34:22 DD-WRT user.warn inadyn[2425]: Error response from DDNS server, ignoring ...

I tried, instead of several hosts separated with the -a, to use only @, only www, and got the same:

Oct 19 13:36:14 DD-WRT user.notice inadyn[2520]: In-a-dyn version 2.12.0-dev -- Dynamic DNS update client.
Oct 19 13:36:14 DD-WRT user.warn inadyn[2520]: Failed resolving hostname @: Name does not resolve
Oct 19 13:36:14 DD-WRT user.notice inadyn[2520]: Update forced for alias @, new IP# xxx.xxx.xxx.xxx
Oct 19 13:36:14 DD-WRT user.warn inadyn[2520]: Fatal error in DDNS server response: DDNS server response not OK
Oct 19 13:36:14 DD-WRT user.warn inadyn[2520]: Error response from DDNS server, ignoring ...
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum