Help with Netgear XR500 VLAN Settings

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Author Message
styro1
DD-WRT Novice


Joined: 17 Nov 2019
Posts: 5

PostPosted: Wed Sep 07, 2022 20:59    Post subject: Help with Netgear XR500 VLAN Settings Reply with quote
Hi all, I was wondering if I could get some help with my VLAN settings in a Netgear XR500, running version r49626 and setup as an AP. OPNSense firewall provides DHCP and DNS. My problem is that VLAN12 has internet via wifi but the wired ports, 3 & 4, physical ports 1 & 2 has no internet but each recieves an IP address from OPnsense. Ports 1 & 2 work fine. These are my commands;

Startup:
swconfig dev switch0 set enable_vlan 1
swconfig dev switch0 vlan 1 set ports "1 2 6"
swconfig dev switch0 vlan 12 set ports "1t 3 4 6t"
swconfig dev switch0 vlan 12 set vid 12
swconfig dev switch0 set apply
vconfig add eth1 12
brctl addif br1 eth1.12
ifconfig eth1.12 up
ifconfig br1 192.168.12.2 netmask 255.255.255.0

Firewall:
iptables -t nat -I POSTROUTING -o `get_wanface` -j MASQUERADE
iptables -I INPUT -p udp --dport 68 -j ACCEPT
iptables -I FORWARD -i br1 -o br0 -m state --state NEW -j DROP
iptables -I FORWARD -i br0 -o br1 -m state --state NEW -j DROP


These are my listed bridge assignments and bridging table on the Setup/Networking page.

Thanx in advance any help I get. styro1
Sponsor
styro1
DD-WRT Novice


Joined: 17 Nov 2019
Posts: 5

PostPosted: Wed Sep 07, 2022 21:05    Post subject: Reply with quote
I messed up and posted the image for my R7800 router under the bridge assignments. The real assignment in eth1.12 not eth1.8. Embarassed
dale_gribble39
DD-WRT Guru


Joined: 11 Jun 2022
Posts: 867

PostPosted: Thu Sep 08, 2022 3:23    Post subject: Reply with quote
So, click "edit" and post the proper screenshots... <wink>
_________________
"The woods are lovely, dark and deep,
But I have promises to keep,
And miles to go before I sleep,
And miles to go before I sleep." - Robert Frost

"I am one of the noticeable ones - notice me" - Dale Frances McKenzie Bozzio

<fact>code knows no gender</fact>

This is me, knowing I've ruffled your feathers, and not giving a ****
Some people are still hard-headed.

--------------------------------------
Mac Pro (Mid 2012) - Two 2.4GHz 6-Core Intel Xeon E5645 processors 64GB 1333MHz DDR3 ECC SDRAM OpenSUSE Leap 15.4
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum