New Build - 08/31/2022 - r50012

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3  Next
Author Message
MuzzleVelocity
DD-WRT User


Joined: 23 Apr 2010
Posts: 118

PostPosted: Thu Sep 01, 2022 15:07    Post subject: Reply with quote
Linksys EA8500
dd-wrt-webupgrade.bin r50012/Linux 4.9.326 #1181 SMP Mon Aug 29 01:53:59 +07 2022 armv7l
previous r46885/ Reset: Yes Sad
Mode: entware on ext4 USB, lighttpd, samba /Status: operational
Issues/Errors: proftpd is read only

Was able to view my ftp share but could not write to it. finally determined the nvram entry to enable FTP writing was missing. had to fix it with
Code:
nvram set proftpd_writeen=2
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10788
Location: Netherlands

PostPosted: Thu Sep 01, 2022 15:56    Post subject: Reply with quote
MuzzleVelocity wrote:
Linksys EA8500
dd-wrt-webupgrade.bin r50012/Linux 4.9.326 #1181 SMP Mon Aug 29 01:53:59 +07 2022 armv7l
previous r46885/ Reset: Yes Sad
Mode: entware on ext4 USB, lighttpd, samba /Status: operational
Issues/Errors: USB Disk Info is gone!

been a while since i upgraded, so i dont know if this is a recent bug or its been a while. But on the USB tab the Disk-info box only lists Disk-space, nothing else. Among other things, this is where it used to show the UUID of any drives you inserted, which need to be copied up to the "mount partition to /opt" box.


It shows alright on my router, have you tried to refresh browser cache or use another bowser and/or incognito mode

I just label my partitions opt and jffs and they will mount automatically, no need to add the UUID

_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
MuzzleVelocity
DD-WRT User


Joined: 23 Apr 2010
Posts: 118

PostPosted: Thu Sep 01, 2022 16:53    Post subject: Reply with quote
egc wrote:

It shows alright on my router, have you tried to refresh browser cache or use another bowser and/or incognito mode


I had tried those, and still no luck. But, I just installed r50012 on my identical "spare" EA5800, put in a freshly formatted ext4 USB stick, and the USB info shows up fine there.

So this must be something screwy with the USB drive i have in the main router.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10788
Location: Netherlands

PostPosted: Thu Sep 01, 2022 16:56    Post subject: Reply with quote
If the USB stick is NTFS formatted it can become flagged as "dirty" and you have to run chkdks from a Windows PC
_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
johnnyNobody999
DD-WRT User


Joined: 10 Jan 2014
Posts: 464

PostPosted: Thu Sep 01, 2022 17:38    Post subject: Reply with quote
Router/Version: R9000
File/Kernel: dd-wrt_r9000-webupgrade-r50012.bin
Previous/Reset: dd-wrt_r9000-webupgrade-r49599.bin
Mode/Status: operational
Issues/Errors: I had to roll back to firmware 49599 because I was having issues with DNS.


Last edited by johnnyNobody999 on Fri Sep 02, 2022 16:02; edited 1 time in total
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 805

PostPosted: Thu Sep 01, 2022 17:41    Post subject: Reply with quote
30 hours up and stable, no issues. Thanks, BS & Team!
_________________
Netgear R9000 X10
DD-WRT v3.0-r50963 std (11/28/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: VANILLA Firmware, Airtime Fairness Enabled, NG-Mixed, ACK Timing 3150, WPA2 w/AES
5GHz: VANILLA Firmware, Airtime Fairness Enabled, AC/N Mixed, ACK Timing 3150, WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
whitebeard
DD-WRT User


Joined: 26 Jul 2013
Posts: 52
Location: Canada

PostPosted: Thu Sep 01, 2022 18:01    Post subject: Reply with quote
Router/Version: Netgear R7500V2
File/Kernel: DD-WRT v3.0-r50012 std (08/31/22)
Previous/Reset: 49866 / No
Mode/Status: Wifi 5/2.4 Main+Guest(VAP) w/DDWRT, USB Entware, Dnscrypt, NAS, Static & DHCP
Issues/Errors: None

Thanks BS & crew.
thommy181
DD-WRT User


Joined: 16 Mar 2019
Posts: 308
Location: Szczecin, Poland EU

PostPosted: Fri Sep 02, 2022 9:29    Post subject: New Build - 08/31/2022 - r50012 Reply with quote
Router/Version: Tp-Link TL-WDR3600 v 1.5
Kernel: Linux 3.10.108-d11 #115598 Wed Aug 31 03:52:41 +07 2022 mips
Reset: No
Mode: Internet gateway, WIFI 5GHz AP, dnsmasq, firewall
Status: Working
Issues: Nothing significant
Uptime: almost 48h

Device working good. I don't see any problems. I have plan to restore factory default soon, cause firmware have many changes at last time. Generic device condition and performance is good.
xl600
DD-WRT Novice


Joined: 04 Dec 2019
Posts: 26

PostPosted: Fri Sep 02, 2022 13:00    Post subject: Reply with quote
Netgear Nighthawk X10 R9000
Firmware Version DD-WRT v3.0-r50012 std (08/31/22)
GUI over 49626
Reset: no


For the last few builds, I haven't been able to get freeRADIUS working with my old setup. The logs keep filling with entries about being unable to contact the freeRADIUS server. I haven't yet tried to fully reset and restore manually (Too much work right now) but I was wondering if anyone else has had this issue?

For now, I've restored back to 49626 and everything is working fine.
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5946
Location: Texas

PostPosted: Sat Sep 03, 2022 0:06    Post subject: Reply with quote
Linksys EA8500 ...main gateway
DD-WRT v3.0-r50012 std (08/31/22)
Linux 4.9.326 #1181 SMP Mon Aug 29 01:53:59 +07 2022 armv7l
GUI install over r49838
yea twas a PITA to reconfig it all.
Had to dig in logs to see WTH with ovpn server...Nobody told me after a reset you cannot use the
DH field any longer...yea, Diffie Hellman prolly cussin ya Twisted Evil


Everything is working just great now Laughing


br1 is isloated from main net but br1 has access to me webserver which is at 10.72.28.1 ...yous can see in firewall
Doing my VLAN twasn't too bad. I just looked at:
sweatbee post:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1119771#1119771
...link has always been on my VLAN page for yous R7800 peoples but its handy now for us all Smile
Don't know what happen to sweatbee but he had setup a VLAN same as I been using on
his R7800 back in the day --- prolly have to read most of the link but it is all simple
once you get the ol head wrapped around it. Works now on the EA8500
thanky sweatbee where ever yous at...

statrtup cmds:
Code:
swconfig dev switch0 set enable_vlan 1
swconfig dev switch0 vlan 1 set ports "1 2 3 6"
swconfig dev switch0 vlan 4 set ports "4 6t"
swconfig dev switch0 set apply
vconfig add eth1 4
brctl addif br1 eth1.4
ifconfig eth1.4 up
sleep 10
for CPUFREQ in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor; do [ -f $CPUFREQ ] || continue; echo -n ondemand > $CPUFREQ; done
echo 35 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 10 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor


me firewall:
Code:
iptables -t nat -I POSTROUTING -o `get_wanface` -j MASQUERADE
iptables -I INPUT -i br1 -m state --state NEW -j DROP
iptables -I INPUT -i br1 -p udp -m multiport --dports 53,67 -j ACCEPT
iptables -I FORWARD -i br1 -o br0 -m state --state NEW -j DROP
iptables -I FORWARD -i br1 -o br0 -d 10.72.28.1 -m state --state NEW -j ACCEPT
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5946
Location: Texas

PostPosted: Sat Sep 03, 2022 1:29    Post subject: Reply with quote
yeahuh she is all good Cool
Code:
root@Citadel-Station-Homeworld:~# ps
  PID USER       VSZ STAT COMMAND
    1 root      1076 S    /sbin/init
    2 root         0 SW   [kthreadd]
    4 root         0 SW<  [kworker/0:0H]
    6 root         0 SW   [ksoftirqd/0]
    7 root         0 SW   [rcu_sched]
    8 root         0 SW   [rcu_bh]
    9 root         0 SW   [migration/0]
   10 root         0 SW<  [lru-add-drain]
   11 root         0 SW   [cpuhp/0]
   12 root         0 SW   [cpuhp/1]
   13 root         0 SW   [migration/1]
   14 root         0 SW   [ksoftirqd/1]
   15 root         0 SW   [kworker/1:0]
   16 root         0 SW<  [kworker/1:0H]
   17 root         0 SW   [oom_reaper]
   18 root         0 SW<  [writeback]
   19 root         0 SW   [kcompactd0]
   20 root         0 SW<  [crypto]
   21 root         0 SW<  [bioset]
   22 root         0 SW<  [kblockd]
   24 root         0 SW<  [watchdogd]
   26 root         0 SW   [kworker/0:1]
   43 root         0 SW   [kswapd0]
   44 root         0 SW<  [vmstat]
   71 root         0 SW<  [cryptodev_queue]
   72 root         0 SW   [kworker/1:1]
   75 root         0 SW<  [bioset]
   76 root         0 SW<  [bioset]
   77 root         0 SW<  [bioset]
   78 root         0 SW<  [bioset]
   79 root         0 SW<  [bioset]
   80 root         0 SW<  [bioset]
   81 root         0 SW<  [bioset]
   82 root         0 SW<  [bioset]
   83 root         0 SW<  [bioset]
   84 root         0 SW<  [kworker/0:1H]
   85 root         0 SW<  [bioset]
   86 root         0 SW<  [bioset]
   87 root         0 SW<  [bioset]
   88 root         0 SW<  [bioset]
   89 root         0 SW<  [bioset]
   90 root         0 SW<  [bioset]
   91 root         0 SW<  [bioset]
   92 root         0 SW<  [bioset]
   93 root         0 SW<  [bioset]
   94 root         0 SW<  [bioset]
   99 root         0 SW<  [kworker/1:1H]
  761 root       824 S    /sbin/hotplug2 --set-rules-file /etc/hotplug2.rules --persistent
  765 root       832 S    /sbin/mstpd
  773 root      1012 S    irqbalance -t 10
  815 root         0 SW<  [cfg80211]
  816 root         0 SW   [kworker/0:2]
  828 root         0 SW<  [ath10k_wq]
  829 root         0 SW<  [ath10k_aux_wq]
  830 root         0 SW<  [ath10k_tx_compl]
  835 root         0 SW<  [ath10k_wq]
  836 root         0 SW<  [ath10k_aux_wq]
  837 root         0 SW<  [ath10k_tx_compl]
  857 root      1804 S    watchdog
 1034 root      4692 S    hostapd -B -P /var/run/wlan0_hostapd.pid /tmp/wlan0_hostap.conf
 1094 root      4584 S    hostapd -B -P /var/run/wlan1_hostapd.pid /tmp/wlan1_hostap.conf
 1262 root      1424 S    syslogd -Z -L
 1264 root      1424 S    klogd
 1272 root      1212 S    dropbear -b /tmp/loginprompt -r /tmp/root/.ssh/ssh_host_rsa_key -p 22 -s
 1345 root      2104 S    dnsmasq -u root -g root -C /tmp/dnsmasq.conf
 1804 root      4860 S    httpd -n -p 80
 1806 root      1388 S    resetbutton
 2095 root      1768 S    wland
 2140 root      3528 S    /tmp/openvpnserver --config /tmp/openvpn/openvpn.conf --daemon
 2679 root         0 SW   [scsi_eh_0]
 2683 root         0 SW<  [scsi_tmf_0]
 2684 root         0 SW   [usb-storage]
 2701 root         0 SW<  [ata_sff]
 2723 root         0 SW   [scsi_eh_1]
 2724 root         0 SW<  [scsi_tmf_1]
 2907 root         0 SW<  [bioset]
 3074 root         0 SW   [jbd2/sda1-8]
 3077 root         0 SW<  [ext4-rsv-conver]
 3307 root       768 S    wsdd2 -d -N Citadel-Station-Homeworld -G WORKGROUP -b vendor:dd-wrt,model:Linksys EA8500,sku:50012
 3312 root       896 S    ksmbd.mountd -c /tmp/smb.conf -u /tmp/smb.db
 3314 root       928 S    ksmbd.mountd -c /tmp/smb.conf -u /tmp/smb.db
 3317 root         0 SW   [ksmbd-lo]
 3320 root         0 SW   [ksmbd-eth0]
 3328 root         0 SW   [ksmbd-br0]
 3335 root         0 SW   [ksmbd-br1]
 3339 root         0 SW   [ksmbd-tun2]
 3351 root       768 S    wsdd2 -d -N Citadel-Station-Homeworld -G WORKGROUP -b vendor:dd-wrt,model:Linksys EA8500,sku:50012
 3640 root      1424 S    udhcpc -i eth0 -p /var/run/udhcpc.pid -s /tmp/udhcpc -O routes -O msstaticroutes -O staticroutes
 4371 root         0 SW   [ksmbd-imq0]
 4502 root       744 S    cron
 4506 root      1800 S    process_monitor
 6063 root         0 SW<  [kworker/u5:3]
 6769 root         0 SW<  [kworker/u5:1]
 6882 root         0 RW<  [kworker/u5:4]
 7227 root         0 SW   [kworker/u4:0]
 7246 root         0 SW<  [kworker/u5:0]
 7247 root         0 SW   [kworker/u4:1]
 7292 root         0 SW   [kworker/u4:2]
 7302 root      1232 R    dropbear -b /tmp/loginprompt -r /tmp/root/.ssh/ssh_host_rsa_key -p 22 -s
 7303 root      1428 S    -sh
 7306 root      1432 R    ps
root@Citadel-Station-Homeworld:~# dmesg | tail
[   45.513257] br1: port 2(wlan1.1) entered learning state
[   46.688106] IMQ driver unloaded successfully.
[   49.010989] IMQ: use 2 as queue number
[   49.050783] IMQ driver loaded successfully. (numdevs = 16, numqueues = 2, imq_dev_accurate_stats = 1)
[   49.050809]    Hooking IMQ after NAT on PREROUTING.
[   49.059089]    Hooking IMQ before NAT on POSTROUTING.
[   56.513284] br1: port 1(wlan0.1) entered forwarding state
[   56.513408] br1: port 3(eth1.4) entered learning state
[   60.513341] br1: port 2(wlan1.1) entered forwarding state
[   71.513893] br1: port 3(eth1.4) entered forwarding state
root@Citadel-Station-Homeworld:~# cat /proc/interrupts
           CPU0       CPU1       
 16:    4119472    5099817     GIC-0  18 Edge      gp_timer
 18:         65          0     GIC-0  51 Edge      qcom_rpm_ack
 19:          0          0     GIC-0  53 Edge      qcom_rpm_err
 20:          0          0     GIC-0  54 Edge      qcom_rpm_wakeup
 95:          0          0     GIC-0 241 Edge      ahci[29000000.sata]
 96:          0          0     GIC-0 210 Edge      tsens_interrupt
 97:     224972     743726     GIC-0  67 Edge      qcom-pcie-msi
 98:     107952    1460433     GIC-0  89 Edge      qcom-pcie-msi
 99:          0          0     GIC-0 103 Edge      qcom-pcie-msi
100:     107722      75603     GIC-0 202 Edge      adm_dma
101:     202060     352250     GIC-0 255 Level     eth0
102:     158841     251590     GIC-0 258 Level     eth1
103:          0          0   PCI-MSI   0 Edge      aerdrv
104:     224972     743726   PCI-MSI   1 Edge      ath10k_pci
136:          0          0   PCI-MSI   0 Edge      aerdrv
137:     107952    1460433   PCI-MSI   1 Edge      ath10k_pci
201:       2394          8     GIC-0 184 Level     msm_serial0
202:       2098          0     GIC-0 142 Level     xhci-hcd:usb1
203:          0          0     GIC-0 237 Level     xhci-hcd:usb3
IPI0:         0          0       CPU wakeup interrupts
IPI1:         0          0       Timer broadcast interrupts
IPI2:   1568548    1033232       Rescheduling interrupts
IPI3:    184097     244399       Function call interrupts
IPI4:         0          0       CPU stop interrupts
IPI5:     42332      42199       IRQ work interrupts
IPI6:         0          0       completion interrupts
Err:          0
root@Citadel-Station-Homeworld:~# date
Fri Sep  2 20:25:40 CDT 2022
root@Citadel-Station-Homeworld:~#
Connection to citadel-station-homeworld.mrjcd.com closed.
mrjcd@daDeb:~$
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5946
Location: Texas

PostPosted: Sun Sep 04, 2022 1:01    Post subject: Reply with quote
mrjcd wrote:
Linksys EA8500 ...main gateway
DD-WRT v3.0-r50012 std (08/31/22)
Linux 4.9.326 #1181 SMP Mon Aug 29 01:53:59 +07 2022 armv7l
GUI install over r49838
yea twas a PITA to reconfig it all.
Had to dig in logs to see WTH with ovpn server...Nobody told me after a reset you cannot use the
DH field any longer...yea, Diffie Hellman prolly cussin ya Twisted Evil


just to note:
when I did cat /tmp/var/log/messages | grep openvpn
it told me it could NOT find dh.pem in /tmp/openvpn/ ...therefore it would NOT start Rolling Eyes
but it twas there just like it is now cause I checked then Wink
Code:
root@Citadel-Station-Homeworld:~# cd /tmp/openvpn
root@Citadel-Station-Homeworld:/tmp/openvpn# ls
ca.crt         cert.pem       cldiscon.sh    ip-pool        openvpn.conf   route-up.sh
ccd            clcon.sh       dh.pem         key.pem        route-down.sh
root@Citadel-Station-Homeworld:/tmp/openvpn#


after reading several posts in a few DD-WRT forums about things NOT starting up as they should...
...that is likely the case here. Alls I know when I Enabled ECDH it all worked fine then and
yea I done a reboot and everything just make sure all was good.
It is in as main router now with newer build so can't monkey with it now...just gonna mention---end note Twisted Evil
ho1Aetoo
DD-WRT Guru


Joined: 19 Feb 2019
Posts: 1770
Location: Germany

PostPosted: Sun Sep 04, 2022 8:54    Post subject: Reply with quote
log ?

and see

https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1271057#1271057

https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1271168#1271168
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10788
Location: Netherlands

PostPosted: Sun Sep 04, 2022 10:09    Post subject: Reply with quote
I dug up an old DH.PEM certificate and did a quick test and it seems to work fine also after a reboot.

I can trigger the error:
Sep 4 11:56:40 EA8500 daemon.err openvpn[2783]: Cannot load DH parameters from /tmp/openvpn/dh.pem
Sep 4 11:56:40 EA8500 daemon.notice openvpn[2783]: Exiting due to fatal error

if I put in a wrong certificate or did not copy the whole certificate so maybe that is what happened?

But yeah the use of a DH.PEM certificate is not necessary any more, the default is to use ECDH

_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5946
Location: Texas

PostPosted: Sun Sep 04, 2022 12:32    Post subject: Reply with quote
egc wrote:
if I put in a wrong certificate or did not copy the whole certificate so maybe that is what happened?

But yeah the use of a DH.PEM certificate is not necessary any more, the default is to use ECDH

yeahuh I can see where it would fail if used wrong key/PEM but that is NOT the case here

see ---> https://mrjcd.com/junk/dd-wrt/EA8500/r50057-ovpn/

prolly a few already bitchin about me rebooting main unit ...lucky EA8500 starts up fast Smile
Goto page Previous  1, 2, 3  Next Display posts from previous:    Page 2 of 3
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum