Just want to verify WAN port setting

Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 59

PostPosted: Sun Apr 10, 2022 15:41    Post subject: Just want to verify WAN port setting Reply with quote
Shortly after making some changes to my samba settings my internet totally stopped working. Rebooting router & modem didnt help. My WAN IP was all 0 so didnt think it was the samba settings, changed them back anyway and still no internet.

Started looking around at other settings and discovered that my SETUP - NETWORKING - WAN PORT ASSIGNMENT was set to eth0.

Changing it to vlan2 fixed the internet issue.
Just want to confirm that vlan2 is what I definitely want.

DD-WRT v3.0-r48607 std (04/08/22)
Linksys WRT3200ACM
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10775
Location: Netherlands

PostPosted: Sun Apr 10, 2022 16:02    Post subject: Reply with quote
I transferred your question to the Marvell forum as this is a specific Marvell question
_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 1364
Location: Appalachian mountains, USA

PostPosted: Mon Apr 11, 2022 15:42    Post subject: Reply with quote
The WAN port has always been on eth0 on these Marvell routers. I'm not on a build as recent as yours though (I'm on 48141 from late January 2022) so if something has changed recently, perhaps someone will so advise us.
_________________
5 Linksys WRT1900ACSv2 routers on 50474: VLANs, VAPs, NAS, client mode, OpenVPN client (AirVPN), wireguard servers (via AirVPN port forwarding) and clients (AzireVPN and AirVPN), 3 DNSCrypt DNS providers via VPN clients.
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 59

PostPosted: Tue Apr 12, 2022 18:16    Post subject: Reply with quote
So I was uncomfortable leaving my WAN port set wrong with no idea of the consequences. I tried it again on eth0 but same issue no WAN IP so I factory reset it.

Sure enough after a reset the WAN is on eth0 as it should be and WAN does get an IP from the ISP.

Just for fun I tried re-uploading my bad config after the reset and the WAN doesnt work on eth0, just vlan2. I'm not sure what got messed up in that config.

So I'm doing another reset and re configuring by hand.
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 1364
Location: Appalachian mountains, USA

PostPosted: Tue Apr 12, 2022 20:55    Post subject: Reply with quote
Sounds like you found the right solution. Good luck on the hand reconfig... sometimes needed but never fun.
_________________
5 Linksys WRT1900ACSv2 routers on 50474: VLANs, VAPs, NAS, client mode, OpenVPN client (AirVPN), wireguard servers (via AirVPN port forwarding) and clients (AzireVPN and AirVPN), 3 DNSCrypt DNS providers via VPN clients.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum