Warning: ignoring resolv-file flag, no-resolv is set

Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
Ivo_K
DD-WRT Novice


Joined: 12 Jan 2018
Posts: 37

PostPosted: Wed Mar 30, 2022 18:24    Post subject: Warning: ignoring resolv-file flag, no-resolv is set Reply with quote
I am running DD-WRT v3.0-r48567 on a Linksys WRT1200AC router.

DHCP settings enabled:
Use DNSMasq for DNS
DHCP-Authoritative

SmartDNS Resolver options enabled:
SmartDNS Resolver
Prefetch Domain
Serve Expired

Dnsmasq options enabled:
Dnsmasq
Cache DNSSEC data
No DNS Rebind
Query DNS in Strict Order
RFC4039 Rapid Commit support

At every reboot I get the following in the syslog: daemon.warn dnsmasq[1389]: warning: ignoring resolv-file flag because no-resolv is set

My questions:
1. where is the resolv-file flag setting?
2. where is the no-resolv set?
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 14038
Location: Texas, USA

PostPosted: Wed Mar 30, 2022 19:08    Post subject: Reply with quote
If you are using SmartDNS, you shouldn't have use DNSMasq for DNS enabled, methinks. But to answer the no-resolv is usually in additional dnsmasq options on the services page and the resolv-file is set by dnsmasq itself. But I relent to my initial statement regarding SmartDNS and DNSMasq, unless you are pointing DNSMasq to SmartDNS by default (which I think this may be automatic?). I know this has been discussed in the forum, I don't have the thread link handy....
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
DD-WRT Releases 2023 (PolitePol)
DD-WRT Releases 2023 (RSS Everything)

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 2001

PostPosted: Wed Mar 30, 2022 19:15    Post subject: Reply with quote
Ignore Wan DNS enabled on Setup page?


_________________
Forum Guide Lines (with helpful pointers about how to research your router, where and what firmware to download, where and how to post and many other helpful tips!)
How to get help the right way

Before asking for help - Read the forum guidelines AND Upgrade DD-WRT!
Ivo_K
DD-WRT Novice


Joined: 12 Jan 2018
Posts: 37

PostPosted: Wed Mar 30, 2022 21:35    Post subject: Reply with quote
In my case the additional dnsmasq options on the services page is blank. Regarding the dnsmasq and SmartDNS, I have read this: https://wiki.dd-wrt.com/wiki/index.php/SmartDNS. Here they say: "What is the difference between SmartDNS and DNSMASQ? Smartdns is not designed to replace DNSMASQ. The main function of Smartdns is focused on DNS resolution enhancements."

Last edited by Ivo_K on Wed Mar 30, 2022 21:43; edited 2 times in total
Ivo_K
DD-WRT Novice


Joined: 12 Jan 2018
Posts: 37

PostPosted: Wed Mar 30, 2022 21:36    Post subject: Reply with quote
Yes, Ignore Wan DNS is enabled on the Setup page.
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 2001

PostPosted: Wed Mar 30, 2022 23:24    Post subject: Reply with quote
I thought that might be throwing the warning
but I just checked and the only way I get the warning
is when "no-resolv" is set in Additional Dnsmasq Options.

Not using SmartDNS either.

So I don't know Question ¯\_(ツ)_/¯

_________________
Forum Guide Lines (with helpful pointers about how to research your router, where and what firmware to download, where and how to post and many other helpful tips!)
How to get help the right way

Before asking for help - Read the forum guidelines AND Upgrade DD-WRT!
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 14038
Location: Texas, USA

PostPosted: Thu Mar 31, 2022 1:33    Post subject: Reply with quote
Enabling SmartDNS may automatically change DNSMasq to use no-resolv, perhaps. I haven't delved into using SmartDNS,
but there is a forum thread that may amplify what information in the wiki has.

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
DD-WRT Releases 2023 (PolitePol)
DD-WRT Releases 2023 (RSS Everything)

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
plawer
DD-WRT User


Joined: 11 Aug 2019
Posts: 156

PostPosted: Thu Mar 31, 2022 2:24    Post subject: Re: Warning: ignoring resolv-file flag, no-resolv is set Reply with quote
Ivo_K wrote:

My questions:
1. where is the resolv-file flag setting?
2. where is the no-resolv set?


I get the same error but haven't bothered looking at it (I don't use Smart DNS) until now. A few reboots into this, I am confused.

I thought no-resolv was set by the "Ignore WAN DNS" but it is present in the dnsmasq.conf file even with it unchecked. I recall removing no-resolv from my additional configuration when "Ignore WAN DNS" became an option.

The "Ignore WAN DNS" excludes the WAN DNS from being written to resolv.dnsmasq and resolv.dnsmasq_isp. And with it unchecked the ISP DNS goes into both files (to me the files appear identical, but they were different in the past when you had to set no-resolv in the additional configuration)

_________________
Linksys: Several WRTxx00AC variations | Netgear: 4x WNDR4500v2, 7x WNDR4300, R6400v1 | Asus: 2x RT-AC66U | Gl.inet: 3x GL-AR150
manchesterblack
DD-WRT User


Joined: 04 Mar 2021
Posts: 65
Location: Manchester

PostPosted: Mon Sep 12, 2022 18:50    Post subject: Reply with quote
I thought that might be throwing the warning
but I just checked and the only way I get the warning
is when "no-resolv" is set in Additional Dnsmasq Options.

Not using SmartDNS either.

So I don't know Question ¯\_(ツ)_


I am confused Where is the "no-resolv" option in additional dnsmasq options? I cannot find this anywhere.
Was a solution found for this topic?

_________________
Netgear R7000
DD-WRT DD-WRT v3.0-r50595 std (10/23/22)
Manchester
Enable dnsmasq- Yes
Encrypt DNS- NO
DNSCrypt Resolver- No Using Smart DNS
Cache DNSSEC Data- Yes
Validate DNS Replies (DNSSEC)- NO
Check Unsigned DNS Replies- NO
No DNS Rebind- Enable
Query DNS in Strict Order- Enable
Add Requestor MAC to DNS Query- Disable
RFC4039 Rapid Commit Support- Enable
Maximum Cached Entries- 1500

Smart DNS - YES

server-https https://9.9.9.9/dns-query
server-tls 9.9.9.9:853 -host-name: dns.quad9.net
server-tls 5.2.75.75:853 -host-name: dot.nl.ahadns.net
server-https https://1.1.1.1/dns-query

Additional VPN Configuration-
pull-filter ignore "dhcp-option DNS6 "
pull-filter ignore "dhcp-option DNS "

Dnsmasq Additional Options

server=/pool.ntp.org/9.9.9.9
server=/pool.ntp.org/1.0.0.1
server=/adquard-dns.com/9.9.9.9


BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers
dale_gribble39
DD-WRT Guru


Joined: 11 Jun 2022
Posts: 1848

PostPosted: Mon Sep 12, 2022 20:23    Post subject: Reply with quote
This warning is expected behavior, whether you manually add "no-resolv" and "server=" lines to Additional DNSMasq options textbox or whether SmartDNS is enabled - which should automatically add the no-resolv and server= lines to point to the SmartDNS daemon at the router's IP address and prescribed port number. In other words, the "no-resolv" option is text that is manually added or added by SmartDNS after it's been enabled and config saved; there is no checkbox or radio button or anything else involved. The resolv-file flag / line is part of the standard /tmp/dnsmasq.conf in the firmware. This warning has nothing to do with "Ignore WAN DNS" setting. I guess someone forgot to come full circle to answer this completely(?).
_________________
"The woods are lovely, dark and deep,
But I have promises to keep,
And miles to go before I sleep,
And miles to go before I sleep." - Robert Frost

"I am one of the noticeable ones - notice me" - Dale Frances McKenzie Bozzio

<fact>code knows no gender</fact>

This is me, knowing I've ruffled your feathers, and not giving a ****
Some people are still hard-headed.

--------------------------------------
Mac Pro (Mid 2012) - Two 2.4GHz 6-Core Intel Xeon E5645 processors 64GB 1333MHz DDR3 ECC SDRAM OpenSUSE Leap 15.5
turls
DD-WRT Novice


Joined: 29 May 2010
Posts: 7

PostPosted: Sun Mar 19, 2023 18:37    Post subject: Reply with quote
dale_gribble39 wrote:
This warning is expected behavior, whether you manually add "no-resolv" and "server=" lines to Additional DNSMasq options textbox or whether SmartDNS is enabled - which should automatically add the no-resolv and server= lines to point to the SmartDNS daemon at the router's IP address and prescribed port number. In other words, the "no-resolv" option is text that is manually added or added by SmartDNS after it's been enabled and config saved; there is no checkbox or radio button or anything else involved. The resolv-file flag / line is part of the standard /tmp/dnsmasq.conf in the firmware. This warning has nothing to do with "Ignore WAN DNS" setting. I guess someone forgot to come full circle to answer this completely(?).


Except I don't have any of those and still get the warning in the logs...
I have not manually added "no-resolv"
SmartDNS is not enabled

However, when I view the dnsmasq.conf in \tmp the line is there...so wondering how it is there? I wonder if I delete it in the config file, will it come back? Might try and will report back if I do.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 6333
Location: UK, London, just across the river..

PostPosted: Mon Mar 20, 2023 10:01    Post subject: Reply with quote
48567 is quite an old build isnt it...?? Lots of stuff patched, fixed, updated and so on...
try a newer builds ...last is still WIP on certain stuff..but not that bad for marvell

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 55009 WAP
TP-Link WR1043NDv2 -DD-WRT 55109 Gateway/DoT,Forced DNS,AP Isolation,Ad-Block,Firewall,VPN,x1VLAN
TP-Link WR1043NDv2 -DD-WRT 55052 Gateway/DoT,Forced DNS,Ad-Block,Firewall,x4VLAN,VPN
TP-Link WR1043NDv2 -Gargoyle OS 1.15.x AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 55109 Gateway/DoT,AD-Block,Forced DNS,AP&Net Isolation,x3VLAN,Firewall,Vanilla
Netgear R9000 --DD-WRT 55052 Gateway/DoT,AD-Block,AP Isolation,Firewall,Forced DNS,x2VLAN,Vanilla
Broadcom
Netgear R7000 --DD-WRT 55109 Gateway/SmartDNS/DoH,AD-Block,Firewall,Forced DNS,x3VLAN,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby DNS over TLS I DNSCrypt v2 by mac913
dale_gribble39
DD-WRT Guru


Joined: 11 Jun 2022
Posts: 1848

PostPosted: Mon Mar 20, 2023 15:45    Post subject: Reply with quote
SmartDNS, DNSCrypt, or Unbound being enabled will result in this behavior.

https://svn.dd-wrt.com/browser/src/router/services/services/dnsmasq.c#L684

https://github.com/mirror/dd-wrt/blob/69d29f5fd54d3993a5573cb619bbefd6ef7d3547/src/router/services/services/dnsmasq.c#L684

_________________
"The woods are lovely, dark and deep,
But I have promises to keep,
And miles to go before I sleep,
And miles to go before I sleep." - Robert Frost

"I am one of the noticeable ones - notice me" - Dale Frances McKenzie Bozzio

<fact>code knows no gender</fact>

This is me, knowing I've ruffled your feathers, and not giving a ****
Some people are still hard-headed.

--------------------------------------
Mac Pro (Mid 2012) - Two 2.4GHz 6-Core Intel Xeon E5645 processors 64GB 1333MHz DDR3 ECC SDRAM OpenSUSE Leap 15.5
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum