Cant disable WiFi 5GHZ on Asus RT-AC87U

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Author Message
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 59

PostPosted: Mon Mar 28, 2022 0:36    Post subject: Cant disable WiFi 5GHZ on Asus RT-AC87U Reply with quote
I have a Asus RT-AC87U. I have tried DD-WRT versions from 2019-present but am unable to turn off the 5GHZ radio. I have tried multiple ways to deactivate it but I still see it (and can connect to it) in the list of wifi networks.

if I name the 2.4ghz SSID DDWRT-2 and the 5GHZ DDWRT-5 it appears that the 2.4GHZ radio can be disabled, but not the 5GHZ.

I tried to disable both in the GUI (wireless network mode disabled)

I tried SES / AOSS / EZ-SETUP / WPS Button
'Turning off radio' - button appears to have no effect on radios at all

also turn off radios on boot (under SES button) does not help.

I also tried Wireless/advanced/Radio Time restrictions- always off (all times red)
does not turn off radio

and form a a shell: wl down and wl radio off

what am I missing?
Sponsor
the-joker
DD-WRT Developer/Maintainer


Joined: 31 Jul 2021
Posts: 1581
Location: All over YOUR webs

PostPosted: Mon Mar 28, 2022 10:36    Post subject: Reply with quote
Im not familiar with your router as you noted, you can schedule the radio to always be OFF or on at specific hours only.

See screenshot.

On mine I have both radios off between the hours in red, works fine. Neither are up between those times.

So IDK why it doesn't work on yours, only logs would tell, you may need click apply settings, if not a reboot just to ensure it sticks.

Works here 100% of the time.

Other ways, would be to send the interface down, here the 5G wifi radio is eth2, so make sure its the same on yours, if not find out which and use that instead.

That way you would do.

Code:
sleep5; stopservice nas; wlconf eth2 down; startservice nas


if it works you want to add this to administration tab > commands tab and save as firewall

What that will do is , when you click apply or reboot the router the radio will be turned off.

However the better method is the Radio Time Restrictions.



Capture.PNG
 Description:
Radio Time Restrictions
 Filesize:  6.77 KB
 Viewed:  528 Time(s)

Capture.PNG



_________________
Saving your retinas from the burn!🔥
DD-WRT Inspired themes for routers
DD-WRT Inspired themes for the phpBB Forum
DD-WRT Inspired themes for the SVN Trac & FTP site
Join in for a chat @ #style_it_themes_public:matrix.org or #style_it_themes:discord

DD-WRT UI Themes Bug Reporting and Discussion thread

Router: ANus RT-AC68U E1 (recognized as C1)
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12836
Location: Texas, USA

PostPosted: Mon Mar 28, 2022 14:13    Post subject: Reply with quote
5GHz has the Quantenna chip. 5GHz, if it even works, cannot be turned off AFAIK, but you may be able to use those commands with some degree of luck. This device has always had it's quirks under DD-WRT.

https://wikidevi.wi-cat.ru/ASUS_RT-AC87U

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 59

PostPosted: Mon Mar 28, 2022 17:56    Post subject: Reply with quote
Nope. tried everything including a factory reset and wlconf eth2 down. 5GHZ goes off for a few seconds but then something restarts it
the-joker
DD-WRT Developer/Maintainer


Joined: 31 Jul 2021
Posts: 1581
Location: All over YOUR webs

PostPosted: Mon Mar 28, 2022 19:15    Post subject: Reply with quote
You can run a cron job and check for every N seconds and send the interface back down.

OR

Ignore it, clearly its hard to get every router under the dd-wrt umbrella to be relatively bug free. Im sure a bribe to the right person (not me) would go a,long way Wink joking.

_________________
Saving your retinas from the burn!🔥
DD-WRT Inspired themes for routers
DD-WRT Inspired themes for the phpBB Forum
DD-WRT Inspired themes for the SVN Trac & FTP site
Join in for a chat @ #style_it_themes_public:matrix.org or #style_it_themes:discord

DD-WRT UI Themes Bug Reporting and Discussion thread

Router: ANus RT-AC68U E1 (recognized as C1)
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12836
Location: Texas, USA

PostPosted: Mon Mar 28, 2022 21:18    Post subject: Reply with quote
Likely process_monitor and/or check_ps restarts it. So, setting the mode to "disabled" has no effect? Might need to investigate nvram variables if that is not having any effect to see if there is something that you can issue an nvram set against to disable the interface. That's the only other option that I can think of without looking at the associated code.
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum