SMB Server & Windows XP

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Author Message
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 53

PostPosted: Sat Jan 22, 2022 1:32    Post subject: SMB Server & Windows XP Reply with quote
Just switched out old router that was running 3.0-r31277 2/7/17 for a new one running 3.0-r4911 12/23/21. Was using the old one as a NAS and have several WinXP virtual machines that need to connect to it. I was able to connect the XP machines to the the old router but on the new one I can see the shares but can't log int them.

I know that XP uses SMB 1.0 and tried setting protocol level to "NT 1.0". I actually tried all of the versions in the drop-down but still can't connect to the shares.

Any ideas?

Thank you
Sponsor
eibgrad
DD-WRT Guru


Joined: 18 Sep 2010
Posts: 8997

PostPosted: Sat Jan 22, 2022 2:52    Post subject: Reply with quote
Did you reboot the router after switching to NT 1.0?
_________________
ddwrt-ovpn-split-basic.sh * ddwrt-ovpn-split-advanced.sh * ddwrt-ovpn-kill-switch.sh * ddwrt-ovpn-watchdog.sh * ddwrt-ovpn-remote-access.sh * ddwrt-ovpn-client-backup.sh * ddwrt-mount-usb-drives.sh * ddwrt-blacklist-domains.sh * ddwrt-wol-port-forward.sh * ddwrt-dns-monitor.sh (NEW!)
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 53

PostPosted: Sat Jan 22, 2022 4:58    Post subject: Reply with quote
I had just been hitting SAVE, APPLY but I just tried it with a reboot and still no joy Crying or Very sad
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 6397
Location: Romerike, Norway

PostPosted: Sat Jan 22, 2022 12:59    Post subject: Reply with quote
Have you tried connecting with IP address?

net use \\192.168.1.1\sharename
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 53

PostPosted: Sat Jan 22, 2022 15:40    Post subject: Reply with quote
Let me clarify/update a few things as when I wrote my original post I was so tired from spending the entire afternoon trying to get this to work that there are a few errors in the original post.

On the XP boxes I dont even see the new NAS as a item in Network Neighborhood I do see all of the other shares and computers on the network. I even see the old NAS which obviously has a different name and IP.

I have been trying to connect the XP boxes the entire time using the IP and/or share name (\\192.168.1.50 & \\192.168.1.50\pub).

If I try to connect through Windows I get A login & password prompt box, if I try through a command prompt I am prompted for user/pw but get system error 5 - access denied.

Windows 7 I can see NAS2 under Network and see the shares and connect and also connect using the IP. All works OK under W7 as long as I dont keep the min/max protocol both set to "NT 1.0". I think SMB 1.0 is disabled on W7 so I have it set to min 1.0 / max 2.02
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 9599
Location: Netherlands

PostPosted: Sat Jan 22, 2022 16:04    Post subject: Reply with quote
Windows XP relies on NetBios which is deprecated (as is Windows XP)

DDWRT and recent Windows version use Windows Service Discovery https://en.wikipedia.org/wiki/WS-Discovery

About the asking for password see my attached notes (The wiki is being updated not sure if that is already done)

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 53

PostPosted: Sat Jan 22, 2022 16:27    Post subject: Reply with quote
So that explains a lot.

I downloaded and quickly skimmed the PDF but didnt see any reference to fixing my issue. So does 'depreciated" = no longer compatible , no fix? or is there some way I can get this to work with XP?

If I cant get this firmware to work what version would I need to revert to to be compatible with XP?

Thanks
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 9599
Location: Netherlands

PostPosted: Sat Jan 22, 2022 16:50    Post subject: Reply with quote
Netbios is deprecated and will likely not return, we probably will see mDNS in future windows versions.

So there is no network discovery for XP but it should be possible to connect by IP address as PYB said, I would think.

As I see it you have three options if you really need Network discovery for XP.
1. Upgrade to at least Windows 7.
2. Use an old build but that is not recommended if the router is directly connected to the internet as there are safety issues in older builds, if you want to go this route, I think the last build of 2019 might work for you.
3. Find someone willing and capable to make a build with the old Samba36 (what router are we talking about, you forgot to mention that)

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
JackPollack
DD-WRT User


Joined: 22 May 2015
Posts: 53

PostPosted: Sat Jan 22, 2022 17:20    Post subject: Reply with quote
The router is an Asus AC87U.

I really dont care about network discovery. I am totally happy using IP address, but have spent over 5 hours trying to get the XP boxes to connect using IP address.

I keep getting stuck on login window. I cant get it to connect using user/password (just rejected) or even sharing as public without PW
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 9599
Location: Netherlands

PostPosted: Sun Jan 23, 2022 9:21    Post subject: Reply with quote
Well this is not tested on windows XP so perhaps it is just not possible Sad

However also for Windows 10 you need some tricks if you want to have either guest login, so without any asking for username/password.

The settings which are of interest are the "Minimum protocol version" which must be set at NT1, "Access level", "Public" access and the use of a username/password

You might try Access Level set to Everyone making share Public and no username/password

or Access Level Restricted and a username/password.

Like I said XP is not tested and it will not be tested so might be a dead end Sad

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum