Need help in setting up my A7

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Author Message
DD-WRT Novice

Joined: 04 Jan 2022
Posts: 5

PostPosted: Wed Jan 05, 2022 7:17    Post subject: Need help in setting up my A7 Reply with quote
So I have been unsuccessfully trying to get the following setup to work for the past 2 days, and I am pretty sure I have missed something.

[ISP Router + Modem(] ---wired-to---> [Archer A7v5(] ------> Wireless devices.

This looks pretty simple and I have managed to accomplish this with other routers(Asus, Netgear) years ago, but this time I seem to have the strange problems.

1. If I disconnect the wired connection between the routers, I am able to access admin.
2. If I connect the two routers, the Archer A7 disappears. All devices connected to Archer A7 get an IP address from subnet. There is no way to connect to, even through a browser or SSH. Heck the Archer A7 does not even appear in any LAN-scan utilities and even the attached devices list for But it's there, why? Because the devices are still connected to Archer's SSID, and are able to access the internet.

Any ideas what could I have missed? Also, the goal was to have the Archer A7 act as Wifi AP and DNS resolver(using NextDNS), but not sure which repeater mode would be the best as per the following wiki:

Joined: 18 Mar 2014
Posts: 12795
Location: Netherlands

PostPosted: Wed Jan 05, 2022 8:16    Post subject: Reply with quote
What build are you using?

To get the best out of DDWRT and the forum read the forum guidelines full of helpful pointers:

You are referring to a wireless connection.

Assuming you are using a recent build you can do one of two things.
1. Hit the reset button and connect the WAN port of the Archer to the ISP router that should work right out of the box but the routers will be on different subnets
2. Hit the reset button and setup as a WAP:

Note make sure you set the Gateway and Local DNS to the primary router and do not change the Operating mode to router

Routers:Netgear R7000, R6400v1, R6400v2, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:
Install guide R7800/XR500:
Forum Guide Lines (important read):

Joined: 21 Jan 2017
Posts: 1782
Location: Illinois Moderator

PostPosted: Wed Jan 05, 2022 19:51    Post subject: Reply with quote
You need to describe in better detail what you want to accomplish because right now it sounds like the modem/router combo is doing all the heavy lifting and what you want to accomplish the way you've written it is not possible. The DNS from the A7 will be "overwritten" likely by the modem/router combo with your present setup.

Usually, you would put the modem/router combo from the ISP into bridge mode and let the A7 do all of the work for you; but, again, we don't know what you're really trying to accomplish so I would start with that full explanation first and then we can point you to the right guides to read.

P.S. I changed your subject to something more meaningful for people than what you originally posted.


TIPS/TRICKS: Best QCA Wifi Settings | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]52396 nightly (Main Router)
[EA8500]43192 & 45493 (2xOffsite)
[R7800] resting
[WDR3600]BS 44715 (Offsite)
[A7v5]BS 43038 (Offsite+spare napping)
DD-WRT Novice

Joined: 04 Jan 2022
Posts: 5

PostPosted: Thu Jan 06, 2022 4:56    Post subject: Reply with quote
Okay. Let me try again.

DD-WRT Build: 47942

What you've described pretty much sums it up. Currently, I am wirelessly connected to the ISP router which acts as a DNS and DHCP server as well.

I wish to connect Archer A7 to ISP router with a wired link, turn off wireless on ISPR, and have Archer A7 be used as a wireless AP for all devices. The Archer-A7 also needs to handle DNS for the network.

Please do note that the sole purpose of placing an extra router is DNS. The ISP router does not have a DDNS option, and it resets to default ISP DNS every few hours. This makes it near impossible for me to use NextDNS.

I've tried what is mentioned in the link posted by egc and almost have it running:

The big problem I keep running into repeatedly is the Router admin interface does not proceed ahead from the Status page, no matter what link I click on. I have tried resetting the router(I know it got reset because it asked to set a new admin/password); I've left it without power supply for almost 2 hours; and numerous reboots.

Sometimes it works for a couple of pages, then goes back to loading perpetually. What is even more strange that "a few times" it works fine on the mobile browser, while at the same time on the desktop browsers(Firefox/Safari/Edge) it refuses to proceed ahead from the status page. It is utterly baffling.

This is the problem that needs to be addressed first, before I even go about setting things.

Joined: 08 May 2018
Posts: 14079
Location: Texas, USA

PostPosted: Thu Jan 06, 2022 6:01    Post subject: Reply with quote
Did your browser save the login credentials or something? Reset, browse to the webUI, set password (user is always root, I never change that). It will take you to the "info" page. Then when you click on any tab from there, you should have to enter username and password. If your browser saved credentials for the router's URL, it's going to balk. The only other thing that would be of any consequence is the status of the wireless access to webUI being disabled by default causing issues. Outside of that, private browsing, no add-ons or extensions...
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
DD-WRT Releases 2023 (PolitePol)
DD-WRT Releases 2023 (RSS Everything)

Linux User #377467 /
DD-WRT Novice

Joined: 04 Jan 2022
Posts: 5

PostPosted: Fri Jan 07, 2022 7:23    Post subject: Reply with quote
So yes, Private Browsing fixes i To the extent that I've been able to complete the entire setup by private browsing.

Everything is up and running perfectly.

I've tried enabling DNSmasq and NextDNS through it, however it hasn't really worked. A note here that my WAN Connection type is Disabled in DD-WRT. Is it supposed to work with WAN disabled in the router?
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum