R8000P - Much Weaker Wireless than Standard Firmware?

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Author Message
DD-WRT Novice

Joined: 28 Dec 2021
Posts: 2

PostPosted: Tue Dec 28, 2021 23:34    Post subject: R8000P - Much Weaker Wireless than Standard Firmware? Reply with quote
Hello All,

I recently flashed DD-WRT v3.0-r47900 std (12/20/21) to my Linksys R8000P Nighthawk router. I got this from the beta build downloads section of this website and NOT the router database like it says to do in the documentation. I found the exact folder for my router and used the most recent one.

I thought my wireless speeds might be slower than the Linksys firmware, but wasn't really sweating it too much. Like one of the TV's in the house would reduce resolution of what it was streaming which never happened before, but I kind of shrugged it off.

Went back to work today and using all the stuff in my office again and definitely noticed it in a major way. I have an older house with plaster walls, router is one floor below me but only about 20 feet away.

I used to get ~10-20MB on one of the 5G radios which was more than enough for what I was doing with it.

After flashing DD-WRT I am getting less than 1MB. Doesn't seem to matter which radio I am connecting to - one of the 5G's is not even usable and both the 2.4G and other 5G give me ~1MB.

I have followed a few guides on here about what settings to manually change in order to increase wireless performance including manually setting the most unused channel in my area (doesn't actually matter what channel I use they all get roughly the same speed), setting the Wireless network mode to AC/N Mixed, setting the channel width to VT80, and also toggling Implicit/Explicit beamforming.

I have tried just about every single configuration of those settings and nothing has made significant difference, like some make it worse, but still nothing over 1MB.

If someone could please tell me that I am using the wrong firmware for my device or what settings I need to change I would greatly appreciate it.

If you all have no idea what dust I am smoking then I could use some help to just get this thing back to the Linksys firmware. I have to use this for work and under 1MB is simply not usable. I have tried a whole bunch of stuff on here and the broader Internet for getting this thing to flash back to the Linksys firmware and none of them have worked. The GUI firmware update definitely didn't work, have tried all manner of flashing time waiting and hitting the factory reset and unplugging in tons of different ways that have been suggested to work on here or the Internet.

I work in IT for a living and have an IT degree that was heavy on networking so I'm not clueless I should be able to provide any data you need or follow any steps you can give.

I don't really want to fork out the cash for a new router right after Christmas so any help you can provide would be greatly appreciated!

DD-WRT Novice

Joined: 09 Dec 2006
Posts: 31

PostPosted: Wed Dec 29, 2021 3:25    Post subject: Reply with quote
Did you do a CLI or telnet, nvram erase after switching to DD-WRT? You will have to set the router up again after doing so, so if you have an elaborate config I'd document it first.

It's definitely the next thing I'd try, as I just went through an issue myself not doing that from stock netgear firmware. If you did do an nvram erase, then I would do a reset to start from scratch again, in case some setting was a problem.

At the same time, using newest DD-WRT makes you a beta tester so I would try an older version (few months older, gives more time for problem reports and look through the build topics in this subforum) before reverting back to the Netgear stock firmware.

I wouldn't change the DD-WRT defaults, "yet". The tweaks for more performance aren't needed to merely get far more than 1Mb, seems like more of a chance to introduce a problem before you have a baseline performance that you'd expect.

If you think there is metal in your walls and floor (for example foil lined insulation), it might be best to make an ethernet run up to that room, even if it terminates in an access point for wifi instead of wired, but it seems telling that you didn't seem to have the problem before DD-WRT so shouldn't have to do that.

What have you tried to get it back to stock firmware that didn't work? If it's an elaborate guide maybe link to that?

Also, your Linksys router thinks it is a Netgear. Wink

Last edited by mono on Wed Dec 29, 2021 4:47; edited 1 time in total
DD-WRT Novice

Joined: 28 Dec 2021
Posts: 2

PostPosted: Wed Dec 29, 2021 4:15    Post subject: Reply with quote
Thanks friend that seemed to be the missing piece of the puzzle. Cool

For anyone else coming across this later:

Hardwired a Windows 10 computer to the router with ethernet cable.

On Windows 10 I went to Control Panel, Programs and Features, on the left "Turn Windows Features On or Off" and from that menu I clicked the box for Telnet Client and clicked OK, it installed/enabled the built in Telnet client in Command Prompt.

Then opened Command Prompt and typed:

Got a login prompt for the router.

use 'root' as the username and the password you setup on the router for the admin account as the password. Got root access to the router and typed:
nvram erase

You will get no confirmation anything happened just another command line prompt. Gave it a few seconds.

Then I powered the router on and off. Got to admit I thought I bricked it because it took forever to fully come back up, the LED's including the one for power were going amber and dark and amber again a few times like it was stuck in a loop, but it eventually came back up completely after about ~2-3 minutes.

Was able to access the router at through a web browser and it was all on DD WRT factory defaults. Setup the wireless settings again, just changing SSID and the password for connecting to it.

Went back upstairs to my office and it is getting decent signal strength and the speed is cruising around 90MB so it is a huge improvement from the Netgear (thx for the correction LOL brain kind of fried about this) firmware and the 1MB that DDWRTI was getting before the NVRAM erase.

Glad I got this sorted I was really baffled because I had used DDWRT in the past on other stuff and it was always an improvement. I knew something was jacked but couldn't figure it out for the life of me.

Thanks for clearing this up and hope it can help someone else in the future with the same issue.

Cheers mate!
DD-WRT Novice

Joined: 23 Dec 2012
Posts: 2

PostPosted: Fri Jan 14, 2022 19:26    Post subject: Reply with quote

Interesting post - however I thought (based on the router DB, compatibility list and various posts in the forum) that the Netgear R8000P does not work with DD WRT.

Did you really successfully flash a "P" version? Does it really work? If yes which firmware did you use?

Looking forward to your answer...


Joined: 08 May 2018
Posts: 12825
Location: Texas, USA

PostPosted: Fri Jan 14, 2022 20:22    Post subject: Reply with quote
Somehow, I doubt it's an R8000P since there isn't an official port for it yet.
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

Linux User #377467 counter.li.org / linuxcounter.net
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum