[SOLVED] Lost Web Interface - What Now?

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2
Author Message
mono
DD-WRT Novice


Joined: 09 Dec 2006
Posts: 31

PostPosted: Sun Dec 26, 2021 0:21    Post subject: Reply with quote
My browser doesn't default to https if I just input the IP # in the URL bar (type "192.168.0.1" and hit enter), and the shortcut I've been using for a decade for the old DD-WRT router it replaces is http://192.168.0.1/ (just double checked this), has same failure to connect to web gui.

Out of curiosity I typed https://192.168.0.1 and there is a significant difference, that the connection is refused immediately instead of timing out after several seconds like it does when the web gui becomes unresponsive, BUT, right now the web gui is working so...

I'm about 99.999999999% sure it isn't the browser, especially since the first thing I did was try different browsers and systems. I haven't tried over wifi yet and will try that next time, if there is a next time. I hope it's that USB over IP setting since I don't seem to need it anyway.

Maybe I should set up my other newer router to r47900 or thereabouts, config it exactly the same (as much as possible, it's a Mediatek running DD-WRT r44715, but then if (since) it doesn't have this web GUI loss problem on r44715, maybe just use it instead. Better wifi, worse processor. It's always something.


Last edited by mono on Sun Dec 26, 2021 0:32; edited 2 times in total
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12855
Location: Texas, USA

PostPosted: Sun Dec 26, 2021 0:25    Post subject: Reply with quote
You can type in http all you want if the settings in the browser are set a certain way and it will not matter. I have literally been in and out of the webUI of about a dozen routers here on the bench without issues. I give up on what the problem is other than doing a hard reset and reconfigure from scratch (not using a backup file) and check each new setting as you go until it breaks.
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
mono
DD-WRT Novice


Joined: 09 Dec 2006
Posts: 31

PostPosted: Sun Dec 26, 2021 0:42    Post subject: Reply with quote
Old DD-WRT router won't connect over https either, but connects every time using same method that fails on the new one after its ran a few hours.

It's not the browser.

EDIT: Okay now that I've been mucking around in DD-WRT GUI so much in last 3 days, I'm remembering where things are, getting things done faster.

Have cleared NVRAM and configured from scratch as before. We'll see, then I'll start disabling things like USB support.


Last edited by mono on Sun Dec 26, 2021 3:22; edited 1 time in total
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 1291

PostPosted: Sun Dec 26, 2021 2:46    Post subject: Reply with quote
The only other dumb questions/thoughts I had is when you telnet in check to see if the router has run out of memory...

Then in theory you could manually kill the httpd process and start it again manually
mono
DD-WRT Novice


Joined: 09 Dec 2006
Posts: 31

PostPosted: Sun Dec 26, 2021 3:56    Post subject: Reply with quote
^ When this GUI loss happened earlier today, I telnetted in and got this:

0;root@R6700: ~root@R6700:~# more /proc/meminfo
total: used: free: shared: buffers: cached:
Mem: 259698688 129384448 130314240 0 9117696 71376896
Swap: 0 0 0
MemTotal: 253612 kB
MemFree: 127260 kB
MemShared: 0 kB
Buffers: 8904 kB
Cached: 69704 kB
SwapCached: 0 kB
Active: 20508 kB
Inactive: 61116 kB
MemAvailable: 129924 kB
Active(anon): 3012 kB
Inactive(anon): 0 kB
Active(file): 17496 kB
Inactive(file): 61116 kB
Unevictable: 0 kB
Mlocked: 0 kB
HighTotal: 131072 kB
HighFree: 87532 kB
LowTotal: 122540 kB
LowFree: 39728 kB
SwapTotal: 0 kB
SwapFree: 0 kB
Dirty: 0 kB
Writeback: 0 kB
AnonPages: 3048 kB
Mapped: 3920 kB
Shmem: 0 kB
Slab: 9152 kB
SReclaimable: 2556 kB
SUnreclaim: 6596 kB
KernelStack: 784 kB
PageTables: 360 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 202888 kB
Committed_AS: 8272 kB
VmallocTotal: 1949696 kB
VmallocUsed: 0 kB
VmallocChunk: 0 kB

I appreciate the idea to kill a process and restart it but that does not seem sustainable, long term if the problem reoccurs (more often than) daily.

If it doesn't get resolved in the next day or two, I'll just swap in some other router without the issue and be more relaxed about resolving it, doesn't help that it's been a very busy couple days due to Christmas.

It could be as simple as "I'm an idiot who didn't follow directions" when I didn't clear the nvram, won't know if doing that made any difference until it does/doesn't have higher uptime, sometime tomorrow.
mono
DD-WRT Novice


Joined: 09 Dec 2006
Posts: 31

PostPosted: Sun Dec 26, 2021 22:52    Post subject: Reply with quote
Clearing nvram seems to have helped if not entirely fixed the problem. It's now near 24hrs uptime, web gui still working.

Edit 12/27 - Now nearly another 24hrs without any GUI loss. Hoping it's fixed, will only add more status reports if it goes away again.
foz111
DD-WRT Guru


Joined: 01 Oct 2017
Posts: 549
Location: Earth

PostPosted: Wed Jan 05, 2022 10:09    Post subject: Reply with quote
Save rebooting your should be able to restart the httpd server from Cli with:
Code:
stopservice httpd && sleep 6 && startservice httpd

or stop the web interface service:
Code:
stopservice httpd
& to start it up again
Code:
startservice httpd

not a fix but hope this helps

_________________
Netgear R7800 PPPoE Main Router
Network IPV4 eth1 - Isolated Vlan eth1.3 on br1 For IoT Devices With 3 x Linksys velop Bridged mesh Nodes (Amazon Echos, smart TV's, etc.)
BT Whole Home 4 Node Mesh Wi-Fi, Router Wi-Fi Disabled. OVPN Server With Paid OVPN client & Wireguard Client.
Gateway Mode, DNSMasq, Static Leases & DHCP, Pi-Hole DNS & Running Unbound.
mono
DD-WRT Novice


Joined: 09 Dec 2006
Posts: 31

PostPosted: Wed Jan 05, 2022 17:16    Post subject: Reply with quote
^ Thanks, but it's been over a week now with no web gui loss after the nvram erase, and reconfigured same as before, so seems solved. I've edited topic title to reflect this.
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum