New Build - 09/20/2021 - r47474

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5  Next
Author Message
hurleyp
DD-WRT User


Joined: 10 Sep 2009
Posts: 343
Location: Ottawa, Ontario, Canada

PostPosted: Wed Sep 22, 2021 13:23    Post subject: Reply with quote
Firmware: v3.0-r47474 std (09/20/21)
Router/Version: Netgear R7000
Kernel: Linux 4.4.283 #4096 SMP Mon Sep 20 05:45:13 +07 2021 armv7l
Previous: v3.0-r47381 std (09/08/21)
Mode/Status: AP wired and wireless / Up and running for 24 hours
Reset: Soft boot before and after upgrade
Temperatures: CPU 62.5 °C / WL0 47.1 °C / WL1 52.1 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

Upload and Download speeds are to ISP spec. Nothing unexpected in the syslog.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- Shortcut Forwarding Engine: CTF, Flow Acceleration: Disabled
- STP - Enabled
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 36, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: disabled.
- USB support - Off
- No custom scripts
- No: ttraf, Tor, VNC, Zabbix, VPN, Radius, OpenVPN
- No: UPnP, DMZ, QoS
- No: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware

_________________
Netgear R7000: v3.0-r47665 std (11/24/21)
EdgeRouter-X: EdgeOS v2.0.9-hotfix 2
Sponsor
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2651
Location: Indy

PostPosted: Wed Sep 22, 2021 15:45    Post subject: Reply with quote
jwh7 wrote:
For completeness, since I was researching it for BS, I found the last working CB build for the old WRT54GL was 46788. r47475 fixes the Switch Config display, but not CB/AP setup.
Since I know y'all care (or maybe at least just mrjcd... Cool ), broadcom and k2.6 configs will be fixed in the next release. CB/AP issues are now resolved. BS found an issue related to the WAN due to the K3X swconfig/vlan changes. GUI responsiveness seems fine now too. \o/
_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
OPNsense x64 5050e ITX|DD: DIR-810L, 2*EA6900@1GHz, R6300v1, RT-N66U@663, WNDR4000@533, E1500@353,
WRT54G{Lv1.1,Sv6}@250
|FreshTomato: F7D8302@532|OpenWRT: F9K1119v1, RT-ACRH13, R6220, WNDR3700v4
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11149
Location: Texas, USA

PostPosted: Wed Sep 22, 2021 15:54    Post subject: Reply with quote
Now all we need is Repeater modes fixed and working... Twisted Evil Razz Rolling Eyes Laughing
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
jacdc
DD-WRT Novice


Joined: 19 May 2021
Posts: 21

PostPosted: Wed Sep 22, 2021 17:34    Post subject: CTF/FA enabled - working for you? Reply with quote
hurleyp wrote:
Firmware: v3.0-r47474 std (09/20/21)
Router/Version: Netgear R7000
Kernel: Linux 4.4.283 #4096 SMP Mon Sep 20 05:45:13 +07 2021 armv7l
Previous: v3.0-r47381 std (09/08/21)
Mode/Status: AP wired and wireless / Up and running for 24 hours
Reset: Soft boot before and after upgrade
Temperatures: CPU 62.5 °C / WL0 47.1 °C / WL1 52.1 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

Upload and Download speeds are to ISP spec. Nothing unexpected in the syslog.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- Shortcut Forwarding Engine: CTF, Flow Acceleration: Disabled
- STP - Enabled
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 36, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: disabled.
- USB support - Off
- No custom scripts
- No: ttraf, Tor, VNC, Zabbix, VPN, Radius, OpenVPN
- No: UPnP, DMZ, QoS
- No: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware


Hi - you mentioned that your router (R7000) is performing to spec. - is your ISP connection greater than 300-400 Mbit up/down? Reason I ask, is that my ISP is 1Gb up/down and I can only get these speeds with CTF/FA enabled on my R7000 (but doing so breaks non-standard Port Forwarding rules). I tried this latest release r47474 - and port forwarding still not working. I also opened an SVN Trac ticket - https://svn.dd-wrt.com/ticket/7472 so hopefully this can get looked at (router logs/info provided in the SVN ticket). I also opened a Forum thread to discuss possible workarounds (IPtables MARK method mostly) but this discussion/progress has stopped - no working solutions.

Curious if Port Forwarding works for you with CTF enabled nonetheless ( I attempted a simple port forward from an NVRAM reset - still did not work). Idea was floated earlier to disable Port Forwarding tab in DDWRT UI if user selects CTF as the Shortcut Forwarding Engine (for now).

J
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11149
Location: Texas, USA

PostPosted: Wed Sep 22, 2021 18:30    Post subject: Reply with quote
So, has any of the Shaw, Charter, Spectrum, etc. customers with the previous search wan domain being forced issue tested and confirmed the patch works? I see no reports...
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
silvermoong
DD-WRT Novice


Joined: 21 Sep 2021
Posts: 2

PostPosted: Wed Sep 22, 2021 19:24    Post subject: Reply with quote
mwchang wrote:
silvermoong wrote:
1. Connecting from Windows to NAS over Samba, I failed to open/list files under any folder with more than 400 files. I can always reproduce this by creating a folder with than 400 blank .txt files. It fails in both file explorer and Samba commands in PowerShell.

In the root directory? Of a FAT32 partition? Don't try that. Shove them into a sub-directory or sub-folder.

And if possible, use EXT3 file-system instead of FAT32 nor NTFS.



Thanks for the suggestions.

These folders are sub-folders. I'm able to access any other folders with less files. It only fails for Samba in Windows. (FTP, Samba command in Ubuntu are working)

Both issues are not occurring in the old DD-WRT version with a NTFS HHD.

I'm thinking of switching to EXT3 or EXT 4. However, I have some data in the current NTFS HDD. I'm not sure how to efficiently transfer them to an EXT 3 HDD as I only have Windows PCs.
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2651
Location: Indy

PostPosted: Wed Sep 22, 2021 23:49    Post subject: Reply with quote
silvermoong wrote:
I'm thinking of switching to EXT3 or EXT 4. However, I have some data in the current NTFS HDD. I'm not sure how to efficiently transfer them to an EXT3 HDD as I only have Windows PCs.
https://sourceforge.net/projects/ext2fsd/
https://github.com/bobranten/Ext4Fsd
Looks like Paragon has something too.

_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
OPNsense x64 5050e ITX|DD: DIR-810L, 2*EA6900@1GHz, R6300v1, RT-N66U@663, WNDR4000@533, E1500@353,
WRT54G{Lv1.1,Sv6}@250
|FreshTomato: F7D8302@532|OpenWRT: F9K1119v1, RT-ACRH13, R6220, WNDR3700v4
itwontbewe
DD-WRT User


Joined: 29 Sep 2020
Posts: 159

PostPosted: Thu Sep 23, 2021 0:48    Post subject: Reply with quote
Router Model: Netgear R7000P
Firmware Version: DD-WRT v3.0-r47474 std (09/20/21)
Kernel Version: Linux 4.4.283 #4102 SMP Mon Sep 20 08:20:14 +07 2021 armv7l
Reset: no
Operating Mode/Setup: Gateway / AP Unbound JFFS2
Status: running well. thanks BS and dd-wrt community

kernel-panic69 wrote:
So, has any of the Shaw, Charter, Spectrum, etc. customers with the previous search wan domain being forced issue tested and confirmed the patch works? I see no reports...


Spectrum here. my setup

Setup/Basic Setup
Ignore WAN DNS: Enabled

Services/Services
DHCP Server
Used Domain: LAN & WLAN
LAN Domain: home.arpa

/tmp/resolv.conf only shows
search home.arpa

works for me. thanks
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11149
Location: Texas, USA

PostPosted: Thu Sep 23, 2021 2:27    Post subject: Reply with quote
@itwontbewe: Thanks for the report; @egc wrote the patch, I won't claim any responsibility... "I'm too stupid" Cool
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
the-joker
DD-WRT Developer/Maintainer


Joined: 31 Jul 2021
Posts: 259
Location: All over the webs

PostPosted: Thu Sep 23, 2021 8:41    Post subject: Reply with quote
silvermoong wrote:
I'm thinking of switching to EXT3 or EXT 4. However, I have some data in the current NTFS HDD. I'm not sure how to efficiently transfer them to an EXT3 HDD as I only have Windows PCs.


You can simply download any Linux distro of your preference and create a bootable USB, boot you PC from that and handle NTFS data to EXT4 easily without installing any 3rd party Linux filesystem drivers into Windows.

On a note relevant to myself and the topic.

Router/Version: Asus RT-AC68U E1
File/Kernel: Linux 4.4.283 #4096 SMP Mon Sep 20 05:45:13 +07 2021 armv7l
Previous/Reset: r47381 / As per doctor orders
Mode/Status: Gateway / mostly operational
Issues/Errors: 2 issues.

1) VAP clients get disconnected on clicking Apply on any page for any reason. Wont reconnect until - Known workaround command line interfaces/NAS down/up (its also stored as a startup command in nvram)

2) I started noticing when I visit websites (doesnt matter if its something I visited the night before or new), no matter which browser but mostly Firefox 92, immediate (Hmm. We’re having trouble finding that site.) and upon trying again (sometimes 2/3 time) it loads the site.

Reverted to previous Version for a quick test and the 2nd issue doesn't seem to be, (1st issue has existed for a few builds now and will exist for many more I guess).

Syslogs show nothing helpful or related/firewall logs only dropping meaningless stuff.

I have cleared DNS both on OS and DD-WRT

So I wonder if this is just me or what? Everyone reports mostly nothing of the sort if anything is reported at all (going back through old such like topics as this)

_________________
Saving your retinas from the burn!🔥
DD-WRT Inspired themes for routers
DD-WRT Inspired themes for the phpBB Forum
DD-WRT Inspired themes for the SVN Trac & FTP site
Join in for a chat @
#style_it_themes_public:matrix.org or
#dd-wrt_non_official:matrix.org
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5597
Location: Texas

PostPosted: Thu Sep 23, 2021 11:27    Post subject: Reply with quote
the-joker wrote:
2) I started noticing when I visit websites (doesnt matter if its something I visited the night before or new), no matter which browser but mostly Firefox 92, immediate (Hmm. We’re having trouble finding that site.) and upon trying again (sometimes 2/3 time) it loads the site.
,,,,So I wonder if this is just me or what?

NO, not just you Razz
Started seeing exact same only after installing Firefox 92.0 (2~3 days back)
running WIN10
OS Build 19043.1237

AFAIK it is NOT DD-WRT related ...anyways:
Linksys EA8500 ...main gateway w/ public IP
DD-WRT v3.0-r47474 std (09/20/21)
Linux 4.9.282 #466 SMP Mon Sep 20 04:24:30 +07 2021 armv7l
Dracula theme Cool current uptime 3 days, 8:38
it is using 'unbound' and NO the WIN10 FF does NOT get around it ...I checked more than once
AND
Never seen such nonsensence with any browser on Debian (Bullseye or Bookworm)

---
EDIT:
goes right thru fine after you click the 'Try Again'
however I do consider it an annoying PITA


Last edited by mrjcd on Thu Sep 23, 2021 12:16; edited 1 time in total
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11149
Location: Texas, USA

PostPosted: Thu Sep 23, 2021 12:00    Post subject: Reply with quote
Was testing using secure dns functionality in the browser disabled or enabled? Most browsers are configured to use secure dns using current provider by default.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
the-joker
DD-WRT Developer/Maintainer


Joined: 31 Jul 2021
Posts: 259
Location: All over the webs

PostPosted: Thu Sep 23, 2021 12:18    Post subject: Reply with quote
mrjcd wrote:

NO, not just you Razz
Started seeing exact same only after installing Firefox 92.0 (2~3 days back)
running WIN10
OS Build 19043.1237

AFAIK it is NOT DD-WRT related ...anyways:


Well its not Firefox only, Edge chromium,G Chrome all do the same with different degrees of success.

How can you tell its not dd-wrt related? if it isnt then plugging the modem into a machine directly would be able to repro, and cannot.

Also previous dd-wrt release seems to work fine with exactly same browsers.

So what gives?

thoughts on what it could be?

kernel-panic69 wrote:
Was testing using secure dns functionality in the browser disabled or enabled? Most browsers are configured to use secure dns using current provider by default.


Disabled, because this bypasses host files in any OS. And I do more specific blocks for telemetry and other things on a per machine basis using hosts files and the like.

_________________
Saving your retinas from the burn!🔥
DD-WRT Inspired themes for routers
DD-WRT Inspired themes for the phpBB Forum
DD-WRT Inspired themes for the SVN Trac & FTP site
Join in for a chat @
#style_it_themes_public:matrix.org or
#dd-wrt_non_official:matrix.org
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11149
Location: Texas, USA

PostPosted: Thu Sep 23, 2021 12:36    Post subject: Reply with quote
The only thing that changed after 47381 that would affect it is that dnsmasq was updated. Not sure if any post v2.86 commits are related or not as I have not gone that far.

https://svn.dd-wrt.com/search?q=dnsmasq

https://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=shortlog

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5597
Location: Texas

PostPosted: Thu Sep 23, 2021 13:14    Post subject: Reply with quote
I really hardly ever use WIN10
so anyways
Never seen it on Chrome 94.0.4606.54
I never use Edge browser.
little more tinkering shows me when accessing any http FF gets in a hissy but does its thing after clink 'Try Again'
from previous pic I posted I tried to access
http://users.brazosnet.com/~jcd/
it is way oldass 20MB directory/stuff they gave users many years ago. NOT sure why they ain't made it all https

ISP main is https://www.brazosnet.com/
Goto page Previous  1, 2, 3, 4, 5  Next Display posts from previous:    Page 3 of 5
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum