New Build - 07/22/2021 - r47086

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2
Author Message
hurleyp
DD-WRT User


Joined: 10 Sep 2009
Posts: 331
Location: Ottawa, Ontario, Canada

PostPosted: Sat Jul 24, 2021 13:17    Post subject: Reply with quote
Firmware: v3.0-r47086 std (07/22/21)
Router/Version: Netgear R7000
Kernel: Linux 4.4.276 #3709 SMP Thu Jul 22 02:07:13 +07 2021 armv7l
Previous: v3.0-r47074 std (07/20/21)
Mode/Status: AP wired and wireless / Up and running for 24 hours
Reset: Soft boot before and after upgrade
Temperatures: CPU 62.5 °C / WL0 47.0 °C / WL1 52.0 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

Upload and Download speeds are to ISP spec. Nothing unexpected in the syslog.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- Shortcut Forwarding Engine: CTF, Flow Acceleration: Disabled
- STP - Enabled
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 36, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: disabled.
- USB support - Off
- No custom scripts
- No: ttraf, Tor, VNC, Zabbix, VPN, Radius, OpenVPN
- No: UPnP, DMZ, QoS
- No: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware

_________________
Netgear R7000: v3.0-r47474 std (09/20/21)
EdgeRouter-X: EdgeOS v2.0.9-hotfix 2
Sponsor
Cows
DD-WRT Novice


Joined: 06 Dec 2015
Posts: 26

PostPosted: Sat Jul 24, 2021 16:35    Post subject: Reply with quote
Router/Version: Tplink Archer C1900
File/Kernel: archer-c1900-webflash.bin
Previous/Reset: Last build was some early June build. Did an nvram erase && reboot after flashing
Mode/Status: Endlessly rebooting
Issues/Errors: Flashed this over some build I that was from early to mid June and all seemed well on boot. I waited a few minutes and did a nvram erase && reboot and now it seems to be endlessly rebooting. The power light goes on once and then flashes and then every light turns on for a second and it repeats that. I don't have time to mess with it right now but I guess I will look into it more later.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 10160
Location: Texas, USA

PostPosted: Sat Jul 24, 2021 17:37    Post subject: Reply with quote
If you could provide serial console output of the brick / bootloop so it can be forwarded to BrainSlayer, that would be awesome.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kribby
DD-WRT Novice


Joined: 10 Apr 2008
Posts: 10

PostPosted: Sat Jul 24, 2021 20:27    Post subject: Reply with quote
Firmware: v3.0-r47086 std (07/22/21)
Router/Version: TP-Link Archer C9 v1
Kernel: Linux 4.4.276 #3711 SMP Thu Jul 22 02:27:54 +07 2021 armv7l
Previous: 07-08-2021-r47033
Mode/Status: Gateway / Seems to be working fine except for problem detailed below
Reset:
Temperatures: CPU 70.8 °C / WL0 48.0 °C / WL1 50.8 °C
Issues/Errors:

Download speed is cut in half using 'SFE' Shortcut Forwarding Engine. When moving to 'CTF', I'm able to get full download saturation within my gigabit network. However with CTF, "Filter WAN NAT Redirection" seems to always be enabled

Both tests were done with 'CTF & FA' Flow Acceleration and QoS disabled



CTF.png
 Description:
 Filesize:  43.3 KB
 Viewed:  1006 Time(s)

CTF.png



SFE.png
 Description:
 Filesize:  42.38 KB
 Viewed:  1006 Time(s)

SFE.png


kooper2013
DD-WRT User


Joined: 10 Jan 2013
Posts: 90
Location: DE

PostPosted: Sat Jul 24, 2021 21:17    Post subject: Reply with quote
Router/Version: Asus RT-AC87U
File/Kernel: ftp../asus_rt-ac87u-firmware.trx / Linux 4.4.276 #3717 SMP Thu Jul 22 03:10:07 +07 2021 armv7l
Previous/Reset: r46974/no
Mode/Status: Gateway, WAN disabled, Wireguard client (to commercial service), DHCP-server (dnsmasq)
Issues/Errors: Unusable: clients have no connectivity to the internet, but router has

Last working build is r47040. Perhaps something is wrong with changeset 47053 (egc's changes for wg).

No client can reach the internet, IPs are resolved on the clients when pinging www.google.com from client, but all pings timeout.

The routing-table is same.

ntp and handshake of wg-status are normal.
ping and traceroute are normal via ssh directly on the router.

SFE on/off doesn't matter.

Probably relevant enabled wg-settings (can't try disabling each right now):
CVE-2019-14899 Mitigation
NAT via tunnel
Firewall inbound
Kill Switch
Local Private Key
Route Allowed IP's via tunnel
Endpoint
Allowed IPs 0.0.0.0/0

I could provide logs, if necessary.
Now on r47040.

_________________
3xBuffalo WLI-H4-D1300
1xBuffalo WZR-D1800H
1xBuffalo WHR-HP-G300N
1xBuffalo WHR-1166D (stock f/w)
1xAsus RT-AC87U
1xAsus RT-AC88U
1xTP710
Huike
DD-WRT Novice


Joined: 10 Sep 2016
Posts: 17

PostPosted: Sun Jul 25, 2021 2:01    Post subject: Reply with quote
Router/Version: Netgear R8000
File/Kernel: Firmware: DD-WRT v3.0-r47086 std
Previous/Reset: DD-WRT v3.0-r3.0r47043 std / no reset
Mode/Status: WiFi AP, WAN as DHCP client with VLAN tagging 10.
Issues/Errors:

The Wireless Security -> Apply Settings button is still not working. Click on it will break the internet connection.

The Privoxy is not working. When it's enabled the internet connection is broken.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 10160
Location: Texas, USA

PostPosted: Sun Jul 25, 2021 2:26    Post subject: Reply with quote
Completely or for a few minutes? Actual steps to reproduce and logs would sure help.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kribby
DD-WRT Novice


Joined: 10 Apr 2008
Posts: 10

PostPosted: Sun Jul 25, 2021 14:59    Post subject: Reply with quote
kribby wrote:
Firmware: v3.0-r47086 std (07/22/21)
Router/Version: TP-Link Archer C9 v1
Kernel: Linux 4.4.276 #3711 SMP Thu Jul 22 02:27:54 +07 2021 armv7l
Previous: 07-08-2021-r47033
Mode/Status: Gateway / Seems to be working fine except for problem detailed below
Reset:
Temperatures: CPU 70.8 °C / WL0 48.0 °C / WL1 50.8 °C
Issues/Errors:

Download speed is cut in half using 'SFE' Shortcut Forwarding Engine. When moving to 'CTF', I'm able to get full download saturation within my gigabit network. However with CTF, "Filter WAN NAT Redirection" seems to always be enabled

Both tests were done with 'CTF & FA' Flow Acceleration and QoS disabled
I forgot to note that I had no problems with SFE before a certain version. I don't remember which one this all started on, but I believe it was the one where the "Flow Acceleration" option became available to me
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8174
Location: Netherlands

PostPosted: Sun Jul 25, 2021 15:47    Post subject: Reply with quote
kooper2013 wrote:
Router/Version: Asus RT-AC87U
File/Kernel: ftp../asus_rt-ac87u-firmware.trx / Linux 4.4.276 #3717 SMP Thu Jul 22 03:10:07 +07 2021 armv7l
Previous/Reset: r46974/no
Mode/Status: Gateway, WAN disabled, Wireguard client (to commercial service), DHCP-server (dnsmasq)
Issues/Errors: Unusable: clients have no connectivity to the internet, but router has

Last working build is r47040. Perhaps something is wrong with changeset 47053 (egc's changes for wg).

No client can reach the internet, IPs are resolved on the clients when pinging www.google.com from client, but all pings timeout.

The routing-table is same.

ntp and handshake of wg-status are normal.
ping and traceroute are normal via ssh directly on the router.

SFE on/off doesn't matter.

Probably relevant enabled wg-settings (can't try disabling each right now):
CVE-2019-14899 Mitigation
NAT via tunnel
Firewall inbound
Kill Switch
Local Private Key
Route Allowed IP's via tunnel
Endpoint
Allowed IPs 0.0.0.0/0

I could provide logs, if necessary.
Now on r47040.


I see you are running WG on a Wireless Access Point.
In that case do not use the built-in killswitch.
If you want a killswitch use:
Code:
iptables -I FORWARD -i br0 -o br0 -j REJECT

Documentation has been updated Smile

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 298

PostPosted: Sun Jul 25, 2021 16:02    Post subject: Reply with quote
Router/Version: RT-AC87U A1
Firmware: DD-WRT v3.0-r47086 std (07/22/21)
Kernel: Linux 4.4.276 #3717 SMP Thu Jul 22 03:10:07 +07 2021 armv7l
Previous: DD-WRT v3.0-r46885 std (06/05/21)
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz, 2.4 GHz guest (VAP), 5.0 GHz, IPv4, DNSMasq, Port Forwarding, NTP TimeSync, VNC Repeater, Wake-on-WAN (internet), and Wireguard
Issues/Errors: OK

_________________
Netgear XR500, R7800
Asus AC87Ua1
Repeater Bridges(s)
Netgear R6400v2otp
Asus AC68Ra1, AC66Ua1
kooper2013
DD-WRT User


Joined: 10 Jan 2013
Posts: 90
Location: DE

PostPosted: Sun Jul 25, 2021 19:39    Post subject: Reply with quote
egc wrote:


I see you are running WG on a Wireless Access Point.
In that case do not use the built-in killswitch.
If you want a killswitch use:
Code:
iptables -I FORWARD -i br0 -o br0 -j REJECT

Documentation has been updated Smile


Great, that's it!

That isn't obvious at all and should be done in the firmware automatically, I guess (disable/grey out button for the killswitch or something).

Thanks egc and BS!

_________________
3xBuffalo WLI-H4-D1300
1xBuffalo WZR-D1800H
1xBuffalo WHR-HP-G300N
1xBuffalo WHR-1166D (stock f/w)
1xAsus RT-AC87U
1xAsus RT-AC88U
1xTP710
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum