New Build - 07/20/2021 - r47074

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2
Author Message
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2233
Location: Canada

PostPosted: Wed Jul 21, 2021 19:15    Post subject: Upgrade Reply with quote
Router/Version: TP-Link Archer C7 v2 (x2)
File/Kernel:
Firmware Version
DD-WRT v3.0-r47074 std (07/20/21)
Kernel Version
Linux 3.18.140-d6 #121228 Tue Jul 20 06:28:11 +07 2021 mips
Previous/Reset: r47040, One of them was recently reset for r47033. All settings were then input manually by hand, no using of a backup file.
Mode/Status: WDS Station
Issues/Errors: Really slow, inconsistent Internet speeds. My main router, the r7800, I can consistently get ~80MB/s download. The Archer C7s, I expect a drop from that due to it being a WiFi to WiFi connection. But ~1-2 MB/s then <100 KB/s is not reasonable. Something changed since r47000. http://www.dslreports.com/speedtest/69010571.png

Router/Version: Netgear R7800
File/Kernel: r47074
Previous/Reset: r47040, no
Mode/Status: WDS AP
Issues/Errors: None. See above.

Router/Version: D-Link DIR-862L A1
File/Kernel: r47074
Previous/Reset: r47040, no
Mode/Status: WDS Station
Issues/Errors: Working. Speeds are ~50MB/s.

Router/Version: TP-Link WDR3600 v1
File/Kernel: r47074
Previous/Reset: r47040, no
Mode/Status: WDS Station, outlying router, no main connection to Netgear R7800. Can't test properly at the moment due to the issues with the Archer C7s above.
Issues/Errors: Can't test properly.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.
QCA Best WiFi Settings


Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one.

Atheros:
Netgear R7800 - WDS AP, gateway, QoS
TP-Link Archer C7 v2 x2 - WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1/E3/I1 x 7 - some gateway
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - not used
UBNT loco M2 x2 - airOS

Broadcom
Linksys EA6400 - Gateway, QoS
Asus N66U - AP
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - switch
Sponsor
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7491
Location: YWG, Canada

PostPosted: Wed Jul 21, 2021 20:28    Post subject: Re: Upgrade Reply with quote
ian5142 wrote:
Router/Version: TP-Link Archer C7 v2 (x2)
File/Kernel:
Firmware Version
DD-WRT v3.0-r47074 std (07/20/21)
Kernel Version
Linux 3.18.140-d6 #121228 Tue Jul 20 06:28:11 +07 2021 mips
Previous/Reset: r47040, One of them was recently reset for r47033. All settings were then input manually by hand, no using of a backup file.
Mode/Status: WDS Station
Issues/Errors: Really slow, inconsistent Internet speeds. My main router, the r7800, I can consistently get ~80MB/s download. The Archer C7s, I expect a drop from that due to it being a WiFi to WiFi connection. But ~1-2 MB/s then <100 KB/s is not reasonable. Something changed since r47000. http://www.dslreports.com/speedtest/69010571.png

Router/Version: Netgear R7800
File/Kernel: r47074
Previous/Reset: r47040, no
Mode/Status: WDS AP
Issues/Errors: None. See above.

Router/Version: D-Link DIR-862L A1
File/Kernel: r47074
Previous/Reset: r47040, no
Mode/Status: WDS Station
Issues/Errors: Working. Speeds are ~50MB/s.

Router/Version: TP-Link WDR3600 v1
File/Kernel: r47074
Previous/Reset: r47040, no
Mode/Status: WDS Station, outlying router, no main connection to Netgear R7800. Can't test properly at the moment due to the issues with the Archer C7s above.
Issues/Errors: Can't test properly.


2.4, 5ghz? if 5ghz that and dir-862L have the same radios, one is fine according to ur report while the other isnt..

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r47040 std
[QUALCOMM] DIR-862L --------------------------------> r47040 std
[QUALCOMM] DIR-862L --------------------------------> r46992 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
Gameman Advanced Kid
DD-WRT Guru


Joined: 18 Nov 2012
Posts: 939

PostPosted: Wed Jul 21, 2021 23:57    Post subject: Reply with quote
egc wrote:
For details of my R7800 see above.

I did a quick test for Samba and it seems to work as intended.

USB stick with two ext2 shares one named opt the other jffs.
Mount automatically.
I do not have any user(s) made, no encryption, public shares with rw.

[b]The shares are readily accessible without password etc. from Windows 10 and via winSCP


Did you even do a full factory reset? or did you flash to the new build without doing a factory reset?

Exactly how did you set this up that you can use samba on the newest build without having to create a user account?

_________________
For people who are new to the dd-wrt forums >> http://www.catb.org/~esr/faqs/smart-questions.html#rtfm

NAS-AP > R7500v2
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2233
Location: Canada

PostPosted: Thu Jul 22, 2021 0:51    Post subject: Re: Upgrade Reply with quote
tatsuya46 wrote:

2.4, 5ghz? if 5ghz that and dir-862L have the same radios, one is fine according to ur report while the other isnt..


The Archer C7s are connected on 2.4GHz to the main R7800. One of the 862Ls is connected on 2.4GHz as well, same main AP (R7800). The 862L, I can get great speeds on WiFi, 2.4GHz or 5GHz. The Archer C7, I was actually hardwired for that speed test. It was connected to the main R7800 on the 2.4GHz network.

Does any of that make any sense?

My wireless settings are in this thread here: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=329709

I just did an in place upgrade to 47074 today, on all routers. No change in the problem.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.
QCA Best WiFi Settings


Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one.

Atheros:
Netgear R7800 - WDS AP, gateway, QoS
TP-Link Archer C7 v2 x2 - WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1/E3/I1 x 7 - some gateway
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - not used
UBNT loco M2 x2 - airOS

Broadcom
Linksys EA6400 - Gateway, QoS
Asus N66U - AP
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - switch
jwieland
DD-WRT Novice


Joined: 31 May 2018
Posts: 38

PostPosted: Thu Jul 22, 2021 3:45    Post subject: Reply with quote
Router/Version: Netgear Nighthawk X4S R7800
File/Kernel: r47074
Previous/Reset: r47073 / no
Mode/Status: Gateway / Operational
Issues/Errors: None
Uptime: 38 Hours
Options: VANILLA 2.4GHz and 5GHz

_________________
Netgear R7800 - DD-WRT v3.0-r47086 std (07/22/21) VANILLA/VANILLA
Linksys WRT1200ACv2 - DD-WRT v3.0-r44048 std (08/02/20)
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7167
Location: Dresden, Germany

PostPosted: Thu Jul 22, 2021 5:49    Post subject: Reply with quote
xraive wrote:
Router Model / Version: Linksys EA8500
Previous Firmware: DD-WRT v3.0-r47033 std (07/19/21)
Current Firmware: DD-WRT v3.0-r47074 std (07/20/21)
File:: dd-wrt-webupgrade.bin / CLI Flash (easyddup.sh)
Kernel: Linux 4.9.274 #327 SMP Mon Jul 19 04:31:41 +07 2021 armv7l
Reset: No
Wireless: Wireless Mode - Client, Firmware Type - DD-WRT
Routing: Operating - Gateway
Setup: SFE, NTP, DDNS (inadyn-Entware),
Services: DNSMasq (GUI+ additional options on USB Syslog, SSH, FreeRadius, USB, ProFTPD (with users), Samba (with users), CoovaChilli (with local users & radius), WiFiDog,
Administration: Remote Access (HTTPS & SSH), Startup Script (For DNSMasq & inadyn)
Uptime: up 4:34, load average: 0.00, 0.00, 0.00
Temperature: CPU 52.492 °C / wlan0 43 °C
Status: OK
Issues: See below for issues.

Router Model / Version: Netgear XR500
Previous Firmware: DD-WRT v3.0-r47033 std (07/19/21)
Current Firmware: DD-WRT v3.0-r47074 std (07/20/21)
File:: dd-wrt-webupgrade.bin /CLI Flash (easyddup.sh)
Kernel: Linux 4.9.274 #329 SMP Tue Jul 20 02:38:27 +07 2021 armv7l
Reset: No
Wireless: Wireless Mode - Client, Firmware Type - DD-WRT
Routing: Operating - Gateway
Setup: Basic Setup, NTP, Switch (VLANS and Trunk config using GUI)
Services: DNSMasq (GUI), Syslog, SSH, FreeRadius, USB,
Administration: Remote Access (HTTPS & SSH),
Uptime: up 3:39, load average: 0.00, 0.00, 0.00

Temperature: CPU 54.693 °C / wlan0 43 °C
Status: OK
Issues: See Below


Issues:

EA8500

Same issues as in the previous build, r47040. See my post here. https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1241379#1241379

XR500
Unable to get Samba Working, Works great on the EA8500 but it won't start on the XR500. See Log below.



Code:

root@DD-WRT:~# cat /var/log/messages | grep smb
Jul 20 17:31:50 DD-WRT user.info : smbd : samba started
Jul 20 17:31:50 DD-WRT local5.err ksmbd: [ksmbd-manager/2902]: ERROR: Can't open `/tmp/ksmbd.subauth': No such file or directory
Jul 20 17:31:50 DD-WRT local5.info ksmbd: [ksmbd-worker/2903]: INFO: User already exists nobody
Jul 20 17:35:05 DD-WRT user.info : ksmbd.mountd : samba daemon successfully stopped
Jul 20 17:35:05 DD-WRT local5.info ksmbd: [ksmbd-worker/2903]: INFO: Child received signal: 15 (Terminated)
Jul 20 17:35:05 DD-WRT local5.info ksmbd: [ksmbd-manager/2902]: INFO: Exiting. Bye!
Jul 20 17:35:05 DD-WRT kern.info kernel: [  581.912608] ksmbd: kill command received
Jul 20 17:35:06 DD-WRT user.info : smbd : samba started
Jul 20 17:35:06 DD-WRT local5.info ksmbd: [ksmbd-worker/3432]: INFO: User already exists nobody
Jul 20 17:42:14 DD-WRT user.info : ksmbd.mountd : samba daemon successfully stopped
Jul 20 17:42:14 DD-WRT local5.info ksmbd: [ksmbd-worker/3432]: INFO: Child received signal: 15 (Terminated)
Jul 20 17:42:14 DD-WRT local5.info ksmbd: [ksmbd-manager/3430]: INFO: Exiting. Bye!
Jul 20 17:42:14 DD-WRT kern.info kernel: [ 1010.277252] ksmbd: kill command received
Jul 20 17:42:14 DD-WRT user.info : smbd : samba started
Jul 20 17:42:14 DD-WRT local5.info ksmbd: [ksmbd-worker/4079]: INFO: User already exists nobody
Jul 20 17:42:51 DD-WRT user.info : ksmbd.mountd : samba daemon successfully stopped
Jul 20 17:42:51 DD-WRT local5.info ksmbd: [ksmbd-worker/4079]: INFO: Child received signal: 15 (Terminated)
Jul 20 17:42:51 DD-WRT local5.err ksmbd: [ksmbd-manager/4078]: ERROR: can't execute kill 4079: No such process
Jul 20 17:42:51 DD-WRT local5.info ksmbd: [ksmbd-manager/4078]: INFO: Exiting. Bye!
Jul 20 17:42:51 DD-WRT kern.info kernel: [ 1047.445478] ksmbd: kill command received



Code:

root@DD-WRT:~# ps | grep smb
10205 root       836 S    ksmbd.mountd -c /tmp/smb.conf -u /tmp/smb.db
10206 root       868 S    ksmbd.mountd -c /tmp/smb.conf -u /tmp/smb.db
10211 root         0 SW   [ksmbd-lo]
10214 root         0 SW   [ksmbd-vlan5]
10217 root         0 SW   [ksmbd-vlan3]
10220 root         0 SW   [ksmbd-vlan4]
10223 root         0 SW   [ksmbd-vlan6]
10226 root         0 SW   [ksmbd-br0]
10229 root         0 SW   [ksmbd-wlan0]
10570 root      1372 S    grep smb



Code:

[b]Copy of Samba config.[/b]
[global]
log level = 1
netbios name = DD-WRT
server string = test
syslog = 10
encrypt passwords = true
preferred master = yes
use sendfile = yes
aio read size = 2048
aio write size = 2048
large readwrite = yes
security = user
oplocks = yes
mangled names = no
max stat cache size = 64
workgroup = WORKGROUP
bind interfaces only = yes
guest account = nobody
map to guest = never
smb passwd file = /var/samba/smbpasswd
private dir = /var/samba
passdb backend = smbpasswd
log file = /var/smbd.log
max log size = 1000
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=262144 SO_RCVBUF=262144
read raw = yes
write raw = yes
max xmit = 65536
dead time = 15
getwd cache = yes
lpq cache time = 30
server min protocol = SMB2_10
server max protocol = SMB3_11
printing = none
load printers = No
usershare allow guests = Yes
smb3 encryption = no
[jffs]
comment = jffs
path = /jffs
read only = no
guest ok = no
valid users = test
force user = root



log shows samba is running. so usually just a config error

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7890
Location: Netherlands

PostPosted: Thu Jul 22, 2021 6:45    Post subject: Reply with quote
Gameman Advanced Kid wrote:
egc wrote:
For details of my R7800 see above.

I did a quick test for Samba and it seems to work as intended.

USB stick with two ext2 shares one named opt the other jffs.
Mount automatically.
I do not have any user(s) made, no encryption, public shares with rw.

[b]The shares are readily accessible without password etc. from Windows 10 and via winSCP


Did you even do a full factory reset? or did you flash to the new build without doing a factory reset?

Exactly how did you set this up that you can use samba on the newest build without having to create a user account?



I did not reset, I posted because I see wildly varying reports, that is why I also posted my config to see if it is somehow different from others.
also see posting of mwchang: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=329716&start=15

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1663
Location: Canada

PostPosted: Thu Jul 22, 2021 6:46    Post subject: Reply with quote
Home Main Gateway Router
Router/Version: R7800
File/Kernel: DD-WRT v3.0-r47074 std (07/20/21)
Previous/Reset: r47033 / No, CLI Update
Mode/Status: GW / Working Well
Issues/Errors: none / none
Services Used: DHCP WAN,IPv6-PD,NTP,WG Client,VLANx,BRx,SSH,Syslog,Cron,USB Storage,Entware DNSCrypt v2.0.45,YAMon3.4.7
Services Disabled: WiFi,QoS,ttraff,SFE,Telnet,NAS,Samba

Home Main AP Router
Router/Version: R7800
File/Kernel: DD-WRT v3.0-r47074 std (07/20/21)
Previous/Reset: r47033 / No, CLI Update
Mode/Status: GW(double-nat) & AP / Working Well
Issues/Errors: none / none
Services Used: Static WAN,IPv6 6to4,WiFi Vannilla,NTP,2xWG Clients,VAPx,VLANx,BRx,SSH,Syslog,Cron,USB Storage,Entware DNSCrypt v2.0.45
Services Disabled: QoS,ttraff,SFE,Telnet,NAS,Samba

Thank-you BrianSlyer for your Great Work and everyone else who makes DD-WRT Great on the Forum!

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r47086 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r47086 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r47086 Std
E3000 - Client Bridge - DDWRT r46979 Mega K4.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r44483 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2
spon
DD-WRT Novice


Joined: 23 Jul 2021
Posts: 1

PostPosted: Fri Jul 23, 2021 13:31    Post subject: r47074 Reply with quote
Router/Version: Tp-Link WDR4300
Firmware: r47074 std
File/Upload: tl-wdr4300-webflash.bin / Upload using GUI
Mode: Gateway/AP
Reset: Yes
Previous Build: r41686 std
Services: PPPOE, 2.4 GHz (with a virtual SSID added), 5.0 GHz, OpenVPN 2.5 Server, QoS

Status: Uptime past 24hs, everything OK so far.

Great build! Thanks!
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum