New Build - 06/21/2021 - r46979

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3135

PostPosted: Mon Jun 21, 2021 7:39    Post subject: New Build - 06/21/2021 - r46979 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r46974 (GitHub mirror)

Notes:
OpenVPN 2.5.3: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210606/Tools: Guides, Client, Server, Advanced, PBR, KS, update tips, scripts & more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
Experimental build option for Broadcom 8MB+ K2.x devices (limited currently): broadcom_K3X_mipsel32r1
• Broadcom MIPS devices are now on kernel 4.4. • Support added for TP-Link Archer C8 v2 and v3.
SmartDNSMiniDLNA • Unbound 1.13.1 • CoovaChilli 1.6 • Tor 0.4.5.8 • OpenSSL 1.1.1k • Dnsmasq 2.85 • Privoxy 3.0.32
In-kernel Samba (ksmbd 3.3.9+): default min/max versions changed. • WSD updateANTFS/NTFS3 kernel mode driver++.
• Added swconfig support for Broadcom devices.
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.
• "Assign WAN port to Switch" feature removed to be reworked in a future release.

Issues, observations, and/or workarounds reported:
DNScrypt 1.95 can still be used in the GUI, but v2 (not compatible) requires Golang and thus Entware. #6246
WDS does not work on Broadcom ARM devices (only MIPS<->MIPS) & bridge modes on k4.4 devices may sometimes work
in some configurations for certain builds but are not supported by the bcmdhd driver. Use client or repeater instead.
VAPs not working at boot fixed for unbridged VAPs in 40562 - 40566. Effective startup commands discussion thread is here.
If start-up scripts do not work from USB add a delay, e.g. wait script or 'sleep 25'.
Broadcom ARM devices if 5 GHz channels are missing, via Telnet/SSH: 'nvram set brcm_unlock=1' 'nvram commit' 'reboot'
Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Valeriy_tc
DD-WRT User


Joined: 03 Sep 2016
Posts: 70
Location: Ukraine

PostPosted: Mon Jun 21, 2021 10:00    Post subject: Linksys EA6400 Reply with quote
Router/Version: Linksys EA6400
Mode: Gateway/AP
Firmware: DD-WRT v3.0-r46979 std (06/21/21)
Kernel: Linux 4.4.273 #3499 SMP Mon Jun 21 02:36:17 +07 2021 armv7l
Previous: DD-WRT v3.0-r46885 std (06/05/21)
Reset: No.
Issues/Errors: Working well so far.
SinCalChewy
DD-WRT User


Joined: 09 Nov 2014
Posts: 314
Location: Bakersfield, CA

PostPosted: Mon Jun 21, 2021 10:33    Post subject: Reply with quote
Router/Version: NETGEAR R7800
File/Kernel: DD-WRT v3.0-r46979 std (06/21/21)
Previous/Reset: DD-WRT v3.0-r46974 std (06/18/21), no.
Mode/Status: Gateway, working well so far.
Issues/Errors: Nope

Router/Version: 3x NETGEAR R7000
File/Kernel: DD-WRT v3.0-r46979 std (06/21/21)
Previous/Reset: DD-WRT v3.0-r46974 std
Mode/Status: 2x Client Bridge, 1x Access Point
Issues/Errors: Nope

_________________

Deployed Routers:
Netgear R7800 - 1x build 46979
- Gateway (USB /w Entware, CAKE QoS)
Netgear R7000 - 3x build 46979
IONK
DD-WRT User


Joined: 19 Aug 2011
Posts: 310

PostPosted: Mon Jun 21, 2021 13:42    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin / Linux 4.4.273 #3499 SMP Mon Jun 21 02:36:17 +07 2021 armv7l
Previous/Reset: DD-WRT v3.0-r46974 std (06/18/21) / no
Mode/Status: Repeater Bridge on 5GHz AC/N-Mixed (wl0 is purposely turned off) + USB Storage + lighttpd + ProFTPD + Cron / working
Issues/Errors: none

_________________
▫ RSS feed for DD-WRT releases: https://politepol.com/fd/NfCoAP5bUJXU
easyddup - A simple upgrade/downgrade utility by yoyoma2
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Mon Jun 21, 2021 14:40    Post subject: Reply with quote
Router: Linksys E2000
Build: K3 mega 46979

Status: no Internet

From a client I can reach my router which looks OK, but I do not have internet.

When I SSH into my router I can ping from my router to the internet.
On first glance routing/iptables/ifconfig look OK

But iptables do not show any rules hit
Status page shows 0 active IP connections

I have resetted twice but no internet.

Packets do not seem to be processed by the router.

The last working build was just before the switch to swconfig.

Can this be a switch problem, is my CPU really port 8?

See attached output of: swconfig dev switch0 show



E2000 46979 no internet.doc
 Description:

Download
 Filename:  E2000 46979 no internet.doc
 Filesize:  41.5 KB
 Downloaded:  47 Time(s)


_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
thommy181
DD-WRT User


Joined: 16 Mar 2019
Posts: 223
Location: Szczecin, Poland EU

PostPosted: Mon Jun 21, 2021 15:27    Post subject: Reply with quote
The same problem in my Netgear WNR3500L v2. I'm make clean configuration and Internet is connected to router, but it isn't available on workstations. I'm analyze problem and I'm decide to restore factory defaults one more time. After restore I'm login to GUI and MACs are stored still. MACs was incorrect - the same MAC was for LAN and WAN interface. I don't know why is that situation. In the next step I'm restore factory defaults by button on case. I'm make full configuration one more time and internet start to work. In first try problem is the same. Router have all services working, but internet unavailable on workstations. Actually everything work good. You must to make another tries with totally fresh configuration.
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 422

PostPosted: Mon Jun 21, 2021 15:55    Post subject: Reply with quote
Router/Version: Asus RT-N66U
File: dd-wrt.v24-46979 NEWD-2_K3.x-big-RT-N66U.trx
Firmware: DD-WRT v3.0-r46979 big (06/21/21) (will go back to DD-WRT v3.0-r46949 big (06/13/21))
Kernel: Linux 4.4.273 #10309 Mon Jun 21 03:51:41 +07 2021 mips
Mode: Gateway, Wifi disabled, WAN disabled, Wireguard Endpoint for external VPS, connected via LAN to R7800, Keep Alive reboot 6:05 in the morning
Reset: No
Status: Active IP Connections on STATUS Router states "0" even when connected with Webif and SSH.
Wireguard Endpoint does not connect, tunnel does not establish.
Went back to r46949, Problems gone. Reflashed 46979 --> problems appeared again.
Settings uploaded to https://i.imgur.com/xsqMQpm.jpg
(I changed /32 to /24 for testing purposes, but to no avail).
Same problem as r46958.
Attached /var/log/messages. Let me know if further information is needed Smile



var log messages.txt
 Description:

Download
 Filename:  var log messages.txt
 Filesize:  31.32 KB
 Downloaded:  36 Time(s)

egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Mon Jun 21, 2021 16:14    Post subject: Reply with quote
thommy181 wrote:
The same problem in my Netgear WNR3500L v2. I'm make clean configuration and Internet is connected to router, but it isn't available on workstations. I'm analyze problem and I'm decide to restore factory defaults one more time. After restore I'm login to GUI and MACs are stored still. MACs was incorrect - the same MAC was for LAN and WAN interface. I don't know why is that situation. In the next step I'm restore factory defaults by button on case. I'm make full configuration one more time and internet start to work. In first try problem is the same. Router have all services working, but internet unavailable on workstations. Actually everything work good. You must to make another tries with totally fresh configuration.


My MAC addresses look ok (i.e. different)

I resetted once more also with reset button but still nothing yet Sad

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 10001
Location: Texas, USA

PostPosted: Mon Jun 21, 2021 16:49    Post subject: Reply with quote
Worst case is to nvram erase to see if it's an issue with nvram variables. I emailed BrainSlayer about this.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Mon Jun 21, 2021 17:11    Post subject: Reply with quote
Thanks @kp69 !
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
mj666
DD-WRT Novice


Joined: 26 Nov 2010
Posts: 37

PostPosted: Mon Jun 21, 2021 18:11    Post subject: Reply with quote
Router/Version: RT-AC66U/Asus RT-AC66U
File DD-WRT v3.0-r46979 giga (06/21/21)
Kernel:
Previous/Reset: 46949/no
Mode/Status: access point, MAC filter/not working
Issues/Errors: Rebooting multiple times after upgrade every few seconds. Finally the configuration was reset to defaults. After this I tried to reconfigure the router as an access point from scratch and the rebooting is still starting after configuration was completed. Could not find out the step which causes the reboot. I disabled the "Reset after 5 Bootfails" to keep the configuration and restored 46949 via ASUS mini webserver. Configuration was working after going back to 46949.

Router/Version: E3000/Linksys E3000
File DD-WRT v3.0-r46979 mega (06/21/21)
Kernel: Linux 4.4.271 #9906 Sat Jun 5 04:02:55 +07 2021 mips
Previous/Reset: 46885/no
Mode/Status: access point, MAC filter/not working
Issues/Errors: The upgrade was successful and the router was running but stopped responding after 2-3hours. Restart does not bring it back. I need to recover it again.

My RT-AC88U routers have still the same problems as described in: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=329353

_________________
Asus AC-RT88U (Gateway, asus_rt-ac88u-firmware_47305.trx)
Asus AC-RT88U (AP, asus_rt-ac88u-firmware_47305.trx)
Asus AC-RT68U (AP, asus_rt-ac68u-firmware_47305.trx)
Asus AC-RT66U (AP, dd-wrt-47305-Asus_RT-AC66U.trx)
Linksys E3000 (AP, dd-wrt.v24-47305_NEWD-2_K3.x_mega-e3000.bin)
Linksys E4200 V2 (openwrt-18.06.5-kirkwood-linksys_viper-squashfs-sysupgrade.bin) not used at the moment


Last edited by mj666 on Mon Jun 21, 2021 20:01; edited 5 times in total
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 8127
Location: Netherlands

PostPosted: Mon Jun 21, 2021 18:15    Post subject: Reply with quote
Router Model: Netgear R6400v2, board_id: U12H332T

Firmware Version: DD-WRT v3.0-r46979M Community Build (06/21/21)
Kernel Version: Linux 4.4.273 #1 SMP Mon Jun 21 13:05:31 CEST 2021 armv7l

Upgraded from: DD-WRT v3.0-r46974 std (06/18/21)
Reset: No not this time

Status: Up and running for 6 hours, basic setup as Gateway, static leases, OpenVPN client with Policy Based Routing up and running, 2,4GHz and 5Ghz working, USB storage NAS working, WireGuard server working with 8 clients (phones, Windows and two other routers for site-to-site setup).

Errors: None

Thanks BS!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
twindragon6
DD-WRT User


Joined: 29 Jun 2008
Posts: 223

PostPosted: Tue Jun 22, 2021 0:26    Post subject: Netgear Nighthawk R7000 Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46979 std (06/21/21)
Kernel: Linux 4.4.273 #3499 SMP Mon Jun 21 02:36:17 +07 2021 armv7l
Mode: Gateway, Wireless AP. CTF & FA Enabled. NAT and QOS Off.
Reset: Nope.
Previous: 06-18-2021-r46974
Status: Working really well so far, still testing. CPU really hot!
Temperatures: CPU 67.5 °C / WL0 51.3 °C / WL1 56.6 °C



Logs.txt
 Description:
Full system logs. MAC scrubbed, password scrubbed, the fun stuff at the bottom as usual!

nvram set console_debug=1

cat /var/log/messages (Initial Flash)
dmesg (Initial Flash)
cat /proc/cpuinfo
cat /tmp/dnsmasq.conf
cat /tmp/DNSCache.log
cat /tmp/unbound

Download
 Filename:  Logs.txt
 Filesize:  233.89 KB
 Downloaded:  31 Time(s)

kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 10001
Location: Texas, USA

PostPosted: Tue Jun 22, 2021 2:29    Post subject: Re: Netgear Nighthawk R7000 Reply with quote
twindragon6 wrote:
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46979 std (06/21/21)
Kernel: Linux 4.4.273 #3499 SMP Mon Jun 21 02:36:17 +07 2021 armv7l
Mode: Gateway, Wireless AP. CTF & FA Enabled. NAT and QOS Off.
Reset: Nope.
Previous: 06-18-2021-r46974
Status: Working really well so far, still testing. CPU really hot!
Temperatures: CPU 67.5 °C / WL0 51.3 °C / WL1 56.6 °C

You were told specifically by BrainSlayer to stop reporting CPU temperature being hot. You're going to make him remove the functionality altogether if you do not listen.
BrainSlayer wrote:
twindragon6 wrote:
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r46949 std (06/13/21)
Kernel: Linux 4.4.272 #3431 SMP Fri Jun 11 13:15:03 +07 2021 armv7l
Mode: Gateway, Wireless AP. CTF & FA Enabled. NAT and QOS Off.
Reset: Nope.
Previous: 06-05-2021-r46885
Status: Working so far, still testing. High CPU temps. Poor throughput compared to 06-05-2021-r46885.
Temperatures: CPU 67.5 °C / WL0 50.6 °C / WL1 55.9 °C



if i contantly see messages about high cpu temp i will remove the temperature sensor from gui. i'm not sitting in your router and heating it up. broadcom builds that hot cpu and these temperatures are absolutelly normal and it was always like that. these values are for informational use and not for reporting or commenting it

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1675
Location: Canada

PostPosted: Tue Jun 22, 2021 6:56    Post subject: Reply with quote
HOME Wired Multicast ISP 4K TV Network

Router/Version: R7000
File/Kernel: DD-WRT v3.0-r46979 std (06/21/21)
Previous/Reset: r46885 / No, CLI Update
Mode/Status: GW / Working Well
Issues/Errors: none / none
Services Used: Multicast,IGMP,SFE,SSH,Syslog
Services Disabled: WiFi,QoS,ttraff,Telnet


OffSite #1

Router/Version: R7000
File/Kernel: DD-WRT v3.0-r46979 std (06/21/21)
Previous/Reset: r46885 / No, Remote CLI Update
Mode/Status: GW & AP / Working Well
Issues/Errors: none / none
Services Used: DHCP WAN,IPv6-6to4,NTP,WG Client,VLANx,BRx,SSH,Syslog,Cron,USB Storage,Entware DNSCrypt v2.0.45,YAMon3.4.7
Services Disabled: SFE,QoS,ttraff,Telnet

Router/Version: E3000
File/Kernel: DD-WRT v3.0-r46979 mega (06/21/21)
Previous/Reset: r46885 / No, Remote GUI Update
Mode/Status: Client-Bridge / Working Well
Issues/Errors: none / none
Services Used: WiFi 5G,NTP,SSH,Syslog,VLANx,BRx,
Services Disabled: WAN,QoS,ttraff,SFE,Telnet


TESTING at Home for OffSite #2

Router/Version: R7000
File/Kernel: DD-WRT v3.0-r46979 std (06/21/21)
Previous/Reset: r46885 / No, CLI Update
Mode/Status: GW & AP / Working Well
Issues/Errors: none /none
Services Used: DHCP WAN,IPv6-PD,NTP,VLANx,BRx,SSH,Syslog,Cron,USB Storage,Entware DNSCrypt v2.0.45,YAMon3.4.7
Services Disabled: SFE,QoS,ttraff,Telnet
This Router is NOT Deployed to Off-Site #2 yet, TESTING.


Thank-you BrianSlyer for your Great Work and everyone else who makes DD-WRT Great on the Forum!

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r47377 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r47117 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r47117 Std
E3000 - Client Bridge - DDWRT r46979 Mega K4.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r47117 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum