New Build - 06/05/2021 - r46885

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2860

PostPosted: Sat Jun 05, 2021 5:08    Post subject: New Build - 06/05/2021 - r46885 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r46836 (GitHub mirror)

Notes:
OpenVPN 2.5.2: Guides, Server, PBR, Reverse PBR, Client (see second post), Kill Switch, update tips, scripts and more.
WireGuard 1.0.20210219/Tools: Guides, Client, Server, Advanced, PBR, KS, update tips, scripts & more. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
SmartDNSMiniDLNA • Unbound 1.13.1 • CoovaChilli 1.6 • Tor 0.4.5.8 • OpenSSL 1.1.1k • Dnsmasq 2.85 • Privoxy 3.0.32
In-kernel Samba (ksmbd 3.3.9+): default min/max versions changed. • WSD updateANTFS/NTFS3 kernel mode driver++.
CVE-2020-26147, CVE-2020-24586, CVE-2020-24587 & CVE-2020-24588 (Fragattack) fixed.
• "Assign WAN port to Switch" feature removed to be reworked in a future release.

Issues:
• Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 293

PostPosted: Sat Jun 05, 2021 17:25    Post subject: Reply with quote
Upgraded WRT1200AC v1's from r46854 to r46885 using Brave 1.10.97 (64-bit) running on Linux Mint 20.1 OS hardwired via Cat6.

Successful update and reboot. No reset, nothing disabled prior to update, uptime approx 6+ hrs, wired/wireless connected, vpn up immediately (Expressvpn). I do not use NAS. SFE, QoS and IPv6 are always disabled. OpenVPN client/DNSMasq and radios always enabled. I do not have any Apple devices.

Kernel Version Linux 4.9.271 #2648 SMP Sat Jun 5 02:20:14 +07 2021 armv7l

No issues with a routine update session. No reds in syslog. Seems to have a slightly faster response time than previous build.
jifffy
DD-WRT Novice


Joined: 08 Jun 2020
Posts: 48

PostPosted: Sat Jun 05, 2021 20:51    Post subject: Reply with quote
I briefly installed this image 06/05/2021 - r46885
but it did not last long. For the first time ever I lost all connections to all my apple wifi devices, they did not even show up on the Status -> Lan section. Also had connection problems on my LAN line eth0, some sites would load, some would not, there was no obvious reason. I went back to 06/03/2021 - r46854 and everything went back to normal, well almost normal..there are problems with apple devices still after that apple firmware update.
raywan
DD-WRT Novice


Joined: 16 Jun 2020
Posts: 34

PostPosted: Sun Jun 06, 2021 6:26    Post subject: Reply with quote
Router/Version: WRT32x
File/Kernel: Linux 4.9.271 #2648 SMP Sat Jun 5 02:20:14 +07 2021 armv7l
Previous/Reset: 05-21-2021-r46733
Mode/Status: AP only
Issues/Errors: Web update via Firefox 89.0 without any problem. Reboot after update.Uptime 21hr without problem.
2.4GHz wifi disable WMM support for temporarily fix ESP8266 connection problem.
raywan
DD-WRT Novice


Joined: 16 Jun 2020
Posts: 34

PostPosted: Sun Jun 06, 2021 6:34    Post subject: Reply with quote
jifffy wrote:
I briefly installed this image 06/05/2021 - r46885
but it did not last long. For the first time ever I lost all connections to all my apple wifi devices, they did not even show up on the Status -> Lan section. Also had connection problems on my LAN line eth0, some sites would load, some would not, there was no obvious reason. I went back to 06/03/2021 - r46854 and everything went back to normal, well almost normal..there are problems with apple devices still after that apple firmware update.


For some new builds, you need to reset to default setting before upgrade.Some setting in old build are not compatible with new builds. I know that wrt1900acs has some problems on the new build no matter you reset to default or clean update. Anyway, if you feel the new build has some problem while other has no stability problem, i recommend that you do the system reset after upgrade. It will solve most of stability or wifi problem. I am pretty sure that WRT32x has no more stability issues for the new build recently while wrt1900acs still has some stability problems.
chong67
DD-WRT Novice


Joined: 26 Feb 2021
Posts: 7

PostPosted: Mon Jun 07, 2021 0:31    Post subject: Reply with quote
@rayman I never done reset before :

1. When I reset first, will it go to default username and password? From there just update?

2. Just save the configuration files and load it back after the new flash?
raywan
DD-WRT Novice


Joined: 16 Jun 2020
Posts: 34

PostPosted: Mon Jun 07, 2021 14:51    Post subject: Reply with quote
chong67 wrote:
@rayman I never done reset before :

1. When I reset first, will it go to default username and password? From there just update?

2. Just save the configuration files and load it back after the new flash?


1) Yes, everything will be go back from zero. So, you need to backup before reset to default. SSID will change back to ddwrt. Once you login, the website will ask you to set username and password.
2) It doesn't help to much if the upgrade build is far away from your existing build. Try to setup from zero is much better. I will try to write down all the setting or capture the screen setting then reset to default. Manually input the setting after upgrade. The reason is that in the new build, some setting is deleted or removed in the newest build. Old setting may not be necessary or doesn't match in the new build.
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 547
Location: Rural Manitoba

PostPosted: Tue Jun 08, 2021 1:45    Post subject: Reply with quote
Just upped all routers to r46885 from 46854 using IE11, no reset. All came up well including VPN. The massive overkill I did at r46750 seems to have eliminated any problems with these new builds.
_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r46854
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r46854 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r46854 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r46854
2.4Ghz AP Ch1 HT20 Mixed

WRT1900AC V1 r46854 On LAN
5Ghz WDS AP Ch149(+6) 80Mghz
2.4Ghz Ch 6 20Mhz N/G Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900 V1 -> WDS 5Ghz -> 1900 V1
3200 Master -> WDS -> 3200 Slave & 1900V1
o2bad455
DD-WRT User


Joined: 08 Oct 2015
Posts: 121

PostPosted: Tue Jun 08, 2021 13:56    Post subject: Reply with quote
Router/Version: WRT1900ACSv2 / r46885
File/Kernel: webflash / Linux 4.9.271 #2648 SMP Sat Jun 5 02:20:14 +07 2021 armv7l
Previous/Reset: r46733 / No
Mode/Status: Gateway, OpenVPN Client, FreeRadius Server / Up 30 min, load and temps look normal.
Issues/Errors: Flashed from Putty. Almost everything worked after the first reboot, except the 5 GHz radio wasn't actually broadcasting until after a second reboot (even though status/wireless claimed it was). This is the same symptom that I first experiencd with r46733, which additionally stopped broadcasting 5 GHz after several days up. I'll follow up if I notice any fallovers of 5 GHz with this build, but everything else looks good so far, thanks! Smile

EDIT:
As a follow-up, it looks like my initial trouble with 5 GHz was caused by an errant autochannel process that chose a channel with 0 eirp on 5260 KHz. Quality measurements look confused between 0 measured and 95 default, FWIW. Log attached.

_________________
My DD-WRT Routers:
Linksys/Marvell WRT1900ACSv2 (r46885 - test only)
Linksys/Marvell WRT1900ACSv1 (r46069 - daily use)
HP-Laptop/Intel/x86-64 (r46316 - test only due to unsupported wifi)
Netgear/Broadcom R7000 (3x: r45928 - remote use)
Linksys/Broadcom WRT54G/GS (4x: r44715 - occasional use)
Netgear/Atheros R9000 (bought broken and awaiting delivery)


Last edited by o2bad455 on Fri Jun 11, 2021 14:16; edited 2 times in total
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 547
Location: Rural Manitoba

PostPosted: Thu Jun 10, 2021 0:15    Post subject: Reply with quote
Everything seemed to be running well. Appeared that some of my cameras were having trouble maintaining connection but didn't see anything in the logs. Today I couldn't communicate with my WiFi Printer.
While trying to diagnose I had trouble accessing the GUI on most routers and one in particular I could not access at all even though it was fully operational as I could see all my cameras, just couldn't get to it even over the 2.4Ghz. Had to telnet in and reboot.
By this time I concluded that something was amiss with this build as numerous reboots on all the routers and the desktop still get me access to my printer.
I finally switched partitions on all the routers back to r46854 and everything started working again properly.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r46854
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r46854 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r46854 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r46854
2.4Ghz AP Ch1 HT20 Mixed

WRT1900AC V1 r46854 On LAN
5Ghz WDS AP Ch149(+6) 80Mghz
2.4Ghz Ch 6 20Mhz N/G Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900 V1 -> WDS 5Ghz -> 1900 V1
3200 Master -> WDS -> 3200 Slave & 1900V1
o2bad455
DD-WRT User


Joined: 08 Oct 2015
Posts: 121

PostPosted: Thu Jun 10, 2021 14:22    Post subject: Reply with quote
Update: Ours has been up for over two days without any issues. Webif is still working fine (I just checked with Firefox 89.0 64-bit). Loads and temperatures still look normal.
_________________
My DD-WRT Routers:
Linksys/Marvell WRT1900ACSv2 (r46885 - test only)
Linksys/Marvell WRT1900ACSv1 (r46069 - daily use)
HP-Laptop/Intel/x86-64 (r46316 - test only due to unsupported wifi)
Netgear/Broadcom R7000 (3x: r45928 - remote use)
Linksys/Broadcom WRT54G/GS (4x: r44715 - occasional use)
Netgear/Atheros R9000 (bought broken and awaiting delivery)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum