New Build - 02/25/2021 - r45849

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3  Next
Author Message
flood404
DD-WRT User


Joined: 18 Dec 2013
Posts: 234

PostPosted: Fri Feb 26, 2021 14:56    Post subject: Reply with quote
BrainSlayer wrote:
Abboo wrote:
Router Model: Netgear R8000
Firmware Version: DD-WRT v3.0-r45849 std (02/25/21)
Kernel Version: Linux 4.4.258 #2141 SMP Thu Feb 25 10:57:00 +06 2021 armv7l
Previous Version: DD-WRT v3.0-r45820 std (02/23/21)
Drivers: Experimental
Services: samba, wireguard client, openvpn client, dhcp, wifi 2.4 ghz, usb, nas
Status: working with the exception of accessing usb from win7 explorer
Updated: via webgui
Mode: AP/gateway
Issues: cannot access the usb from win7 explorer
Reset: no
Reboot: yes
Uptime: 3 min
Temperatures: CPU 47.5 °C
Errors: as reported in the syslog below

Dec 31 20:00:10 DD-WRT kern.err kernel: bcmsflash: found no supported devices
Dec 31 20:00:13 DD-WRT kern.err kernel: brcmfmac: brcmf_cfg80211_dump_survey: cca_get_stats failed (-52)
Dec 31 20:00:20 DD-WRT user.err wsdd2[1193]: error: wsdd-mcast-v4: wsd_send_soap_msg: send: Network unreachable
Dec 31 20:00:20 DD-WRT user.err wsdd2[1193]: error: wsdd-mcast-v6: wsd_send_soap_msg: send: Address not available
Dec 31 20:00:20 DD-WRT local5.err ksmbd: [ksmbd-manager/1204]: ERROR: Can't open `/tmp/ksmbd.subauth': No such file or directory
Dec 31 20:00:20 DD-WRT local5.err ksmbd: [ksmbd-worker/1205]: ERROR: Can't open `/tmp/smb.db': No such file or directory
Dec 31 20:00:20 DD-WRT local5.err ksmbd: [ksmbd-worker/1205]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
Dec 31 20:00:23 DD-WRT kern.err kernel: hub 3-0:1.0: config failed, hub doesn't have any ports! (err -19)
Feb 25 13:32:36 DD-WRT user.err wsdd2[1193]: Terminated received.
Feb 25 13:32:36 DD-WRT local5.err ksmbd: [ksmbd-manager/1204]: ERROR: WARNING: child process exited abnormally: 1205
Feb 25 13:32:38 DD-WRT local5.err ksmbd: [ksmbd-worker/2453]: ERROR: Can't open `/tmp/smb.db': No such file or directory
Feb 25 13:32:38 DD-WRT local5.err ksmbd: [ksmbd-worker/2453]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
Feb 25 13:32:41 DD-WRT local5.err ksmbd: [ksmbd-manager/2787]: ERROR: Failed to create lock file: File exists
Feb 25 13:33:13 DD-WRT daemon.err httpd[1417]: httpd : Request Error Code 401: Authorization required. please note that the default username is "root" in all newer releases
Feb 25 13:45:04 DD-WRT local5.err ksmbd: [ksmbd-worker/3474]: ERROR: treecon: user account not found:

Username and password required to access files across the network relative to the ‘share’ folder.
The said files can be access via ‘media devices’.


if in guest if you are asked for user account. wenn known windows behaviour. you are trying to forcefully authenticate with a empty username





I have the same issue. I can't access Samba shares even using a user name and password on any Windows Pc. When I rolled back to r45767 everything works again.
Sponsor
IONK
DD-WRT User


Joined: 19 Aug 2011
Posts: 216

PostPosted: Fri Feb 26, 2021 16:14    Post subject: Reply with quote
Router/Version: D-Link DIR-868L Rev.A1
File/Kernel: dir868a-webflash.bin / Linux 4.4.258 #2133 SMP Wed Feb 24 11:29:36 +06 2021 armv7l
Previous/Reset: DD-WRT v3.0-r45820 std (02/23/21) / no
Mode/Status: Repeater Bridge on 5GHz AC/N-Mixed (wl0 is purposely turned off) / working
Issues/Errors: none

_________________
▫ RSS feed for DD-WRT releases: https://feed43.com/ddwrt-downloads.xml (unofficial)
easyddup - A simple upgrade/downgrade utility by yoyoma2
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 170

PostPosted: Fri Feb 26, 2021 19:18    Post subject: Reply with quote
kernel-panic69 wrote:
Abboo wrote:
kernel-panic69 wrote:
@Abboo: You completely glazed over reading this in the next post under that.

BrainSlayer wrote:
if in guest if you are asked for user account. wenn known windows behaviour. you are trying to forcefully authenticate with a empty username


I have enter all usernames I know and matching passwords, nothing works, dd-wrt username and password, windows administrator password and username; to log into my computer you must also enter the administrator password; nothing work.


I was trying to find if you had posted a screenshot of your samba configuration. That may help us figure out where the problem is, BUT there was a couple of commits to hopefully work around this issue in the next release:

https://svn.dd-wrt.com/changeset/45852

https://svn.dd-wrt.com/changeset/45853


Samba images attached

Moderator edit: Please refer to this post, point 5 on how to properly attach images to your posts.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8359
Location: Texas, USA

PostPosted: Fri Feb 26, 2021 19:51    Post subject: Reply with quote
Why don't you have a user added?
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 170

PostPosted: Fri Feb 26, 2021 22:28    Post subject: Reply with quote
kernel-panic69 wrote:
Why don't you have a user added?


It always work without a user added
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 170

PostPosted: Fri Feb 26, 2021 23:02    Post subject: Reply with quote
Abboo wrote:
kernel-panic69 wrote:
Why don't you have a user added?


It always work without a user added


Having added a user and password the results are still the same; I cannot access the shared network folder from Win7 explorer.

Moderator edit: Please refer to this post, point 5 on how to properly attach images to your posts.
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2779

PostPosted: Fri Feb 26, 2021 23:10    Post subject: Reply with quote
Please learn how to take a screenshot within a current active window: alt + print screen then paste into Paint.NET.

...or windows key + print screen saves automatically to a file...or use snipping tool, all no wider than 768 pixels.

...or use an external image host such as postimages to directly link an image with the forum's insert img function.
flood404
DD-WRT User


Joined: 18 Dec 2013
Posts: 234

PostPosted: Sat Feb 27, 2021 1:15    Post subject: Reply with quote
I posted my Samba config and the issue here.


https://svn.dd-wrt.com/ticket/7348
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 170

PostPosted: Sat Feb 27, 2021 2:53    Post subject: Reply with quote
blkt wrote:
Please learn how to take a screenshot within a current active window: alt + print screen then paste into Paint.NET.

...or windows key + print screen saves automatically to a file...or use snipping tool, all no wider than 768 pixels.

...or use an external image host such as postimages to directly link an image with the forum's insert img function.


Did
blkt wrote:
took a screenshot within a current active window: alt + print screen then paste into Paint.NET.
and resize pixel to 700, save as and uploaded; what you see is the result.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4224
Location: UK, London, just across the river..

PostPosted: Sat Feb 27, 2021 8:02    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r45849 std (02/25/21)
Kernel: Linux 4.4.258 #2133 SMP Wed Feb 24 11:29:36 +06 2021 armv7l

update: CLI
reset: NO
status: Operational 12h+
errors: Nothing new, yet

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45993 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46316 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46166 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46259 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46259 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
lolloobernie
DD-WRT Novice


Joined: 27 Sep 2019
Posts: 18

PostPosted: Sat Feb 27, 2021 11:09    Post subject: R7000 DD-WRT v3.0-r45849 std (02/25/21) Reply with quote
Router Model
Netgear R7000
Firmware Version
DD-WRT v3.0-r45849 std (02/25/21)
Kernel Version
Linux 4.4.258 #2133 SMP Wed Feb 24 11:29:36 +06 2021 armv7l
Uptime
17:28

CPU Clock
1400 MHz
Load Average
1%
0.02, 0.06, 0.01
Temperatures
CPU 65.8 °C / WL0 47.0 °C / WL1 53.0 °C

Works great Smile

_________________
R7000@1400mhz

amadeus
DD-WRT Novice


Joined: 06 Nov 2019
Posts: 31

PostPosted: Sat Feb 27, 2021 11:12    Post subject: Reply with quote
Router/Version: Netgear r6700v3
Firmware: DD-WRT v3.0-r45849 std (02/25/21)
Kernel: Linux 4.4.258 #2133 SMP Wed Feb 24 11:29:36 +06 2021 armv7l
Mode: AP
Previous: r45767
Reset: No
Status: cli upgrade, no issues.
hurleyp
DD-WRT User


Joined: 10 Sep 2009
Posts: 308
Location: Ottawa, Ontario, Canada

PostPosted: Sat Feb 27, 2021 14:43    Post subject: Reply with quote
Firmware: v3.0-r45849 std (02/25/21)
Router/Version: Netgear R7000
Kernel: Linux 4.4.258 #2133 SMP Wed Feb 24 11:29:36 +06 2021 armv7l
Previous: v3.0-r45767 std (02/17/21)
Mode/Status: AP wired and wireless, Up and running for 1.5 days.
Reset: Soft boot before and after upgrade
Temperatures: CPU 56.9 °C / WL0 44.5 °C / WL1 49.7 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

There is a minor issue with the packet count on wl0.1 and "Connected Clients" stuck at zero. The wl0 and wl1 counts seem correct.
Upload and Download speeds are to ISP spec. Nothing unexpected in the syslog.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- SFE - On
- STP - On
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 149, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: disabled.
- USB support - Off
- No custom scripts
- NO: ttraf, Tor, VNC, Zabbix, VPN, Radius, OpenVPN
- NO: UPnP, DMZ, QoS
- NO: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware

_________________
Netgear R7000: v3.0-r46166 std (03/24/21)
EdgeRouter-X: EdgeOS v2.0.9-hotfix 1
flood404
DD-WRT User


Joined: 18 Dec 2013
Posts: 234

PostPosted: Sat Feb 27, 2021 19:09    Post subject: Reply with quote
Abboo wrote:
Abboo wrote:
kernel-panic69 wrote:
Why don't you have a user added?


It always work without a user added


Having added a user and password the results are still the same; I cannot access the shared network folder from Win7 explorer.


The guest access is broken even in r45859.

The fix so far for me was to add more users to your shares for each computer to have access to the shares. One account does not work over more than 1 computer since it is not allowed now.

So add another user name and password to your list in dd-wrt. Then click save and apply and I would suggest a reboot too of the router.

Then wait about 5 to 10 mins for the Samba service to boot and set itself up.

Then use the user name and password that is not being used on other systems. It will allow access this time.
thommy181
DD-WRT User


Joined: 16 Mar 2019
Posts: 174
Location: Szczecin, Poland EU

PostPosted: Sat Feb 27, 2021 19:10    Post subject: New Build - 02/25/2021 - r45849 Reply with quote
Router: Netgear WNR3500L v2
Kernel: Linux 4.4.258 #7123 Thu Feb 25 17:01:46 +06 2021 mips
Reset: No
Mode: Internet gateway, WIFI AP, Dnsmasq server
Errors: kern.warn kernel: br0: received packet on eth1 with own address as source address. It's repeated many times.
Status: Working
Uptime: ~45 h

I'm updated device via ssh. Generally router work rather good. I have problem with MACs still. I don't know how to fix that.
Goto page Previous  1, 2, 3  Next Display posts from previous:    Page 2 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum