Effective workarounds for bridged VAPs not working at boot

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
mjurgens
DD-WRT Novice


Joined: 12 Jan 2011
Posts: 34

PostPosted: Tue Nov 03, 2020 23:56    Post subject: Effective workarounds for bridged VAPs not working at boot Reply with quote
Creating this thread with the single purpose of listing which VAP workarounds actually work for specific router models and build versions. I'm intending that posts in this thread are only to confirm working configurations to make it easier to find them.

This thread is not looking for posts confirming that Wifi generally works, this is specifically referring to builds that are released with the issue listed as:
Quote:
VAPs not working at boot fixed for unbridged VAPs with r40564:40566. Workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas (there are a few alternatives, search).



For example, I tried a couple of workarounds for Netgear R7000 before I found one that worked, so that was easy. However, for R7000P, some people in other threads seem to be referring to having it working but I have tried all the workarounds I can find and multiple firmware versions and still do not have it working. That has taken some time to test all those combinations. It would be great if working configuration information could more easily be found.

Example Template:
Code:
[b]Router Model: [/b]
[b]Build Version(s): [/b]
[b]Working Workaround (exact command): [/b]


Some possible workarounds that I have found are:
Code:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas



Code:
sleep 10;stopservice nas;wlconf eth1 down;wlconf eth1 up;wlconf eth2 down;wlconf eth2 up;startservice nas   



Code:
sleep 20
nvram set wl1.1_hwaddr=
nvram commit
stopservice nas; wlconf eth1 down; wlconf eth2 down; wlconf eth1 up; wlconf eth2 up; startservice nas; logger "VAP workaround executed";



Code:
sleep 1
logger "VAP workaround starting";
nvram set wl1.1_hwaddr=
nvram commit
stopservice nas; wlconf eth1 down; wlconf eth2 down; wlconf eth1 up; wlconf eth2 up; startservice nas; logger "VAP workaround executed";


Last edited by mjurgens on Wed Nov 04, 2020 0:01; edited 1 time in total
Sponsor
mjurgens
DD-WRT Novice


Joined: 12 Jan 2011
Posts: 34

PostPosted: Tue Nov 03, 2020 23:59    Post subject: R7000 working Reply with quote
Router Model: R7000
Build Version(s): 44213
Working Workaround (exact command): sleep 10;stopservice nas;wlconf eth1 down;wlconf eth1 up;wlconf eth2 down;wlconf eth2 up;startservice nas
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7248
Location: Netherlands

PostPosted: Wed Nov 04, 2020 9:53    Post subject: Reply with quote
R6400

This one is guaranteed to work:

sleep 20; stopservice nas; wlconf eth1 down; wlconf eth2 down; wlconf eth1 up; wlconf eth2 up; startservice nas

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Pat_Rich
DD-WRT Novice


Joined: 05 Nov 2020
Posts: 28

PostPosted: Sat Nov 07, 2020 22:59    Post subject: DIR-868L Reply with quote
Router: DIR-868L
Version :r44715

work around : sleep 10;stopservice nas;wlconf eth1 down;wlconf eth1 up;wlconf eth2 down;wlconf eth2 up;startservice nas

it works.
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11483
Location: Wherever the wind blows- North America

PostPosted: Mon Nov 09, 2020 14:37    Post subject: Reply with quote
Here is one of the things I've found with my R7000 and R6300v2 units.

If your physical does not need encryption and you add a VAP with encryption then it doesn't seem to work correctly. (like setting up a repeater in a hotel room where the host AP isn't encrypted)

If your physical and VAP are both on the same encryption then the work-around works. (like when I'm home on my fully encrypted network)

Can someone with a working R7000 setup please confirm?

sleep 10;stopservice nas;wlconf eth1 down;wlconf eth1 up;wlconf eth2 down;wlconf eth2 up;startservice nas

redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
HalfBit
DD-WRT Guru


Joined: 04 Sep 2009
Posts: 766
Location: AR, USA

PostPosted: Mon Nov 09, 2020 18:55    Post subject: Reply with quote
Router Model: R7000 (2 units)
Build Version(s): 40270M
Working Workaround (exact command) in startup config: sleep 20; stopservice nas; wlconf eth1 down; wlconf eth2 down; wlconf eth1 up; wlconf eth2 up; startservice nas

_________________
R7000 Nighthawk - DD-WRT v3.0-r40270M kongac (07/11/19)
R7000 Nighthawk - DD-WRT v3.0-r40270M kongac (07/11/19)
~~~~~~~~~~Dismantled for learning opportunities~~~~~~~~~~
WRT54Gv2
WRT54Gv8.2
Azaka
DD-WRT Novice


Joined: 19 Feb 2021
Posts: 5

PostPosted: Wed Feb 24, 2021 1:19    Post subject: Reply with quote
Router Model: Netgear WNDR4000
Build Version(s): v3.0-r45735 mega (02/11/21)
Working Workaround (exact command):

Code:
sleep 10; stopservice cron; stopservice wlconf; wlconf eth1 up; wlconf eth2 up; startservice cron
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11483
Location: Wherever the wind blows- North America

PostPosted: Wed Feb 24, 2021 17:37    Post subject: Reply with quote
Azaka wrote:
Router Model: Netgear WNDR4000
Build Version(s): v3.0-r45735 mega (02/11/21)
Working Workaround (exact command):

Code:
sleep 10; stopservice cron; stopservice wlconf; wlconf eth1 up; wlconf eth2 up; startservice cron


cron? What does that have to do with the network config? Do you use a special cron job for setting up network configs?

redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8085
Location: Texas, USA

PostPosted: Wed Feb 24, 2021 18:40    Post subject: Reply with quote
It may have to do with process_monitor, but I was kind of scratching my head, too.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11483
Location: Wherever the wind blows- North America

PostPosted: Wed Feb 24, 2021 19:43    Post subject: Reply with quote
Possibly...but you can do a stopservice process_monitor of that's the goal.

I'm kinda curious if he's using cron in some way to setup networking processes.

redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
Azaka
DD-WRT Novice


Joined: 19 Feb 2021
Posts: 5

PostPosted: Wed Feb 24, 2021 20:07    Post subject: Reply with quote
Apologies for any confusion. I am no expert on these matters, you are probably much better informed. I will try to give some more background.

The WNDR4000 is an additional upstairs access point in our house, not the main wan side router. It has an extra VAP as a guest network. This VAP would not work properly at boot. VAP is visible but clients fail to connect.

I have added this bit of code to the Startup section, under Administration->Commands.

Code:
sleep 10; stopservice cron; stopservice wlconf; wlconf eth1 up; wlconf eth2 up; startservice cron


I cannot tell why it works. It is one of the options listed in the OP of this thread under "Some possible workarounds that I have found are:". Running this from the Startup section causes my VAP to accept client connections.

Feel free to ask for further clarification. If it would be helpful I can see if can pull more information from my access point for troubleshooting.

EDIT:
I went back to the OP and you guys are right. The cron bit wasn't there. I must have been confused with another piece of code. However, this snippet does help my router to get the VAP accessible. Shoot me, I don't understand why but it does work.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8085
Location: Texas, USA

PostPosted: Wed Feb 24, 2021 20:16    Post subject: Reply with quote
The cron executable is NOT listed in ANY examples anywhere in this thread until you posted. Please re-read the OP. Maybe now we have a NEW workaround, thanks to your experiment (?)
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Azaka
DD-WRT Novice


Joined: 19 Feb 2021
Posts: 5

PostPosted: Wed Feb 24, 2021 20:48    Post subject: Reply with quote
Yes you are right Embarassed

I can remove the cron bit from my code snippet, see if it makes a difference. Cannot do that now though, a few people in my household are using the AP at this time.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8085
Location: Texas, USA

PostPosted: Wed Feb 24, 2021 21:15    Post subject: Reply with quote
Or, you could leave it and test it to see if it continues to work when you upgrade in the future.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum