New Build - 02/23/2021 - r45820

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2409

PostPosted: Tue Feb 23, 2021 14:19    Post subject: New Build - 02/23/2021 - r45820 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and device specific recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link does not work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r45767 (GitHub mirror)

Notes:
OpenVPN version 2.5.0 and Guides
WireGuard 1.0.20210219/Tools: Guides, PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key. Thanks BS & egc!
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle since r41813.
• Dnsmasq 2.84 r45632. • SmartDNS update r45690. • MiniDLNA 1.3.0 r45767. Privoxy 3.0.31 and Unbound 1.13.1 r45820.
In-kernel Samba (ksmbd 3.3.5): default min/max versions changed. WSD updated. ANTFS & NTFS3 kernel mode drivers.
Select ath10k radios now feature on-the-fly firmware type switching between Customized DD-WRT and Vanilla QCA binaries!

Issues:
• Show us your findings with steps to reproduce, configuration, output, logs and important information below!

Important:
• For issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, klog, serial, strace, tcpdump, wireshark etc.
• Any firewall NAT or WAN issues, show output: 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and /tmp/.ipt file.
• Search SVN tickets & discuss in forum before opening. Before reporting: reset & manually set up, not restore from a backup.
• Please include operating & wireless modes (e.g. Gateway, Router, AP, CB, WDS, Mesh) & relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 275

PostPosted: Tue Feb 23, 2021 15:52    Post subject: Reply with quote
Router/Version: R7800
Firmware: DD-WRT v3.0-r45820 std (02/23/21)
Kernel: Linux 4.9.257 #1157 SMP Tue Feb 23 02:37:39 +07 2021 armv7l
Previous: DD-WRT v3.0-r45767 std (02/17/21)
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: 2.4 GHz, 2.4 GHz guest (VAP), 5.0 GHz, IPv4, DNSMasq, Port Forwarding, USB, NAS, Samba NTFS, NTP TimeSync, VNC Repeater, and Wake-on-WAN (internet)
Issues/Errors: Yes, Samba NTFS came up dirty [not available!] after upgrade. Required to remove USB from router, connect to Windows 10, repair drive, and attach back to router USB port.

Update: After 12 hours devices were loosing internet access on 2.4 GHz so rolled back to r45767

_________________
Netgear R7800 - DD-WRT v3.0-r45767 std (02/17/21)
Asus AC87U A1 - DD-WRT v3.0-r45767 std (02/17/21)
Repeater Bridges(s)
Asus AC68R A1 - DD-WRT v3.0-r45767 std (02/17/21)
Netgear R6400 V2 - DD-WRT v3.0-r45767 std (02/17/21)
Asus AC66U A1 - DD-WRT v3.0-r45767 giga (02/17/21)


Last edited by jrscs on Wed Feb 24, 2021 10:22; edited 1 time in total
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4175
Location: UK, London, just across the river..

PostPosted: Tue Feb 23, 2021 18:28    Post subject: Reply with quote
Router Model TP-Link WR1043ND V2
Firmware Version DD-WRT v3.0-r45820 std (02/23/21)
Kernel Version Linux 3.18.140-d5 #107713 Tue Feb 23 05:55:45 +06 2021 mips

update: CLI
reset: NO
status: Operational 6h+
errors: Nothing new...so far so good ...will report later...

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45849 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 45849 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 45849 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 45859 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 45859 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
al_bo
DD-WRT User


Joined: 22 Dec 2015
Posts: 51

PostPosted: Tue Feb 23, 2021 18:48    Post subject: Reply with quote
Router Model: Netgear R7800
Firmware: DD-WRT v3.0-r45820 std (02/23/21)
Kernel: Linux 4.9.257 #1157 SMP Tue Feb 23 02:37:39 +07 2021 armv7l
Previous: DD-WRT v3.0-r45735
Mode/Status: Gateway/AP/Ok
Reset: No
Setup Using: by default, + usb nas samba & dlna
Issues/Errors: Yes, Samba, - 2 of 3 EXT4 drives not connect to Windows 10, asking for login and password that is not set in router\nas tab.
I have to roll back to r45735.
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2409

PostPosted: Tue Feb 23, 2021 19:08    Post subject: Reply with quote
al_bo wrote:
2 of 3 EXT4 drives not connect to Windows 10, asking for login and password that is not set in router\nas tab.

Did you disconnect and boot into a linux computer to run e2fsck? For others with NTFS run chkdsk to clean.
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 359

PostPosted: Tue Feb 23, 2021 20:20    Post subject: Reply with quote
Update method: SSH
Router/Version: Netgear R9000 Nighthawk X10
File/Kernel: DD-WRT v3.0-r45820 std (02/23/21)
Previous/Reset: DD-WRT v3.0-r45767 std (02/17/21) / No
Mode/Status: Gateway / Working Normally / Clock 2000MHz
Issues/Errors: None

So far, no problems. Thank, BS!

_________________
Netgear R9000 X10
DD-WRT v3.0-r45891 std (03/04/21)
Gateway, AP, DNSMasq
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HFSC w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 450
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 450
Clock 2000MHz
Xfinity 1Gbps(max)/42Mbps
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Tue Feb 23, 2021 20:51    Post subject: Reply with quote
blkt wrote:
al_bo wrote:
2 of 3 EXT4 drives not connect to Windows 10, asking for login and password that is not set in router\nas tab.

Did you disconnect and boot into a linux computer to run e2fsck? For others with NTFS run chkdsk to clean.


I have the same issue with my broadcom. I have 'cleaned' the drive, it mounts. I can see the files from my television but cannot access them from Win7 using explorer
al_bo
DD-WRT User


Joined: 22 Dec 2015
Posts: 51

PostPosted: Tue Feb 23, 2021 21:30    Post subject: Reply with quote
blkt wrote:
al_bo wrote:
2 of 3 EXT4 drives not connect to Windows 10, asking for login and password that is not set in router\nas tab.

Did you disconnect and boot into a linux computer to run e2fsck? For others with NTFS run chkdsk to clean.

Personally me, - I was not do it, but in previous upper post are proofing that the problem is not on HDDs. On build 45735 or on 44715 that my r7800 was running, there's no problems at all with access to HDDs.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8082
Location: Texas, USA

PostPosted: Tue Feb 23, 2021 23:28    Post subject: Reply with quote
Not sure if the EXT* filesystem drives are having the same issue as NTFS (that is ntfs3 driver-related), but it wouldn't hurt to run a filesystem check on them.

@Abboo: Does Win7 even support the newer ntfs3 linux driver?

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
johnnyNobody999
DD-WRT User


Joined: 10 Jan 2014
Posts: 394

PostPosted: Wed Feb 24, 2021 0:10    Post subject: Reply with quote
Router/Version: R7800
File/Kernel: dd-wrt-webupgrade-netgear_r7800-r45820.bin
Previous/Reset: dd-wrt-webupgrade-netgear_r7800-r45767.bin / no reset
Mode/Status: WDS with 4 stations
Issues/Errors: uptime 5 hours - OK so far
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Wed Feb 24, 2021 0:20    Post subject: Reply with quote
kernel-panic69 wrote:
Not sure if the EXT* filesystem drives are having the same issue as NTFS (that is ntfs3 driver-related), but it wouldn't hurt to run a filesystem check on them.

@Abboo: Does Win7 even support the newer ntfs3 linux driver?


I could not access the shared network folder with Win7 with the previous build either.
pandemonium420
DD-WRT User


Joined: 21 Nov 2013
Posts: 53
Location: Cathedral City, CA, USA

PostPosted: Wed Feb 24, 2021 0:47    Post subject: Reply with quote
Abboo wrote:
blkt wrote:
al_bo wrote:
2 of 3 EXT4 drives not connect to Windows 10, asking for login and password that is not set in router\nas tab.

Did you disconnect and boot into a linux computer to run e2fsck? For others with NTFS run chkdsk to clean.


I have the same issue with my broadcom. I have 'cleaned' the drive, it mounts. I can see the files from my television but cannot access them from Win7 using explorer


Router/Version: r7800 / DD-WRT v3.0-r45820 std (02/23/21)
File/Kernel: Linux 4.9.257 #1157 SMP Tue Feb 23 02:37:39 +07 2021 armv7l
Previous/Reset: r45767 / No Reset
Mode/Status: Working / ksmbd maybe issue
Issues/Errors: Cannot get to shares

Greetings,

Running into issues accessing shares from a Win10 system to USB drive connected to r7800. When browsing through network neighborhood, when I click on Router's icon it prompts for username and password, which there shouldn't be any. I also have share "mapped" to same location. I checked out the file smb.conf and noticed that the shares had an extra "/" similar to this: *** NOTE *** whole USB drive formatted EXT4 and check with e2fsck

force user = root
[Video]
comment = Video
path = /mnt/data//video
read only = no
guest ok = yes

force user = root
[opt]
comment = opt
path = /opt/
read only = no
guest ok = yes

I went into the web interface SERVICES/NAS and removed all the starting "/" from the "subdir" boxes (example: /video = video), note these "/" in subdir were always there with previous firmware versions. I was able to browse and use the files in "mapped" drive, which maps to /mnt/data, this share pre-existed before this firmware upgrade on win10. Browsing through network neighborhood still brings up username/password box, and nothing works there. And trying to add a share in win10, it will prompt for name/password. Once I removed the extra "/" I was able to browse the preexisting mapped share.

Error in the logfile shows this each time trying to access.

Feb 23 16:25:23 PANDA-WRT-1 local5.err ksmbd: [ksmbd-worker/4144]: ERROR: treecon: user account not found:

Full smb.conf [global] section

[global]
log level = 1
netbios name = PANDA-WRT-1
server string = PANDA-SAMBA %h
syslog = 10
encrypt passwords = true
preferred master = yes
use sendfile = yes
aio read size = 2048
aio write size = 2048
large readwrite = yes
security = user
oplocks = yes
mangled names = no
max stat cache size = 64
workgroup = MSHOME
bind interfaces only = yes
guest account = nobody
map to guest = Bad User
smb passwd file = /var/samba/smbpasswd
private dir = /var/samba
passdb backend = smbpasswd
log file = /var/smbd.log
max log size = 1000
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=262144 SO_RCVBUF=262144
read raw = yes
write raw = yes
max xmit = 65536
dead time = 15
getwd cache = yes
lpq cache time = 30
server min protocol = SMB2_02
server max protocol = SMB3_11
printing = none
load printers = No
usershare allow guests = Yes
smb3 encryption = yes

Maybe extra "/" somewhere causing the problem as the username and password will popup if asking for a share that is misspelled, using an uppercase when lowercase needed, or share does not exist.

Thanks for the wonderful firmware BS, and to the many people who make this firmware the best.

_________________
Router/Version: Netgear 7800

File/Kernel: DD-WRT v3.0-r45073M std (12/21/20), Linux 4.9.248 #939 SMP Mon Dec 21 06:35:27 +07 2020 armv7l




BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7089
Location: Dresden, Germany

PostPosted: Wed Feb 24, 2021 7:35    Post subject: Reply with quote
by default the subdir box is empty and does not contain a "/". so you entered it already in your config and its indeed wrong if you enter a leading /
its named subdir and subdir is just a directory name where a leading slash indicates root

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1521
Location: Belgrade

PostPosted: Wed Feb 24, 2021 9:15    Post subject: Reply with quote
@tatsuya @anyone

did you tried new new firmware switch feature?
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2409

PostPosted: Wed Feb 24, 2021 13:48    Post subject: Reply with quote
I have and it works on EA8500. =) Running Vanilla now and one behavior I notice, which may be intentional,

is during boot it loads default custom DD-WRT binaries then at the end of dmesg output switches to VANILLA.

Router/Version: Linksys EA8500 / Box Rev.A00 PCB REV:205(XC) hw_rev=1 hw_ver=XB / r45820 (02/23/21)
File/Kernel: CLI Flash dd-wrt-webupgrade.bin / Linux 4.9.257 #1155 SMP Mon Feb 22 21:13:04 +07 2021 armv7l
Previous/Reset: r45767 (02/17/21) / No
Mode/Status: AP Gateway / Mixed, 20 MHz, Channels 1 and 149, TX Power 30 dBm, Short Preamble
Issues/Errors: None / Uptime 21 hours 25 minutes

DD-WRT ver 10.4-ddwrt-9980-tW-13-6049M api 5 features mfp,peer-flow-ctrl,allows-mesh-bcast,peer-fixed-rate crc32 85419a3b

VANILLA ver 10.4-3.15-00015 api 5 features no-p2p,mfp,peer-flow-ctrl,allows-mesh-bcast,no-ps,peer-fixed-rate crc32 e2c838df
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum