TEW-812DRU V2 Intermittent Connection Timeouts to Some Sites

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
own3mall
DD-WRT Novice


Joined: 26 Jul 2014
Posts: 20

PostPosted: Tue Jan 12, 2021 5:33    Post subject: TEW-812DRU V2 Intermittent Connection Timeouts to Some Sites Reply with quote
Hi All,

I've been running DD-WRT v24-sp2 (03/27/14) std
(SVN revision 23808) on my Trendnet TEW-812DRUv2 wireless router for about 5 years now. It's been stable and has always worked well until recently. For a few months now, certain websites randomly timeout for no reason. They intermittently work, and then sometimes, the connection times out. Browser tools show a connection time out. DNS is not the issue.

I can refresh a specific site every 5 seconds or so, and sometimes it loads fine, and other times it times out. I have been pulling out my hair trying to figure out what's wrong. I recently upgraded my cable modem to a Netgear CM400 (officially supported by Comcast) from a Motorola SB6121 (no longer officially supported by Comcast). This didn't fix my problem, so I tried my super old wireless router that doesn't run DD-WRT. Lo and behold I no longer have the issue when using my extremely old router (which happens to be an even older Trendnet than the one I'm using now). I also didn't have the problem when connecting my laptop directly to the modem. Thus, something is going on with my DD-WRT wireless router, but I have no idea what. I haven't changed my settings in years, and now all of a sudden, this appears to be a big problem.

It's so weird how it's only a few sites. I've seen it happen on more than just these, but here are some it times out loading:

hostmon(dot)net
hostmon(dot)tk

Each is hosted on a different server, and the server is in no way blocking or interfering with the connection (I run those servers).

Anyone have any idea what might be going on? What should I adjust in DD-WRT? I only have this problem on a few websites, and it seems to happen only on specific sites, but I have no idea what the full list is. Other than that, my whole setup works great. I get good pings when gaming, and my speeds are fast. I don't recall having this issue in the past.

I've changed TCP / UDP timeouts to lower values, changed to Westwood TCP Congestion Control, and removed some QoS rules prioritizing certain traffic over others. Unfortunately, none of that has helped, and I really don't want to replace this router with something else. It would take me forever to transfer all of the forwarded ports, settings, and rules to another router running a newer version of DD-WRT.

Hope someone has something I can try.
Sponsor
own3mall
DD-WRT Novice


Joined: 26 Jul 2014
Posts: 20

PostPosted: Tue Jan 12, 2021 8:02    Post subject: Reply with quote
Using TCPView, I'm seeing that when the connections time out, a SYN_SENT state is shown. However, the connection doesn't establish.
own3mall
DD-WRT Novice


Joined: 26 Jul 2014
Posts: 20

PostPosted: Wed Jan 13, 2021 19:04    Post subject: Reply with quote
Turns out, this problem was caused on my server's end due to the following setting:

/proc/sys/net/ipv4/tcp_tw_recycle was set to 1

I disabled tcp_tw_recycle, and now, I no longer have issues with the domains that were timing out.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum