New Build - 12/12/2020 - r44980

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2874

PostPosted: Sat Dec 12, 2020 16:07    Post subject: New Build - 12/12/2020 - r44980 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


WireGuard users read this first


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link doesn't work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r44970 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle. 6920, 6928, 6931, 6932 (WIP 7040)
In-kernel Samba has been implemented this year and default min/max versions have changed 6954, 6957, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
• Local DNS option removed from Services->DNSMasq in changesets 43080 and 43081; ref: #7092
• DHCP and DNS help (English) updated in 43083; ref: #7091
• WireGuard 1.0.20200908 & Tools: PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key, Guides. Thanks BS & egc!
• OpenVPN Version 2.5.0

Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog, serial output, strace, tcpdump etc.
• For firewall NAT or WAN issues provide 'iptables -vnL', 'iptables -t nat -vnL', 'iptables -t mangle -vnL' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
Frakko
DD-WRT User


Joined: 06 May 2016
Posts: 403

PostPosted: Sat Dec 12, 2020 16:54    Post subject: Reply with quote
BRICK BRICK BRICK

Netgear 6400 v2
(just bought) yesterday I had installed the previous one of 11-dec-2020 and it worked correctly. Thanks...
Sad
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7721
Location: Netherlands

PostPosted: Sat Dec 12, 2020 17:32    Post subject: Reply with quote
Router Model: Linksys EA8500

Firmware Version: DD-WRT v3.0-r44980 std (12/12/20)
Kernel Version: Linux 4.9.247 #908 SMP Sat Dec 12 05:53:46 +07 2020 armv7l

Upgraded: DD-WRT v3.0-r44849 std (11/20/20)
Reset: No not this time

Status: Up and running for 6 hours, basic setup as Gateway, static leases, Wifi 2,4GHz and 5 GHz working.
WireGuard client working (need to set WG tunnel address as per instructions in first post).

Errors: No

Big Thanks to the devs!!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7484
Location: YWG, Canada

PostPosted: Sat Dec 12, 2020 19:44    Post subject: Reply with quote
Router Model: dir-862L(x2), wndr4300, x86_64(2x qca9984 ,1x qca9882)

Status: it runs
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6842
https://svn.dd-wrt.com/ticket/6903 *
https://svn.dd-wrt.com/ticket/6921
https://svn.dd-wrt.com/ticket/7154
https://svn.dd-wrt.com/ticket/7222 *
https://svn.dd-wrt.com/ticket/7226
https://svn.dd-wrt.com/ticket/7246

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r46968 std
[QUALCOMM] DIR-862L --------------------------------> r46968 std
[QUALCOMM] DIR-862L --------------------------------> r46968 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 421

PostPosted: Sun Dec 13, 2020 2:44    Post subject: Reply with quote
Update method: SSH
Router/Version: Netgear Nighthawk X10
File/Kernel: DD-WRT v3.0-r44980 std (12/12/20)
Previous/Reset: DD-WRT v3.0-r44970 std (12/11/20) / None
Mode/Status: Gateway
Issues/Errors: None

_________________
Netgear R9000 X10
DD-WRT v3.0-r46949 std (06/13/21)
Gateway, AP, DNSMasq
IPv4 & IPv6 (Prefix Delegation)
CloudFlare, Ignore WAN DNS
QoS Disabled
Vanilla
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 450
5GHz: 100 + 114 (5500 MHz VHT160), ACK Timing 450
Clock 2000MHz
Xfinity 1.2Gbps/42Mbps
ArjenR49
DD-WRT User


Joined: 05 Oct 2008
Posts: 418
Location: Helsinki, Finland

PostPosted: Sun Dec 13, 2020 10:12    Post subject: Reply with quote
USB shares are accessible from a client whether the corresponding Access Shares on the Services NAS page is active or not.
This was reported on the new build 49970 thread, but 49980 does the same.

Upgraded via the GUI without resetting from 49970 to 49980 because of the rx buffer setting.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4393
Location: UK, London, just across the river..

PostPosted: Sun Dec 13, 2020 11:38    Post subject: Reply with quote
Router Model TP-Link WR1043ND V2
Firmware Version DD-WRT v3.0-r44980 std (12/12/20)
Kernel Version Linux 3.18.140-d5 #99457 Sat Dec 12 07:55:20 +07 2020 mips

update: CLI 44715 > 44980
reset: NO
status: Operational 12h+
errors: Nothing yet, its working ok and all rules regarding old Ath interface name ware auto renamed to wlan...less hassle and trouble Wink

good job BS 10x...!!

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 46949 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46885 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46949 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46949 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46949 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
giuliomagnifico
DD-WRT User


Joined: 11 Apr 2016
Posts: 377
Location: Italy

PostPosted: Sun Dec 13, 2020 12:20    Post subject: Reply with quote
Router Model: Netgear R7800
Firmware Version: DD-WRT v3.0-r44980 std (12/12/20)
Kernel Version: 4.9.247 #912 SMP Sat Dec 12 14:07:50 +07 2020 armv7l
Reset: No
Status: Working very good, no errors on wlan0/1. First time since Kong's builds!

Errors: None but my interfaces still has wlan0/1 name and not ath0/1
abhijitat
DD-WRT User


Joined: 06 Feb 2020
Posts: 131
Location: Maharashtra, India

PostPosted: Sun Dec 13, 2020 12:51    Post subject: Reply with quote
giuliomagnifico wrote:
Router Model: Netgear R7800
Firmware Version: DD-WRT v3.0-r44980 std (12/12/20)
Kernel Version: 4.9.247 #912 SMP Sat Dec 12 14:07:50 +07 2020 armv7l
Reset: No
Status: Working very good, no errors on wlan0/1. First time since Kong's builds!

Errors: None but my interfaces still has wlan0/1 name and not ath0/1


The interfaces have been renamed from ath0/1 to wlan0/1. they used to be ath0/1 in the prior build. now wlan0/1 is new normal
abhijitat
DD-WRT User


Joined: 06 Feb 2020
Posts: 131
Location: Maharashtra, India

PostPosted: Sun Dec 13, 2020 12:54    Post subject: Reply with quote
Router/Version: Netgear R7800
Firmware: DD-WRT v3.0-r44980 std (12/12/20)
Kernel: Linux 4.9.247 #912 SMP Sat Dec 12 14:07:50 +07 2020 armv7l
File/Upload: dd-wrt-webupgrade.bin / Upload using SSH
Mode: Gateway/AP
Reset: No
Previous: DD-WRT v3.0-r44970 std (12/11/20)reboot
Setup Using: 2.4 GHz, 5.0 GHz, IPv4, DNSMasq, USB, NTP TimeSync, wireguard
Status: Working Fine

Thank you BrainSlayer for Wonderful firmware.

Thanks all Guru for your help in forums.

Tried activating wireguard without success, I will wait for egc to update the guide. i am doing something wrong i am able to browse internet sites, but not able to connect to internal LAN using wireguard. when I started with woreguard, egc's guide was my savior so i will patiently wait.
computerperson
DD-WRT Novice


Joined: 16 May 2019
Posts: 6

PostPosted: Sun Dec 13, 2020 16:18    Post subject: Reply with quote
Code:
Router/Version: Netgear / r7800
Firmware: DD-WRT v3.0-r44980 std (12/12/20)
File/Kernel: Linux 4.9.247 #912 SMP Sat Dec 12 14:07:50 +07 2020 armv7l
Previous/Reset: r44849 / reset
Mode/Status: AP
Issues/Errors: commands will not run or parse properly on or after starup or reboot, need to hard reset and reload configuration

I am noticing the issue with startup commands not running. I can find nothing in the error logs, but if I then try to run a long command I get parsing errors (like unexpected line feed) and commands abort. In order to get commands to work, I need to hard reset the router and reload a saved configuration file. No other boot or software reset works.

This has been the case for at least the past 3 builds.

Once hard reset and configuration reload all is working well.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4393
Location: UK, London, just across the river..

PostPosted: Sun Dec 13, 2020 16:41    Post subject: Reply with quote
computerperson wrote:
.......In order to get commands to work, I need to hard reset the router and reload a saved configuration file. No other boot or software reset works.

This has been the case for at least the past 3 builds.

Once hard reset and configuration reload all is working well.


please define...hard reset... ? 30/30/30 ???? Laughing Laughing Laughing

In case of you are loading an old config file, from different builds...there you go...problems..
In case you load same settings after reset, you care the same buggy settings abroad....

in order to do the correct reset...you must reset and manually rebuild settings...do not load safe file...

very likely, your issue is due to bad configuration or your very own mess...

P.S.
computerperson wrote:
commands will not run or parse properly


where do you parse commands for execution...in GUI>commands> commands box ????
there you go more problems....

for commands use CLI not the GUI commands box...

to save commands for start up, firewall, and custom script than use command box..
if your syntax is wrong there you go...

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 46949 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46885 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46949 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46949 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46949 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
abhijitat
DD-WRT User


Joined: 06 Feb 2020
Posts: 131
Location: Maharashtra, India

PostPosted: Sun Dec 13, 2020 16:55    Post subject: Reply with quote
abhijitat wrote:
Router/Version: Netgear R7800
Firmware: DD-WRT v3.0-r44980 std (12/12/20)
Kernel: Linux 4.9.247 #912 SMP Sat Dec 12 14:07:50 +07 2020 armv7l
File/Upload: dd-wrt-webupgrade.bin / Upload using SSH
Mode: Gateway/AP
Reset: No
Previous: DD-WRT v3.0-r44970 std (12/11/20)reboot
Setup Using: 2.4 GHz, 5.0 GHz, IPv4, DNSMasq, USB, NTP TimeSync, wireguard
Status: Working Fine

Thank you BrainSlayer for Wonderful firmware.

Thanks all Guru for your help in forums.

Tried activating wireguard without success, I will wait for egc to update the guide. i am doing something wrong i am able to browse internet sites, but not able to connect to internal LAN using wireguard. when I started with woreguard, egc's guide was my savior so i will patiently wait.


Update:

I have successfully setup wireguard by using egc's guide and changed IP seeting using CIDR notation. Now I am able to connect to internal LAN allowed IP. I am still not able to connect to router. I can connect and ping all internal IP's except router IP
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 6130
Location: Romerike, Norway

PostPosted: Sun Dec 13, 2020 17:38    Post subject: Reply with quote
Router/Version: Netgear R7800
Firmware: DD-WRT v3.0-r44980 std (12/12/20)
Kernel: Linux 4.9.247 #912 SMP Sat Dec 12 14:07:50 +07 2020 armv7l
File/Upload: dd-wrt-webupgrade.bin / Upload using GUI
Mode: Gateway/AP
Reset: No
Previous: DD-WRT v3.0-r44944
Setup Using: 2.4 GHz, 5.0 GHz, IPv4, IPv6, DNSMasq, USB, NTP TimeSync, wireguard, Samba
Status: Working Fine. Samba is working again (Broken i previous)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum