Is it possible to disable WMM power save on the R7000?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
DD-WRT Novice

Joined: 14 Feb 2014
Posts: 13

PostPosted: Mon Feb 23, 2015 23:05    Post subject: Is it possible to disable WMM power save on the R7000? Reply with quote
I made some post about issues with an iPad Air 2 and my Netgear R7000 Nighthawk running DD-WRT a while ago.

In the meantime with the new DD-WRT builds using the new driver WiFi runs pretty great on all of my devices except the iPad Air 2. Now I tend to believe this is some issue on the Air 2 side.

Anyway it is still not possible to stream TV from my Dreambox to the Air 2 using the Blackbox Pro app. The video will hang every 30s to 1min (an iPhone 6+ now works perfectly fine with the new DD-WRT firmwares with the new driver, as does an iPad Air 1).
I even had a second iPad Air 2 here for testing which showed the exact same issues (while all the time the 6+ was streaming at the same time without any issue).

Now after some more googling I found this thread and despite the thread being about the Air 1 I have a suspicion the issue here might be the same: (messages from "OneManHiking", not sure how to extract the direct links to the posts from their forum).

It's about the WMM power save feature with the possible solution of disabling it on the router.

I have made the following observations:

* If I turn off WMM completely in DD-WRT then the Air 2 streams just fine, video doesn't hang, however there are some other issues then and the speed in speed tests doesn't go over 30 mbps on average (with WMM enabled over 200 mbps).

* If I switch to A mode (which doesn't support WMM) then also everything is fine (but being in A mode of course also is very slow).

-> So it seems the issue is definitely related to WMM and this WMM power save feautre might really be the reason.

Now the best solution would be to try to turn off WMM power save and leave WMM generally on, but I don't see an option for that.

Is there some way to do that, maybe via command line, or am I just not seeing the option, maybe it is called differently?
DD-WRT Novice

Joined: 14 Feb 2014
Posts: 13

PostPosted: Wed Feb 25, 2015 19:05    Post subject: Reply with quote
Anyone? Crying or Very sad

Joined: 03 Sep 2013
Posts: 729

PostPosted: Wed Feb 25, 2015 19:34    Post subject: Reply with quote
wish i could help, but i fall into the #4 category from here

reenignE esreveR
Resistance is NOT futile... It's Voltage divided by Current!

_.-:Curently Deployed Devices:-._
Loc_1.0: R6400 -- Kong PTB 35550M 03-28-2018
Loc_2.0: R6300v2 -- Kong PTB 35550M 03-28-2018
Loc_3.0: R6300v2 -- Kong PTB 35030M 02-19-2018
Loc_4.0: R6300v2 -- Kong PTB 28600M 12-31-2015 (Radios OFF) & 5 Ubiquity UniFi APs
Loc_4.1: E4200 -- BrainSlayer K2.6 30880
Others: too many others to list

UNofficial Repo Kong's old builds HERE.

R7000 (& similar HW) Tips/Tricks HERE.

1. Everyone on the forum has read the relevant forum section announcements.
2. For Broadcom section we have ALL at least tried to understand the "Peacock" thread,
DD-WRT Novice

Joined: 14 Feb 2014
Posts: 13

PostPosted: Wed Feb 25, 2015 20:33    Post subject: Reply with quote
Well I guess at least some people here should know. Wink

Apparently some routers do have a setting for this so the question is why there is no setting for this in dd-wrt if dd-wrt is supposed to give more options than stock firmwares. Wink

Or this is something that is only controlled by hardware nowadays and can't be changed with software on the routers that dd-wrt runs on!?

If there was some way to change this it would be worth a try seeing whether the issues with the iPad Air 2 can be circumvented with it.

Joined: 09 Feb 2008
Posts: 639
Location: Canada

PostPosted: Thu Dec 03, 2020 16:03    Post subject: Reply with quote
I'd like to know if there has been on update on this topic?

It is possible to disable the power saving in WMM while leaving WMM itself enabled?

Location (urban) - 1x Linksys EA8500 (AP wlan0 & wlan1 enabled)
1x Asus 68u (Repeater Bridge w/VAP) - wl0 disabled
1x Asus 87u (Client Bridge) - wl1 disabled

Latest and greatest builds Wink

Joined: 21 Jan 2017
Posts: 1677
Location: Illinois Moderator

PostPosted: Thu Dec 03, 2020 17:28    Post subject: Reply with quote
The feature is known as U-APSD and you can turn it off...

That said, it's a hard baked chipset feature and not all chipsets comply/play nice with the setting. It's a crapshoot if you enable it if the client will comply or not...

You can certainly try playing with the setting, but YMMV.

On a lot of atheros, u-apsd is not implemented on the router end to work; though, I saw some recent SVN's about that feature...

Maybe another guru will chime in for BCM.


TIPS/TRICKS: Best QCA Wifi Settings | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]45778 nightly (Main Router)
[EA8500]43192 & 45493 (2xOffsite)
[WDR3600]BS 44715 (Offsite)
[A7v5]BS 43038 (Offsite+spare napping)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum