New Build 07-14-2020-r43800

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4166
Location: UK, London, just across the river..

PostPosted: Tue Jul 14, 2020 13:46    Post subject: New Build 07-14-2020-r43800 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link doesn't work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r43711 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix (applicability depends on VPN setup) and GUI toggle. 6920, 6928, 6931, 6932 (WIP 7040)
In-kernel Samba has been implemented this year and default min/max versions have changed 6954, 6957, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
• Local DNS option removed from Services->DNSMasq in changesets 43080 and 43081; ref: #7092
• DHCP and DNS help (English) updated in 43083; ref: #7091
WireGuard 1.0.20200623: PBR, Kill Switch, Inbound Firewall, Naming of Peers, Status, Key, Guides. Thanks egc!

Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: 'dmesg', 'cat /tmp/var/log/messages', syslog/serial output, strace etc.
• For firewall issues provide 'iptables -L', 'iptables -t nat -L' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 45711 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 45820 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 45711 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 45735 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 45735 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
Sponsor
turbowells
DD-WRT User


Joined: 14 Sep 2019
Posts: 185
Location: Maine, USA

PostPosted: Tue Jul 14, 2020 15:23    Post subject: Reply with quote
Router/Version: Netgear WNR2000v3
File: wnr2000v3-webflash.bin
Firmware: DD-WRT v3.0-r43800 std (07/14/20)
Kernel: Linux 3.10.108-d10 #52378 Tue Jul 14 05:05:39 +04 2020 mips
Mode: AP
Previous: r43711
Reset?: N
Status: Working
ArjenR49
DD-WRT User


Joined: 05 Oct 2008
Posts: 391
Location: Helsinki, Finland

PostPosted: Tue Jul 14, 2020 15:35    Post subject: Reply with quote
There's a small problem on the Administration page:

Dynamic Host Configuration Protocol
DHCP Status
DHCP Server
Enabled
Start IP Address
192.168.5.10
End IP Address
192.168.5.9,
Client Lease Expiration
1440 min

The end IP address should end in 29 in my case.

I don't know when this error came about. I haven't noticed DHCP to not work as intended. I have two devices which get their IP from the address space defined above.
The settings page has the correct values:
start IP 192.168.5.10 and 20 max users.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7962
Location: Texas, USA

PostPosted: Tue Jul 14, 2020 15:42    Post subject: Reply with quote
There was a change in the webUI for configuring DHCP. Thanks for noticing the error.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5398
Location: Texas

PostPosted: Tue Jul 14, 2020 16:04    Post subject: Reply with quote
Linksys EA8500 ...main router
Version DD-WRT v3.0-r43800 std (07/14/20)
Linux 4.9.230 #601 SMP Thu Jul 9 19:40:35 +03 2020 armv7l
GUI install over r43793
all ok
uptime 14:25

#

Netgear WNDR3700 V4
DD-WRT v3.0-r43800 std (07/14/20)
Linux 3.18.140-d5 #83975 Tue Jul 14 04:58:42 +04 2020 mips
GUI install over r43736
all ok
uptime 14:32
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 217

PostPosted: Tue Jul 14, 2020 16:07    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r43800 std (07/14/20)
Kernel: Linux 4.9.230 #601 SMP Thu Jul 9 19:40:35 +03 2020 armv7l
Status: Working
Reset: No
Previous: 43720
Errors: No

Temperatures : CPU 55.113 °C / ath0 52 °C / ath1 52 °C

Working very well :
Router mode : DHCP
SFE Enable
STP Disable
DNSMasq
Cache DNSSEC data
Validate DNS Replies (DNSSEC)
Check unsigned DNS replies
Local DNS
No DNS Rebind
ath0, ath1
Vpn (OpenVPN Client)

without VPN


with VPN
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7187
Location: Netherlands

PostPosted: Tue Jul 14, 2020 16:17    Post subject: Reply with quote
kernel-panic69 wrote:
There was a change in the webUI for configuring DHCP. Thanks for noticing the error.


@kp69 I just checked the DHCP range is OK it is just the Status/LAN -> End IP address which is wrong

I trust you inform BS Smile

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
marcelo3d
DD-WRT User


Joined: 07 Aug 2017
Posts: 74

PostPosted: Tue Jul 14, 2020 16:24    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r43800 std (07/14/20)
Kernel: Linux 4.9.230 #601 SMP Thu Jul 9 19:40:35 +03 2020 armv7l
Reset: No

smbd.mountd seems to have gotten worse:
This is during boot after upgrade:
Code:

<11>: Caught SIGSEGV (11) in strcmp
<11>: Fault at memory location 0x00000000 due to address not mapped to object (1).
<11>: Thread 3059: ksmbd.mountd
<11>: === Context:
<11>:    TRAPNO:0000000e   ERRCODE:00000017   OLDMASK:00000000        R0:b6ed3540
<11>:        R1:00000000        R2:0000006e        R3:00000001        R4:b6ed35c0
<11>:        R5:00031724        R6:00000000        R7:00000000        R8:00000000
<11>:        R9:00000000       R10:b6f0981c        FP:b6f9f248        IP:00031050
<11>:        SP:b6ea0c98        LR:00013b68        PC:b6f703c8      CPSR:60000010
<11>: FAULTADDR:00000000
<11>: === Backtrace:
<11>: # Searching frame 0 (FP=0xb6f9f248, PC=0xb6f703c8)
<11>: # PC-1de4[0xb6f6e5e4]: 0xe92d4ff0 stmfd sp!
<11>: # FP-00[0xb6f9f248]: 0x00000000 {LR}
<11>: # FP-04[0xb6f9f244]: 0x00001000 {FP}
<11>: # FP-08[0xb6f9f240]: 0x00000001 {R10}
<11>: # FP-0c[0xb6f9f23c]: 0x00000004 {R9}
<11>: # FP-10[0xb6f9f238]: 0x000000d0 {R8}
<11>: # FP-14[0xb6f9f234]: 0xb6f9d7d4 {R7}
<11>: # FP-18[0xb6f9f230]: 0xbe908dbc {R6}
<11>: # FP-1c[0xb6f9f22c]: 0x00000001 {R5}
<11>: # FP-20[0xb6f9f228]: 0x00000000 {R4}
<11>: # Crashed at /lib/ld-musl-armhf.so.1[0xb6f26000](strcmp+0x00000004)[0xb6f703c8]
<11>: # Searching frame 1 (FP=0x00001000, PC=0x00000000)
<11>: # Instruction at 0x00000000 is not mapped; terminating backtrace.
<11>: /lib/ld-musl-armhf.so.1[0xb6f26000](strcmp+0x00000004)[0xb6f703c8]
<11>: ???(+0)[0x00000000]
<11>: === Code:
<11>: b6f70388:  e5f02001 e3520000 0affffdc e1520001 1afffffa e1cd40d0 e59d6008 e28dd00c
<11>: b6f703a8:  e49df004 eb000102 e0840000 e1cd40d0 e59d6008 e28dd00c e49df004 e5d02000
<11>: b6f703c8: >e5d13000 e1530002 0a000004 ea000005 e5f02001 e5f13001 e1520003 1a000001
<11>: b6f703e8:  e3520000 1afffff9 e0420003 e12fff1e e52d4008 e1a04000 e58de004 ebfffec8
<171>Jul 14 16:17:12 ksmbd: [ksmbd-worker/2848]: ERROR: Child received signal: 11 (Segmentation fault)
<171>Jul 14 16:17:13 ksmbd: [ksmbd-worker/2848]: ERROR: Recv() error Bad socket [-3]
<11>: Caught SIGILL (4) in free
<11>: Fault at memory location 0xb6f4de48 due to illegal opcode (1).
<11>: Thread 2848: ksmbd.mountd
<11>: === Context:
<11>:    TRAPNO:00000006   ERRCODE:00000000   OLDMASK:00000000        R0:b6f25a27
<11>:        R1:00000031        R2:00000020        R3:b6ed3630        R4:b6f09890
<11>:        R5:b6f0981c        R6:00013d50        R7:00000000        R8:00000000
<11>:        R9:00020394       R10:b6f9c760        FP:00000007        IP:00031164
<11>:        SP:be908b88        LR:0001deec        PC:b6f4de48      CPSR:20000010
<11>: FAULTADDR:00000000
<11>: === Backtrace:
<11>: # Searching frame 0 (FP=0x00000007, PC=0xb6f4de48)
<11>: # PC-188c[0xb6f4c5bc]: 0xe92d4ff0 stmfd sp!
<11>: # Stack at 0x00000007 is not mapped; terminating backtrace.
<11>: /lib/ld-musl-armhf.so.1[0xb6f26000](free+0x00000030)[0xb6f4de48]
<11>: === Code:
<11>: b6f4de08:  1afffff4 eaffffeb 00051518 000514b8 e2501000 0a00000c e5112004 e2410008
<11>: b6f4de28:  e3120001 1a000007 e5111008 e3c22001 e3110001 e0400001 e0821001 0a000000
<11>: b6f4de48: >e7f000f0 ea001c15 eafffcad e12fff1e e16d42f4 e2505000 e1cd60f8 e1cd81f0
<11>: b6f4de68:  e1cda1f8 e58de020 e24dd00c 0a00006a e59f021c e3e02142 e2413001 e08f0000
<171>Jul 14 16:17:13 ksmbd: [ksmbd-worker/2848]: ERROR: Child received signal: 4 (Illegal instruction)
<11>: Caught SIGILL (4) in free
<11>: Fault at memory location 0xb6f4de48 due to illegal opcode (1).
<11>: Thread 2848: ksmbd.mountd
<11>: === Context:
<11>:    TRAPNO:00000006   ERRCODE:00000000   OLDMASK:00000000        R0:b6f25a27
<11>:        R1:00000031        R2:00000020        R3:b6ed3630        R4:b6f09890
<11>:        R5:b6f0981c        R6:00013d50        R7:00000000        R8:00000000
<11>:        R9:00020394       R10:b6f9c760        FP:00000007        IP:00031164
<11>:        SP:be908b88        LR:0001deec        PC:b6f4de48      CPSR:20000010
<11>: FAULTADDR:00000000
<11>: === Backtrace:
<11>: # Searching frame 0 (FP=0x00000007, PC=0xb6f4de48)
<11>: # PC-188c[0xb6f4c5bc]: 0xe92d4ff0 stmfd sp!
<11>: # Stack at 0x00000007 is not mapped; terminating backtrace.
<11>: /lib/ld-musl-armhf.so.1[0xb6f26000](free+0x00000030)[0xb6f4de48]
<11>: === Code:
<11>: b6f4de08:  1afffff4 eaffffeb 00051518 000514b8 e2501000 0a00000c e5112004 e2410008
<11>: b6f4de28:  e3120001 1a000007 e5111008 e3c22001 e3110001 e0400001 e0821001 0a000000
<11>: b6f4de48: >e7f000f0 ea001c15 eafffcad e12fff1e e16d42f4 e2505000 e1cd60f8 e1cd81f0
<11>: b6f4de68:  e1cda1f8 e58de020 e24dd00c 0a00006a e59f021c e3e02142 e2413001 e08f0000
<171>Jul 14 16:17:13 ksmbd: [ksmbd-manager/2847]: ERROR: WARNING: child process exited abnormally: 2848
<3>Jul 14 16:17:14 kernel: [   99.648703] ksmbd: handle_startup_event:370: Reconnect to a new user space daemon
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7962
Location: Texas, USA

PostPosted: Tue Jul 14, 2020 16:31    Post subject: Reply with quote
egc wrote:
kernel-panic69 wrote:
There was a change in the webUI for configuring DHCP. Thanks for noticing the error.


@kp69 I just checked the DHCP range is OK it is just the Status/LAN -> End IP address which is wrong

I trust you inform BS Smile


Yep, did screenshots from my R7000P and sent myself an email and forwarded it.

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
marcelo3d
DD-WRT User


Joined: 07 Aug 2017
Posts: 74

PostPosted: Tue Jul 14, 2020 16:42    Post subject: Reply with quote
marcelo3d wrote:
Router: Netgear R7800
Firmware: DD-WRT v3.0-r43800 std (07/14/20)
Kernel: Linux 4.9.230 #601 SMP Thu Jul 9 19:40:35 +03 2020 armv7l
Reset: No

smbd.mountd seems to have gotten worse:
[dump]

After that SMB seemed to work. I rebooted the PC, browsed to the share and clocked on the IP address part and got a new failure on Windows Explorer: "The array bounds are invalid"
Nothing on Syslog.
SMB seems to somewhat work even with the errors.
ArjenR49
DD-WRT User


Joined: 05 Oct 2008
Posts: 391
Location: Helsinki, Finland

PostPosted: Tue Jul 14, 2020 16:45    Post subject: Reply with quote
There seems to be a new problem with DDNS:

Tue Jul 14 19:39:54 2020: I:INADYN: IP address for alias 'Axxxxx.no-ip.org' needs update to '82.xxx.xxx.xxx'
Tue Jul 14 19:39:59 2020: INADYN:IP: Error '0x16' resolving host name 'dynupdate.no-ip.com'
Tue Jul 14 19:39:59 2020: W:'RC_IP_INVALID_REMOTE_ADDR' (0x12) updating the IPs. (it 7)


I get these every 10 minutes now. The problem may have been present for a while, because my public IP doesn't change often (only when I change the router).
However, it used to work without errors before.

I have always had external IP check off. I'll try now with it enabled.

That didn't help:

Tue Jul 14 19:46:14 2020: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater.
Tue Jul 14 19:46:14 2020: INADYN: IP read from cache file is '82.xxx.xxx.xxx'. No update required.
Tue Jul 14 19:46:20 2020: INADYN:IP: Error '0x16' resolving host name 'ip1.dynupdate.no-ip.com'
Tue Jul 14 19:46:20 2020: W: DYNDNS: Error 'RC_IP_INVALID_REMOTE_ADDR' (0x12) when talking to IP server
Tue Jul 14 19:46:20 2020: W:'RC_IP_INVALID_REMOTE_ADDR' (0x12) updating the IPs. (it 0)

It says no update required, but then it tries to update anyway ...

For good measure I have whitelisted dynupdate.no-ip.com, even though I haven't seen it getting blocked by PiHole.
In fact, I cannot even find dynupdate.no-ip.com in the query log. Odd.

After disabling the external check and applying settings I get this:

Tue Jul 14 19:51:16 2020: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater.
Tue Jul 14 19:51:16 2020: INADYN: IP read from cache file is '82.xxx.xxx.xxx'. No update required.
Tue Jul 14 19:51:16 2020: I:INADYN: IP address for alias 'Axxxxxx.no-ip.org' needs update to '82.xxx.xxx.xxx'
Tue Jul 14 19:51:21 2020: INADYN:IP: Error '0x16' resolving host name 'dynupdate.no-ip.com'
Tue Jul 14 19:51:21 2020: W:'RC_IP_INVALID_REMOTE_ADDR' (0x12) updating the IPs. (it 0)

On my laptop, which is a client of the R7800 router, I get this:

arjen@HP430G5:~$ dig dynupdate.no-ip.com

; <<>> DiG 9.11.3-1ubuntu1.12-Ubuntu <<>> dynupdate.no-ip.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51605
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;dynupdate.no-ip.com. IN A

;; ANSWER SECTION:
dynupdate.no-ip.com. 60 IN A 54.219.9.206
dynupdate.no-ip.com. 60 IN A 52.9.108.157

;; Query time: 44 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Tue Jul 14 20:01:47 EEST 2020
;; MSG SIZE rcvd: 80

Looking altogether normal, I'd say.
Also my own domain name resolves to its IP without a hitch.


Last edited by ArjenR49 on Tue Jul 14, 2020 17:09; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5398
Location: Texas

PostPosted: Tue Jul 14, 2020 16:56    Post subject: Reply with quote
egc wrote:
kernel-panic69 wrote:
There was a change in the webUI for configuring DHCP. Thanks for noticing the error.


@kp69 I just checked the DHCP range is OK it is just the Status/LAN -> End IP address which is wrong

I trust you inform BS Smile


I usually don't pay attention to such pages but since you mentioned it...
EA8500 its webif ../Status_Lan.asp page is little off Rolling Eyes


It ain't been reset in long long time and I can assure you DNSmasq DHCP is working correctly Cool
Code:
root@(-:~# cat /tmp/dnsmasq.conf
interface=br0,br1
resolv-file=/tmp/resolv.dnsmasq
strict-order
server=127.0.0.1#7053
no-resolv
domain=mrjcd.com
dhcp-leasefile=/tmp/dnsmasq.leases
dhcp-lease-max=129
dhcp-option=br0,3,10.72.28.13
dhcp-option=br1,3,10.15.26.225
dhcp-authoritative
dhcp-range=br0,10.72.28.100,10.72.28.174,255.255.255.0,1440m
dhcp-range=br1,10.15.26.232,10.15.26.251,255.255.255.224,720m
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7962
Location: Texas, USA

PostPosted: Tue Jul 14, 2020 17:21    Post subject: Reply with quote
A reset won't fix the status page. @ArjenR49: If the router is not resolving DNS, then there is a problem on the WAN side, unless you are forcing the router to use it's own resolver and then forwarding the queries upstream to OpenDNS, Cloudflare, Google, etc.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
abhijitat
DD-WRT User


Joined: 06 Feb 2020
Posts: 97
Location: Maharashtra, India

PostPosted: Tue Jul 14, 2020 17:25    Post subject: Reply with quote
Router/Version: Netgear R7800
Firmware: DD-WRT v3.0-r43800 std (07/14/20)
Kernel: Linux 4.9.230 #601 SMP Thu Jul 9 19:40:35 +03 2020 armv7l
File/Upload: dd-wrt-webupgrade.bin / Upload using SSH
Mode: Gateway/AP
Reset: No
Previous: DD-WRT v3.0-r43762 std (07/12/20) - test build
Setup Using: 2.4 GHz, 5.0 GHz, IPv4, DNSMasq, USB, NTP TimeSync, wireguard
Status: Working Fine including smbd

Thank you BrainSlayer for Wonderful firmware.

Thanks kernel-panic & egc for your help in forums. and egc's wireguard setup guide is one to preserve for long, it helped me setup wireguard in minutes.
ArjenR49
DD-WRT User


Joined: 05 Oct 2008
Posts: 391
Location: Helsinki, Finland

PostPosted: Tue Jul 14, 2020 19:50    Post subject: Reply with quote
kernel-panic69 wrote:
A reset won't fix the status page. @ArjenR49: If the router is not resolving DNS, then there is a problem on the WAN side, unless you are forcing the router to use it's own resolver and then forwarding the queries upstream to OpenDNS, Cloudflare, Google, etc.


It appears that this problem has been in existence in my setup for a number of weeks at least. I reverted to 43516 and a corresponding settings backup.
Still the same problem with dig dynupdate.no-ip.com. I mean, it's like you indicated, the router can't resolve this (ssh'd into router), but both PiHole server and laptop can.

Still, some time ago I also tested dig commands in all three devices, laptop, pihole server and router. They all resolved the domain in the dig command back then. Just the source:
;; Query time: 255 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Tue Jul 14 22:41:20 EEST 2020
;; MSG SIZE rcvd: 80

differed between these three devices. I was curious about that back then.

I have no idea yet what broke DNS resolving on the router alone. I'll try and restore older and olxer setting backups. They do not differ all that much and I can perhaps deduct what stopped the router from resolving a name. It is supposed to use the PiHole just as everything else.

I know I am not very savvy at this.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum