New Build - 06-04-2020-r43334

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3
Author Message
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 694
Location: Hung Hom, Hong Kong

PostPosted: Sun Jun 07, 2020 7:27    Post subject: Reply with quote
iFrog wrote:

I seem to have sorted out my smart home issues, and they didn't appear to be related to DD-WRT. I tried the router NAS features about a year or so back, and I just find it a bad idea overall to depend on these limited devices for something a dedicated NAS, or even desktop computer are better suited for....

I am the only person using the Samba share in DD-WRT, and I am only listening to MP3 music. So my RT-N18U was not overloaded.

Thank you for sharing your opinion! Continuing my Samba ksmbd adventure .... Was WSDD2 at fault as well? Smile

Update:
So far accessing Samba in this build 43334 did NOT reboot....


_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832


Last edited by mwchang on Sun Jun 07, 2020 16:08; edited 1 time in total
Sponsor
wicket
DD-WRT Novice


Joined: 18 Jul 2017
Posts: 41
Location: Wisconsin, USA

PostPosted: Sun Jun 07, 2020 14:13    Post subject: EA6500 V1 Boot Loop (Don't Flash) Reply with quote
Router/Version: Linksys EA6500 v1
Firmware: dd-wrt-43334-ea6500.trx
Kernel: Linux 4.4.226 #1622 Thu Jun 4 15:08:48 +04 2020 mips
Previous: DD-WRT v3.0-r43324 giga (06/02/20)
Mode/Status: Gateway/AP
Reset: No
Issues/Errors: Boot Loop, consistently unable to ping, or telnet into unit ended up letting it loop and for around half an hour until I finally was able to TFTP it back to 43324 should probably have just serial flashed it to save time.

Unfortunately since I was unable to access telnet or web GUI I was unable to see the syslog so I can't tell what is causing this behavior but rolling back one version everything working again.

_________________
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3868
Location: UK, London, just across the river..

PostPosted: Sun Jun 07, 2020 16:55    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r43334 std (06/04/20)
Kernel: Linux 4.4.226 #304 SMP Thu Jun 4 07:59:59 +04 2020 armv7l

Update: via CLI
Previous: r43324
Mode/Status: Gateway with DNS DoT & VPN
Reset: No
Issues/Errors: still boot-up with that gimmick, log or dmesg dont show anything to identify the problem...
its kind of ext2 drive miss identification or some start up confront.. its been like that since 42054 (last problem-less boot)
otherwise its ok and working...so far so good..

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 44538 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 44538 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 44538 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 44538 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 44538 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
hurleyp
DD-WRT User


Joined: 10 Sep 2009
Posts: 284
Location: Ottawa, Ontario, Canada

PostPosted: Sun Jun 07, 2020 21:05    Post subject: Reply with quote
Firmware: v3.0-r43334 std (06/04/20)
Router/Version: Netgear R7000
Kernel: Linux 4.4.226 #304 SMP Thu Jun 4 07:59:59 +04 2020 armv7l
Previous: v3.0-r43320 std (06/01/20)
Mode/Status: AP wired and wireless, Up and running for 2+ days
Reset: Soft boot before and after upgrade
Temperatures: CPU 61.4 °C / WL0 47.6 °C / WL1 52.6 °C
Issues/Errors: Nothing significant

Updated via webif. No 'nvram erase' this time, last one was in July 2018 (r36325).

The minor issue with the zero packet count on wl0 has returned, and "Connected Clients" is stuck at zero. The wl1 counts seem correct.

Current basic R7000 setup (subject to change of course):
- Static WAN IP
- SFE - On
- STP - On
- IPv4 only, both WAN and LAN
- LAN DHCP Enabled
- Wireless: AP, Regulatory Domain = CANADA, wl0 Mixed (ch. 6), wl1 AC/N-Mixed (ch. 149, VHT80), AES
- 1 wireless VLAN on wl0
- SNMP disabled, SSH enabled, Telnet disabled
- Firewall enabled, Log Level high
- Syslog: to local server. klogd: enabled.
- USB support - Off
- No custom scripts
- NO: ttraf, Tor, VNC, Zabbix, VPN, Radius
- NO: UPnP, DMZ, QoS
- NO: Samba, CIFS, JFFS2, miniDLNA, Entware, Optware

_________________
Netgear R7000: v3.0-r44538 std (10/13/20)
EdgeRouter-X: EdgeOS v2.0.8
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 694
Location: Hung Hom, Hong Kong

PostPosted: Fri Jun 12, 2020 7:28    Post subject: DD-WRT BS build 43334 and Asus RT-N18U Reply with quote
speedtest.net result for DD-WRT BS build 43334 and Asus RT-N18U

Router/Version: Asus RT-N18U (rev. A1)
Firmware: DD-WRT v3.0-r43334 std (06/04/20)
Kernel: Linux 4.4.226 #308 Thu Jun 4 08:33:27 +04 2020 armv7l
Previous: DD-WRT v3.0-r43217 std (05/22/20)
Mode: WAN @ DHCP, Wireless @ AP
Status: Working (Not 24/7; Not using IPv6, VAP, VPN; Using NASd & USB)
Reset: NO reset during firmware upgrade but cold boot

Summary

Could those ksmbd and wsdd2 messages be solved? Smile

System Log

Error(s): grep -i err /var/log/messages
Code:

Jan  1 08:00:13 RT-N18U kern.err kernel: bcmsflash: found no supported devices
Jan  1 08:00:14 RT-N18U daemon.info mstpd[600]: error, CTL_set_cist_bridge_config: Couldn't find bridge with index 7
Jan  1 08:00:14 RT-N18U daemon.info mstpd[600]: error, CTL_set_cist_bridge_config: Couldn't find bridge with index 7
Jan  1 08:00:23 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jan  1 08:00:23 RT-N18U local5.err ksmbd: [ksmbd-worker/961]: ERROR: Can't open `/tmp/smb.db': No such file or directory
Jan  1 08:00:23 RT-N18U local5.err ksmbd: [ksmbd-worker/961]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
Jan  1 08:00:24 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jan  1 08:00:24 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jun 12 15:17:51 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jun 12 15:17:52 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jun 12 15:17:52 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jun 12 15:17:52 RT-N18U user.err wsdd2[957]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
Jun 12 15:18:00 RT-N18U kern.err kernel: hub 3-0:1.0: config failed, hub doesn't have any ports! (err -19)
Jun 12 15:18:02 RT-N18U user.err wsdd2[957]: Terminated received.
Jun 12 15:18:02 RT-N18U local5.err ksmbd: [ksmbd-manager/960]: ERROR: WARNING: child process exited abnormally: 961
Jun 12 15:18:08 RT-N18U local5.err ksmbd: [ksmbd-worker/1591]: ERROR: Can't open `/tmp/smb.db': No such file or directory
Jun 12 15:18:08 RT-N18U local5.err ksmbd: [ksmbd-worker/1591]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
Jun 12 15:19:26 RT-N18U daemon.err httpd[1309]: httpd : Request Error Code 401: Authorization required. please note that the default username is "root" in all newer releases
Jun 12 15:19:30 RT-N18U daemon.err httpd[1309]: httpd : Request Error Code 404: File style/elegant/logo.png not found.


Emergency: grep -i emerg /var/log/messages
Code:

Jan  1 08:00:13 RT-N18U kern.emerg kernel: Asus-RT-AC56U init
Jan  1 08:00:13 RT-N18U kern.emerg kernel: Asus-RT-AC68U init


Warning(s): grep -i warn /var/log/messages | grep -v DROP
Code:

Jan  1 08:00:14 RT-N18U kern.warn kernel: COEX: downgraded chanspec 0x1803 to 0x1001: channel 6 used by exiting BSSs
Jan  1 08:00:15 RT-N18U kern.warn kernel: COEX: downgraded chanspec 0x1803 to 0x1001: channel 6 used by exiting BSSs
Jan  1 08:00:20 RT-N18U kern.warn kernel: COEX: downgraded chanspec 0x1803 to 0x1001: channel 6 used by exiting BSSs
Jan  1 08:00:21 RT-N18U kern.warn kernel: COEX: downgraded chanspec 0x1803 to 0x1001: channel 6 used by exiting BSSs
Jun 12 15:17:58 RT-N18U daemon.warn dnsmasq[1144]: possible DNS-rebind attack detected: tracker.publicbt.com
Jun 12 15:18:02 RT-N18U local5.err ksmbd: [ksmbd-manager/960]: ERROR: WARNING: child process exited abnormally: 961


Firmware Size

From 30515200 (b.31277) to 24711168 (b.33555) = -5804032 bytes
From 24711168 (b.33555) to 27054080 (b.34929) = 2342912 bytes
From 27054080 (b.34929) to 26640384 (b.35531) = -413696 bytes
From 26640384 (b.35531) to 25022464 (b.36995) = -1617920 bytes
... <snipped> ....
From 26988544 (b.42366) to 26988544 (b.42514) = 0 bytes
From 26988544 (b.42514) to 29143040 (b.42681) = 2154496 bytes
From 29143040 (b.42681) to 27693056 (b.42914) = -1449984 bytes
From 27693056 (b.42914) to 27705344 (b.43055) = 12288 bytes
From 27705344 (b.43055) to 26619904 (b.43171) = -1085440 bytes
From 26619904 (b.43171) to 26345472 (b.43192) = -274432 bytes
From 26345472 (b.43192) to 26341376 (b.43209) = -4096 bytes
From 26341376 (b.43209) to 26341376 (b.43217) = 0 bytes
From 26341376 (b.43217) to 26472448 (b.43334) = 131072 bytes


_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
coletrain
DD-WRT User


Joined: 01 Oct 2016
Posts: 171
Location: St.louis, MO USA

PostPosted: Mon Jul 20, 2020 14:54    Post subject: Seems Good Reply with quote
Based on another review, I flashed this build last night via web interface and reset to default settings.

I have only gone in and added WIFI info and DDNS. But everything seems to be great!

The last build was topping out at 100 Mbps, this one is smoking at near 200 Mbps via LAN. I assumed it was something with my last build, but never got around to change it.

Router: R7000
Firmware: 06/04/2020 -r43334
Previous: DD-WRT v3.0-r33770M kongac (11/15/17)
Mode: Gateway
Errors/Issues: none
Uptime: About 12 hours


If there is a more recent good build to try, please reply or PM, but happy at this time.
[/b]

_________________
[MAIN GATEWAY] Netgear R7000 DD-WRT v3.0-r43324 std (06/02/20)
[AP1-wired] Asus RT-AC68U - D-WRT v3.0-r44467 std (09/24/20)
[AP2-wired] Asus RT-AC68RD-WRT v3.0-r44467 std (09/24/20)
(switch) 1 AP WRT160N v3 - DD-WRT v3.0-r30731 mini (10/06/16)
==
YOU CAN'T STOP THE COLETRAIN BABY!
Goto page Previous  1, 2, 3 Display posts from previous:    Page 3 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum