New Build - 05/13/2020 - r43136

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 1794

PostPosted: Wed May 13, 2020 14:20    Post subject: New Build - 05/13/2020 - r43136 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP (try another if a link doesn't work)

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Repository: Trac SVN changelog since last build r43099 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix from December, since then various revisions including recently 7040.
In-kernel Samba has been implemented this year and default min/max versions have changed, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
WireGuard 1.0 & tools! New GUI Tunnel options since r42872; now with key management! Setup guides: Client & Server by egc
Local DNS option removed from Services->DNSMasq in changesets 43080 and 43081; ref: #7092
DHCP and DNS help (English) updated in 43083; ref: #7091


Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: syslog output, 'dmesg', 'cat /tmp/var/log/messages', serial output, strace etc.
• For firewall issues provide 'iptables -L', 'iptables -t nat -L' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with any relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 525
Location: Rural Manitoba

PostPosted: Wed May 13, 2020 18:07    Post subject: Reply with quote
Upgrade all Routers r43099 -> r43136

Failure to upgrade with IE11, GUI locked out and had to reset with Telnet. Finally successful with using EDGE to upgrade.
Some difficulty with remote cameras connecting on 1900 V1 WDS. After a few reboots all came up well.

Monitoring with IE11 seem to work fine.
When update from IE11 the following log appeared when unable to upgrade on any router;

May 13 12:17:20 204.112.158.103 kernel [ 270.291445] ieee80211 phy0: staid 3 deleted
May 13 12:27:02 204.112.158.103 logger : Caught SIGSEGV (11) in fclose
May 13 12:27:02 204.112.158.103 logger : Fault at memory location 0x0000004c due to address not mapped to object (1).
May 13 12:27:02 204.112.158.103 logger : Thread 24816: httpd
May 13 12:27:02 204.112.158.103 logger : === Context:
May 13 12:27:02 204.112.158.103 logger : TRAPNO:0000000e ERRCODE:00000017 OLDMASK:00000000 R0:00000000
May 13 12:27:02 204.112.158.103 logger : R1:000060f0 R2:00000000 R3:b6f000cc R4:b6c0a420
May 13 12:27:02 204.112.158.103 logger : R5:00000000 R6:01fe5da0 R7:00000000 R8:01ff5000
May 13 12:27:02 204.112.158.103 logger : R9:b6f00080 R10:01fe5da0 FP:00101101 IP:00033120
May 13 12:27:02 204.112.158.103 logger : SP:b6b81bc8 LR:00017644 PC:b6ec9d90 CPSR:40000010
May 13 12:27:02 204.112.158.103 logger : FAULTADDR:0000004c
May 13 12:27:02 204.112.158.103 logger : === Backtrace:
May 13 12:27:02 204.112.158.103 logger : # Searching frame 0 (FP=0x00101101, PC=0xb6ec9d90)
May 13 12:27:02 204.112.158.103 logger : # PC-22c8[0xb6ec7ac8]: 0xe92d4ff7 stmfd sp!
May 13 12:27:02 204.112.158.103 logger : # Stack at 0x00101101 is not mapped; terminating backtrace.
May 13 12:27:02 204.112.158.103 logger : /lib/ld-musl-armhf.so.1[0xb6e88000](fclose+0x00000000)[0xb6ec9d90]
May 13 12:27:02 204.112.158.103 logger : === Code:
May 13 12:27:02 204.112.158.103 logger : b6ec9d50: 10400003 e12fff1e e9900009 e1500003 10433000 03a00000 15813000 e12fff1e
May 13 12:27:02 204.112.158.103 logger : b6ec9d70: e5903004 e0833001 e5803004 e12fff1e e5903000 e3833020 e5803000 e12fff1e
May 13 12:27:02 204.112.158.103 logger : b6ec9d90: >e590304c e92d4070 e1a04000 e3530000 b3a06000 ba000001 ebfffdea e1a06000
May 13 12:27:02 204.112.158.103 logger : b6ec9db0: e1a00004 eb00003d e594300c e1a05000 e1a00004 e12fff33 e3560000 e1855000

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 36 (+6) r44048
Ath1 2.4Ghz Disabled
99 Static Leases

WRT3200acm r44048 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r44048 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r44048
2.4Ghz AP Ch1 HT20 Mixed

(SPARE)WRT1900AC V1 r44048 On LAN
5Ghz WDS AP Ch149(+6) 80Mghz
2.4Ghz Ch 6 20Mhz N/G Mixed

WRT1200AC V1 r44048 LAN
2.4Ghz 20Mhz Ch 6 Mixed
5 Ghz 80Mhz Ch 149 (UUU+6) WDS AP

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1200 V1 -> WDS 5Ghz -> 1900 V1 & 1900V1
3200 Master -> WDS -> 3200 Slave
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 328
Location: South Carolina

PostPosted: Wed May 13, 2020 19:10    Post subject: DD-WRT v3.0-r43136 std (05/13/20) Reply with quote
WRT3200ACM V1 r43136 Firefox 76.0.1 (64-bit) webflash

OpenVPN CLIENT seems fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES) Seems fine 40MHz Mixed
2.4GHz wpa2 CCMP-128 (AES) Disabled
NAS via USB Samba seems fine

Router reboot, connections, and samba logon seemed quite frisky with this update. May be purely coincidental. Router returned to service quicker than the last dozen or so updates (IMHO).
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 235
Location: FL

PostPosted: Thu May 14, 2020 9:31    Post subject: Reply with quote
All went well on flash firefox latest.
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2020
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 206

PostPosted: Thu May 14, 2020 19:18    Post subject: Reply with quote
Upgraded WRT1200AC v1 from r43078 to r43136 using Firefox 76.0 (64 bit) running on Linux Mint 19.3 OS.

Successful update and reboot. No reset, nothing disabled prior to update, up-time since release, wireless connected, vpn up immediately. I do not use NAS. SFE is always disabled. OpenVPN client/DNSMasq, QoS with PIE always enabled.

Kernel VersionLinux 4.9.223 #1784 SMP Wed May 13 01:44:28 +03 2020 armv7l

OpenVPN 2.4.9 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on May 13 2020
library versions: OpenSSL 1.1.1g 21 Apr 2020 LZO 2.09

These errors are new to this release for me . . . don't seem to affect function although they appear/disappear in certain releases. Have not seen this error in more than 2 dozen releases so . . .
May 14 14:45:53 router daemon.err openvpn[1634]: FRAG TTL expired i=6
May 14 14:45:53 router daemon.err openvpn[1634]: FRAG TTL expired i=13
May 14 14:45:53 router daemon.err openvpn[1634]: FRAG TTL expired i=14

The auth fail error is still occurring
May 14 14:49:22 router daemon.info httpd[1623]: httpd : Authentication fail
May 14 14:49:22 router daemon.err httpd[1623]: httpd : Request Error Code 401: Authorization required. please note that the default username is "root" in all newer releases

r43055 and r43099 were both dropping my wifi connection about two hrs into an evening streaming session. Rebooting router restored wifi connection. Not dropping wifi with r43078 or r43136 but I will revert to r43078 at days end due to fewer error messages. None seem to affect function but r43078 seems to be the most stable for me with no FRAG TTL errors.
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 525
Location: Rural Manitoba

PostPosted: Fri May 15, 2020 2:14    Post subject: Reply with quote
21+ hours in and DHCP disappeared.

Disabled 2.4Ghz on Master and moved devices to 1200 V1 AP

Reboot Master and all returned to normal.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 36 (+6) r44048
Ath1 2.4Ghz Disabled
99 Static Leases

WRT3200acm r44048 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r44048 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r44048
2.4Ghz AP Ch1 HT20 Mixed

(SPARE)WRT1900AC V1 r44048 On LAN
5Ghz WDS AP Ch149(+6) 80Mghz
2.4Ghz Ch 6 20Mhz N/G Mixed

WRT1200AC V1 r44048 LAN
2.4Ghz 20Mhz Ch 6 Mixed
5 Ghz 80Mhz Ch 149 (UUU+6) WDS AP

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1200 V1 -> WDS 5Ghz -> 1900 V1 & 1900V1
3200 Master -> WDS -> 3200 Slave
zephyr76
DD-WRT Novice


Joined: 02 Dec 2019
Posts: 8

PostPosted: Fri May 15, 2020 3:45    Post subject: DD-WRT Samba Windows 10 Permission Reply with quote
Hello,

Seems real shame this is now listed for official download on main page and Samba for Windows 10 seems completely broken.

Flashed this on WRT3200ACM

Setup Samba, USB drive is mounted /opt. Setup Samba with defaults with username/password.

After typing in username/password to access it in Windows 10 I keep getting unable to access may not have permission. How do I fix this?

Edit:

I set Samba limit to SMBv1. Now whenever I type in the username/password it says access denied. With previous versions that were still running SMBV1 by default no problems. Not sure why it is saying access is denied.

I set it to public, still getting prompt for username/password with access denied.
Prsa01
DD-WRT Novice


Joined: 19 Jun 2018
Posts: 10

PostPosted: Fri May 15, 2020 10:55    Post subject: 1900 v1 boot loop unless network cables unplugged Reply with quote
Since 43028

Continue to have this issue. Other 1900 v1 don't seem to be having it. I use nas/samba and Wan port configured as std port.

Any logs or anything I can capture to try to see what is going on? I've tried just unplugging Wan cable and that didn't work. Will try the others one at a time to see if it is a specific device. Other ideas?

Thanks

_________________
Wrt1900acv1 r43028
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 235
Location: FL

PostPosted: Fri May 15, 2020 18:06    Post subject: Reply with quote
i was told this build had connectivity issues by the family, So i just went backwards a build last night and no more wifi bridge hangs
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2020
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
zephyr76
DD-WRT Novice


Joined: 02 Dec 2019
Posts: 8

PostPosted: Sat May 16, 2020 20:01    Post subject: Reply with quote
May 16 15:59:39 Waffle local5.err ksmbd: [ksmbd-worker/1129]: ERROR: Can't open `/tmp/smb.db': No such file or directory
May 16 15:59:39 Waffle local5.err ksmbd: [ksmbd-worker/1129]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
zephyr76
DD-WRT Novice


Joined: 02 Dec 2019
Posts: 8

PostPosted: Sat May 16, 2020 20:46    Post subject: Reply with quote
Downgraded back to Firmware: DD-WRT v3.0-r42054 std (01/21/20), Samba/NAS working, but with SMBv1. Dunno why SMBv2 with NTFS Windows 10 seems broken on DDWRT. Curious to me as I imagine the majority of DDWRT users use W10.
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 335

PostPosted: Sun May 17, 2020 0:43    Post subject: Reply with quote
zephyr76 wrote:
Downgraded back to Firmware: DD-WRT v3.0-r42054 std (01/21/20), Samba/NAS working, but with SMBv1. Dunno why SMBv2 with NTFS Windows 10 seems broken on DDWRT. Curious to me as I imagine the majority of DDWRT users use W10.


zephyr76,

FYI, r42054 was the last DD version with DISCOVERY that allowed you to see Windows 10 with SMB v1.
After that there was a switch to KSMBD which has no discovery. I switched to Asus-Merlin (RT-AC86u) which has an option to switch on MASTER BROWSER service under SAMBA which enabled me to see all my Windows 10 machines again (Using SMB v1).

_________________
WRT1900ACSv2
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7454
Location: Texas, USA

PostPosted: Sun May 17, 2020 0:56    Post subject: Reply with quote
Ok. So, this *could* be an issue where wsdd2 is not sync'd with upstream, or some other ksmbd/samba issue. But I do not understand why people are bitterly clinging to SMBv1 protocols when they don't have to anymore with the updates. I mean, folks do realize that wsdd2 was added 4 months ago, right?

https://svn.dd-wrt.com/browser/src/router/wsdd2

https://github.com/Andy2244/wsdd2

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 335

PostPosted: Sun May 17, 2020 1:00    Post subject: Reply with quote
In my case wsdd2 only worked on half of my Windows 10 clients. (Reset networking,etc.)Also as discussed long time ago my backup software (Acronis) did not work without Discovery. Gonna bow out now as I'm no longer DD user..Just wanted to answer a question. Best to all.

kernel-panic69 wrote:
Ok. So, this *could* be an issue where wsdd2 is not sync'd with upstream, or some other ksmbd/samba issue. But I do not understand why people are bitterly clinging to SMBv1 protocols when they don't have to anymore with the updates. I mean, folks do realize that wsdd2 was added 4 months ago, right?

_________________
WRT1900ACSv2
zephyr76
DD-WRT Novice


Joined: 02 Dec 2019
Posts: 8

PostPosted: Sun May 17, 2020 1:21    Post subject: Reply with quote
kernel-panic69 wrote:
Ok. So, this *could* be an issue where wsdd2 is not sync'd with upstream, or some other ksmbd/samba issue. But I do not understand why people are bitterly clinging to SMBv1 protocols when they don't have to anymore with the updates. I mean, folks do realize that wsdd2 was added 4 months ago, right?

https://svn.dd-wrt.com/browser/src/router/wsdd2

https://github.com/Andy2244/wsdd2


Not bitterly clinging to SMBv1, SMBv1 works with DDWRT, SMBv2/3 is broken, doesn't work. Keeps asking for username/pw when it shouldn't, even if you do, constantly denies access. I've tried this with all three machines, samba fails miserably with DDWRT beyond SMBv1.

If WSDD2 is supposed to fix this, then I don't know, I've tried the latest release and previous releases after 42054 and it keeps failing.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum