Samba not working r42925

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Sat Apr 18, 2020 23:58    Post subject: Samba not working r42925 Reply with quote
Router/Version: Netgear R8000
Firmware: DD-WRT v3.0-r42925 std (04/18/20)
Kernel: Linux 4.4.219 #1337 SMP Sat Apr 18 08:57:52 +04 2020 armv7l
Mode: Client, samba, vpn client, usb, nas
Previous: DD_WRT v3.0-r42514
Flash: GUI

Status: Samba not working, all the others are working

System info under Status says samba is enabled and running, I can see the shared files from Windows 7 but when I try to access those files from the television, it says: no stored files found.

I do not know if this will be of any help but the system log has these highlighted in red:
DD-WRT kern.err kernel: bcmsflash: found no supported devices
DD-WRT local5.err ksmbd: [ksmbd-worker/1084]: ERROR: Can't open `/tmp/smb.db': No such file or directory
DD-WRT local5.err ksmbd: [ksmbd-worker/1084]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
DD-WRT user.err wsdd2[1080]: error: wsdd-mcast-v4: wsd_send_soap_msg: send
kern.err kernel: hub 3-0:1.0: config failed, hub doesn't have any ports! (err -19)
DD-WRT user.err wsdd2[1080]: Terminated received.
DD-WRT user.err wsdd2[1527]: Terminated received.
DD-WRT local5.err ksmbd: [ksmbd-manager/1530]: ERROR: WARNING: child process exited abnormally: 1531
local5.err ksmbd: [ksmbd-worker/2013]: ERROR: Can't open `/tmp/smb.db': No such file or directory
local5.err ksmbd: [ksmbd-worker/2013]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
local5.err ksmbd: [ksmbd-manager/2012]: ERROR: WARNING: child process exited abnormally: 2013
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8051
Location: Texas, USA

PostPosted: Sun Apr 19, 2020 2:37    Post subject: Reply with quote
Did you try resetting and configuring from scratch without restoring configs from backup?
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Sun Apr 19, 2020 2:40    Post subject: Reply with quote
I didn't reset
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8051
Location: Texas, USA

PostPosted: Sun Apr 19, 2020 2:43    Post subject: Reply with quote
Well, the only way to rule out a bad configuration is to reset. There have been changes to Samba that may affect how you need to configure your router and client devices.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8051
Location: Texas, USA

PostPosted: Sun Apr 19, 2020 2:46    Post subject: Reply with quote
ALSO, keep in mind, you may have to access via smb://your.router.ip.address instead of using a hostname.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Sun Apr 19, 2020 16:17    Post subject: Reply with quote
I manually reconfigured the router with r42925. I started with basic setup, services, vpn, usb and nas. At this point I was able to view samba on television. I proceeded to wireless, wireless security and administration. I was able to access the internet but now, even though status, sys info says samba is enabled and running I cannot see any files on television anymore.
The errors in the system log is the same as mentioned above.
If the config for the new samba is different, can you point me in the direction of this guide?
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5972
Location: Romerike, Norway

PostPosted: Sun Apr 19, 2020 16:41    Post subject: Reply with quote
For me the volumes didn't mount because the configured device names had changed. Changed the device names in the config and all start working again.
grc
DD-WRT User


Joined: 11 Jul 2018
Posts: 98

PostPosted: Sun Apr 19, 2020 16:56    Post subject: Reply with quote
i had similar problem on several newer builds with Netgear r6300v2, but with jffs enabled. My syslog was:

Quote:
Apr 11 09:48:30 HOVADO user.info : smbd : samba started
Apr 11 09:48:30 HOVADO user.info wsdd2[1958]: starting.
Apr 11 09:48:30 HOVADO local5.info ksmbd: [ksmbd-manager/1962]: INFO: Unlink orphaned '/tmp/ksmbd.lock'
Apr 11 09:48:30 HOVADO local5.err ksmbd: [ksmbd-worker/1963]: ERROR: Can't open `/jffs/etc/smb.db': No such file or directory
Apr 11 09:48:30 HOVADO local5.err ksmbd: [ksmbd-worker/1963]: ERROR: User database file does not exist. Only guest sessions (if permitted) will work.
Apr 11 09:48:30 HOVADO local5.info ksmbd: [ksmbd-worker/1963]: INFO: Drop non-existing user `cloud'




after cleaning jffs the problem gone. Probably something with permissions? But i have no idea what to do with /tmp
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Sun Apr 19, 2020 18:48    Post subject: Reply with quote
Per Yngve Berg wrote:
For me the volumes didn't mount because the configured device names had changed. Changed the device names in the config and all start working again.


My volume appeared to be mounted correctly. I detached the external hard drive from the router and restarted the router without the drive and it would not boot. I stopped the router, attached the external hard drive and restarted the router. I could access samba via the television but the files were doubled. I rebooted the router again and samba was working via the television but now the files were tripled. Also the jff was mounted twice in usb. Another instance I reboot the router and there is no file to access via the television.

I have reinstalled r42514 and all is fine with samba. I did not do a reset and the doubled jff is there. I will perform a reset for r42514
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5972
Location: Romerike, Norway

PostPosted: Sun Apr 19, 2020 19:00    Post subject: Reply with quote
Looks like you have jffs both in nvram and on the disc.
Abboo
DD-WRT User


Joined: 03 Apr 2016
Posts: 155

PostPosted: Sun Apr 19, 2020 19:31    Post subject: Reply with quote
Per Yngve Berg wrote:
Looks like you have jffs both in nvram and on the disc.


I reinstalled r42514 with a reset to default. I manually config from start. Samba is working in r42514. Until there is a guide for samba in the kernel, I am staying with the tried and working beta
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum