Netgear R7800 and Espressif ESP32 / 8266 WiFi issues

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Vaako
DD-WRT User


Joined: 10 Jun 2009
Posts: 333

PostPosted: Tue Mar 17, 2020 2:39    Post subject: Netgear R7800 and Espressif ESP32 / 8266 WiFi issues Reply with quote
Hi,

I'm using Netgear R7800 with firmware r42681 (03/13/20).

I got some Espressif ESP32 and ESP8266 that just won't to connect to the router.

I geuss it's related to WiFi incompability.

Can someone tell me the "VERY" standard 2.4GHz WiFi settings.

Thanks in advance!

_________________
Regards,
Vaako

1x Netgear R7800 Nighthawk - firmware not decided yet !!!!
1x Netgear R7000 Nighthawk r36410
1x Ubiquiti RouterStation Pro DD-WRT r23204 std (12/24/13)
1x Asus RT-N16 SVN revision 20675 NEWD-2 K2.6
1x Linksys E4200 v3.0 r34777 mega (01/31/18 )
1x Buffalo WZR-HP-G300NH B0 B0 Gargoyle FW
1x Linksys WRT600N v1.1 (Bricked)
1x Linksys WRT54GL v1.1 (DD-WRT 26446)
1x Linksys WRT54GS v2.2 (DD-WRT 26446)
1x Linksys RVS4000 (stock fw)
3x D-Link DWL-7100AP (openWRT)
2x TP-Link TL-WA801ND (Bridge mode) 100mW TX-Power
Asus WL-520GU SVN 16403M NEWD-2 Eko std-nokaid
4x Fonera with Gargoyle FW


Last edited by Vaako on Fri Mar 20, 2020 1:42; edited 2 times in total
Sponsor
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 888
Location: Illinois

PostPosted: Tue Mar 17, 2020 4:57    Post subject: Reply with quote
I think you should be going to the sparkfun people and not dd-wrt for help. Feel free to see my recommended settings just in case, but I have a feeling it's the sparkfun board and not dd-wrt.

https://www.sparkfun.com/technical_assistance

One review I read:

The module is very picky about power. I recommend powering this with a dedicated power supply. I also recommend using a dedicated power supply along with filtering capacitors to ensure that the power is steady. When I finally got the modules to communicate, there were numerous resets. Good jumper wires and good connections to the breadboard along with filtering capacitors solved the problem.

Documentation is shall I say "not really up to speed". I have found that there are pictures of the pinouts on the internet that are wrong.

_________________
TIPS/TRICKS: Best QCA Wifi Settings||QCA WIFI WIKI||Latency tricks||QoS Port priority||NEVER USE MU-MIMO||
Why to NOT use MU-MIMO||Max Wifi Pwr by Country||Linux Wifi Pwr||MCS Index Speeds & AX MCS||Correct QCA 5Ghz chnls to use||WIFI Chnl Freq WIKI

[R9000]BS 42835 (Main Router)
[EA8500]BS 42598 (Offsite)
[R7800]taking a nap
[WDR3600]BS 42567 (Offsite)
[A7v5]BS 42790 (Offsite+spare here napping)
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 4493
Location: Texas, USA

PostPosted: Tue Mar 17, 2020 8:58    Post subject: Reply with quote
ESP32 and ESP8266 chipsets. Oh, where to begin. They are not friendly with some configurations, at least on Marvells. @MSOE, do Qualcomm / Atheros devices have issues with those wifi smart devices with the ESP chipsets in them, or do you know? This is a documented issue with Marvell, so not sure if the QCA/Atheros wi-fi chipsets balk as well. If I remember right, Wireless-G mode and WMM disabled was the fix for Marvell.
_________________
"Are you leaving anything out of the picture, or is your post complete with all information required for us to help you? If it is not complete, fix it now."
---------------------------------------------------------
E4200 v1 DD-WRT 42819 mega K3.x
R7000P DD-WRT 40270M kongac
R7800 DD-WRT 42819 std
E4200 v1 FreshTomato 2020.2
E4200 v1 FreshTomato 2020.3.development
R7000 FreshTomato 2020.3.development
E4200 v1 1.0.07.development
WRT3200ACM OpenWRT 18.06.8
---------------------------------------------------------
Linux User #377467 counter.li.org / linuxcounter.net
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 888
Location: Illinois

PostPosted: Tue Mar 17, 2020 15:14    Post subject: Reply with quote
My best guess is that you need to use Mixed mode as these are only b/g/n devices. I would start with NG-Mixed and then try mixed... I have no idea about these devices and don't have the hobby time to play with things like this.

Two kids under 7 and corona virus shutdowns don't leave any spare time right now to research this anymore.

Again, I don't think this is an appropriate dd-wrt topic, but should be on the ESP forums.

_________________
TIPS/TRICKS: Best QCA Wifi Settings||QCA WIFI WIKI||Latency tricks||QoS Port priority||NEVER USE MU-MIMO||
Why to NOT use MU-MIMO||Max Wifi Pwr by Country||Linux Wifi Pwr||MCS Index Speeds & AX MCS||Correct QCA 5Ghz chnls to use||WIFI Chnl Freq WIKI

[R9000]BS 42835 (Main Router)
[EA8500]BS 42598 (Offsite)
[R7800]taking a nap
[WDR3600]BS 42567 (Offsite)
[A7v5]BS 42790 (Offsite+spare here napping)
Vaako
DD-WRT User


Joined: 10 Jun 2009
Posts: 333

PostPosted: Tue Mar 17, 2020 18:56    Post subject: Reply with quote
Well I think this issue can be discussed here as I have no problems with it connecting to Ubiquiti UniFi AP-AC-LR and an old TP-Link WA830RE with stock fw.

I try to disable WMM but no success.

All my little gizmo's are provided with a good power supply, so this can not be the issue.

_________________
Regards,
Vaako

1x Netgear R7800 Nighthawk - firmware not decided yet !!!!
1x Netgear R7000 Nighthawk r36410
1x Ubiquiti RouterStation Pro DD-WRT r23204 std (12/24/13)
1x Asus RT-N16 SVN revision 20675 NEWD-2 K2.6
1x Linksys E4200 v3.0 r34777 mega (01/31/18 )
1x Buffalo WZR-HP-G300NH B0 B0 Gargoyle FW
1x Linksys WRT600N v1.1 (Bricked)
1x Linksys WRT54GL v1.1 (DD-WRT 26446)
1x Linksys WRT54GS v2.2 (DD-WRT 26446)
1x Linksys RVS4000 (stock fw)
3x D-Link DWL-7100AP (openWRT)
2x TP-Link TL-WA801ND (Bridge mode) 100mW TX-Power
Asus WL-520GU SVN 16403M NEWD-2 Eko std-nokaid
4x Fonera with Gargoyle FW
Vaako
DD-WRT User


Joined: 10 Jun 2009
Posts: 333

PostPosted: Fri Mar 20, 2020 0:44    Post subject: Reply with quote
Update:

I have been playing around with the wireless security settings and now they do connect to the router.

So it was a DD-WRT related thing Smile

_________________
Regards,
Vaako

1x Netgear R7800 Nighthawk - firmware not decided yet !!!!
1x Netgear R7000 Nighthawk r36410
1x Ubiquiti RouterStation Pro DD-WRT r23204 std (12/24/13)
1x Asus RT-N16 SVN revision 20675 NEWD-2 K2.6
1x Linksys E4200 v3.0 r34777 mega (01/31/18 )
1x Buffalo WZR-HP-G300NH B0 B0 Gargoyle FW
1x Linksys WRT600N v1.1 (Bricked)
1x Linksys WRT54GL v1.1 (DD-WRT 26446)
1x Linksys WRT54GS v2.2 (DD-WRT 26446)
1x Linksys RVS4000 (stock fw)
3x D-Link DWL-7100AP (openWRT)
2x TP-Link TL-WA801ND (Bridge mode) 100mW TX-Power
Asus WL-520GU SVN 16403M NEWD-2 Eko std-nokaid
4x Fonera with Gargoyle FW
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 908

PostPosted: Fri Mar 20, 2020 1:46    Post subject: Reply with quote
What did it want? TKIP or something else ancient?

Never mind I answered my own question.

https://www.esp8266.com/viewtopic.php?p=81997#p81997

https://github.com/esp8266/Arduino/issues/2795
Vaako
DD-WRT User


Joined: 10 Jun 2009
Posts: 333

PostPosted: Sat Mar 21, 2020 11:36    Post subject: Reply with quote
Well they all connecting fine now !

This is what I have changed:
WPA2 Personal
WPA Algorithms: CCMP-128 (AES)

_________________
Regards,
Vaako

1x Netgear R7800 Nighthawk - firmware not decided yet !!!!
1x Netgear R7000 Nighthawk r36410
1x Ubiquiti RouterStation Pro DD-WRT r23204 std (12/24/13)
1x Asus RT-N16 SVN revision 20675 NEWD-2 K2.6
1x Linksys E4200 v3.0 r34777 mega (01/31/18 )
1x Buffalo WZR-HP-G300NH B0 B0 Gargoyle FW
1x Linksys WRT600N v1.1 (Bricked)
1x Linksys WRT54GL v1.1 (DD-WRT 26446)
1x Linksys WRT54GS v2.2 (DD-WRT 26446)
1x Linksys RVS4000 (stock fw)
3x D-Link DWL-7100AP (openWRT)
2x TP-Link TL-WA801ND (Bridge mode) 100mW TX-Power
Asus WL-520GU SVN 16403M NEWD-2 Eko std-nokaid
4x Fonera with Gargoyle FW
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5435
Location: Akershus, Norway

PostPosted: Sun Mar 22, 2020 13:43    Post subject: Reply with quote
WPA2 CCMP-128 is the legacy default encryption. some clients may have problems with newer options.
Vaako
DD-WRT User


Joined: 10 Jun 2009
Posts: 333

PostPosted: Fri Mar 27, 2020 1:45    Post subject: Reply with quote
What is the now todays default encryption?
_________________
Regards,
Vaako

1x Netgear R7800 Nighthawk - firmware not decided yet !!!!
1x Netgear R7000 Nighthawk r36410
1x Ubiquiti RouterStation Pro DD-WRT r23204 std (12/24/13)
1x Asus RT-N16 SVN revision 20675 NEWD-2 K2.6
1x Linksys E4200 v3.0 r34777 mega (01/31/18 )
1x Buffalo WZR-HP-G300NH B0 B0 Gargoyle FW
1x Linksys WRT600N v1.1 (Bricked)
1x Linksys WRT54GL v1.1 (DD-WRT 26446)
1x Linksys WRT54GS v2.2 (DD-WRT 26446)
1x Linksys RVS4000 (stock fw)
3x D-Link DWL-7100AP (openWRT)
2x TP-Link TL-WA801ND (Bridge mode) 100mW TX-Power
Asus WL-520GU SVN 16403M NEWD-2 Eko std-nokaid
4x Fonera with Gargoyle FW
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum