Please tell me the introduction of Entware to dd-wrt

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Fri Feb 14, 2020 22:22    Post subject: Please tell me the introduction of Entware to dd-wrt Reply with quote
cat / proc / version
Linux version 3.10.108-dd (root @ linux) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6438-46177a850f)) # 54598 Thu Apr 26 02:19:11 Used in CEST 2018.

Once, I used Entware by setting the following as a reference
https://wiki.dd-wrt.com/wiki/index.php/Installin

After doing opkg update after a long time, if you type opkg, it will output a bus error and it will be an error

Since it is inevitable, refer to the following
https://wiki.dd-wrt.com/wiki/index.php/Installin

[For MIPS-based devices (Atheros, not dual-core):]

cd / opt (Enter key pressed)
wget http://bin.entware.net/mipssf-k3.4/installer/gen… (press Enter key)
sh generic.sh (press Enter key)

I installed
Typing / opt / bin / opkg outputs a bus error and results in an error ntware-for-kernel-3x / Entware-ng-3x / wiki / General-installation-notes
With reference
https://github.com/Ehttp://entware-3x.zyxmon.org
And run install_std.sh,
./opkg list
busybox-1.27.2-2
entware-opt-1.0-6
findutils-4.6.0-1
libc-2.25-8
libgcc-6.3.0-8
libpthread-2.25-8
librt-2.25-8
libssp-6.3.0-8
libstdcpp-6.3.0-8
locales-2.25-8
opkg-2011-04-08-9c97d5ec-17a
terminfo-6.0-1c
zoneinfo-asia-2017c-1
zoneinfo-europe-2017c-1

And / opt / bin / opkg execution no longer gives an error

Running after / opt / bin / opkg update will result in a Segmentation fault
How can you give advice?

Crying or Very sad
Sponsor
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 585

PostPosted: Fri Feb 14, 2020 23:13    Post subject: Reply with quote
I am not sure that I follow what you did. Have you tried:

https://github.com/Entware-for-kernel-3x/Entware-ng-3x/wiki/General-installation-notes
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 0:21    Post subject: Reply with quote
Am I doing something wrong?
I hope you'll tell me

I downloaded and executed install_std.sh from the URL provided,
and I think that the update of the package list is the same as other entware
(there is no particular description on the corresponding page)

If you think that opkg upgrade should be performed after opkg update,
typing opkg after upgrade will output the following,
so it is excluded from this post

opkg: /opt/lib/libc.so.6: version `GLIBC_2.27 'not found (required by opkg)
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2053
Location: Canada

PostPosted: Sat Feb 15, 2020 13:03    Post subject: Wiki Reply with quote
Have you read the wiki here: https://wiki.dd-wrt.com/wiki/index.php/Installing_Entware

I wrote it a while ago but it should still be accurate.

opkg update - downloads the latest package list
opkg upgrade - checks the list against your installed packages, looking for upgrades

By the way, the Entware located here, the same one I linked to in the wiki, is the most up-to-date: https://github.com/Entware/Entware

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
Linksys WRT400N - bricked
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
TP-Link 1043nd v1, inactive, unstable hardware
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - Gateway, DHCP, QoS
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 585

PostPosted: Sat Feb 15, 2020 17:23    Post subject: Reply with quote
agree with ian5142

once the install has happened run
Code:

opkg update
opkg upgrade


and then start using opkg to install new packages
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 18:31    Post subject: Reply with quote
I'm sorry, my equipment is a WZR-300HP.
https://wiki.dd-wrt.com/wiki/index.php/Supported_Devices#Buffalo
I don't think that the latest DD-WRT works

So I presented cat / proc / version as a prerequisite

If Entware-3X doesn't work at all, give up,
https://github.com/Entware-for-kernel-3x/Entware-ng-3x/wiki/General-installation-notes
Has an installation shell that can be installed and has a package presentation.
I want to know the suggested way to install the package

Perhaps the subject was bad. Sorry if you should have asked "how to run old Entware-3X on a machine that only runs kernel 3.X"
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 18:43    Post subject: Reply with quote
To check, use the ipkg command to find the local ipk file
But my DD-WRT does not have ipkg, disappointed
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2053
Location: Canada

PostPosted: Sat Feb 15, 2020 18:44    Post subject: DD-WRT Build Reply with quote
Hello,
A very recent dd-wrt build is found here: ftp://ftp.dd-wrt.com/betas/2020/02-14-2020-r42366/buffalo_wzr-300hp/

Use the webupgrade file if the router is already running dd-wrt. If you are coming from a build older then a few months, sometimes even only a few builds ago, reset to factory defaults. Then add in your settings manually, don't restore a nvram backup.

I would highly suggest using the Entware that I linked to, it is still being updated, the other one is not.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
Linksys WRT400N - bricked
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
TP-Link 1043nd v1, inactive, unstable hardware
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - Gateway, DHCP, QoS
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 18:58    Post subject: Reply with quote
Somehow, the following thread seems to be helpful
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=314719&sid=1eb86b7e23b798998c0037f29d493242
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 19:16    Post subject: Reply with quote
I'm surprised you have the latest build
Thanks for any useful information
Then, I will examine the release notes etc.
Because old love machines do not grow into bricks
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 21:14    Post subject: Reply with quote
I could not stand it and updated it
It seems to have been upgraded.
cat / proc / version
【new】
Linux version 3.10.108-d10 (root @ linux) (gcc version 9.2.0 (OpenWrt GCC 9.2.0 r10890-7d542dc804)) # 38363 Fri Feb 14 05:53:18 +04 2020
[Old]
Linux version 3.10.108-dd (root @ linux) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6438-46177a850f)) # 54598 Thu Apr 26 02:19:11 Used in CEST 2018.

However,
Running after / opt / bin / opkg update will result in a Segmentation fault
And
opkg update will output:
./opkg: /opt/lib/libc.so.6: version `GLIBC_2.27 'not found (required by ./opkg)

Crying or Very sad
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 21:24    Post subject: Reply with quote
The following message at the time of the update seems like evidence
Upgrading libc on root from 2.25-8 to 2.27-9 ...
Downloading http://bin.entware.net/mipssf-k3.4/libc_2.27-9_mips-3.4.ipk
wget: read error: Connection reset by peer

It can be downloaded with a browser, but is the work area of opkg update too small?
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sat Feb 15, 2020 22:05    Post subject: Reply with quote
If you change the extension of downloaded libc_2.27-9_mips-3.4.ipk to tgz and browse with Archive Manager, you can see the directories and files of / opt / etc and / opt / lib
Should this be placed in / opt? But I doubt that there is a file called control in /
Katu_Ueda
DD-WRT Novice


Joined: 14 Feb 2020
Posts: 10

PostPosted: Sun Feb 16, 2020 0:19    Post subject: Reply with quote
opkg worked by changing the extension of libc_2.27-9_mips-3.4.ipk to tgz
and placing the contents in / opt / lib / opt / etc in dd-wrt.
Older packages, simply on platforms
opkg update opkg update is not good Wink
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3295
Location: UK, London, just across the river..

PostPosted: Sun Feb 16, 2020 7:16    Post subject: Reply with quote
Katu_Ueda wrote:
opkg worked by changing the extension of libc_2.27-9_mips-3.4.ipk to tgz
and placing the contents in / opt / lib / opt / etc in dd-wrt.
Older packages, simply on platforms
opkg update opkg update is not good Wink


well...did you follow those instructions...
https://wiki.dd-wrt.com/wiki/index.php/Installing_Entware

make sure:
format USB thumb drive to ext2....
you have internet & DNS
install entware
than 'opkg update' (no quotes)
followed by 'opkg upgrade' (no quotes)

opkg update downloads the last opkg package with all updated binaries/tools/entware installations

opkg upgrade is the command to proceeds/apply the update...

if your package/installation is broken, than start from scratch...

or may be some obsolete stuff was removed and you are looking for it...than you need some old/previous entware builds instead...

i have to admit, it tends to happen once in a while..
as im using entware too...it breaks on new updates, well for various reasons...

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 42132 BS WAP/Switch
TP-Link WR740Nv4 ------DD-WRT 42054 BS AP, NAT
TP-Link WR1043NDv2 ----DD-WRT 42287 BS AP,NAT,AD Block,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----DD-WRT 42174 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 42287 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN
Broadcom
Netgear R7000 -------DD-WRT 42054 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum