New Build 42287: 02-06-2020-r42287

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12875
Location: Texas, USA

PostPosted: Thu Feb 06, 2020 14:45    Post subject: New Build 42287: 02-06-2020-r42287 Reply with quote
WARNING: DO NOT flash this experimental test build unless you know the risks and recovery methods. Report here to provide important info for developers and users. Always state your hardware model & version, mode (e.g. Repeater) and SPECIFIC build (e.g. netgear-r7000-webflash). Avoid discussions and create a new thread for specific problems or questions as this thread is not for support, and posts may be deleted or moved.

Downloads: if a link does not work, try another (alternative @DD-WRT website)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/02-06-2020-r42287/
ftp://ftp.dd-wrt.com/betas/2020/02-06-2020-r42287/
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or ftp

Changelogs:
SVN* changelog since last build: 42278
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Issues, observations, and/or workarounds reported:
1. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246
2. WDS does not work on Broadcom ARM devices (only MIPS<->MIPS)
3. VAPs not working at boot fixed for unbridged VAPs with r40564:40566. Workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas (there are a few alternatives to search)

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.2 and newer
2. 'KRACK' vulnerability fixes were completed in r33678 for Broadcom, including k26 (33655) & k24 (33656); use 33772 or later.
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issues below).
4. PBR/UDP with SFE working again since r40513 (see 6729)
5. CAKE scheduler changes "completed" with r41057 (see 5796) & FQ_CODEL_FAST with r41027 (reset first!)
6. Reset button was broken in 40571; fixed in build 40750.
7. Radio Timer / GTK Renewal issues, syslog spam and wireless issues (BCM MIPS) fixed with r41662
8. New Broadcom build option for 8MB+ K2.x devices (limited currently):
broadcom_K3X_mipsel32r1 [BS has tested on a WRT600N v1.1]
9. CVE-2019-14899 VPN fix (r41784: applicability depends on VPN setup) and GUI toggle (r41812): ticket 6920, 6928, 6931, 6932
10. In-kernel samba now used and default min/max versions have changed, so change them if needed: 6954, 6957

Template example to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b][u]Router/Version: [/u][/b]
[b]Mode: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Status: [/b]

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.
Because they are tired of bottom-feeders and the same old hat.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
tinkeruntilitworks
Guest





PostPosted: Thu Feb 06, 2020 16:08    Post subject: Reply with quote
deleted

Last edited by tinkeruntilitworks on Thu Feb 06, 2020 18:13; edited 1 time in total
grc
DD-WRT User


Joined: 11 Jul 2018
Posts: 107

PostPosted: Thu Feb 06, 2020 16:10    Post subject: Reply with quote
Router/Version: Netgear r6300v2
File: 42287: 02-06-2020-r42287
Status: Error

No Wireless, no Wireless Settings in the GUI
scampganter
DD-WRT Novice


Joined: 10 Aug 2015
Posts: 32
Location: Nashville, TN

PostPosted: Thu Feb 06, 2020 16:51    Post subject: Reply with quote
Router: Buffalo WZR-1750DHP
Kernel: Linux 4.4.212 #852 SMP Wed Feb 5 08:54:57 +04 2020 armv7l
Mode: Wireless Client
Status: Wireless Tab missing, and both radios are disabled. Temps for WL0 and WL1 "Unavailable"
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 5192
Location: UK, London, just across the river..

PostPosted: Thu Feb 06, 2020 17:30    Post subject: Reply with quote
hmm those 3 reports are very interesting as they do not mention anything about reset or no reset...
i need to contact ghosts from the 6th dimension to find about...grrrr im out of juice ...will wait to charge up...a bit... Razz

_________________
Atheros
TP-Link WR740Nv1 ---DD-WRT 49599 WAP
TP-Link WR1043NDv2 -DD-WRT 49741 Gateway,DNS,AP Isolation,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -DD-WRT 49741 Gateway,DNS,Ad-Block,Firewall,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 -Gargoyle OS 1.13.0b AP,DNS,QoS,Quotas
Qualcomm-Atheros
Netgear R7800 --DD-WRT 49741 Gateway,DNS,AD-Block,AP&Net Isolation,VLAN's,Firewall,DoT,Vanilla
Netgear R9000 --DD-WRT 49741 Gateway,DNS,AD-Block,AP Isolation,Firewall,Forced DNS,DoT,2,4Ghz only,Vanilla
Broadcom
Netgear R7000 ---DD-WRT 49741 Gateway,DNS,AD-Block,Firewall,Forced DNS,VLAN's,DoT,VPN
NOT USING 5Ghz ANYWHERE
------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4143

PostPosted: Thu Feb 06, 2020 17:38    Post subject: Reply with quote
tinkeruntilitworks
Guest





PostPosted: Thu Feb 06, 2020 18:16    Post subject: Reply with quote
Router: Netgear R7000P
Kernel: Linux 4.4.213 #872 SMP Thu Feb 6 21:56:34 +04 2020 armv7l
Mode: Gateway/AP 2.4GHz 5GHz Unbound JFFS2 static leases
Status: just booted up a bit ago but all seems well

*updated after new build was pushed


Last edited by tinkeruntilitworks on Thu Feb 06, 2020 20:22; edited 3 times in total
flyzipper
DD-WRT Guru


Joined: 21 Feb 2016
Posts: 504

PostPosted: Thu Feb 06, 2020 18:23    Post subject: Reply with quote
R7000 factory-to-dd-wrt.chk file is missing from the directory and the available .bin file is larger than recent versions...
... the combo of both characteristics has signaled bad builds in the past.

Watching from the sidelines for a bit.
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2660
Location: Indy

PostPosted: Thu Feb 06, 2020 20:14    Post subject: Reply with quote
scampganter wrote:
Status: Wireless Tab missing, and both radios are disabled. Temps for WL0 and WL1 "Unavailable"
BS has now overwritten the broken k4.4 bcm arm builds.
This was posted in the wrong build thread (42278) though:
Mile-Lile wrote:
FOR PEOPLE WITH NORTHSTAR UNITS!!!

BS wrote:
fixed. was a accidental commit and only affects northstar. will rebuild now all northstar targets and overwrite it on the ftp

BS wrote:
all files on the official server for this target type are now replaced
You can see the bcm arm dates are newer now (6300v1 is MIPS):
    netgear-r6300/ 06-Feb-2020 13:20
    netgear-r6300v2/ 06-Feb-2020 18:57
    netgear-r6400/ 06-Feb-2020 18:55
    netgear-r6400v2/ 06-Feb-2020 18:56
The apocalypse has been averted. Twisted Evil

_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
OPNsense x64 5050e ITX|DD: DIR-810L, 2*EA6900@1GHz, R6300v1, RT-N66U@663, WNDR4000@533, E1500@353,
WRT54G{Lv1.1,Sv6}@250
|FreshTomato: F7D8302@532|OpenWRT: F9K1119v1, RT-ACRH13, R6220, WNDR3700v4


Last edited by jwh7 on Thu Feb 06, 2020 20:21; edited 1 time in total
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1554
Location: Belgrade

PostPosted: Thu Feb 06, 2020 20:16    Post subject: Reply with quote
thx jwh7
Pdobrien3
DD-WRT User


Joined: 12 Dec 2015
Posts: 138

PostPosted: Thu Feb 06, 2020 20:16    Post subject: Reply with quote
Router/Version: Asus RT-AC68U
Mode: AP, NAS
File: asus_rt-ac68u-firmware.trx
Kernel: Linux 4.4.212 #845 SMP Tue Feb 4 21:51:46 +04 2020 armv7l
Status: Windows shares are visible using both IP and Server String but using Apple FileBrowser App errors out with "SMB: Corrupt lead byte"

Router/Version: Asus RT-AC68U
Mode: AP, NAS
File: asus_rt-ac68u-firmware.trx
Kernel: Linux 4.4.208 #651 SMP Thu Jan 9 12:55:41 +04 2020 armv7l
Status: On Firmware: DD-WRT v3.0-r41954 std (01/09/20), configured Samba with Minimum/Maximum Protocol Version as NT 1.0 and my Hikvision cameras connect and work fine. As soon as I upgrade to any version higher than DD-WRT v3.0-r41954 std (01/09/20), the shares show offline. Apple FileBrowser App also errors out with "SMB: Corrupt lead byte"

Router/Version: Asus RT-AC68U
Mode: AP, NAS
File: asus_rt-ac68u-firmware.trx
Kernel: Linux 4.4.208 #651 SMP Thu Jan 9 12:55:41 +04 2020 armv7l
Status: On Firmware: DD-WRT v3.0-r41954 std (01/09/20), configured Samba with Minimum/Maximum Protocol Version as NT 1.0 and my Hikvision cameras connect and work fine. As soon as I upgrade to any version higher than DD-WRT v3.0-r41954 std (01/09/20), the shares show offline. Apple FileBrowser App also errors out with "SMB: Corrupt lead byte"

Others are reporting working SAMBA shares with the Asus RT-AC68U, what am I doing wrong?


Last edited by Pdobrien3 on Thu Feb 06, 2020 20:19; edited 1 time in total
Lanchon
DD-WRT Novice


Joined: 05 Oct 2019
Posts: 17

PostPosted: Thu Feb 06, 2020 20:18    Post subject: Reply with quote
Netgear AC1450
going from: r42015-20200118-netgear-ac1450-webflash.bin
to: r42287-20200206-netgear-ac1450-webflash.bin
reset: no

same as other reports: Wireless Tab missing, and both radios are disabled.

this is a production router so i needed to restore it ASAP. i was able to restore it by reflashing r42015 without reset.

although i have auto nvram backups before upgrades (which are also semi-auto), a while back some issue cropped up by which i could not longer restore nvram, so i am weary of these kinds of issues. (i also cannot test whether restores have been fixed or not without risking screwing up the router.)

(FYI, restoring nvram resulted in some critical nvram values getting deleted/cleared (they are present in the backup but they are not restored). which values did not get restored was a bit random depending on the router state prior to the restore. to fix the issue i had to try and look for a restore attempt that mostly worked and then manually set the missing nvram values using the command line. this process was very time consuming because basic router parameters like IP, mask, ssh configuration, etc were usually lost. in all cases, a reset made the router boot again. but this particular router is hard to factory-reset.)

back on track...

since restoring the previous image worked, i can try do things for you if you want:

1) i can flash the problem release and get dmesg.
2) i can bisect builds to find which introduces the problem.

i am offering to do this things, but this being a production router, i rather not do it if there is an alternative.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12875
Location: Texas, USA

PostPosted: Thu Feb 06, 2020 20:22    Post subject: Reply with quote
Junk code from someone at the company, now an accidental commit. Nice. Unwanted experiment, even. @Lanchon, just download the fixed firmware image and call it a day, it's already fixed.
_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.
Because they are tired of bottom-feeders and the same old hat.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net


Last edited by kernel-panic69 on Thu Feb 06, 2020 20:24; edited 1 time in total
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2660
Location: Indy

PostPosted: Thu Feb 06, 2020 20:24    Post subject: Reply with quote
Lanchon wrote:
Netgear AC1450
going from: r42015-20200118-netgear-ac1450-webflash.bin
to: r42287-20200206-netgear-ac1450-webflash.bin
reset: no

same as other reports: Wireless Tab missing, and both radios are disabled.
See my post above (via Mile-Lile); the k4.4 builds were fixed and replaced. Check the timestamp of yours, and redownload. Wink
_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
OPNsense x64 5050e ITX|DD: DIR-810L, 2*EA6900@1GHz, R6300v1, RT-N66U@663, WNDR4000@533, E1500@353,
WRT54G{Lv1.1,Sv6}@250
|FreshTomato: F7D8302@532|OpenWRT: F9K1119v1, RT-ACRH13, R6220, WNDR3700v4
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12875
Location: Texas, USA

PostPosted: Thu Feb 06, 2020 20:26    Post subject: Reply with quote
jwh7 wrote:
Lanchon wrote:
Netgear AC1450
going from: r42015-20200118-netgear-ac1450-webflash.bin
to: r42287-20200206-netgear-ac1450-webflash.bin
reset: no

same as other reports: Wireless Tab missing, and both radios are disabled.
See my post above (via Mile-Lile); the k4.4 builds were fixed and replaced. Check the timestamp of yours, and redownload. Wink


Gee, couldn't let me edit my post fast enough, huh? Rolling Eyes Razz Laughing

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.
Because they are tired of bottom-feeders and the same old hat.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum