AP leitet nicht zu DHCP Server weiter

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC basierende Hardware
Author Message
Garadian
DD-WRT Novice


Joined: 28 Jan 2020
Posts: 4

PostPosted: Tue Jan 28, 2020 19:06    Post subject: AP leitet nicht zu DHCP Server weiter Reply with quote
Aufbau:

Router 1:
Model: Huawei E5186s-22a.
Firmware: 21.306.01.07.22 (Standard Huawei)
IP: 192.168.1.1
DHCP ist deaktiviert.
Stellt die Verbindung zum Internet her.

Router 2:
Model: Linksys WRT54GS Version 6
Firmware: DD-WRT v3.0-r40559 micro (08/06/19)
IP: 192.168.1.2
Subnet Mask: 255.255.255.0
Gateway: 192.168.1.1
Local DNS: 192.168.1.1
DHCP ist deaktiviert.
Konfiguriert als AP lt. Anleitung: https://wiki.dd-wrt.com/wiki/index.php/Wireless_Access_Point#Normal_Version_.28Same_Subnet.29 (Normal Version (Same Subnet)). Selbe SSID wie Router 1 aber auf anderem Kanal.

DHCP Server:
Model: Raspberry Pi Zero mit PiHole installiert.
IP: 192.168.1.10
DHCP Range:
192.168.1.100 - 192.168.1.250

Der DHCP Server ist via Ethernet an Router 1 angeschlossen.
Router 1 und Router 2 sind via Ethernet verbunden.

Problem:
Alle Geräte die sich über den AP (Router 2) verbinden erhalten eine inkorrekte IP (169......).
Ich habe bereits versucht im AP (Router 2) DHCP Forwarding an den DHCP Server (192.168.1.10) zu aktivieren aber ohne Erfolg.
Sponsor
casjopaia
DD-WRT Novice


Joined: 20 Feb 2015
Posts: 16

PostPosted: Tue Mar 03, 2020 14:15    Post subject: Reply with quote
Hallo!

Ich kann Dir zwar antworten, weiß aber nicht ob ich eine Hilfe bin.

Ich nutze einen LinkSYS WRT54GL (192.168.13.1) der sich als Repeater mit einem Hitron verbindet um ins Internet zu gelangen. Er ist als DHCP konfiguriert und nutzt eine dort eingestellte IP-Liste, die nach erkannter MAC einstellt. Für unbekannte MAC's habe ich 5 IP's vorgesehen.

Folgende Einstellungen im Service sind gegeben:

DNSMasq für DHCP: deaktiviert
DHCP-Authoritative: deaktiviert.

Nutze NVRAM für Clientzuweisungs-DB: aktiviert
Genutzte Domain: LAN & WLAN
DNSMasq: aktiviert
Kein DNS Rebind: aktiviert
DNS in fester Reihenfolge abfragen: aktiviert
Zusätzliche DNSMasq-Optionen:
interface=br0
dhcp-option=br0,3,192.168.13.1 # Gateway
dhcp-option=br0,6,192.168.13.1 # DNS Server


Mit vorgenanntem Router verbindet sich lediglich ein ASUS RT-AC66U (192.168.13.2) via Netzkabel über WAN-Port, indem der DHCP ausgeschaltet, aber DHCP-Weiterleitung zum oberen Router eingestellt ist. Alle IP's werden korrekt eingestellt. WAN ist natürlich deaktiviert und dem Switch zugewiesen.

In meinem Fall gibt es keinen 3. Part, der den DHCP übernimmt. Hast Du schon mal DHCP von Router 2 auf Router 1 weitergeleitet und in Router 1 eine zusätzliche Weiterleitung auf deinen Raspberry versucht? Ich bin keine Expertin in Topologie, aber muss man den Routern nicht explizit sagen was sie wo suchen müssen?!

Übrigens: Ich habe auf ftp.dd-wrt.org gesehen, dass es die Version r42602 vom 03.03.2020 zum download gibt. Vielleicht war es auch ein Fehler in der Soft, die inzwischen beseitigt ist.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC basierende Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum