New Build 42054: 01-21-2020-r42054

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7246
Location: Texas, USA

PostPosted: Tue Jan 21, 2020 21:57    Post subject: New Build 42054: 01-21-2020-r42054 Reply with quote
WARNING: DO NOT flash this experimental test build unless you know the risks and recovery methods. Report here to provide important info for developers and users. Always state your hardware model & version, mode (e.g. Repeater) and SPECIFIC build (e.g. netgear-r7000-webflash). Avoid discussions and create a new thread for specific problems or questions as this thread is not for support, and posts may be deleted or moved.

Downloads: if a link does not work, try another (alternative @DD-WRT website)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/01-21-2020-r42054/
ftp://ftp.dd-wrt.com/betas/2020/01-21-2020-r42054/
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or ftp

Changelogs:
SVN* changelog since last build: 42015
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template example to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b][u]Router/Version:[/u][/b]
[b]Mode:[/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Status: [/b]

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5336
Location: Texas

PostPosted: Tue Jan 21, 2020 22:31    Post subject: Reply with quote
Linksys EA8500
DD-WRT v3.0-r42054 std (01/21/20)
Linux 4.9.210 #512 SMP Tue Jan 21 04:24:29 +03 2020 armv7l
switch / ovpn server / VLAN / samba set min & max to SMB 2
All good so far-- up 10:19

#

Netgear WNDR3700 V4
DD-WRT v3.0-r42054 std (01/21/20)
Linux 3.18.140-d3 #66449 Tue Jan 21 08:00:41 +04 2020 mips
GUI install over r42045
switch / ovpn server
samba set min NT 1.0 & max to SMB 2 ....that's just so I can get at it with my oldass droid phone
working very nicely -- up 18:08

#

Linksys WRT160NL
DD-WRT v3.0-r42054 std (01/21/20)
Linux 3.10.108-d9 #34987 Tue Jan 21 03:53:12 +04 2020 mips
GUI install over r42045
switch / samba set min NT 1.0 & max to SMB 2
all good -- up 19:48

#

EA8500 main router still on r42015 w/her samba set min & max SMB 3.11
she 's still working very well -- up 3 days, 8:16
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 315

PostPosted: Tue Jan 21, 2020 22:40    Post subject: Reply with quote
SSH flash, no issues
Smooth reboot
No issues

_________________
Netgear R9000 X10
DD-WRT v3.0-r44538 std (10/13/20)
Gateway, AP
DNSMasq, SmartDNS, Local DNS
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HTB w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 0
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 0
Xfinity 1Gbps(max)/42Mbps
volos
DD-WRT Novice


Joined: 25 Dec 2019
Posts: 14

PostPosted: Wed Jan 22, 2020 1:40    Post subject: Reply with quote
any luck running this on the TP-link 4300? Thanks@!
wheaton4prez
DD-WRT User


Joined: 14 Jul 2015
Posts: 84

PostPosted: Wed Jan 22, 2020 2:22    Post subject: Reply with quote
Linksys EA-8500

I was just running some tests because I was fed up with the wireless performance on my network. I was streaming movies through Plex to 3 LAN connected devices and 2 wireless devices at the same time (one 5G and the other NG). The point was to try and deduce if the bottleneck was on the server side, client side or router.

Since the LAN devices worked perfectly and both wireless devices were constantly buffering, I was pretty sure that it was something in the router. So, I was about to resurrect an old thread I put up about this same issue to see if I could get to the bottom of it once and for all. But, I thought I would try updating to this build first to see if it made a difference.

AND, I'm happy to report that now all 5 devices are running great with no buffering. It at least appears that something in this build fixed wireless performance for me.

(Of course, it's possible that the previous issue could pop up again if something is crashing or getting bogged down over time in the router. We will see. But, so far I'm happy to finally see wireless streaming working again.)
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 215

PostPosted: Wed Jan 22, 2020 10:43    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r42054 std (01/21/20)
Kernel: Linux 4.9.210 #512 SMP Tue Jan 21 04:24:29 +03 2020 armv7l
Status: Working
Reset: No
Previous: 42015
Errors: No

Temperatures : CPU 53.125 °C / ath0 50 °C / ath1 50 °C

Working very well :
Router mode : DHCP
SFE Enable
STP Enable
DNSMasq
Cache DNSSEC data
Validate DNS Replies (DNSSEC)
Check unsigned DNS replies
Local DNS
No DNS Rebind
ath0, ath1
Vpn (OpenVPN Client)

without VPN


with VPN
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 129
Location: UK

PostPosted: Wed Jan 22, 2020 11:12    Post subject: Reply with quote
Router/Version: Netgear R9000
Firmware: DD-WRT v3.0-r42054 std (01/21/20)
Kernel: Linux 4.9.210 #425 SMP Tue Jan 21 02:33:15 +03 2020 armv7l
Status: Working
Reset: Yes
Previous: 41892
Errors: No

The previous 3 firmwares (41954, 41986 & 42015) wouldn't allow alot of my devices to connect to the internet, both wired and wireless. Now everything is connecting and working again as normal with all the same settings I had used for 41892.
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 315

PostPosted: Wed Jan 22, 2020 13:39    Post subject: Reply with quote
Bernadoe wrote:
Router: Netgear R7800
Firmware: DD-WRT v3.0-r42054 std (01/21/20)
Kernel: Linux 4.9.210 #512 SMP Tue Jan 21 04:24:29 +03 2020 armv7l
Status: Working
Reset: No
Previous: 42015
Errors: No

Temperatures : CPU 53.125 °C / ath0 50 °C / ath1 50 °C

Working very well :
Router mode : DHCP
SFE Enable
STP Enable
DNSMasq
Cache DNSSEC data
Validate DNS Replies (DNSSEC)
Check unsigned DNS replies
Local DNS
No DNS Rebind
ath0, ath1
Vpn (OpenVPN Client)


Are you using QoS, and if so, can you tell me your settings? I'm trying to improve my router's performance.

_________________
Netgear R9000 X10
DD-WRT v3.0-r44538 std (10/13/20)
Gateway, AP
DNSMasq, SmartDNS, Local DNS
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HTB w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 0
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 0
Xfinity 1Gbps(max)/42Mbps
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1594
Location: Canada

PostPosted: Wed Jan 22, 2020 18:23    Post subject: Reply with quote
Router: 2x Netgear R7800 (Gateway Router & AP Router)
Firmware: DD-WRT v3.0-r42054 std (01/21/20) [from: DD-WRT v3.0-r41813 std (12/29/19)]
Linux Rel: Linux 4.9.210 #512 SMP Tue Jan 21 [from: Linux 4.9.207 #502 SMP Sun Dec 22]
Reset: NO
Status & Uptime: Working over 30min uptime
Issues from r41813: QoS & USB Storage

QoS Settings Used - HTB/FQ_CODEL_FAST 160K-Down/160K-Up

Thank You BrainSlayer for your Great Work with DDWRT!!

LOGIN TO SEE IMAGES

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r44483 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r44483 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r44483 Std
WRT610Nv1 - Client Bridge - DDWRT r33679 Mega K2.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r44483 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 162

PostPosted: Wed Jan 22, 2020 21:55    Post subject: Reply with quote
Updated my EA8500 from r42015 to r42054 via GUI, no reset, without issues.
However, I lost access to other devices on the network, so Samba/SMB issue.
Samba settings same as before, tried changing from smb2 to the others, no joy.
Shut everything down and went to bed.
This morning, only got "Limited Connectivity".
Internet access down.
Tried restarting router and Arch Linux PC - same.
Rolled back to r42015 - now everything works again...
EDIT:
Restarted everything and reflashed r42054
At first "Limited Connectivity" appeared but disappeared after a few seconds.
Internet accessable.
Connection to other devices now works.
Bloody computers...

_________________
------------------------------------
Linksys EA8500 DD-WRT r44538 (Gateway)
Linksys WRT1900ACv1 DD-WRT r44538 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r44538 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
giuliomagnifico
DD-WRT User


Joined: 11 Apr 2016
Posts: 334
Location: Italy

PostPosted: Thu Jan 23, 2020 8:17    Post subject: Reply with quote
Updated from Kong 40270M on a Netgear R7800 and works very good, instead with 42015 I was unable to access the Internet with the devices connected via WiFi. Now all works, great bufferbload with HFS and FQ CODEL FAST.

Thanks to Brainslayer for this build Cool
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 315

PostPosted: Thu Jan 23, 2020 17:09    Post subject: Reply with quote
I have found something I did not expect. Enabling QoS, and it does not seem to matter which discipline or scheduler I use, limits my download speed to 200Mbp. My connection is 500Mbps down (or higher sometimes). Disabling QoS gives me the 500Mbps, enabling limits to 200. I do not remember seeing this before the latest build.
_________________
Netgear R9000 X10
DD-WRT v3.0-r44538 std (10/13/20)
Gateway, AP
DNSMasq, SmartDNS, Local DNS
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HTB w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 0
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 0
Xfinity 1Gbps(max)/42Mbps
robbbaxley
DD-WRT Novice


Joined: 12 Apr 2013
Posts: 25

PostPosted: Fri Jan 24, 2020 16:28    Post subject: Netgear X10 r9000 Reply with quote
Netgear X10 r9000:

Upon upgrading to r42054 from r41892, I lost internet access. In order to regain internet, I had to disable "Encrypt DNS" to have internet access again. I tried to re-enable "Encrypt DNS" and again lost internet access, so I am leaving it disable for the moment.

I am also having some weird permission issues with the Hard Drive connected directly to the router that I am using as a NAS. If I can figure out what is going on I will post more information later.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3858
Location: UK, London, just across the river..

PostPosted: Sat Jan 25, 2020 6:54    Post subject: Re: Netgear X10 r9000 Reply with quote
robbbaxley wrote:
Netgear X10 r9000:

Upon upgrading to r42054 from r41892, I lost internet access. In order to regain internet, I had to disable "Encrypt DNS" to have internet access again. I tried to re-enable "Encrypt DNS" and again lost internet access, so I am leaving it disable for the moment.

I am also having some weird permission issues with the Hard Drive connected directly to the router that I am using as a NAS. If I can figure out what is going on I will post more information later.


make sure your DNSCrypt server is not down and you have a working NTP time...

using GUI option "Encrypt DNS" provides connection to only one server, while running DNSCrypt via CLI/script provides connection to more than 1 server.... the downside of it, it takes sightly more resources, but not much to be that noticeable...

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 44538 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 44538 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 44538 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 44538 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 44538 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
Frakko
DD-WRT User


Joined: 06 May 2016
Posts: 384

PostPosted: Sat Jan 25, 2020 8:51    Post subject: Reply with quote
Router Model Netgear R7000
Firmware Version DD-WRT v3.0-r42054 std (01/21/20)
Kernel Version Linux 4.4.210 #736 SMP Mon Jan 20 10:27:54 +04 2020 armv7l
Status: Working
Firmware: DD-WRT v3.0-r42054 std (01/21/20)
Previous: DD-WRT v3.0-r42015 std (01/18/20)
Reset: no
[b]Issues/Errors:[/b] the problem is also present in the version v3.0-r42015. The SSH connection is always active even when you block it from the administrator panel. The connection is also guaranteed to IP outside the established range. It is not possible to change the connection port, it always remains 22. Exclamation I hope the problem is resolved quickly. Thank you Exclamation
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum