New Build - 01/18/2020 - r42015

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7364
Location: YWG, Canada

PostPosted: Sat Jan 18, 2020 13:56    Post subject: New Build - 01/18/2020 - r42015 Reply with quote
New Build - 01/18/2020 - r42015

ftp://ftp.dd-wrt.com/betas/2020/01-18-2020-r42015

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline


Router Model:

Status:
Reset:
Errors:

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ----> DD-WRT v3.0-r44425 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44412 std
[QUALCOMM] WNDR4300 v1 ------------------------> DD-WRT v3.0-r44412 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44412 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------------------------> DD-WRT v3.0-r44251 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
Sponsor
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7364
Location: YWG, Canada

PostPosted: Sat Jan 18, 2020 13:57    Post subject: Reply with quote
Router Model: dir-862L(x2), wndr4300, x86_64, r7800

Status: well it runs..
Reset: no/yes no effect
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6842
https://svn.dd-wrt.com/ticket/6903 *
https://svn.dd-wrt.com/ticket/6921
https://svn.dd-wrt.com/ticket/6947 *


r7800 latency is on par with kong builds, but the cpu usage for sirq on wifi interfaces is still broken and over 3x higher than kong builds and BS k3.18 builds..



kong r40720m firewall/qos/nat disabled, 5ghz sirq cpu load @ 320mbps:

core0: 15%
core1: 3%


ANY k4.x bs build firewall/qos/nat disabled, 5ghz sirq cpu load @ 320mbps:

core0: 60%
core1: 40%

if the r7800 was doing nat+qos, it still would be choking at these speeds from not enough cpu free.. keep the latency the same and fix the cpu usage, this will be finally 100% fixed for the first time..

STILL FORCED DISABLED HOSTAPD SYSLOG EVEN ON ROUTERS WITH BIG FLASH (assuming its intentionally removed) Evil or Very Mad

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ----> DD-WRT v3.0-r44425 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44412 std
[QUALCOMM] WNDR4300 v1 ------------------------> DD-WRT v3.0-r44412 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44412 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------------------------> DD-WRT v3.0-r44251 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5316
Location: Texas

PostPosted: Sat Jan 18, 2020 14:06    Post subject: Reply with quote
Linksys EA8500 ...main router
DD-WRT v3.0-r42015 std (01/18/20)
Linux 4.9.210 #509 SMP Thu Jan 16 03:56:42 +03 2020 armv7l
No Reset -- GUI install over r42006
unbound / JFFS / ovpn server / samba share / local DNS
VLAN on one port with ath0.1 via br1 / static DHCP / HFSC CAKE
everything working very well -- uptime 3:03

http://www.dslreports.com/speedtest/58646694

EDIT
This does have the new samba in kernel on the EA8500.
I am using samba 'SMB 3.11' as min & max protocol on both the EA8500.
NOTE: if you make any changes to samba and 'Apply Settings' it may or may not work ... 'bout promise ya it will kill port forwarding.
'Apply Settings' in port range forwarding may or may not work. This build & r42006 caused me a bit of grief mainly because lost access to wesite.
IF YOU MAKE ANY CHANGES to SAMBA, REBOOT the EA8500 and all is good.
I can access samba share just fine from WIN10 or Debian without a problem.

end EDIT

#

Netgear WNDR3700 V4
Firmware Version DD-WRT v3.0-r42015 std (01/18/20)
Kernel VersionLinux 3.18.140-d3 #66007 Sat Jan 18 06:11:00 +04 2020 mips
No Reset -- GUI install over r42006
switch / ovpn server / samba share
all good

#

Linksys WRT160NL
DD-WRT v3.0-r42015 std (01/18/20)
Linux 3.10.108-d9 #34515 Sat Jan 18 04:04:44 +04 2020 mips
No Reset -- GUI install over r42006
switch / samba share
all very good
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1401

PostPosted: Sat Jan 18, 2020 16:27    Post subject: Reply with quote
R7500v2 WDS STA
Previous 42006
CLI upgrade no reset

Samba:
Foolin with it kills the radio for a time. Gotta be patient.
Got it to work briefly when I switched to SMB 3 Min/Max using Dolphin file manager-My Default.
Have not tried 3.11 yet.
Odd but it works fine when I use Krusader file manager with SMB 2 min/max.

All set to Encryption Auto with no Server String or Workgroup cause I never have.
More testing needed here.

ProFTPD works fine and preferred, it's faster for me.

Thanks BS.

_________________
STUBBY DoT install guide----Tips-DD-WRT

Forum Guide Lines (Please read!)----How to get help the right way
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 129
Location: UK

PostPosted: Sat Jan 18, 2020 16:47    Post subject: Reply with quote
Router Model: R9000
DD-WRT v3.0-r42015 std (01/18/20)
Linux 4.9.210 #422 SMP Thu Jan 16 03:07:41 +03 2020 armv7l
Status: Kinda works
Reset: GUI install over 41892
Errors: Some ethernet devices will not connect and all my Amazon products will not connect - Alexa or FireTV

A handful of ethernet devices will not connect using firmwares from 41954 onwards, and none of my Amazon products will connect. Or rather, they say connected, but there's no internet. After reverting back to 41892, using exactly the same settings, and everything goes back to working again.
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 312

PostPosted: Sat Jan 18, 2020 21:13    Post subject: Reply with quote
Router Model: Nighthawk r9000 X10
SSH flash
Status: Normal
Reset: Not needed
Errors: None

_________________
Netgear R9000 X10
DD-WRT v3.0-r44406 std (09/18/20)
Gateway, AP
DNSMasq, SmartDNS, Local DNS
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HTB w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 0
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 0
Xfinity 1Gbps(max)/42Mbps
duhceb
DD-WRT User


Joined: 11 Apr 2010
Posts: 50

PostPosted: Sun Jan 19, 2020 4:42    Post subject: Reply with quote
Router Model: Nighthawk r9000 X10
GUI flash
Status: Normal
Reset: Not needed
Errors: I configured Samba without a workgroup and set the Min and Max versions to 3.11. The 'Status' shows stopped, but I CAN access the share from Windows 10 and my Mac.
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 215

PostPosted: Sun Jan 19, 2020 6:01    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r42015 std (01/18/20)
Kernel: Linux 4.9.210 #509 SMP Thu Jan 16 03:56:42 +03 2020 armv7l
Status: Working
Reset: No
Previous: 41986
Errors: No

Temperatures : CPU 50.916 °C / ath0 48 °C / ath1 47 °C

Working very well :
Router mode : DHCP
SFE Enable
STP Enable
DNSMasq
Cache DNSSEC data
Validate DNS Replies (DNSSEC)
Check unsigned DNS replies
Local DNS
No DNS Rebind
ath0, ath1
Vpn (OpenVPN Client)

without VPN


with VPN
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1384

PostPosted: Sun Jan 19, 2020 8:37    Post subject: Reply with quote
R9000

All 22 Amazon, Alexa, Google, and IOT devices up and running normal. 13 on 2.4Ghz and 9 on 5Ghz spread over 3 channels each band.

1Gb & 10Gb ethernets running normal.

YAMon running as usual.

_________________
Segment 1 R9000 10Gb LAN, 1Gb ISP BS
Test Bed R9000 10Gb LAN
Wired AP 1 R9000 10Gb LAN
Wired AP 2 R9000 1Gb LAN
Wired AP 3 R9000 1Gb LAN
Test Bed R7800 1Gb LAN OpenWRT Kong
download1.dd-wrt.com/dd-wrtv2/downloads/betas/ (Brain Slayer)
www.desipro.de/openwrt/ (Kong's)
YAMon usage-
www.monitoring.com/manualInstall.php


Last edited by ddaniel51 on Sun Jan 19, 2020 20:25; edited 1 time in total
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 129
Location: UK

PostPosted: Sun Jan 19, 2020 16:50    Post subject: Reply with quote
@ddaniel51

Could you possibly PM with your settings as, while my settings work with firmwares pre 41954, my same settings no longer work with any firmware post 41954.

Thanks...
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1384

PostPosted: Sun Jan 19, 2020 20:48    Post subject: Reply with quote
buffalo0207 wrote:
@ddaniel51

Could you possibly PM with your settings as, while my settings work with firmwares pre 41954, my same settings no longer work with any firmware post 41954.

Thanks...



I don't think my settings will help you very much. None of my routers are used as ethernet switches as all my computers, NAS's, routers, and printer are connected to a 16 port 10Gb switch.
The Segment 1 R9000 has the radios turned off and only acts as router, firewall, DHCP, and YAMon host.

The 3 AP's are on default Wifi settings (I don't care what their connection bandwidth/speed is.) and DHCP forwarding to the main router.

If one of BS's builds are buggy I will run known good builds until corrections are made.

The system may look like overkill but, ease of maintenance and failover reliability are exceptional.

_________________
Segment 1 R9000 10Gb LAN, 1Gb ISP BS
Test Bed R9000 10Gb LAN
Wired AP 1 R9000 10Gb LAN
Wired AP 2 R9000 1Gb LAN
Wired AP 3 R9000 1Gb LAN
Test Bed R7800 1Gb LAN OpenWRT Kong
download1.dd-wrt.com/dd-wrtv2/downloads/betas/ (Brain Slayer)
www.desipro.de/openwrt/ (Kong's)
YAMon usage-
www.monitoring.com/manualInstall.php
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 1246
Location: Illinois Moderator

PostPosted: Sun Jan 19, 2020 21:00    Post subject: Reply with quote
buffalo0207 wrote:
@ddaniel51

Could you possibly PM with your settings as, while my settings work with firmwares pre 41954, my same settings no longer work with any firmware post 41954.

Thanks...


See my signature below.

_________________
TIPS/TRICKS: Best QCA Wifi Settings | QCA WIFI WIKI | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]44374 nightly (Main Router)
[EA8500]43192 nightly (2xOffsite)
[R7800]taking a nap
[WDR3600]BS 42567 (Offsite)
[A7v5]BS 43038 (Offsite+spare here napping)
T-Fork
DD-WRT User


Joined: 06 Oct 2010
Posts: 51

PostPosted: Sun Jan 19, 2020 21:03    Post subject: Reply with quote
Netgear WNDR3700 v1
Mode Client bridge
GUI install over r31544 (02/28/17) then 30/30/30 reset

Note: abysmal dl speed that tops out at 3-5 mbps, upload how ever is usual 120mbps.
Also tried 42015 same thing, reverted back to 31544 and I get 120/120 again.
Running r31544, the router has never missed a beat in client bridge mode.
batmanrobin
DD-WRT Novice


Joined: 23 Jul 2019
Posts: 12

PostPosted: Mon Jan 20, 2020 14:08    Post subject: Reply with quote
Router Models: Trendnet TEW-673GRU and DLink DIR-825 Rev B
OS: Windows 10
Reset: GUI install over 41892
Status: Seems to have bricked both routers!

I can't get an IP to either of them. Tried 30/30/30 reset. Cannot ping 192.168.1.1 either manual IP settings of PC ethernet to 192.168.1.10. I get a "destination host unreachable" message. I also tried tftpd64 but could not get anything come up on the log.

Please help.


Last edited by batmanrobin on Mon Jan 20, 2020 16:24; edited 1 time in total
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 129
Location: UK

PostPosted: Mon Jan 20, 2020 15:41    Post subject: Reply with quote
@msoengineer

Thanks for the info. I have already been using your settings for sometime now. It's just odd that on my R9000, these settings work absolutely fine right up to 41892, but not for any firmware thereafter. There's definitely something different from 41954, as most of my devices fail to connect to the internet.

The only scripts I have are the following...


Administration>Commands>Start Up

ddwrt-ovpn-dns-leak-fix.sh: v1.0.0, 20 January 2017, by EIBGRAD

ddwrt-ovpn-table-10-fix.sh: v2.0.0, 28 February 2017, by EIBGRAD

ddwrt-ultimate-dns-leak-test.sh: v1.0.2, 29th JUNE 2019, by EIBGRAD


Administration>Commands>Firewall

Unblock Firewall DHCP Renewal Responses

Country BLOCKING Firewall Commands

ddwrt-ovpn-Kill-switch-PBR.sh: v2.0.2, 12-Feb-2016, by EIBGRAD



...and I have the following in DNSMasq

# Assign IP range, NetBIOS and DNS & DNSMasq Settings
domain-needed
bogus-priv
dns-loop-detect
no-resolv
no-poll
strict-order
#server=192.168.10.10
server=1.1.1.1
server=1.0.0.1
no-negcache
filterwin2k
dhcp-option=br0,3,192.168.10.1
dhcp-range=br0,192.168.10.201,192.168.10.220,255.255.255.0,infinite
dhcp-option=43,01:04:00:00:00:02
#
# Log the results of DNS queries with EXTRAs
log-queries=extra
#
# Set static IP addresses from USB
conf-file=/jffs/config/static_ip.cfg



@ddaniel51

Thanks for the info. As suggested, I'm just going to stay on 41892 until I get a firmware that is agin compatible with my settings...
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum