New Build - 12/03/2019 - r41659

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 1129
Location: Illinois Moderator

PostPosted: Tue Dec 03, 2019 23:06    Post subject: New Build - 12/03/2019 - r41659 Reply with quote
New Build - 12/03/2019 - r41659

ftp://ftp.dd-wrt.com/betas/2019/12-03-2019-r41659/

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline


Router Model:

Status:
Reset:
Errors:

_________________
TIPS/TRICKS: Best QCA Wifi Settings | QCA WIFI WIKI | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]43874 nightly (Main Router)
[EA8500]43192 nightly (2xOffsite)
[R7800]taking a nap
[WDR3600]BS 42567 (Offsite)
[A7v5]BS 43038 (Offsite+spare here napping)
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5265
Location: Texas

PostPosted: Wed Dec 04, 2019 0:25    Post subject: Reply with quote
Linksys EA8500
DD-WRT v3.0-r41659 std (12/03/19)
Linux 4.9.205 #497 SMP Sun Dec 1 10:11:14 CET 2019 armv7l
No Reset in long time
GUI install over r41656
up 5:31
ovpn server good
local DNS good
samba good
I disabled JFFS2 & unbound 'bout a week ago and just using openNIC DNS ... don't know why really--
--can't tell any difference anyways. The openNIC DNS I use also does DNSSEC.

CPU set to ondemand
still using HFSC CAKE
from wired desktops
WIN10
http://www.dslreports.com/speedtest/57083163

Debian
http://www.dslreports.com/speedtest/57083360
http://www.dslreports.com/speedtest/57083450
http://www.dslreports.com/speedtest/57083523

prolly be a good build ... thanks BS Cool
marcelo3d
DD-WRT User


Joined: 07 Aug 2017
Posts: 74

PostPosted: Wed Dec 04, 2019 0:43    Post subject: Reply with quote
Router Name DD-WRT
Router Model Netgear R7800
Firmware Version DD-WRT v3.0-r41659 std (12/03/19)
Kernel Version Linux 4.9.205 #497 SMP Sun Dec 1 10:11:14 CET 2019 armv7l

Samba requires "Apply settings" to start after reboot. The Status page shows Samba: Enabled: Stopped

QoS requires "Apply settings" to work after reboot. BufferBloat shows huge latency. Going to the QoS page and re-applying the settings fixes it.

These things have been happening for a few builds to me.

The rest seems to work properly.
Uptime: 12 min.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7342
Location: YWG, Canada

PostPosted: Wed Dec 04, 2019 0:57    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300, x86-64, r7800

Status: well it runs..
Reset: no/yes no effect
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6903


finally better on r7800..half way fixed. the latency is on par with kong builds, but the cpu usage for sirq on wifi interfaces is still broken and over 3x higher than kong builds and BS k3.18 builds..the latency fix wasnt even "intentional" after looking at the issue, it was cause of a different related issue another user re-brought up.



kong r40720m firewall/qos/nat disabled, 5ghz sirq cpu load @ 320mbps:

core0: 15%
core1: 3%


ANY k4.x bs build firewall/qos/nat disabled, 5ghz sirq cpu load @ 320mbps:

core0: 60%
core1: 40%

if the r7800 was doing nat+qos, it still would be choking at these speeds from not enough cpu free.. keep the latency the same and fix the cpu usage, this will be finally 100% fixed for the first time..

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/6174 ---> DD-WRT v3.0-r44112 std
[QUALCOMM] DIR-862L ------------------------> DD-WRT v3.0-r44112 std
[QUALCOMM] DIR-862L ------------------------> DD-WRT v3.0-r44112 std
[QUALCOMM] WNDR4300 v1 ------------------> DD-WRT v3.0-r44112 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 -------------------> DD-WRT v3.0-r44048 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
marcelo3d
DD-WRT User


Joined: 07 Aug 2017
Posts: 74

PostPosted: Wed Dec 04, 2019 1:07    Post subject: Reply with quote
Router Name DD-WRT2
Router Model Dlink DIR859
Firmware Version DD-WRT v3.0-r41659 std (12/03/19)
Kernel Version Linux 3.18.140 #60863 Tue Dec 3 15:14:32 +04 2019 mips

Used as AP, so not much to test.
It works.
After update, unit reboots and starts providing WiFi and routing packets. WebIF and Telnet are not functional.
Power cycle fixes WebIF and Telnet.

Thanks BS for your work and everybody else on the board for their testing!
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 1129
Location: Illinois Moderator

PostPosted: Wed Dec 04, 2019 6:00    Post subject: Reply with quote
R9000-No reset, went from 41656alpha to 41659... Gui has crashed twice on me and I needed to telnet in to stop httpd and start back up.

EA8500- No reset, went from 41604 to 41659...Gui has crashed and I can't remote back in....hopefully the cron job to reboot holds up and gets it back in line at 2AM...

The gui is very unhappy and crashes when hitting save and apply on wireless security tab.

_________________
TIPS/TRICKS: Best QCA Wifi Settings | QCA WIFI WIKI | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]43874 nightly (Main Router)
[EA8500]43192 nightly (2xOffsite)
[R7800]taking a nap
[WDR3600]BS 42567 (Offsite)
[A7v5]BS 43038 (Offsite+spare here napping)
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1382

PostPosted: Wed Dec 04, 2019 8:09    Post subject: Reply with quote
R9000 for a few builds now.

stopservice & startservice not working.

stopservice 704
startservice 704
Has no effect on cron service.

_________________
Segment 1 R9000 10Gb LAN, 1Gb ISP BS
Test Bed R9000 10Gb LAN
Wired AP 1 R9000 10Gb LAN
Wired AP 2 R9000 1Gb LAN
Wired AP 3 R9000 1Gb LAN
Test Bed R7800 1Gb LAN OpenWRT Kong
download1.dd-wrt.com/dd-wrtv2/downloads/betas/ (Brain Slayer)
www.desipro.de/openwrt/ (Kong's)
YAMon usage-
www.monitoring.com/manualInstall.php
s1mf3r
DD-WRT Novice


Joined: 29 Mar 2017
Posts: 22

PostPosted: Wed Dec 04, 2019 10:04    Post subject: Reply with quote
msoengineer wrote:

The gui is very unhappy and crashes when hitting save and apply on wireless security tab.


I'm having the same issues on my R9000 although it also happens on DD-WRT v3.0-r41517 std

I cba telnetting in anymore so I just restart the router...

Edit: also I still get loads of errors of missing .gifs / css when using "Elegant" theme
Quote:

Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/top_left.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/top_mid.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/top_right.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/center_right.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/center_left.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/bottom_left.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/bottom_right.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/bottom_mid.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/close.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/sizer.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/minimize.gif not found.
Dec 4 11:04:01 DD-WRT daemon.err httpd[10183]: httpd : Request Error Code 404: File style/pwc/default/maximize.gif not found.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3709
Location: UK, London, just across the river..

PostPosted: Wed Dec 04, 2019 13:00    Post subject: Reply with quote
Router Model TP-Link WR1043ND V2
Firmware Version DD-WRT v3.0-r41659 std (12/03/19)
Kernel Version Linux 3.18.140 #60847 Tue Dec 3 14:53:43 +04 2019 mips

update: CLI
reset: NO
status: Operational 4h+
errors: Nothing new for my set up...unit is working as it should...

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 44085 BS AP,NAT
TP-Link WR740Nv4 ------DD-WRT 43028 BS WAP/Switch
TP-Link WR1043NDv2 ----DD-WRT 44085 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----DD-WRT 44048 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 44112 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -------DD-WRT 44112 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
vortex05
DD-WRT User


Joined: 14 Mar 2014
Posts: 199

PostPosted: Wed Dec 04, 2019 13:40    Post subject: Reply with quote
Router Model: WNDR4300v1

Status: OK
Reset: No
Errors: None
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1377

PostPosted: Wed Dec 04, 2019 14:43    Post subject: Reply with quote
Netgear R7800
DD-WRT v3.0-r41659 std (12/03/19)
Linux 4.9.205 #497 SMP Sun Dec 1
Previous 41656
Webif upgrade without reset
Uptime 23:57

WDS AP 5GHz +2.4GHz AP
Working well
0.3% drops on eth0
Samba still won't run without workaround. Seems to be limited to small number of users?
I thought my HDD was having problems (stubby/DNS trouble) and switched to different one
attached to esata and no change for samba.

If interested All I am using.
--------------------------------
root@7500v2:~# iperf3 -c 192.168.1.1 -R -t 3
Connecting to host 192.168.1.1, port 5201
Reverse mode, remote host 192.168.1.1 is sending
[ 5] local 192.168.1.4 port 33478 connected to 192.168.1.1 port 5201
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 56.8 MBytes 476 Mbits/sec
[ 5] 1.00-2.00 sec 66.4 MBytes 557 Mbits/sec
[ 5] 2.00-3.00 sec 64.2 MBytes 539 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-3.05 sec 188 MBytes 516 Mbits/sec 0 sender
[ 5] 0.00-3.00 sec 187 MBytes 524 Mbits/sec receiver
--------------------------------
Netgear R7500v2
DD-WRT v3.0-r41659 std (12/03/19)
Linux 4.9.205 #497 SMP Sun Dec 1
Previous 41643
CLI upgrade without reset

WDS STA 5GHZ +2.4GHz AP
Working fine
---------------------------------
Buffalo WZR-HP-AG300H
DD-WRT v3.0-r41659 std (12/03/19)
Linux 3.10.108-d8 #29307 Tue Dec 3
Previous openwrt-18.06.5->41517->41603->41631->41643
CLI upgrade no reset this time

WDS STA 5GHz
Been working fine since I got him unbricked Very Happy


Last edited by bushant on Thu Dec 05, 2019 19:02; edited 1 time in total
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 300

PostPosted: Thu Dec 05, 2019 1:25    Post subject: Reply with quote
Flashed using SSH. No issues, clean reboot. All functions working as expected.
_________________
Netgear R9000 X10
DD-WRT v3.0-r44112 std (08/09/20)
Gateway, AP
DNSMasq, SmartDNS, Local DNS
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
No QoS
Static Leases & DHCP
2.4GHz: 3 (2422 MHz HT20)
5GHz: 100 + 106 (5500 MHz VHT80)
Xfinity 1Gbps(max)/42Mbps
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum