New Build - 10/12/2019 - r41303

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7465
Location: YWG, Canada

PostPosted: Sun Oct 13, 2019 8:25    Post subject: New Build - 10/12/2019 - r41303 Reply with quote
New Build - 10/12/2019 - r41303

ftp://ftp.dd-wrt.com/betas/2019/10-12-2019-r41303/

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline


Router Model:

Status:
Reset:
Errors:

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
Sponsor
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7465
Location: YWG, Canada

PostPosted: Sun Oct 13, 2019 8:27    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300, x86-64, r7800

Status: well it runs..
Reset: no/yes no effect
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6841
https://svn.dd-wrt.com/ticket/6846 *


absolutely horrid, worst state ipq806x has ever been in yet. wifi is full of "ghost load" now on top of the usual k4.x latency and high cpu load etc. unusable even when bridged with no nat/firewall/qos on the r7800. and BS has "no issues"... (r7800). ipq806x is trashed by kernel 4.x even after all these years. seems kong was the only one on earth able to fix it..

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Tue Oct 15, 2019 6:12; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5404
Location: Texas

PostPosted: Sun Oct 13, 2019 8:48    Post subject: Reply with quote
r41303 JFFS2 still broken on EA8500 Confused

https://svn.dd-wrt.com/ticket/6841#comment:15
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4291
Location: UK, London, just across the river..

PostPosted: Sun Oct 13, 2019 9:36    Post subject: Reply with quote
Router Model TP-Link WR1043ND V2
Firmware Version DD-WRT v3.0-r41303 std (10/12/19)
Kernel Version Linux 3.18.140 #56940 Sat Oct 12 08:02:14 +04 2019 mips

update: CLI 41269 > 41303
reset: NO
status: Operational 3h+
errors: Nothing 4 my setup...

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 46446 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46446 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46446 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46446 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46446 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
SDundee
DD-WRT User


Joined: 22 May 2011
Posts: 55

PostPosted: Sun Oct 13, 2019 14:17    Post subject: Agree, UBIFS not working Reply with quote
Getting close but no cigar yet on r41303.

Dec 31 18:00:19 Veritas kern.info kernel: [ 18.017046] jffs2: version 2.2. (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.037774] ubi0: default fastmap pool size: 10
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.037796] ubi0: default fastmap WL pool size: 5
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.041101] ubi0: attaching mtd18
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.328360] ubi0: scanning is finished
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.339779] ubi0: attached mtd18 (name "ddwrt", size 32 MiB)
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.339799] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.344494] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.351259] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.358103] ubi0: good PEBs: 260, bad PEBs: 0, corrupted PEBs: 0
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.364805] ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.371123] ubi0: max/mean erase counter: 1/1, WL threshold: 4096, image sequence number: 2356922027
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.378152] ubi0: available PEBs: 234, total reserved PEBs: 26, PEBs reserved for bad PEB handling: 20
Dec 31 18:00:19 Veritas kern.notice kernel: [ 18.387392] ubi0: background thread "ubi_bgt0d" started, PID 933
Dec 31 18:00:19 Veritas kern.err kernel: [ 18.396740] UBIFS error (pid: 916): cannot open "ubi1:ddwrt", error -19
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5404
Location: Texas

PostPosted: Sun Oct 13, 2019 14:37    Post subject: Reply with quote
My EA8500 no longer gives error ---- it just don't mount, no way, no how Confused
Code:
Oct 13 08:07:20 EA8500 kern.info kernel: [   25.829535] jffs2: version 2.2. (NAND) (SUMMARY)  (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
Oct 13 08:07:20 EA8500 daemon.info httpd[1434]: httpd : httpd server started at port 80
Oct 13 08:07:20 EA8500 user.info : httpd : http daemon successfully started
Oct 13 08:07:20 EA8500 kern.notice kernel: [   26.346879] ubi0: default fastmap pool size: 10
Oct 13 08:07:20 EA8500 kern.notice kernel: [   26.346900] ubi0: default fastmap WL pool size: 5
Oct 13 08:07:20 EA8500 kern.notice kernel: [   26.350293] ubi0: attaching mtd18
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.521053] ubi0: scanning is finished
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.521074] ubi0: empty MTD device detected
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.543110] ubi0: attached mtd18 (name "ddwrt", size 32 MiB)
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.543130] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.547884] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.554508] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.561445] ubi0: good PEBs: 260, bad PEBs: 0, corrupted PEBs: 0
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.568189] ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.574389] ubi0: max/mean erase counter: 0/0, WL threshold: 4096, image sequence number: 3851444388
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.581495] ubi0: available PEBs: 234, total reserved PEBs: 26, PEBs reserved for bad PEB handling: 20
Oct 13 08:07:21 EA8500 kern.notice kernel: [   26.590786] ubi0: background thread "ubi_bgt0d" started, PID 1441

root@EA8500:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                21248     21248         0 100% /
none                       512         0       512   0% /dev
/dev/sda              15416264   8075480   6537968  55% /tmp/mnt/sda


maybe BS will sort it someday Rolling Eyes
NO sense trying to tell him iffin he thinks he's right.
I remember back in the day when I THOUGHT I knew everything Twisted Evil
... BS is 15 years younger than me
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 1692
Location: Illinois Moderator

PostPosted: Sun Oct 13, 2019 15:15    Post subject: Reply with quote
did this fix get rolled into 41303?
https://svn.dd-wrt.com/changeset/41304

_________________
FORUM RULES

TIPS/TRICKS: Best QCA Wifi Settings | Latency tricks | QoS Port priority | NEVER USE MU-MIMO |
Why to NOT use MU-MIMO | Max Wifi Pwr by Country | Linux Wifi Pwr | AC MCS & AX MCS | QCA 5Ghz chnls to use | WIFI Freq WIKI | TFTP R7800 | Don't buy AX | IPERF3 How-To

[R9000]46450 nightly (Main Router)
[EA8500]43192 & 45493 (2xOffsite)
[R7800]napping
[WDR3600]BS 44715 (Offsite)
[A7v5]BS 43038 (Offsite+spare napping)
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 4291
Location: UK, London, just across the river..

PostPosted: Sun Oct 13, 2019 16:36    Post subject: Reply with quote
mrjcd wrote:
My EA8500 no longer gives error ---- it just don't mount, no way, no how Confused e]

maybe BS will sort it someday Rolling Eyes
NO sense trying to tell him iffin he thinks he's right.
I remember back in the day when I THOUGHT I knew everything Twisted Evil
... BS is 15 years younger than me


soon very soon...
https://svn.dd-wrt.com/changeset/41314

but BS stated its ubi now no more jffs, so have to start from the scratch, clear, format and than mount..
I use only opt but don't have this issue..tottaly diff case...i know... Smile

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 46446 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 46446 BS AP,NAT,AP Isolation,Ad-Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 46446 BS AP,NAT,AD/Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 46446 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 46446 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,VLAN's,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5404
Location: Texas

PostPosted: Sun Oct 13, 2019 16:38    Post subject: Reply with quote
yes Sir, mightbe maybe BS got'er sorted
just have to wait & see Very Happy
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1438

PostPosted: Sun Oct 13, 2019 19:05    Post subject: Reply with quote
My test bed R9000 rejected 41303 and won't upgrade to it.
Stays on it's current version.

Went from 41269 to 41218 ok and still won't load 41303.

Dl'd 303 twice, same story.

_________________
Segment 0 Cisco RV340 Dual WAN router
Segment 1 R9000 10Gb LAN, 1Gb ISP BS
Test Bed R9000 AP 10Gb LAN
Wired AP 1 Unifi Wifi 6 LR US 1Gb LAN
Wired AP 2 Unifi Wifi 6 LR US 1Gb LAN
Wired AP 3 Unifi UAP AC PRO 1Gb LAN
Test Bed R7800 1Gb LAN OpenWRT Kong
DHCP & Syslog Services Asustor 7010T NAS 10GB
NetGear XS716T 10GB Switch
download1.dd-wrt.com/dd-wrtv2/downloads/betas/ (Brain Slayer)
www.desipro.de/openwrt/ (Kong's)
YAMon
https://usage-monitoring.com/index.php
ironstaff
DD-WRT User


Joined: 11 Oct 2019
Posts: 157

PostPosted: Sun Oct 13, 2019 20:36    Post subject: Reply with quote
mrjcd wrote:
yes Sir, mightbe maybe BS got'er sorted
just have to wait & see Very Happy


What was status after you cleaned existing jffs partition in order to reformat to ubifs. Did it mount afterwards? Shocked

My R9000 refused to take the latest firmware as well.
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5404
Location: Texas

PostPosted: Sun Oct 13, 2019 20:42    Post subject: Reply with quote
ironstaff wrote:
mrjcd wrote:
yes Sir, mightbe maybe BS got'er sorted
just have to wait & see Very Happy


What was status after you cleaned existing jffs partition in order to reformat to ubifs. Did it mount afterwards? Shocked

My R9000 refused to take the latest firmware as well.



NO, it did not mount for the EA8500.
Hopefully BS has it sorted out now for my type router.
Have to wait for next release.

I don't have a r9000 and don't know anything 'bout them.... I think msoengineer has one so he'll prolly know Cool
ironstaff
DD-WRT User


Joined: 11 Oct 2019
Posts: 157

PostPosted: Sun Oct 13, 2019 22:13    Post subject: Reply with quote
mrjcd wrote:
ironstaff wrote:
mrjcd wrote:
yes Sir, mightbe maybe BS got'er sorted
just have to wait & see Very Happy


What was status after you cleaned existing jffs partition in order to reformat to ubifs. Did it mount afterwards? Shocked

My R9000 refused to take the latest firmware as well.



NO, it did not mount for the EA8500.
Hopefully BS has it sorted out now for my type router.
Have to wait for next release.

I don't have a r9000 and don't know anything 'bout them.... I think msoengineer has one so he'll prolly know Cool



Thank you! I guess I’ll hang tight and wait then.
duhceb
DD-WRT User


Joined: 11 Apr 2010
Posts: 52

PostPosted: Mon Oct 14, 2019 2:26    Post subject: R9000 Reply with quote
My R9000 won't accept the 41303 build either...
_________________
NETGEAR R9000 DD-WRT v3.0-r45192 std (12/29/20) (ROUTER)
NETGEAR ORBI Stock FW V2.7.2.102 (MESH)
WRT3200ACM (BS Build Usually) (BACKUP)
robbbaxley
DD-WRT Novice


Joined: 12 Apr 2013
Posts: 25

PostPosted: Mon Oct 14, 2019 2:41    Post subject: Netgear X10 r9000 Reply with quote
My r9000 is NOT working with this firmware (r41303). The firmware appears to load but once the router reboots it's still showing that it's on the previous version.

I am receiving some new RED warning in the Syslog which I haven't seen before:

Oct 13 22:36:54 r9000 daemon.err dnscrypt-proxy[3949]: Suspicious certificate received
Oct 13 22:36:54 r9000 daemon.err dnscrypt-proxy[3949]: No useable certificates found

These errors show up every 5 to 10 minutes in the log, give or take.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum