New Build: 09-04-2019-r40900

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2, 3  Next
Author Message
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 233
Location: FL

PostPosted: Wed Sep 04, 2019 12:23    Post subject: New Build: 09-04-2019-r40900 Reply with quote
Downloads:
http site: https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/09-04-2019-r40900
ftp site: ftp://ftp.dd-wrt.com/betas/2019/09-04-2019-r40900/

SVN Timeline:
https://svn.dd-wrt.com/timeline

How to switch partitions if needed.
"GUI" Flash Method
go to Administrator>Command (paste this)
1: ubootenv set boot_part 2 or fw_setenv boot_part 2
2: Dont REBOOT
3: Flash new WEBFLASH from Firmware Upgrade - DO NOT RESET.

"Console" Method
ubootenv get boot_part ( says 1 )
ubootenv set boot_part 2
cd /tmp
wget firmware from ftp site.
write frimware linux
reboot

Flashed this and all is still well in wonderland. Very Happy

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2020
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 190

PostPosted: Wed Sep 04, 2019 13:06    Post subject: Reply with quote
Updated WRT1200AC v1 from r40890 to r40900 with no reset using Firefox 68.0.2 (64 bit) running on Win 8.1. Usual OpenVPN client yellows in syslog.

Was currently booted on Partition 2 so I forced install on partition 2 with successful update with no issues. Release installs on either partition for me.

Kernel Version Linux 4.9.190 #1275 SMP Wed Sep 4 07:31:42 CEST 2019 armv7l

Sep 4 08:50:04 router daemon.notice openvpn[1656]: OpenVPN 2.4.7 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Sep 4 2019
Sep 4 08:50:04 router daemon.notice openvpn[1656]: library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.09

Up-time about 20 minutes with wired/wireless/openvpn client working as expected.
ttowling
DD-WRT User


Joined: 01 Mar 2019
Posts: 130

PostPosted: Wed Sep 04, 2019 13:44    Post subject: Reply with quote
The urge to flash is strong.. is this business critical?
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 327
Location: South Carolina

PostPosted: Wed Sep 04, 2019 15:27    Post subject: DD-WRT v3.0-r40900 std (09/04/19) Reply with quote
WRT3200ACM V1 r40900 Firefox 68.0.2 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
2.4GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
NAS via USB Samba also working fine
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 327
Location: South Carolina

PostPosted: Wed Sep 04, 2019 15:33    Post subject: Reply with quote
ttowling wrote:
The urge to flash is strong.. is this business critical?


ttowling, take a look at https://svn.dd-wrt.com// and scroll through the changes and see if it has changes you need/want. If nothing changed that you care about, don't flash unless you are like me, and just need the latest.
Yemble
DD-WRT Guru


Joined: 17 Feb 2010
Posts: 608
Location: Yorkshire (GOC)

PostPosted: Wed Sep 04, 2019 17:28    Post subject: Reply with quote
ttowling wrote:
The urge to flash is strong.. is this business critical?


Well 40900 is a nice round number, which is as good a reason as any Wink

_________________
Linksys WRT32X v1 - r44628
Linksys WRT1900AC v1 - r44628
TP-Link Archer C9 v1 - r44628
Firmware: ftp://ftp.dd-wrt.com/betas/2020/
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 335

PostPosted: Wed Sep 04, 2019 17:37    Post subject: Reply with quote
Flashed to both partitions without issue...
(I just like saying that)...

_________________
WRT1900ACSv2
ttowling
DD-WRT User


Joined: 01 Mar 2019
Posts: 130

PostPosted: Wed Sep 04, 2019 18:17    Post subject: Reply with quote
Yemble wrote:
ttowling wrote:
The urge to flash is strong.. is this business critical?


Well 40900 is a nice round number, which is as good a reason as any Wink


My logic entirely.. which may be my OCD flaring up again.
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 316

PostPosted: Wed Sep 04, 2019 19:27    Post subject: Reply with quote
GUI flash w/FF68.0.2x64. On reboot, even though OpenVPN Client was enabled, the VPN was not active. Went to the VPN settings tab and made no changes, just hit Apply. The GUI hung and I could not get the GUI to respond. However, the router was working...with no VPN. Used SSH to connect and reboot. After reboot, the VPN was not connected again but and the settings were still enabled. Hit Apply again, and again the GUI hung. Used SSH a second time to reboot. After reboot, the VPN was connected and all seems normal. I think there is a problem with flashing with OpenVPN connected.
_________________
Netgear R9000 X10
DD-WRT v3.0-r44628 std (10/22/20)
Gateway, AP
DNSMasq, SmartDNS, Local DNS
IPv4 & IPv6 (Prefix Delegation)
CloudFlare
QoS: HTB w/CAKE & ACK, SYN, FIN & RST
Static Leases & DHCP
2.4GHz: 10 + 6 (2457 MHz HT40), ACK Timing 0
5GHz: 100 + 106 (5500 MHz VHT80), ACK Timing 0
Xfinity 1Gbps(max)/42Mbps
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7270
Location: Texas, USA

PostPosted: Wed Sep 04, 2019 19:57    Post subject: Reply with quote
Probably one of those rare cases where shutting down VPN first may help, OR doing a reset to defaults first would do the trick. I don't quite understand why, though, but.
ellick
DD-WRT User


Joined: 28 Mar 2016
Posts: 265

PostPosted: Wed Sep 04, 2019 20:13    Post subject: Reply with quote
@MLandi

I'm been seeing the same openvpn bug for a while now. It doesn't activate initially when pressing "apply". I made a ticket.
https://svn.dd-wrt.com/ticket/6785

I don't leave my vpn connected but the bug is still there in this build. You could be right that your problems were from leaving it on when flashing.
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 335

PostPosted: Wed Sep 04, 2019 20:22    Post subject: Reply with quote
Just for the record...
I've had no problems with my VPN (OpenVPN/PIA).
I have had no hangs. It starts correctly after a reboot. It does not require to be manually started.
And I do leave it enabled when I flash...Have not experienced any issues with my VPN in the latest builds.

_________________
WRT1900ACSv2
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 162

PostPosted: Thu Sep 05, 2019 1:23    Post subject: Reply with quote
Ellick,
I've had the same OpenVPN issue that you describe for a few builds now.
Restarts are ok, but if I change VPN servers, I have to press "apply" twice for it to take effect.
Thank you for creating a ticket.

_________________
------------------------------------
Linksys EA8500 DD-WRT r44632 (Gateway)
Linksys WRT1900ACv1 DD-WRT r44628 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r44538 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
Justanotherbrokenrouter
DD-WRT User


Joined: 27 Apr 2019
Posts: 104

PostPosted: Thu Sep 05, 2019 4:19    Post subject: Reply with quote
I haven't had any problems with OpenVPN. OpenVPN starts fine after web update without reset. Build 40900 is probably one of the better builds. Speeds have increased after enabling OpenVPN with Nordvpn. First noticed speed increases with build 40890.

Last edited by Justanotherbrokenrouter on Thu Sep 05, 2019 18:59; edited 1 time in total
ellick
DD-WRT User


Joined: 28 Mar 2016
Posts: 265

PostPosted: Thu Sep 05, 2019 14:35    Post subject: Reply with quote
You don't mention which router you have. I have the wrt1900acs v.1

I've had two bugs, one major since the new linux kernel was introduced in the builds. That's why I've stuck to r40009 firmware which is the last build that was perfect for my use.

With builds after that, I started randomly losing access to the GUI from multiple browsers and machines on the network. The router would still be up and working but I couldn't access it without a reboot. The other bug is this openvpn issue which others have corroborated.

I want to jump to a later build for the newly introduced Cake QoS discipline. I used that in Openwrt and it's performance is much better for me than fq-codel or Pie.
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum