Netgear R7800 (Nighthawk X4S – AC2600) - status

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... 178, 179, 180 ... 189, 190, 191  Next
Author Message
seombre
DD-WRT Novice


Joined: 12 Dec 2018
Posts: 15

PostPosted: Sun Aug 18, 2019 11:54    Post subject: Re: Push notifications not getting through Reply with quote
seombre wrote:

...
I'm having problems with push notifications getting through. Specifically I mean Signal, WhatsApp, GMail, etc. on Android (tried multiple devices + versions). I've been having the issue for a while now and so I decided to do a factory reset, just to check, whether that solves my problem.
...


Turns out, not even a factory reset actually works. After factory reset, I only configured these values:
- Setup
-- Basic Setup
--- WAN Setup
---- Router Name
---- Hostname
---- Domain name
--- Network Setup
---- Local IP Address
---- Subnet Mask
---- Start IP Address
---- Maximum DHC Users
---- Static DNS 1, 2 & 3 (8.8.8.8, 8.8.4.4, 9.9.9.9)

- Wireless
-- Basic Settings
--- SSID for ath0 (5GHz) and ath1 (2,4GHz) - same SSID for both
-- Wireless Security
--- WPA Shared Key - the same for both ath0 and ath1

... and that's it. Even with this very basic setup (imho), I can still reproduce the issue.
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4693
Location: Netherlands

PostPosted: Sun Aug 18, 2019 12:01    Post subject: Reply with quote
I assume you are using WPA 2 personal / AES for wireless security if not try that

It could have been something related to the sleep mode of your devices which are not awakend by the router pushing a message

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
seombre
DD-WRT Novice


Joined: 12 Dec 2018
Posts: 15

PostPosted: Sun Aug 18, 2019 12:23    Post subject: Reply with quote
Yes, it's WPA2 Personal and the only enabled WPA algorithm is "CCMP-128 (AES)".

I don't know the exact build number, however, I have setup a second R7800 with a Kong build and there's absolutly no problem, when my device is in that router's WLAN. Also no problems at work or other WLANs, so this actually looks like a bug to me.

Edit: The build of the other router is probably 9 to 12 months old.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4693
Location: Netherlands

PostPosted: Sun Aug 18, 2019 13:14    Post subject: Reply with quote
seombre wrote:
Yes, it's WPA2 Personal and the only enabled WPA algorithm is "CCMP-128 (AES)".

I don't know the exact build number, however, I have setup a second R7800 with a Kong build and there's absolutly no problem, when my device is in that router's WLAN. Also no problems at work or other WLANs, so this actually looks like a bug to me.

Edit: The build of the other router is probably 9 to 12 months old.


Well there is your problem solved Smile

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
seombre
DD-WRT Novice


Joined: 12 Dec 2018
Posts: 15

PostPosted: Sun Aug 18, 2019 13:17    Post subject: Reply with quote
To be honest, going back to such an old build is absolutely not a solution. This is a regression introduced along the way.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7173
Location: YWG, Canada

PostPosted: Sun Aug 18, 2019 19:56    Post subject: Reply with quote
seems k4.14 eol was extended, will we move to that? its not like its any worse, all k4.x are equally broken on ipq806x BS builds..


(and lol at that k5.4 eol date)

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r42015 std
[QUALCOMM] R7800 ------------------> DD-WRT v3.0-r42015 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r42015 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r42015 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r42015 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 471

PostPosted: Mon Aug 19, 2019 14:47    Post subject: Reply with quote
seombre wrote:
To be honest, going back to such an old build is absolutely not a solution. This is a regression introduced along the way.


I can't imagine it's a bug or you'd be seeing other reports of the behavior. I have multiple Android and Apple devices using push notifications on 40270 without any issues.

_________________
Routing:.......Asus RT-AX88U (Asuswrt-Merlin 384.14)
Switching:....Netgear GS608_V3 & GS605_V4, TrendNet TEG-S82G & TEG-S50G
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 3129
Location: Texas, USA

PostPosted: Mon Aug 19, 2019 15:11    Post subject: Re: Push notifications not getting through Reply with quote
seombre wrote:
Hi guys!

I'm having problems with push notifications getting through. Specifically I mean Signal, WhatsApp, GMail, etc. on Android (tried multiple devices + versions). I've been having the issue for a while now and so I decided to do a factory reset, just to check, whether that solves my problem.

And it did solve the problem. Everything got through pretty fast (within a couple of seconds).
However, I then started to reconfigure everything, not using a backup on purpose. And sure enough, the push notifications stopped working again.

When going through all the configuration, I just couldn't find anything, which I think would have an impact on this. Anybody got a suggestion, what could be wrong?

Currently running build 40270.


Go step by step, save, apply, check. Repeat until you find the configuration detail that breaks it, and then undo it. Pretty simple concept. And by step by step, I mean INDIVIDUAL, line-by-line, dot-by-dot. Obviously, you are using something or adding something to a config that is breaking something....
seombre
DD-WRT Novice


Joined: 12 Dec 2018
Posts: 15

PostPosted: Tue Aug 20, 2019 17:42    Post subject: Reply with quote
Did another factory reset now and will be doing every change one by one now. Quite time consuming, since it takes a while, until my devices go to standby Wink
seombre
DD-WRT Novice


Joined: 12 Dec 2018
Posts: 15

PostPosted: Wed Aug 21, 2019 16:13    Post subject: Reply with quote
Sigh... As it turned out, the problem seems to be the modem/router, which I got a couple of years ago from my ISP. The same problem can be reproduced, when my devices are in this routers WLAN, so it's definitly not an issue with my R7800 or any specific build.

Thanks anyways, guys! Smile
Cool Ranch
DD-WRT Novice


Joined: 24 Aug 2019
Posts: 3

PostPosted: Tue Aug 27, 2019 0:52    Post subject: r7800 builds Reply with quote
Hows the r7800 with bs builds? What's the current most stable one,etc? Just bought one to replace my r7000. Was looking to use kong's but seen the message about him departing from dd-wrt (Tons of respect for him - Thanks for everything done for the community!).
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4951
Location: Texas

PostPosted: Tue Aug 27, 2019 1:04    Post subject: Reply with quote
tatsuya46 wrote:
seems k4.14 eol was extended, will we move to that? its not like its any worse, all k4.x are equally broken on ipq806x BS builds..


(and lol at that k5.4 eol date)


I'm all for trying k4.14 on the IPQ806x routers but don't know 'bout further with'em
just today got my old Linux computer, I normally use, up to k5.x ...and yea he's running very well
Code:
mrjcd@Deb:~$ uname -a
Linux Deb 5.2.0-2-amd64 #1 SMP Debian 5.2.9-2 (2019-08-21) x86_64 GNU/Linux
mrjcd@Deb:~$
marcelo3d
DD-WRT Novice


Joined: 07 Aug 2017
Posts: 42

PostPosted: Tue Aug 27, 2019 20:46    Post subject: Reply with quote
My R7800 Ath0 (5GHz) interface was dead today.
Firmware: DD-WRT v3.0-r40723 std (08/21/19)
Here is what I see in the log:
Code:

Aug 26 20:24:54 DD-WRT daemon.info process_monitor[2070]: cyclic NTP Update success (servers 2.pool.ntp.org 212.18.3.19 88.99.174.22)
Aug 26 21:24:54 DD-WRT daemon.debug ntpclient[20573]: Connecting to 2.pool.ntp.org [72.87.88.202] ...
Aug 26 21:24:54 DD-WRT daemon.info ntpclient[20573]: Time set from 2.pool.ntp.org [72.87.88.202].
Aug 26 21:24:54 DD-WRT daemon.info process_monitor[2070]: cyclic NTP Update success (servers 2.pool.ntp.org 212.18.3.19 88.99.174.22)
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.185222] ath10k_pci 0000:01:00.0: firmware crashed! (uuid n/a)
Aug 26 22:21:02 DD-WRT kern.info kernel: [475099.185268] ath10k_pci 0000:01:00.0: qca9984/qca9994 hw1.0 target 0x01000000 chip_id 0x00000000 sub 168c:cafe
Aug 26 22:21:02 DD-WRT kern.info kernel: [475099.190419] ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 0 dfs 0 testmode 0
Aug 26 22:21:02 DD-WRT kern.info kernel: [475099.204504] ath10k_pci 0000:01:00.0: firmware ver 10.4-3.10-00047 api 5 features no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps crc32 19ca6df2
Aug 26 22:21:02 DD-WRT kern.info kernel: [475099.209779] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id 0:1 crc32 cf58c3bc
Aug 26 22:21:02 DD-WRT kern.info kernel: [475099.222755] ath10k_pci 0000:01:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 512 raw 0 hwcrypto 1
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.230538] ath10k_pci 0000:01:00.0: firmware register dump:
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.240562] ath10k_pci 0000:01:00.0: [00]: 0x0000000A 0x000015B3 0x0099FBDE 0x00975B31
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.246205] ath10k_pci 0000:01:00.0: [04]: 0x0099FBDE 0x00060130 0x00000008 0x00434F94
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.254084] ath10k_pci 0000:01:00.0: [08]: 0x00446B54 0x0000001B 0x00000008 0x00000000
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.262084] ath10k_pci 0000:01:00.0: [12]: 0x00000009 0xFFFFFFFF 0x00973D28 0x00973D33
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.270047] ath10k_pci 0000:01:00.0: [16]: 0x00973AB0 0x009606CA 0x009606CA 0x00000000
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.278045] ath10k_pci 0000:01:00.0: [20]: 0x4099FBDE 0x0040652C 0x00446B98 0xFFFCFFFF
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.285961] ath10k_pci 0000:01:00.0: [24]: 0x8099FD9C 0x0040658C 0x00000001 0xC099FBDE
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.294010] ath10k_pci 0000:01:00.0: [28]: 0x809A5A06 0x004065BC 0x0045D884 0x00000001
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.302010] ath10k_pci 0000:01:00.0: [32]: 0x809B7C21 0x004065DC 0x0045D884 0x009A59FC
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.310007] ath10k_pci 0000:01:00.0: [36]: 0x809A5328 0x004065FC 0x000000FE 0x0045D8DC
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.317970] ath10k_pci 0000:01:00.0: [40]: 0x809A5AAE 0x0040662C 0x0045D884 0x00000003
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.325893] ath10k_pci 0000:01:00.0: [44]: 0x809B7A5E 0x0040664C 0x0045D884 0x00000000
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.333965] ath10k_pci 0000:01:00.0: [48]: 0x809B7A98 0x0040666C 0x0045F33C 0x0045D8DC
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.341933] ath10k_pci 0000:01:00.0: [52]: 0x809A5347 0x0040669C 0x0045F33C 0x0045D8DC
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.349929] ath10k_pci 0000:01:00.0: [56]: 0x809CC754 0x004066DC 0x0045D884 0x00000000
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.357836] ath10k_pci 0000:01:00.0: Copy Engine register dump:
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.365899] ath10k_pci 0000:01:00.0: [00]: 0x0004a000 2 2 3 3
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.372145] ath10k_pci 0000:01:00.0: [01]: 0x0004a400 1 1 9 10
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.378486] ath10k_pci 0000:01:00.0: [02]: 0x0004a800 26 26 25 26
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.384922] ath10k_pci 0000:01:00.0: [03]: 0x0004ac00 15 15 17 15
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.391514] ath10k_pci 0000:01:00.0: [04]: 0x0004b000 4661 4661 244 204
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.398011] ath10k_pci 0000:01:00.0: [05]: 0x0004b400 11 11 42 43
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.404800] ath10k_pci 0000:01:00.0: [06]: 0x0004b800 13 13 13 13
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.411194] ath10k_pci 0000:01:00.0: [07]: 0x0004bc00 1 1 1 1
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.417650] ath10k_pci 0000:01:00.0: [08]: 0x0004c000 0 0 127 0
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.424224] ath10k_pci 0000:01:00.0: [09]: 0x0004c400 1 1 1 1
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.430750] ath10k_pci 0000:01:00.0: [10]: 0x0004c800 0 0 0 0
Aug 26 22:21:02 DD-WRT kern.err kernel: [475099.437177] ath10k_pci 0000:01:00.0: [11]: 0x0004cc00 0 0 0 0
Aug 26 22:21:02 DD-WRT kern.info kernel: [475099.560123] ieee80211 phy0: Hardware restart was requested
Aug 26 22:21:08 DD-WRT kern.warn kernel: [475105.582704] ath10k_pci 0000:01:00.0: 10.4 wmi init: vdevs: 16 peers: 528 tid: 102
Aug 26 22:21:08 DD-WRT kern.info kernel: [475105.752027] disable 4addr src learn 0: 0
Aug 26 22:21:08 DD-WRT kern.warn kernel: [475105.752654] ath10k_pci 0000:01:00.0: Unknown eventid: 36933
Aug 26 22:21:09 DD-WRT kern.info kernel: [475106.345799] ath10k_pci 0000:01:00.0: device successfully recovered

Although it says "device recovered", it never did. The LED stayed off and no device could connect to it.
I changed a setting (ACK timing) on Ath0 and hit "Apply Settings" and it revived the interface.

BS, I hope this helps somewhat.

Cheers,

M.-
lobyte
DD-WRT Novice


Joined: 28 Apr 2016
Posts: 25

PostPosted: Sun Sep 01, 2019 13:41    Post subject: Reply with quote
Repository desipro.de/ddwrt with assemblies of Kong is not available now even through proxy, reload to another repository.
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1316
Location: Indiana

PostPosted: Sun Sep 01, 2019 14:09    Post subject: Reply with quote
lobyte wrote:
Repository desipro.de/ddwrt with assemblies of Kong is not available now even through proxy, reload to another repository.

<Kong> has left the building.
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321043

_________________
SUPPORTED DEVICES -- DON'T USE ROUTER DATABASE!
--IMPORTANT UPGRADE INFORMATION--STUBBY DoT install guide
Qualcomm-Atheros:
R7800 x2 BS std GW AP & GW WDS AP -- R7500V2 BS std WDS STA-- WZR-HP-AG300H BS std WDS STA
WNDR3700v4 BS std WDS STA-- Nanostation M2 AirOS-- LocoM2 AirOS
MikroTik SXT R LTE RouterOS
Broadcom:
R6200v2 41813std TFTP R6250.chk WLAN Repeater Archer C9 v1 OEM WAP

DDWRT Policy Based Routing Guide-1.03 by egc
Goto page Previous  1, 2, 3 ... 178, 179, 180 ... 189, 190, 191  Next Display posts from previous:    Page 179 of 191
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum