New BS Build: r40527 (08/04/19)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message

Joined: 31 Jan 2015
Posts: 5398
Location: Texas

PostPosted: Sun Aug 04, 2019 14:35    Post subject: New BS Build: r40527 (08/04/19) Reply with quote
New BS Build: r40527 (08/04/19)

Please report errors or other changes with this new build release.

Release Notes:

Router Model:

Joined: 31 Jan 2015
Posts: 5398
Location: Texas

PostPosted: Sun Aug 04, 2019 14:38    Post subject: Reply with quote
DD-WRT v3.0-r40527 std (08/04/19)
Linux 4.9.187-rc1 #353 SMP Sat Aug 3 03:04:37 CEST 2019 armv7l

damnit heck I put it on main EA8500 install without reset over r40501 and the stupid simple port forwarding
DON'T freakin work
so that killed access to me webserver.
Had to boot back into r40501
I never use SFE on main router ...have NO need for it with my 50/50 ISP connection.

Ok then finally got a few minutes to look at the port forwarding crap.
Reset the 2nd EA8500 that is normally used as just ovpn server and a switch.
Enabled its 'Port Range Forwarding' 80 ~ 80 which is what I've used for many years and it always worked just fine.
I also enabled unbound & Forced DNS Redirection like I use on main ...of course I had to disable those on main cause
you can't use unbound behind another router that is also using unbound.

Anyways port forwarding still worked fine.
Only thing I did NOT setup on this is ovpn server which is running on main EA8500.
That shouldn't make a difference AFAIK.
Looks like the main EA8500 needs a good reset & reconfig and she should be good for r40257 but I ain't gonna do that
till maybe next build comes out ...or might swap in the backup and do that in the wee hours tonight
Then again, OTOH I don't really see the point since r40405 has been doing great job for me.
that's 'bout all I can tell ya
end EDIT

anyone wondering --
I think BS may have fixed my problem after I realized it had nothing to do with port forwarding.
Twas stupid NAT loopback.
Crazy thing would be ok if connected from the br1 net or connected to thru its ovpn server or any outside network.
I fianlly found out it also worked fine when connected to the br0 net ONLY if QOS was disabled.
twas same on BS test build r40555
end edit2

did do some testing early this morning on spare EA8500
NO more stinking 'shortcut_fe' mod ...only 'fast_classifier' mod

see ---> 'EA8500 speed across WAN'


DD-WRT v3.0-r40527 std (08/04/19)
Linux 3.18.140 #49108 Sun Aug 4 04:59:44 +04 2019 mips
all good


DD-WRT v3.0-r40527 std (08/04/19)
Linux 3.10.108-d8 #17129 Sun Aug 4 02:52:47 +04 2019 mips
all good

Last edited by mrjcd on Mon Aug 05, 2019 20:42; edited 2 times in total

Joined: 03 Jan 2010
Posts: 7428
Location: YWG, Canada

PostPosted: Sun Aug 04, 2019 15:05    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300

Status: well it runs..
Reset: no
Errors: see tickets below * * * * * * * *

the ticket list shrunk a bit not cause things are fixed, but cause no one seems to care to fix them, they are all "invalid"..

see for latest post of full actual issues..

zero differences or fixes


BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9888 ------> r45885 std
[QUALCOMM] DIR-862L --------------------------------> r45875 std
[QUALCOMM] WNDR4300 v1 --------------------------> r45875 std
[QUALCOMM] DIR-862L --------------------------------> r45865 std
[BROADCOM] DIR-860L A1 ----------------------------> r44901 std

If you use DSLReports please enable hi-res bufferbloat.

Sigh.. why do i exist anyway..

Joined: 18 Nov 2015
Posts: 1542
Location: WCentral Indiana USA

PostPosted: Sun Aug 04, 2019 19:48    Post subject: Reply with quote
DD-WRT v3.0-r40527 std (08/04/19)
Linux 4.9.187-rc1 #353
Webif upgrade over 40526
No reset
Uptime 11:37

All I use is good

I have no port forwards, cannot comment on that.
Have not experienced the OVPN client not starting issue:

Thank You BrainSlayer and others.

STUBBY DoT install guide----Forum Guide Lines (Please read!) --- How to get help the right way----PIA Setup Guide by egc----

Joined: 07 Apr 2016
Posts: 133

PostPosted: Mon Aug 05, 2019 18:16    Post subject: Reply with quote
Flashed it on top of Kong 40270 without any reset and gotta tell you, it's running very well on my R7800.

Updated the TCP congestion control to Vegas and QOS is HTB/Pie and finally I see an A for bufferbloat. This is from a device which doesn't have a good wifi card and the results are below:

Netgear R7800 - KONG 19 2019-Q2 / LuCI openwrt-19.07 branch (git-19.190.55584-ab90938)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum