New Build - 07/26/2019 - r40439

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Fri Jul 26, 2019 13:54    Post subject: New Build - 07/26/2019 - r40439 Reply with quote
New Build - 07/26/2019 - r40439

ftp://ftp.dd-wrt.com/betas/2019/07-26-2019-r40439/

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline


Router Model:

Status:
Reset:
Errors:

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Fri Jul 26, 2019 16:01; edited 2 times in total
Sponsor
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Fri Jul 26, 2019 13:55    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300

Status: well it runs..
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6666 *

the ticket list shrunk a bit not cause things are fixed, but cause no one seems to care to fix them, they are all "invalid"..

see https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320097 for latest post of full actual issues..

qos rates function again.

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Fri Jul 26, 2019 13:58    Post subject: Reply with quote
fastest. build removal. ever.

edit: its back..

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Fri Jul 26, 2019 16:01; edited 1 time in total
Jovan
DD-WRT User


Joined: 06 Nov 2018
Posts: 97

PostPosted: Fri Jul 26, 2019 15:31    Post subject: Reply with quote
It seems r40439 it's back online. Confused
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4858
Location: Texas

PostPosted: Fri Jul 26, 2019 16:16    Post subject: Reply with quote
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/07-26-2019-r40439/
Is all still alive for me

#

EA8500
DD-WRT v3.0-r40439 std (07/26/19)
Linux 4.9.186 #348 SMP Fri Jul 26 00:25:03 CEST 2019 armv7l
switch / ovpn server / samba share ext4
looks good

#

WNDR3700 V4
DD-WRT v3.0-r40439 std (07/26/19)
Linux 3.18.140 #48288 Fri Jul 26 06:59:01 +04 2019 mips
switch / ovpn server / samba share ext4
he's all good

#

WRT160NL
DD-WRT v3.0-r40439 std (07/26/19)
Linux 3.10.108-d8 #16298 Fri Jul 26 04:56:09 +04 2019 mips
switch / samba share FAT
very good

#

I'm still running r40438 on the main EA8500 AFAIK tis 'bout same as r40439
just have a tiny bit ---- 321 errors on ath0 (2.4) but that is very good and likely due to me being out and about this morning listening to live radio on the phone when I wondered a bit too far
It's all good Smile
https://www.grc.com/shieldsup


http://www.dslreports.com/speedtest/52362881
Code:
mrjcd@Deb:~$ ssh root@citadel-station-homeworld.mrjcd.com
DD-WRT v3.0-r40438 std (c) 2019 NewMedia-NET GmbH
Release: 07/25/19
Board: Linksys EA8500
==========================================================
 
     ___  ___     _      _____  ______       ____  ___
    / _ \/ _ \___| | /| / / _ \/_  __/ _  __|_  / / _ \
   / // / // /___/ |/ |/ / , _/ / /   | |/ //_ <_/ // /
  /____/____/    |__/|__/_/|_| /_/    |___/____(_)___/
                                                     
                       DD-WRT v3.0
                   http://www.dd-wrt.com
 
==========================================================


BusyBox v1.31.0 (2019-07-25 12:06:32 CEST) built-in shell (ash)

root@Citadel-Station-Homeworld:~# uptime
 11:04:20 up 22:22,  load average: 0.12, 0.05, 0.00
root@Citadel-Station-Homeworld:~# date
Fri Jul 26 11:04:22 CDT 2019
root@Citadel-Station-Homeworld:~# exit
Connection to citadel-station-homeworld.mrjcd.com closed.

mrjcd@Deb:~$ speedtest-cli --share
Retrieving speedtest.net configuration...
Testing from Brazos Internet (96.46.208.xxx)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by Suddenlink Communications LLC (Abilene, TX) [138.14 km]: 38.309 ms
Testing download speed................................................................................
Download: 46.77 Mbit/s
Testing upload speed......................................................................................................
Upload: 46.59 Mbit/s
Share results: http://www.speedtest.net/result/8449348532.png
mrjcd@Deb:~$
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4345
Location: Netherlands

PostPosted: Fri Jul 26, 2019 17:10    Post subject: Reply with quote
Router Model: Netgear R7800

Firmware Version: DD-WRT v3.0-r40439 std (07/26/19)
Kernel Version: Linux 4.9.186 #349 SMP Fri Jul 26 00:47:25 CEST 2019 armv7l

Upgraded from: DD-WRT v3.0-r40270M kongac (07/11/19)
Reset: No, not this time

Status: Up and running for 8 hours, basic setup as Gateway, static leases, OpenVPN client (on PIA) with Policy Based Routing up and running, 2,4GHz, 5Ghz USB storage NAS and OpenVPN server working.

Errors: Yes
1. SFE is blocking PBR, see: https://svn.dd-wrt.com/ticket/6729
2. SFE does not seem to work at all in accelerating/off loading, see: https://svn.dd-wrt.com/ticket/6729
3. DNS leak see: http://svn.dd-wrt.com/ticket/6020
4. The following code is missing in route-up.sh, meaning that the pushed DNS servers from the OpenVPN client are not added to resolv.dnsmasq:
Code:
stopservice dnsmasq -f
startservice dnsmasq -f
cat /tmp/resolv.dnsmasq > /tmp/resolv.dnsmasq_isp
env | grep 'dhcp-option DNS' | awk '{ print "nameserver " $3 }' > /tmp/resolv.dnsmasq
cat /tmp/resolv.dnsmasq_isp >> /tmp/resolv.dnsmasq
sleep 2
touch /tmp/resolv.dnsmasq


The good news is SFE is off by default and if you disable SFE in the GUI it is really unloaded after Save/Apply and SFE is not blocking UDP forwarding Smile

Otherwise build is fine

Big Thanks to BrainSlayer, Kong and others devs!! Very Happy

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1258
Location: Indiana

PostPosted: Fri Jul 26, 2019 20:28    Post subject: Reply with quote
Netgear R7800
DD-WRT v3.0-r40439 std (07/26/19)
Linux 4.9.186 #349

GUI upgrade from 40438 with nvram erase

PBR clients have no internet if SFE enabled

SFE enable/disable working in GUI
DDNS working
ProFTP and Samba working
USB 1tb hdd ext2/jffs ext2/opt ntfs partitions working
MiniDLNA working
Entware + STUBBY + other working

WDS AP on ATH0 + AP on ATH1

Not using QOS

Thanks BS and others!

_________________
SUPPORTED DEVICES -- DON'T USE ROUTER DATABASE!
--IMPORTANT UPGRADE INFORMATION--STUBBY install guide
Qualcomm-Atheros:
R7800 x2 kongat & BS WDS AP & Sta-- R7500V2 BS std WDS STA-- WZR-HP-AG300H BS std WDS STA
WNDR3700v4 BS std WDS STA-- Nanostation M2 AirOS-- LocoM2 AirOS
Broadcom:
R6200v2 41491std using R6250.chk WLAN Repeater Archer C9 v1 OEM WAP

DDWRT Policy Based Routing Guide by egc
Maverick98087
DD-WRT Novice


Joined: 23 Dec 2018
Posts: 9

PostPosted: Fri Jul 26, 2019 21:50    Post subject: Reply with quote
Hmm...

Netgear R8500
Flashed https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/07-26-2019-r40439/netgear-r8500/netgear-r8500-webflash.bin via ssh.

Write was complete.

Reboot

Power light stays red (dark orange), I get port activity from connected devices (However I don't know if there is connectivity)

WiFi is inactive.

I've tried a hard reset, but no changes. (Not 100% sure that I am attempting a hard reset properly, never had a flash do this before)

I attempted a hold reset 7 seconds and it blinked and restarted, but no changes. I also 30/30/30 reset, but no noticeable changes.


Last edited by Maverick98087 on Fri Jul 26, 2019 22:02; edited 1 time in total
community
DD-WRT Novice


Joined: 04 Feb 2018
Posts: 10

PostPosted: Fri Jul 26, 2019 22:00    Post subject: Reply with quote
r6400
am in the same boat with you brother.The power stays on red and thats it.i have tried restoring with tftp but will not work.I guess its bricked.time to but a new router
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Fri Jul 26, 2019 22:33    Post subject: Reply with quote
wrong section and.. wrong section.. both of those are broadcom
_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2623
Location: Texas, USA

PostPosted: Fri Jul 26, 2019 22:53    Post subject: Reply with quote
This build is bricking Broadcom units: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320634
vortex05
DD-WRT User


Joined: 14 Mar 2014
Posts: 187

PostPosted: Sat Jul 27, 2019 2:06    Post subject: Reply with quote
Router Model: WNDR4300v1

Status: OK
Reset: No
Errors: None


Router Model: WR841N V9

Status: OK
Reset: No
Errors: None
Gradius
DD-WRT Novice


Joined: 11 May 2013
Posts: 38

PostPosted: Sat Jul 27, 2019 4:02    Post subject: Reply with quote
Router: TP-Link AC1900 v1

FW:
ftp://ftp.dd-wrt.com/betas/2019/07-26-2019-r40439/tplink_archer-c9v1/

It BRINKED my TP-Link.

I cannot do anything, tried hard reset and all. I was running 07-20-2019-r40400 w/o any issues.

Now, what can I do ?!?
kretex
DD-WRT Novice


Joined: 24 Apr 2019
Posts: 48

PostPosted: Sat Jul 27, 2019 6:57    Post subject: Reply with quote
Router Name: 3420v.1
Router Model: TP-Link TL-MR3420
Firmware Version: DD-WRT v3.0-r40439 std (07/26/19)
Kernel Version: Linux 3.10.108-d8 #16342 Fri Jul 26 05:42:06 +04 2019 mips
Status: OK, Flash over previous fw using winscp/putty
Reset: No
Errors: WebGUI still buggy

Apply Settings
Restore Settings
Firmware Upgrade

Not working properly Rolling Eyes
Jovan
DD-WRT User


Joined: 06 Nov 2018
Posts: 97

PostPosted: Sat Jul 27, 2019 20:19    Post subject: Reply with quote
Router Model TP-Link TL-WR841ND v11
Firmware Version DD-WRT v3.0-r40439 std (07/26/19)
Kernel Version Linux 3.18.140 #48250 Fri Jul 26 05:57:02 +04 2019 mips
Uptime 1 day, 1:18

Previous: r40400
Reset: No
Status: Working OK as AP, HT 40, QOS
Problems: none

Router Model TP-Link TL-WR841ND v7
Previous: r39xxxx - (can't remember, I updated it a couple of months ago while I was visiting. This is not my router, it's in my mother-in-law house and updated it to last version at the time, via telnet)
Reset: No
Status: Still working OK-ish as AP, HT 20 (needed a couple of power cycles)
Problems: Web interface refuses connection. Still keeps previous settings but it can be accessed only by telnet. I left it like that, because still works, but can't make any modification to settings because refuses connection. . I had no time to investigate more, I am happy it still works and my mother in law doesn't hate me for my recklessness. Probably in the future (at my next visit in 2 months or so) either I revert it via telnet to a previous version or, I hope, a future version will not refuse connection via web interface.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum