New Build 06-30-2019-r40167 * DONT USE THIS BUILD *

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2
Author Message
joe_lopez
DD-WRT Novice


Joined: 01 Jul 2019
Posts: 2

PostPosted: Mon Jul 01, 2019 18:45    Post subject: Reply with quote
I have the same problem but I have a wrt1200AC. Can you tell me how you unbricked it? TFTP does not work either. Router wired and wireless works but I cannot do anything in the gui.
Sponsor
joe_lopez
DD-WRT Novice


Joined: 01 Jul 2019
Posts: 2

PostPosted: Mon Jul 01, 2019 19:07    Post subject: Got it working! Reply with quote
I was inpatient but the turning it off and on several times instructions that Justanotherbrokenrouter gave worked for me eventually. I was not sure it would on my wrt1200AC. Thanks!
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 113
Location: FL

PostPosted: Mon Jul 01, 2019 19:37    Post subject: Reply with quote
Glad you got it to go, told you just keep at it, took me a bit to get mine flipped from that as well, Just keep at it people it will flip patitions.....
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Issues:
1. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
ALTERNATE for VAP issue run command ifconfig ath0.1 down then ifconfig ath0.1 up ( works better for me )

Linksys WRT1900ACv1 08-06-2019-r40559
WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
T-z3P
DD-WRT Novice


Joined: 18 Nov 2011
Posts: 4

PostPosted: Tue Jul 02, 2019 13:22    Post subject: Reply with quote
Well, I didn't know that the build is broken, so I've updated my WRT32x. Now the router is performing well, but the web interface looks like isn't loading properly.

What are my options now? Should I wait for the next build and try to upgrade?

I've also tried to revert to an older firmware, but nothing happens when I hit the "Upgrade" button.

_________________
Linksys WRT32X - DD-WRT v3.0-r40134
Linksys EA6300 - DD-WRT v3.0-r40167
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 113
Location: FL

PostPosted: Tue Jul 02, 2019 18:02    Post subject: Reply with quote
Manually switch the router from primary to alternate partition or vice versa [backup] partition:

Power off router with power switch.
Turn power back on and Power LED will light.
As soon as all LEDs turn off (~2s), power off router with power switch
Turn power back on and Power LED will light.
As soon as all LEDs turn off (~2s), power off router with power switch
Turn power back on and Power LED will light.
As soon as all LEDs turn off (~2s), power off router with power switch
Turn power back on and allow router to fully boot.
It should now be booted to the alternate firmware partition

T-z3P wrote:
Well, I didn't know that the build is broken, so I've updated my WRT32x. Now the router is performing well, but the web interface looks like isn't loading properly.

What are my options now? Should I wait for the next build and try to upgrade?

I've also tried to revert to an older firmware, but nothing happens when I hit the "Upgrade" button.

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Issues:
1. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
ALTERNATE for VAP issue run command ifconfig ath0.1 down then ifconfig ath0.1 up ( works better for me )

Linksys WRT1900ACv1 08-06-2019-r40559
WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
T-z3P
DD-WRT Novice


Joined: 18 Nov 2011
Posts: 4

PostPosted: Tue Jul 02, 2019 19:09    Post subject: Reply with quote
PIZZEDMEOFF wrote:
Manually switch the router from primary to alternate partition or vice versa [backup] partition:

Power off router with power switch.
Turn power back on and Power LED will light.
As soon as all LEDs turn off (~2s), power off router with power switch
Turn power back on and Power LED will light.
As soon as all LEDs turn off (~2s), power off router with power switch
Turn power back on and Power LED will light.
As soon as all LEDs turn off (~2s), power off router with power switch
Turn power back on and allow router to fully boot.
It should now be booted to the alternate firmware partition


Thank you for the answer, I've already read the solution you provided in a previous post, but I want to keep the main partition intact. That would be my last resort, if nothing else works. I've also forgot to mention that I can access SSH on the affected router. Is there a way to push an older version from terminal?

_________________
Linksys WRT32X - DD-WRT v3.0-r40134
Linksys EA6300 - DD-WRT v3.0-r40167
T-z3P
DD-WRT Novice


Joined: 18 Nov 2011
Posts: 4

PostPosted: Tue Jul 02, 2019 21:31    Post subject: Reply with quote
Ok, so I've managed to return the router into a working state. I will detail the steps below:

1. SSH into router
2. cd /tmp
3. Download firmware with wget ftp://ftp.dd-wrt.com/betas/2019/06-27-2019-r40134/linksys-wrt32x/ddwrt-linksys-wrt32x-webflash.bin
4. Check what partition is in use with ubootenv get boot_part (on the 3rd line it will return 1 or 2) and change it if needed with ubootenv set boot_part 1 or 2 (mine was already set to 1, as the default firmware is still on partition 2)
5. Flash firmware with write ddwrt-linksys-wrt32x-webflash.bin linux (if your partition is set to 2, use linux2)
6. Wait to complete and then reboot

PS: The above instructions were followed on WRT32x. I'm not sure if it will work on other routers.

PS2: If you are not able to SSH into router, you can get a USB to TTL cable and follow the steps in this video https://www.youtube.com/watch?v=PZYXKAkuJ5w

_________________
Linksys WRT32X - DD-WRT v3.0-r40134
Linksys EA6300 - DD-WRT v3.0-r40167
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 105

PostPosted: Wed Jul 03, 2019 17:29    Post subject: Reply with quote
So far, on R40134, I've not experienced any of the issues that others have described with these latest builds. Then again, my setup is very straightforward: no VPN, WiFi on each interface, and a virtual WiFi for guests.

My escape plan, should I need one, is:
    Flash to R36154 that worked quite well (including the automatic reboot), letting it reset.
    After reboot, restore from the settings file I'd previously saved from that release.

I blew away the stock firmware quite some time ago, so I'm okay with overwriting the opposite partition.

Does this all make sense? Thanks!

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r40134 std (06/27/19)
ISP: RCN
NAS: ReadyNas314
gufus
DD-WRT Guru


Joined: 04 Aug 2012
Posts: 554
Location: behind the screen

PostPosted: Wed Jul 03, 2019 19:37    Post subject: Reply with quote
Be carefull with these builds, u should know how to recover if you want to test these images. Rolling Eyes
_________________
WRT3200ACM dd-wrt r40559
WRT1900AC openwrt 18.06
WRT54GL dd-wrt r21676
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 113
Location: FL

PostPosted: Thu Jul 04, 2019 0:39    Post subject: Reply with quote
i agree, unless your checking the forums first looking for any mishaps, make sure you can use a usb to ttl serial cable to recover and already have the other necessary tools already in place to recover the firmware.
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Issues:
1. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
ALTERNATE for VAP issue run command ifconfig ath0.1 down then ifconfig ath0.1 up ( works better for me )

Linksys WRT1900ACv1 08-06-2019-r40559
WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 105

PostPosted: Thu Jul 04, 2019 11:14    Post subject: Reply with quote
I'm sorry...I just couldn't resist.
_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r40134 std (06/27/19)
ISP: RCN
NAS: ReadyNas314
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 157
Location: South Carolina

PostPosted: Thu Jul 04, 2019 16:00    Post subject: Reply with quote
giles02134 wrote:
I'm sorry...I just couldn't resist.


ROFL! Laughing
ellick
DD-WRT User


Joined: 28 Mar 2016
Posts: 81

PostPosted: Fri Jul 05, 2019 16:13    Post subject: Reply with quote
giles02134 wrote:
I'm sorry...I just couldn't resist.


Perfect!

Dr. Frankenstein: [Holds up hand] Ah. Good. Uh... would you mind telling me... whose brain... I did put in?
Igor: And you won't be angry?
Dr. Frankenstein: I will not be angry.
Igor: [Shrugs] Abby...someone.
Dr. Frankenstein: Abby someone? Abby who?
Igor: Abby Normal.
Dr. Frankenstein: [takes a deep breath] Abby Normal?
Igor: I'm almost sure that was the name. [He and Dr. Frankenstein laugh]
Dr. Frankenstein: Are you saying... [Stands] that I put an abnormal brain... [Puts hand on Igor's hump] into a 7 and a half foot long... 54- inch wide... [Grabs Igor by throat] GORILLA?!?!?! [Strangling Igor] IS THAT WHAT YOU'RE TELLING ME!?!
Mojave83
DD-WRT Novice


Joined: 07 Jul 2019
Posts: 1

PostPosted: Sun Jul 07, 2019 6:14    Post subject: Reply with quote
I've been so stupid to install this build without thinking.
Now after 20 tries to start the other partition, I still have no luck.

Should I order the USB TTL cable?
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum