Help required Please on Linksys WRT32X not booting

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2
Author Message
foz111
DD-WRT User


Joined: 01 Oct 2017
Posts: 216
Location: Earth

PostPosted: Wed Feb 20, 2019 12:04    Post subject: Reply with quote
thank you again for your time helping me, i really appreciate this.
i noticed the cpu stall myself in the logs, it could be faulty, i purchased this in broken state, i just thought it would make a faster vpn throughput than my current router with its 1.8ghz cpu.
seems odd that it will take the image if cpu faulty unless the file writes straight to the nand and bypasses the cpu, again above my knowledge i am afraid.
i noticed the two file sizes are different
image file named flat-FW_WRT32x.......img is 11.8MB but the EW_WRT32X_1.0.17919.......img is 13.1MB
i will try what you suggested when i get home this evening.
again massive thanks for your time in replying and help with this
Sponsor
blkt
DD-WRT User


Joined: 20 Jan 2019
Posts: 236

PostPosted: Wed Feb 20, 2019 12:28    Post subject: Reply with quote
Yes flat-FW_WRT32X_1.0.180404.58.img from a different guy (same thread). The explanation of his conversion method is good and others have repeated his steps with success on other files. It's also the latest "official" build available.

Maybe it's a bad power supply? Who knows, maybe it's toast. Have you examined the board?
foz111
DD-WRT User


Joined: 01 Oct 2017
Posts: 216
Location: Earth

PostPosted: Wed Feb 20, 2019 17:34    Post subject: Reply with quote
Nothing visible on the board no nasty electrical burns or smells nothing like that, looks mint to be honest.
it's a strange one as you say everything seems to look ok comparing the output to others i've seen posted.
I've tried another power supply none genuine but correct volts/amps/polarity still same...
Is there a DD-WRT or openwrt image that can be flashed from TFTP server? maybe worth trying that, i seemed to have tried everything else now lol although i dont expect it will work but worth a go if there is an image.
Gutted really gutted, when it took the image first time i really thought it was there.
Is there a erase nvram command? before i setenv ip, subnet, server etc?
Thanks again for your help
Foz
blkt
DD-WRT User


Joined: 20 Jan 2019
Posts: 236

PostPosted: Fri Feb 22, 2019 5:32    Post subject: Reply with quote
The DD-WRT and OpenWRT images are not formatted for serial flashing; we have the correct flat images.

Have you tried flashing the other image? flat-FW_WRT32X_1.0.180404.58.img

Rename it venom.img, make sure TFTP is pointed to the new file and go through the same serial flash process as before, only this time adding the few envars that were wiped during the reset. Don't forget to disable firewall and set your ethernet adapter's tcp/ip properties.

setenv SMT-2D NK90H500215CX01
setenv mv_pon_addr 00:50:43:db:f5:00
setenv bootdelay 5
setenv silent
saveenv
run update_both_images
reset
foz111
DD-WRT User


Joined: 01 Oct 2017
Posts: 216
Location: Earth

PostPosted: Fri Feb 22, 2019 8:03    Post subject: Reply with quote
Hi blkt

yes tried that, seems to always stall at

[ 10.070646] FW len = 447616
[ 10.074500] fw download start 88
[ 10.077745] init ddr...
[ 10.080471] bad len: 0x3a5 !!

followed by
[ 70.061173] INFO: rcu_sched self-detected stall on CPU
then continues to recycle the next part of the output over and over until i power it off.

thanks again blkt
blkt
DD-WRT User


Joined: 20 Jan 2019
Posts: 236

PostPosted: Sat Feb 23, 2019 9:14    Post subject: Reply with quote
Well, only one more thing I can recommend at this point is to attempt a U-Boot Recovery.

Keep the venom.img from the last attempt in the TFTP folder ( flat-FW_WRT32X_1.0.180404.58.img renamed venom.img ).

Download this file and place it in the same TFTP folder. Specify your Ethernet adapter's TCP/IP settings just as before and set up your TFTP server (firewall off).

http://www.protechs-online.com/downloads/McDebian/u-boot-recovery/WRT32X_uboot_2.0.9.bin

Be sure to type these commands exactly as shown.

tftp 2000000 WRT32X_uboot_2.0.9.bin
nand erase 0 200000
nand write 2000000 0 200000
reset

Pray you can get back into U-Boot.

env default -a
saveenv
reset

setenv SMT-2D NK90H500215CX01
setenv mv_pon_addr 00:50:43:db:f5:00
setenv ipaddr 192.168.1.1
setenv serverip 192.168.1.254
setenv netmask 255.255.255.0
setenv firmwareName venom.img
setenv bootdelay 5
setenv silent
saveenv
reset

run update_both_images
reset

Neutral
foz111
DD-WRT User


Joined: 01 Oct 2017
Posts: 216
Location: Earth

PostPosted: Tue Feb 26, 2019 16:17    Post subject: Reply with quote
No good blkt, still stops at the same point during boot .
Gutted...
Well blkt all i can do is thank you for all the time and help you've provided mate, your a genuine star, sadly on this occasion i think the router has a hardware issue.
Very strange how it takes an image and even a u-boot file but it will not boot, stops at the same point as before, cpu self detect stall
blkt
DD-WRT User


Joined: 20 Jan 2019
Posts: 236

PostPosted: Wed Feb 27, 2019 8:11    Post subject: Reply with quote
Yeah it fails shortly after init ddr with bad len followed by a cpu stall; not sure what Linksys would offer in terms of RMA but maybe worth a shot after posting your results to a support rep. These routers run really hot due to packaging, thermal pad, heatsink design and no fan.

I recently picked up a Netgear R7800-100NAS; if you can find one used in your area for half retail or less that would be a good choice (Voxel modified stock or Kong's Stable from 2018-10-28).

Another choice might be the Asus RT-AC86U due to its hardware acceleration of AES for OpenVPN, but you will be limited to modified stock firmware (Asuswrt-Merlin).
WildBillpdx
DD-WRT Novice


Joined: 23 Jun 2019
Posts: 7

PostPosted: Thu Jul 04, 2019 17:07    Post subject: Reply with quote
foz111 wrote:
Hi guys

I have managed to get this to a command prompt now, Venom>>


How did you finally get the command prompt? I have a WRT32X in the same mess...
WildBillpdx
DD-WRT Novice


Joined: 23 Jun 2019
Posts: 7

PostPosted: Thu Jul 04, 2019 20:02    Post subject: Reply with quote
foz111 wrote:
Hi guys

I have managed to get this to a command prompt now, Venom>>
i have downloaded the image from Linksys website its quite small 10,490 KB
I've started the TFTPD server pointed to the firmware etc,
then in the putty window i executed the commands

Venom>> setenv ipaddr 192.168.1.1
Venom>> setenv netmask 255.255.255.0
Venom>> setenv serverip 192.168.1.254
Venom>> run update_both_images
Using egiga0 device
TFTP from server 192.168.1.254; our IP address is 192.168.1.1
Filename 'venom.img'.
Load address: 0x2000000
Loading: T T T T T T T T T T
Retry count exceeded; starting again

Any ideas?
i have also tried what was suggested on a youtube guide
setenv firewareName venom.img
also changing firmware_name as was suggested
also setenv firmware_name firmware_venom.img
but still get the retry count exceeded
its like the tftp server is not pushing it


I had the same error...tftp server wasn't on the network since I forgot to reconnect my ethernet. Also assume 192.168.1.254 is the address you used for your NIC?
WildBillpdx
DD-WRT Novice


Joined: 23 Jun 2019
Posts: 7

PostPosted: Fri Jul 05, 2019 2:41    Post subject: WRT32X Un-Bricked Reply with quote
Finally got the stock firmware installed. Here is what finally worked for me:

Using Adafruit cable (not recommended by me due to poor connections):

setenv ipaddr 192.168.1.1 # modify for your LAN
setenv serverip 192.168.1.2 # modify for your TFTP server
setenv firmwareName venom.img (flat-FW_WRT32X_1.0.180404.58.img saved as venom.img)
setenv silent
saveenv
ping 192.168.1.1 # confirm LAN
run update_both_images
reset


Thanks to everyone for the posts that finally helped me solve this.
Winkel
DD-WRT Novice


Joined: 15 Jul 2019
Posts: 13
Location: Rødovre, Denmark

PostPosted: Mon Jul 29, 2019 18:15    Post subject: Reply with quote
I can add a note to the Loading TTTTT... I had same problem and spend half day until it hit me. Disable window firewall, wupti it was installed under 30 seconds! Shocked
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum