shedule reboot not working

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2
Author Message
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Mon Jun 03, 2019 10:11    Post subject: Reply with quote
Yes, I checked to be certain that CRON is enabled...it is.
I dropped back to checking the option on the "Keep Alive" page. I'll let it sit for a few days, and see if it works.

Perhaps on the next release, this will have been reviewed again.

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
Sponsor
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Tue Jun 04, 2019 10:07    Post subject: Reply with quote
Well, last evening, the scheduled reboot worked as it should.
Perhaps un-checking the option, enabling/removing the startup script, and then changing back to the checked option, got it working?

I'll keep watching it.

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
NashBlade
DD-WRT Novice


Joined: 01 Aug 2012
Posts: 26

PostPosted: Wed Jun 05, 2019 0:04    Post subject: Reply with quote
I find it strange that the first scheduled reboot works, but subsequent ones do not Confused I am currently running build 39884.
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Fri Jun 07, 2019 10:56    Post subject: Reply with quote
With the most recent build (39956), Scheduled Reboot is working. Perhaps I just noticed this...or perhaps it's stated for the first time, but now on the Administration/KeepAlive tab, the "Help" for scheduled reboot in the right-side column states that "Cron must be enabled in the management tab."

In my setup , Cron is indeed enabled. Whether it gets enabled automatically when you setup a scheduled reboot, or whether it needs to be enabled separately, I don't know.

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Mon Jun 17, 2019 11:53    Post subject: Reply with quote
Well, back to square one with the scheduled reboot. The setting in Administration/KeepAlive hasn't worked since my most recent upgrade, and the script approach (Commands/Startup) isn't working either.

Not the worst problem I could be having with my router, but it would be great to find a way to get it working reliably once again.

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
rkwood
DD-WRT Novice


Joined: 05 Apr 2018
Posts: 22

PostPosted: Mon Jun 17, 2019 15:34    Post subject: Reply with quote
giles02134, you're not alone. Build r40009 on my WRT32X doesn't allow a scheduled re-boot for me anymore either.

Hopefully this will get fixed soon.
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Mon Jun 17, 2019 16:34    Post subject: Reply with quote
The bizarre thing is that it worked once, and I thought I was home-free. Since that time, no matter what I've tried (changing the time, then rebooting, etc.), nothing works.

Yes--hopefully, this will get addressed in the near-term.

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
rkwood
DD-WRT Novice


Joined: 05 Apr 2018
Posts: 22

PostPosted: Wed Jun 19, 2019 14:36    Post subject: Reply with quote
Good news - r40048 fixed it for me. Scheduled Reboot is now working again. Smile
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Wed Jun 19, 2019 18:29    Post subject: Reply with quote
Hmmm...didn't work for me this morning (3:00a.m.), but I've since changed/saved/changed/rebooted. I'll see if it runs tomorrow morning.
_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Thu Jun 20, 2019 10:13    Post subject: Reply with quote
Third day on this release, and the Scheduled Reboot is still not happening. It's not a big issue, really. However, I'd be grateful if someone could explain to me why it doesn't fire off. If I look in /tmp/cron.d, I see:
    -rw-r--r-- 1 root root 32 Jun 20 05:47 check_ps
    -rw-r--r-- 1 root root 58 Jun 20 05:47 check_schedules

If I cat check_schedules, I see
    0 3 * * * root startservice run_rc_shutdown; /sbin/reboot

So, it seems to me that all the pieces are in place. Why doesn't it run?

Any insights? Thanks!

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
yoyoma2
DD-WRT User


Joined: 24 Sep 2016
Posts: 100

PostPosted: Sun Sep 01, 2019 15:29    Post subject: Reply with quote
I suspect this is a side effect of the cron falling asleep issue. You could give the cron watchdog script workaround a try from this thread.
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 117

PostPosted: Sun Sep 08, 2019 10:45    Post subject: Reply with quote
Thanks very much for the link to that thread. The auto-reboot is working now.
_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r41218 std (10/1/19)
ISP: RCN
NAS: ReadyNas314
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum