New Build 40048: BS 06-16-2019-r40048

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2622
Location: Texas, USA

PostPosted: Sun Jun 16, 2019 18:25    Post subject: New Build 40048: BS 06-16-2019-r40048 Reply with quote
Another day, another build... Wink Check the changelog to see if anything is relevant to you.


Downloads: (if a link doesn't work, try another)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/06-16-2019-r40048/
ftp://ftp.dd-wrt.com/betas/2019/06-16-2019-r40048/
Alternate link: DD-WRT website
Note: to use wget (or curl) for CLI flash (`write {f/w} linux`), change the https to http (or use ftp instead)

Changelogs:
SVN* changelog since last build: 40009
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.2 and newer
2. 'KRACK' vulnerability fixes were completed in r33678 for Broadcom, including k26 (33655) & k24 (33656); use build 33772 or later.
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issues below).
4. Since 39469, udhcpd was removed and replaced with the already present dnsmasq, and PIE qdisc was added for some builds.
5. Policy-Based Routing with SFE enabled was fixed in r39556: 5986 and 5900
6. k2.4 (broadcom/) builds were fixed in 39715 (broken in 39144 through 39654)
7. SFE update (k3.10+ for BCM) was in the 39927 build.


Issues, observations, and/or workarounds reported:
1. Trendnet 81*DRU models are missing factory-to-flash
2. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246
3. WDS does not work on Broadcom ARM devices (only MIPS<->MIPS)
4. K2.6 builds are broken since 38253(?); GUI issues: 6538
5. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
This appears to be fixed for some routers (different kernels, modes, and radios) since build 39508.

Important: if any issues are found, please provide log info (GUI syslog, `dmesg`, `cat /var/log/messages`).
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b]Router/Version: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Mode: [/b]
[b]Status: [/b]

WARNING: This thread is to report on flashing this experimental test build, providing important info for both developers and users. Always state your hardware model, version, mode (e.g. Repeater) and SPECIFIC build (e.g. 33555_NEWD-2_K3.x_mega-nv64k.bin). Please avoid discussions and create a new thread to discuss specific problems or questions, as this thread is for reporting, not support. Posts may be deleted or moved to keep this thread manageable and useful. If you don't understand the risks or what to flash and how, with a means of recovery if it bricks, do NOT flash this experimental test build.
Sponsor
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 297

PostPosted: Sun Jun 16, 2019 20:15    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r40048 std (06/16/19)
Kernel: Linux 4.4.181 #257 SMP PREEMPT Sun Jun 16 09:09:54 CEST 2019 armv7l
Previous: r40009
Mode/Status: Gateway / working
Reset: no
Issues/Errors: Working so far.

Uptime: 42min
Temperatures: CPU 66.9 °C / WL0 47.8 °C / WL1 54.0 °C
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3065
Location: UK, London, just across the river..

PostPosted: Mon Jun 17, 2019 6:33    Post subject: Reply with quote
2.DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246

DNSCrypt v2 is backwards compatible to 1.95
its still working on my R7800 very well...

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 ----DD-WRT 41659 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----DD-WRT 41664 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT)
TP-Link WR1043NDv2 ----Gargoyle OS 1.11.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
2x Netgear R7800 -------DD-WRT 40270M 4.9 Kong (AP,NAT,AD-Blocking,AP&Net Isolation,VLAN's,Firewall,Local DNS,DNSCrypt-proxy v2 x2)
Broadcom
Netgear R7000 -------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
wuruxu
DD-WRT Novice


Joined: 17 Jun 2019
Posts: 15

PostPosted: Mon Jun 17, 2019 11:24    Post subject: Reply with quote
Router/Version: Linksys EA6300 v1/EA6400
Firmware: DD-WRT v3.0-r40048 std (06/16/19)
Kernel: Linux 4.4.181 #257 SMP PREEMPT Sun Jun 16 09:09:54 CEST 2019 armv7l
Previous: DD-WRT v3.0-r39927 std (06/03/19)
Mode/Status: Gateway / working
Reset: no
Issues/Errors: VAP cann't work in this release, but VAP is work well in r39927

Uptime: 42min
wastesubscribe
DD-WRT Novice


Joined: 16 Jun 2019
Posts: 2

PostPosted: Mon Jun 17, 2019 14:05    Post subject: Netgear WNDR4000 Reply with quote
Router/Version: Netgear WNDR4000
File: dd-wrt.v24-40048_NEWD-2_K3.x_mega-nv64k.bin
Kernel: Linux 3.10.108-d8 #24933 Sun Jun 16 16:27:47 CEST 2019 mips
Firmware: DD-WRT v3.0-r40048 mega (06/16/19)
Previous: DD-WRT v24-sp2 (06/07/14) vpnkong - build 22000M
Reset: No
Mode: Gateway/AP with VAPs
Status: Great !!

Uptime 6+ hours
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4345
Location: Netherlands

PostPosted: Mon Jun 17, 2019 15:35    Post subject: Reply with quote
b]Router Model:[/b] Netgear R6400v1

Firmware Version: DD-WRT v3.0-r40048 std (06/16/19)
Kernel Version: Linux 4.4.181 #257 SMP PREEMPT Sun Jun 16 09:09:54 CEST 2019 armv7

Upgraded: from DD-WRT v3.0-r38580M Kong, via GUI
Reset: No, which I would normally do because i am changing from Kong to BS, But I was asked to test SFE and UDP forwarding so just did a dirty upgrade

Status: Up and running 4 hours, basic setup as Gateway, static leases, Advanced routing, Port Forwarding, IPv4, DynDNS, 2.4 GHz and 5 GHz

Errors: No, I upgraded to this version to test UDP forwarding with SFE which was broken on the latest builds.
From limited testing UDP forwarding seems to work with SFE!

Big Thanks to the devs

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135


Last edited by egc on Mon Jun 17, 2019 16:26; edited 1 time in total
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2622
Location: Texas, USA

PostPosted: Mon Jun 17, 2019 16:24    Post subject: Reply with quote
Alozaros wrote:
2.DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246

DNSCrypt v2 is backwards compatible to 1.95
its still working on my R7800 very well...


I think this is a bit confusing. The v2.x dnscrypt-proxy package requires golang to be compiled, as it is no longer written in C like v1.95:

https://svn.dd-wrt.com/ticket/6246 <-- This ticket was closed as 'wontfix' because of the resulting binary size(s).

Now, are you saying you installed dnscrypt-proxy version 2.x via Entware Question /off-topic
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2370
Location: Indy

PostPosted: Mon Jun 17, 2019 16:36    Post subject: Reply with quote
kernel-panic69 wrote:
Alozaros wrote:
DNSCrypt v2 is backwards compatible to 1.95
its still working on my R7800 very well...
Now, are you saying you installed dnscrypt-proxy version 2.x via Entware Question /off-topic
I thought Alozaros meant that v1.95 on his R7800 is able to work with v2 servers. Some clarification would help though. Wink
_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
x64 OPNsense 19.7.7|FT2019.3: EA6900v1.1@1GHz, F7D8302|DD 41596: WNDR4500v2, WNDR4000@533, R6300v1,
E2500, E1500@353, WRT54*@250: GLv1.1 nsg, GSv6 µ, RT-N66U@663
|OEM: WGR614v10@400 -> WNR1000v3 mod
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2622
Location: Texas, USA

PostPosted: Mon Jun 17, 2019 17:04    Post subject: Reply with quote
jwh7 wrote:
kernel-panic69 wrote:
Alozaros wrote:
DNSCrypt v2 is backwards compatible to 1.95
its still working on my R7800 very well...
Now, are you saying you installed dnscrypt-proxy version 2.x via Entware Question /off-topic
I thought Alozaros meant that v1.95 on his R7800 is able to work with v2 servers. Some clarification would help though. Wink


Bingo.
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Mon Jun 17, 2019 17:50    Post subject: Reply with quote
Router/Version: ASUS RT-AC3200
File: asus_rt-ac3200-firmware.trx
Kernel: Linux 4.4.181 #262 SMP PREEMPT Sun Jun 16 09:41:57 CEST 2019 armv7l
Mode: Gateway
Status: Losing my download speed.

Didn't change anything other then flash 40009 to 40048.

Internet speed is 100Mbits down without QoS enabled. With QoS enabled it down to 30-33Mbits used to be fine at around 92-96Mbits. Turn off QoS run fines. Not sure why I am losing so much speed with this build.

Also note - while running speed test and monitoring sirq in ssh, it is hitting 79-89%

Disabling SFE make no difference

_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 297

PostPosted: Mon Jun 17, 2019 20:46    Post subject: Reply with quote
egc wrote:
...upgraded to this version to test UDP forwarding with SFE which was broken on the latest builds.
From limited testing UDP forwarding seems to work with SFE!

Big Thanks to the devs


Hmm, I wonder if this is why connecting to Xbox party chat has been problematic for me since late April after installing r39572 [SFE + PBR fix].

Issue has been: when first connecting, Xbox part chat cycles though the following statuses until things finally connect after about 30 seconds...

Gamertag1 - connected
Gamertag2 - connected

Gamertag1 - connected
Gamertag2 - connecting

Gamertag1 - connecting
Gamertag2 - connecting

Gamertag1 - connected
Gamertag2 - connected
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4345
Location: Netherlands

PostPosted: Mon Jun 17, 2019 21:07    Post subject: Reply with quote
Could well be, UDP forwarding was not broken completely but only when SFE kicks in.

Disabling SFE should cure it.

BS and Quarkysg have been working on it.

This build should be better

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Dr_K
DD-WRT User


Joined: 23 Mar 2018
Posts: 438

PostPosted: Tue Jun 18, 2019 5:03    Post subject: Reply with quote
kernel-panic69 wrote:
jwh7 wrote:
kernel-panic69 wrote:
Alozaros wrote:
DNSCrypt v2 is backwards compatible to 1.95
its still working on my R7800 very well...
Now, are you saying you installed dnscrypt-proxy version 2.x via Entware Question /off-topic
I thought Alozaros meant that v1.95 on his R7800 is able to work with v2 servers. Some clarification would help though. Wink


Bingo.

I believe what he said & what he meant are one & the same...

I also still happily use DNSCrypt...
Most servers I use bark in the log that the server is using version 2.0 of the DNsCrypt protocol every hour when it documents the server certificate re-vallidation.....but all "appears" to be working without issue ¯\_(ツ)_/¯

_________________
Location 1
R6300V2- DD-WRT v3.0-r39345M kongac (04-03-19) Gateway
WNDR3400v1 DD-WRT.v3.0-r35531_mega-nv64k (03/26/18 ) Access Point
WRT160Nv3 DD-WRT ?v3?.0-r35531 mini (03/26/18 ) Access Point
WRT54GSv5 DD-WRT v24-r33555_micro_generic (10/20/17) Repeater
Location 2
R6300V2- DD-WRT v3.0-r39345M kongac (04/03/19) Gateway
R6300V2- DD-WRT v3.0-r39345M kongac (04/03/19) Access Point
WNDR3700v2 DD-WRT v3.0-r35531 std (03/26/18 ) Access Point
E1200 v2 DD-WRT v3.0-r35531 mega-nv64k (03/26/18 ) Gateway(for trivial reasons)
2 devices: SXT 5 ac (mipsbe) RB 6.45.1 (06/27/19) PTP Bridge (0.8km/0.5mi)tx/rx866.6Mbps-1GbpsLAN

Thank You <Kong> & BrainSlayer for ALL that you do also to everyone here that shares their knowledge
parco
DD-WRT User


Joined: 10 Sep 2017
Posts: 100

PostPosted: Tue Jun 18, 2019 6:38    Post subject: Reply with quote
flyzipper wrote:
egc wrote:
...upgraded to this version to test UDP forwarding with SFE which was broken on the latest builds.
From limited testing UDP forwarding seems to work with SFE!

Big Thanks to the devs


Hmm, I wonder if this is why connecting to Xbox party chat has been problematic for me since late April after installing r39572 [SFE + PBR fix].

Issue has been: when first connecting, Xbox part chat cycles though the following statuses until things finally connect after about 30 seconds...

Gamertag1 - connected
Gamertag2 - connected

Gamertag1 - connected
Gamertag2 - connecting

Gamertag1 - connecting
Gamertag2 - connecting

Gamertag1 - connected
Gamertag2 - connected


similar to my case but connecting from my phone instead of xbox
echardcore
DD-WRT Novice


Joined: 06 Aug 2009
Posts: 6

PostPosted: Tue Jun 18, 2019 23:05    Post subject: DHCP Issues Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r40048 std (06/16/19)
Kernel: Linux 4.4.181 #257 SMP PREEMPT Sun Jun 16 09:09:54 CEST 2019 armv7l
Previous: unknown (fairly recent build, this year)
FOUND IT, 38840
Mode/Status: Gateway / working
Reset: nvram erase
Issues/Errors: When I set a static DHCP lease inside/outside the pool and reboot, the DHCP server no longer assigns IPs to clients. I can access everything fine setting a static on clients.

I've done some crazy troubleshooting. Hours worth. Tried the latest Kong build too.

Going to start working backwards until it hopefully works.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum