New BS Build: r40009. (06- 11-2019)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2
Author Message
Eyerex
DD-WRT User


Joined: 11 Feb 2016
Posts: 155
Location: South London

PostPosted: Thu Jun 13, 2019 11:24    Post subject: Reply with quote
Updated over last build with no reset and everything working ok on my Netgear r7800

Big thanks

_________________
| Netgear Nighthawk X4S R7800 | Linksys WRT1900ACS V1 | Huawei Echolife HG612 3B |
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4774
Location: Texas

PostPosted: Thu Jun 13, 2019 21:02    Post subject: Reply with quote
I took the WNDR3700v4 I haven't been using and installed r40009
Reset & reconfig as main router
local DNS
30 static leases
port range forwarding
samba share USB flash drive
isolated guest network -- ath0.1, ath1.1 & VLAN4 port 4 via br1
I just have the one bigscreen VIZO TV wired into port4...well its actually port1 as labeled on the baskasswards netgear router case
other junk on guest net and whomever comes by
QOS HFSC FQ_CODEL
http://www.dslreports.com/speedtest/50822723
and that's while I have Netflix going on the tablet

I am very happy with this Very Happy ---- some previous builds of last few months on the WNDR3700v4 the wireless guest network could
not communicate amongst themselves and since I have chromecast on the 2.4 guest net and I usually control them from tablet on 5GHz guest net so
it was very disappointing...... but r40009 is looky very good to me Wink
labo
DD-WRT Guru


Joined: 30 Jan 2015
Posts: 673
Location: Texas, USA

PostPosted: Fri Jun 14, 2019 11:48    Post subject: Reply with quote
labo wrote:
BrainSlayer wrote:
labo wrote:
There are many changes in Mesh and VHT80+80 modes. Still trying to figure out to make it work.


i tested it with 2 netgear r7800 in vht160 and vht80+80. just do it and it works. if you have a client which isnt capable of doing vht80+80 or vht160 (openwrt doesnt support it. it broken there), then it will not work, but just in vht80.

just ensure to setup the same channel of both sides and the same encryption setup and it works.
if you use openwrt on one side, do not use encryption. openwrt does not support SAE encryption with most algorithms. GCMP etc. is not supported by openwrt.


@BS, Yes I was only testing between two R9000 and 2 R7800 all four in mesh which are all VHT160 and 4x4 streams supported. And NO openwrt.
The only thing I didn't try yet is the RESET. I can try that if its necessary .
And report back

UPDATE: Thanks! BS. Reset fixed the Mesh issues. I'm able to set VHT160 channel 36-64 and 100 - 128 DFS.

UPDATE2: @BS, I found an issue with R9000 Mesh VHT160 mode. It works fine without encryption. But as soon as I enable WPA the Radio shutoff in Mesh mode. Sad

UPDATE3: OK, finally I found the culprit in this build which was responsible Mesh radio shutoff.
I had this option below enabled which was the culprit. Earlier builds were just working fine with this.

802.11r / Fast BSS Transission support

This should be disabled for Mesh VHT160 to work in this build. Hope BS fixes this soon. Still I can't get internet from mesh clients which I will have to figure out.

Also, adding VAP doesn't work (unable to connect to ).


@BS, here are my final findings on latest Mesh commits:

VHT160 mode now works (must disable 802.11r), I tested and works. Unfortunately, I don't get speeds above 600mbps using iperf3. Infact, was getting better results using VHT80.

root@durango-x10:~# iperf3 -c 192.168.1.2 -R
Connecting to host 192.168.1.2, port 5201
Reverse mode, remote host 192.168.1.2 is sending
[ 5] local 192.168.1.9 port 40980 connected to 192.168.1.2 port 5201
[ ID] Interval Transfer Bitrate
[ 5] 0.00-1.00 sec 65.7 MBytes 551 Mbits/sec
[ 5] 1.00-2.00 sec 65.3 MBytes 548 Mbits/sec
[ 5] 2.00-3.00 sec 63.6 MBytes 533 Mbits/sec
[ 5] 3.00-4.00 sec 62.0 MBytes 520 Mbits/sec
[ 5] 4.00-5.00 sec 61.5 MBytes 516 Mbits/sec
[ 5] 5.00-6.00 sec 64.6 MBytes 542 Mbits/sec
[ 5] 6.00-7.00 sec 66.2 MBytes 555 Mbits/sec
[ 5] 7.00-8.00 sec 64.3 MBytes 539 Mbits/sec
[ 5] 8.00-9.00 sec 64.7 MBytes 543 Mbits/sec
[ 5] 9.00-10.00 sec 63.7 MBytes 534 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.04 sec 644 MBytes 538 Mbits/sec 0 sender
[ 5] 0.00-10.00 sec 642 MBytes 538 Mbits/sec receiver

iperf Done.
root@durango-x10:~# iperf3 -c 192.168.1.2
Connecting to host 192.168.1.2, port 5201
[ 5] local 192.168.1.9 port 40984 connected to 192.168.1.2 port 5201
[ ID] Interval Transfer Bitrate Retr Cwnd
[ 5] 0.00-1.00 sec 69.8 MBytes 586 Mbits/sec 0 3.52 MBytes
[ 5] 1.00-2.00 sec 68.8 MBytes 577 Mbits/sec 0 3.52 MBytes
[ 5] 2.00-3.00 sec 70.0 MBytes 587 Mbits/sec 0 3.52 MBytes
[ 5] 3.00-4.00 sec 71.2 MBytes 598 Mbits/sec 0 3.52 MBytes
[ 5] 4.00-5.00 sec 70.0 MBytes 587 Mbits/sec 0 4.15 MBytes
[ 5] 5.00-6.00 sec 68.8 MBytes 577 Mbits/sec 0 4.15 MBytes
[ 5] 6.00-7.00 sec 70.0 MBytes 587 Mbits/sec 0 4.15 MBytes
[ 5] 7.00-8.00 sec 70.0 MBytes 588 Mbits/sec 0 4.15 MBytes
[ 5] 8.00-9.00 sec 71.2 MBytes 598 Mbits/sec 0 4.15 MBytes
[ 5] 9.00-10.00 sec 70.0 MBytes 587 Mbits/sec 0 4.15 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 700 MBytes 587 Mbits/sec 0 sender
[ 5] 0.00-10.04 sec 697 MBytes 582 Mbits/sec

Station dump (on ath0)
inactive time: 390 ms
rx bytes: 1109142927
rx bytes compressed: 0
rx packets: 762527
rx packets compressed: 0
tx bytes: 1134084547
tx bytes compressed: 0
tx packets: 775810
tx packets compressed: 0
tx retries: 0
tx failed: 0
rx drop misc: 33257
signal: -53 [-61, -57, -58] dBm
signal avg: -58 [-69, -63, -58] dBm
Toffset: 18446744072228038471 us
tx bitrate: 1040.0 MBit/s VHT-MCS 5 160MHz short GI VHT-NSS 2
rx bitrate: 1170.0 MBit/s VHT-MCS 6 160MHz short GI VHT-NSS 2
rx duration: 24626404 us
avg ack signal: -62 dBm
expected throughput: 1040.0Mbps
mesh llid: 0
mesh plid: 0
mesh plink: ESTAB
mesh local PS mode: ACTIVE
mesh peer PS mode: ACTIVE
mesh non-peer PS mode: ACTIVE
authorized: yes
authenticated: yes
associated: yes
preamble: long
WMM/WME: yes
MFP: yes
TDLS peer: no
Compression: no
DTIM period: 2
beacon interval:1000
connected time: 3885 seconds
Radio Name:

Issues:
1. Must disable 802.11r.

2. VHT80+80 mode the channels gets disarrayed, for example if I use channel 100 some how it adds channel 42 to the combination instead of susing 100 to 128 range

3. Adding VAP messes up Mesh (Radio channels goes to unknown)

4. Static IP wired clients can't get internet ( DHCP clients work fine)

Thanks for your continued work, appreciate it very much.

_________________
1 X R7800: Main gateway( r39855M kongat (05/25/19)
1 X RAX120 WAP Bridged
1 X R7800 Mesh
2 X R9000 Mesh
1 X R8000: Repeater bridge
1 X R8500: Client bridge (RB doesn't work on R8500)
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 558
Location: Illinois

PostPosted: Mon Jun 17, 2019 14:39    Post subject: Reply with quote
R9000:
Gremlins showed up... 5ghz just stopped working/broadcasting. The gui showed it was working, no device could see 5ghz. Soft reboot, hard reboot, disable/enable radio, nothing worked. Since 40048 was released, I did a facotry reset & upgrade to that firmware and loaded everything fresh again.

Once on 40048, 2.4ghz radio didn't want to broadcast, but it showed as working...I went in wifi settings and played around with the network mode.

Originally-NG mixed, switched to mixed & hit apply, then switched back to NG mixed and hit apply again- Viola- 2.4ghz working again.

I have a cron job to reboot daily...we'll see what happens tomorrow...

_________________
[r9000]BS 41328 (Main Router)
[EA8500]Kong 40270M (Offsite)
[R7800]taking a nap
[WDR3600]BS 36808 (Offsite)


TIPS/TRICKS:

Best QCA Wifi settings to use|Latency tricks|QoS Port priority||NEVER USE MU-MIO

Why to NOT use MU-MIMO||Max Wifi Pwr by Country||MCS Index Speeds||Correct QCA 5Ghz chnls to use||WIFI Chnl Freq WIKI
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum