Port Forward C7000

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Author Message
taylorabc101
DD-WRT Novice


Joined: 29 May 2019
Posts: 9

PostPosted: Thu May 30, 2019 0:36    Post subject: Port Forward C7000 Reply with quote
I have an internal server running openvpn behind my dd-wrt netgear c7000 that works behind my netgear running default firmware. But when I flashed the router to the current dd-wrt release I cannot connect for the life of me. I've port forwarded correctly through the web GUI. That didnt work, so I thought it was an iptables rule issue so I erased NVRam and manually added the rules to port forward but still cant get through. I'm wondering if anyone would be able to help set me straight as im sure im doing something wrong.
Sponsor
taylorabc101
DD-WRT Novice


Joined: 29 May 2019
Posts: 9

PostPosted: Thu May 30, 2019 0:53    Post subject: openVPN Reply with quote
So for openVPN how would I possibly know what port they are coming from? It should be a random high port right? Honestly stared at it for so long didn't even realize it put a zero in there.
taylorabc101
DD-WRT Novice


Joined: 29 May 2019
Posts: 9

PostPosted: Thu May 30, 2019 1:03    Post subject: Reply with quote
I only have one router being the DD-WRT router with the openVPN server behind it. So WAN->DD-WRT(C7000)->openVPN server. I was merely stating that before I flashed the router to DD-wrt I had the service working.
taylorabc101
DD-WRT Novice


Joined: 29 May 2019
Posts: 9

PostPosted: Thu May 30, 2019 1:14    Post subject: Reply with quote
Ah i'm a dumbass I see now that issue, I will for now keep it as 1194 as it will require me to change the openvpn client cert. After adding that I am still unable to complete the connection.
taylorabc101
DD-WRT Novice


Joined: 29 May 2019
Posts: 9

PostPosted: Thu May 30, 2019 1:33    Post subject: Reply with quote
Okay thank you for all of your help. Now im having a TLS Error on the openVPN server so I will go down the path of figuring out why that is now a thing.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 5914
Location: Netherlands

PostPosted: Thu May 30, 2019 6:42    Post subject: Reply with quote
For some builds you had to define the source net.
Normally when empty it defaults to 0.0.0.0/0
Meaning anywhere. But to be sure just fill it in.
The iptables rules you added manually to port forward are wrong. You merely opened the firewall for traffic destined for 192.168.0.199.
That will not work

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum