Not routing traffic over tun0

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions
Author Message
paegus
DD-WRT Novice


Joined: 18 May 2019
Posts: 6

PostPosted: Sat May 18, 2019 10:13    Post subject: Not routing traffic over tun0 Reply with quote
I have installed OpenConnect via Entware-NG and it runs normally, creating a tun0 interface. I can ping, traceroute and ssh to devices on the VPN network from the router's console.

I cannot do this from other machines on the LAN. No traffic is routed over the VPN from any LAN devices.

I have to bounce off the router via...
Code:
ssh -t root@router "ssh user@remote-host"
...which is less than ideal.

Do I need to do something console or UI side to route traffic destined for that domain over the tun0 interface, to that network?

Do I need to craft iptables rules? Can you do this for an entire domain?
Sponsor
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5704
Location: Akershus, Norway

PostPosted: Sat May 18, 2019 11:40    Post subject: Reply with quote
What is the VPN tunnel connected to?

Is it site-site or a site-Internet(commercial provider)?

The network behind the server needs a route to the network used on your LAN:

PS. VPN is discussed in the Advanced Networking Forum.
paegus
DD-WRT Novice


Joined: 18 May 2019
Posts: 6

PostPosted: Sun May 19, 2019 8:31    Post subject: Reply with quote
Per Yngve Berg wrote:
PS. VPN is discussed in the Advanced Networking Forum.


True that. Continued here
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum