TP-Link WR1043ND V1 failed installation

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
fn0rd
DD-WRT Novice


Joined: 16 Oct 2011
Posts: 23

PostPosted: Thu Nov 01, 2018 17:27    Post subject: TP-Link WR1043ND V1 failed installation Reply with quote
Hi all,
I have issues with flashing my TP-Link WR1043ND V1.

What I did so far:
1. Flashed latest TP-Link firmware TL-WR1043ND_V1_140319
https://www.tp-link.com/de/download/TL-WR1043ND_V1.html#Firmware
2. Flashed DDWRT firmware, mentioned here:
https://dd-wrt.com/support/router-database/

TP-Link WR1043N(D) 1.x
Router details

Chipset AR9132
RAM 32 MB
FLASH 8 MB
Supported by v.30 (beta) Build: 37305

After the reboot the Router seems not coming up.
Power LED is on.
LAN1-4 and WAN LEDs are flashing.

LEDs at the Ethernet Cable are going on every few seconds for 1 second.

Hard reset did not change anything after several attempts.

Any ideas?

Thanks in advance



UPDATE:
Might be known problem?
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1140847#1140847
Sponsor
Damian0934850
DD-WRT Novice


Joined: 30 Apr 2019
Posts: 1

PostPosted: Tue Apr 30, 2019 11:32    Post subject: Reply with quote
I had the same problem with my WR1043N v1, every available DD-WRT from database was killing router but have successfully restored original TP-LINK firmware and router is working. Do you still need help with it?
assyriska_ff
DD-WRT Novice


Joined: 16 Mar 2012
Posts: 9

PostPosted: Wed May 01, 2019 8:53    Post subject: Reply with quote
Yep problem was reported long time ago, but nothing changed. The last firmware which runs on our V1 is:
v3.0-r36079

any newer fw will result in a bootloop.
adent
DD-WRT Novice


Joined: 06 Feb 2018
Posts: 31
Location: Vienna, Austria

PostPosted: Wed May 01, 2019 15:44    Post subject: Reply with quote
r36106 works flawlessly on my v1.8 device.
Vico56
DD-WRT Novice


Joined: 31 Mar 2016
Posts: 27

PostPosted: Thu May 02, 2019 16:58    Post subject: Reply with quote
assyriska_ff wrote:
Yep problem was reported long time ago, but nothing changed. The last firmware which runs on our V1 is:
v3.0-r36079

any newer fw will result in a bootloop.

The bootloop issue is already solved (see here). My device is currently running with 03-27-2019-r39296.
fn0rd
DD-WRT Novice


Joined: 16 Oct 2011
Posts: 23

PostPosted: Sat May 04, 2019 8:43    Post subject: Reply with quote
Motivated by replies to this thread I gave later versions a try, but unfortunately the firmware is not getting updated.
I upload via the webgui on Firmware: DD-WRT v3.0-r36104 std (06/10/1Cool, but nothing changes after the restart.

Tried this one, which is mentioned in the post above:
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/03-26-2019-r39290/tplink_tl-wr1043nd/tl-wr1043nd-webflash.bin

And this one:
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/05-03-2019-r39715/tplink_tl-wr1043nd/tl-wr1043nd-webflash.bin
adent
DD-WRT Novice


Joined: 06 Feb 2018
Posts: 31
Location: Vienna, Austria

PostPosted: Sat May 04, 2019 10:25    Post subject: Reply with quote
I upgraded my v1.8 device to r39290 yesterday. Updating via gui did not work for me, so I once more used the method referred to in

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=311642&highlight=1043nd
fn0rd
DD-WRT Novice


Joined: 16 Oct 2011
Posts: 23

PostPosted: Sun May 05, 2019 14:52    Post subject: Reply with quote
I followed the steps, now my AP is not working at all anymore (only power LED shows up).

I assume i have to flash it again with JTAG but too much effort now to open the box and everything.
adent
DD-WRT Novice


Joined: 06 Feb 2018
Posts: 31
Location: Vienna, Austria

PostPosted: Sun May 05, 2019 19:43    Post subject: Reply with quote
Did you dump the correct /dev/mtdblockX? In the example it is /dev/mtdblock6 but that may differ. As Alozaros stated in his initial posting:
Quote:
"my unit is Tplink-WR1043NDv2 with 8MB flash size chip and those
outputs are related to it, ..."

When dumping and/or flashing you always have to be careful and double or triple check every step before executing it.
fn0rd
DD-WRT Novice


Joined: 16 Oct 2011
Posts: 23

PostPosted: Sun May 05, 2019 20:32    Post subject: Reply with quote
Most likely this is the issue. Only validated the flash size.
Vico56
DD-WRT Novice


Joined: 31 Mar 2016
Posts: 27

PostPosted: Sun May 05, 2019 20:55    Post subject: Reply with quote
I always use the TFTP method and revert to the stock firmware first. From there I then flash the latest "factory-to-ddwrt.bin" file (backup settings before and restore after).
Rocketboy235
DD-WRT User


Joined: 14 Oct 2016
Posts: 52
Location: United States

PostPosted: Sun Sep 15, 2019 15:35    Post subject: Reply with quote
Hello,

So r39290 (3/26/2019) works fine but have to first revert back to latest stock firmware before doing a TFTP flash of factory-to-ddwrt.bin (no web gui flash whatsoever)?

I wonder if this could mean that even newer builds work fine but updating from an older version of DD-WRT to a newer version via web gui is out of the question.

I'm currently running r33607 (10/25/2017) and it might be time do update the firmware to stay up to date (in case of any security issues in the past 2 years after KRACK). Only thing that is kind of scaring me is seeing a couple threads where people have been running into flashing failures when trying to update their DD-WRT to a newer version from 2018/2019.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum