R7000 and IPv6

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... , 32, 33, 34  Next
Author Message
hanskloss
DD-WRT User


Joined: 30 May 2010
Posts: 98

PostPosted: Thu Sep 07, 2017 20:08    Post subject: Reply with quote
Recently my provider switched from IPv4 to native IPv6 Dual Stack lite.
I get assigned IPv6 address /56 using DHCPv6 Prefix Delegation mechanism + ATFR name for IPv4


Does anyone have experience setting up Dual Stack using dd-wrt on R7000?

ISP requires some specific options, otherwise will not respond to the query:

send dhcp6.client-id
send dhcp6.auth
send dhcp6.user-class
send dhcp6.vendor-class
also request dhcp6.vendor-opts, dhcp6.auth, dhcp6.aftr-name;

Are these options supported by the current client used by dd-wrt? I have succesfully used isc dhclient to get a DHCPv6 response on another OS.

_________________
Asus RT-AC66R Target:brcm47xx SubTarget:mips74k Packages:mipsel_74kc
Netgear R7000 Target:bcm53xx Packages:arm_cortex-a9
Sponsor
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1405
Location: Canada

PostPosted: Sun Dec 31, 2017 18:58    Post subject: Reply with quote
Solution for IPv6 dropping Default Route
_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway WiFi 3xVPN - KONGAT 39855M
E3000 - Gateway Wired IPTV - DDWRT r35531 Mega
WHR-HP-G54 - Internal Routing - DDWRT r35531 std-special

______________________
Off Site 1

R7000 - Gateway & WiFi & VPN - KONGAC 39855M
WRT610Nv1 - Repeater Bridge - DDWRT r33679 Mega K2.4

__________________________
Off Site 2

2x R7000 - Data Gateway, WiFi & IPTV WiFi, PVR Blocker- KONGAC 39855M

__________________
YAMon 3.4 | Ad-Blocking for DD-WRT | DNSCrypt-Proxy V2
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1405
Location: Canada

PostPosted: Wed Oct 17, 2018 21:57    Post subject: Reply with quote
Ran into IPv6 issues...

With my Telus ISP I recently upgraded my services to include TV. Their OptikTV Boxes connect either Ethernet of Wireless. I have both OptikTV boxes connected via etherent going through an number of Netgear Smart-Plus Switches (layer-2). These OptikTV boxes support 4K streaming and was having stuttering issues with only one 4K stream. So I ended up tweaking the network switches leaving the the QoS set to 802.1p and IGMP tweaks. Now I can stream three 4K streams no problem (view 2x 4K and record HD, ISP has a limit of only two 4K stream with HD/SD or 5 HD streams) all was good util a couple days ago I noticed that no devices was getting IPv6 Internet access. Long story short, these layer-2 Smart-Plus switches do not support IPv6 so Enabling "Block Unknown Multicast Addresses" would break IPv6, so disabling it, fixed it.

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway WiFi 3xVPN - KONGAT 39855M
E3000 - Gateway Wired IPTV - DDWRT r35531 Mega
WHR-HP-G54 - Internal Routing - DDWRT r35531 std-special

______________________
Off Site 1

R7000 - Gateway & WiFi & VPN - KONGAC 39855M
WRT610Nv1 - Repeater Bridge - DDWRT r33679 Mega K2.4

__________________________
Off Site 2

2x R7000 - Data Gateway, WiFi & IPTV WiFi, PVR Blocker- KONGAC 39855M

__________________
YAMon 3.4 | Ad-Blocking for DD-WRT | DNSCrypt-Proxy V2
nihilt_
DD-WRT Novice


Joined: 25 Jun 2017
Posts: 6

PostPosted: Fri Apr 19, 2019 13:22    Post subject: Reply with quote
Followed this guide https://rsalveti.wordpress.com/2016/07/27/netgear-r7000-dd-wrt-ipv6-and-the-lack-of-a-stable-gateway/ and it worked fine for two days without the need to use rdisc6 workaround...but ICMP started failing 17/20 http://ipv6-test.com/
Tried OPKG repositories but rdisc6 is missing. Also tried unchecking Multicast filtering under FW.

@JAMESMTL is there any other solution than rdisc6?

Kong's r39345M R6300v2


Code:

DHCPv6 with Prefix Delegation
Prefix Lenght: 64
MTU: 1452
all other options disabled.

DNSMasq:
conf-file=/jffs/dnsmasq/mpdomains
addn-hosts=/jffs/dnsmasq/mphosts
domain-needed
bogus-priv
no-resolv
no-negcache
server=1.0.0.1
server=1.1.1.1
server=2606:4700:4700::1001
server=2606:4700:4700::1111
dhcp-range=br0,::1000,::FFFF,constructor:br0,ra-stateless,12h
ra-param=br0,10,300
enable-ra
quiet-ra
quiet-dhcp
quiet-dhcp6


Code:

Apr 18 13:23:14 DD-WRT daemon.warn dnsmasq[3348]: warning: ignoring resolv-file flag because no-resolv is set
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq-dhcp[3348]: DHCP, IP range XXX.XXX.X.100 -- XXX.XXX.X.149, lease time 1d
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq-dhcp[3348]: DHCPv6 stateless on br0
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq-dhcp[3348]: router advertisement on br0
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq-dhcp[3348]: DHCPv6 stateless on 2804:zxx:xxxx:xxxx::, constructed for br0
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq-dhcp[3348]: router advertisement on 2804:zxx:xxxx:xxxx::, constructed for br0
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq-dhcp[3348]: IPv6 router advertisement enabled
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq[3348]: using nameserver 2606:4700:4700::1111#53
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq[3348]: using nameserver 2606:4700:4700::1001#53
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq[3348]: using nameserver 1.1.1.1#53
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq[3348]: using nameserver 1.0.0.1#53
Apr 18 13:23:14 DD-WRT user.info : dnsmasq : daemon successfully started
Apr 18 13:23:14 DD-WRT daemon.info dnsmasq[3348]: read /etc/hosts - 2 addresses
Apr 18 13:23:14 DD-WRT user.info : wland : daemon successfully stopped
Apr 18 13:23:14 DD-WRT user.info : wland : daemon successfully started
Apr 18 13:23:14 DD-WRT user.info : wan : WAN is up. IP: 179.XXX.XXX.XXX
Apr 18 13:23:14 DD-WRT user.info : igmprt : successfully started
Apr 18 13:23:14 DD-WRT user.info : process_monitor : daemon successfully stopped
Apr 18 13:23:14 DD-WRT user.info : process_monitor : successfully started
Apr 18 13:23:15 DD-WRT user.info : vpn modules : vpn modules successfully unloaded
Apr 18 13:23:15 DD-WRT user.info : vpn modules : nf_conntrack_proto_gre successfully loaded
Apr 18 13:23:15 DD-WRT user.info : vpn modules : nf_nat_proto_gre successfully loaded
Apr 18 13:23:15 DD-WRT user.info : vpn modules : nf_conntrack_pptp successfully loaded
Apr 18 13:23:15 DD-WRT user.info : vpn modules : nf_nat_pptp successfully loaded
Apr 18 13:23:19 DD-WRT daemon.err ntpclient[3367]: Failed resolving address to hostname br.pool.ntp.org: Try again
Apr 18 13:23:19 DD-WRT daemon.err ntpclient[3367]: Failed resolving server br.pool.ntp.org: Network is down
Apr 18 13:23:19 DD-WRT daemon.err process_monitor[3364]: cyclic NTP Update failed (servers br.pool.ntp.org)
Apr 18 13:23:19 DD-WRT daemon.err process_monitor[3364]: Last update failed, we need to re-update after 30 seconds
Apr 18 13:23:19 DD-WRT daemon.debug process_monitor[3364]: We need to re-update after 3600 seconds
Apr 18 13:23:19 DD-WRT daemon.info process_monitor[3364]: process_monitor : set timer: 3600 seconds, callback: ntp_main()
Apr 18 13:23:21 DD-WRT daemon.info dnsmasq[3348]: read /jffs/dnsmasq/mphosts - 347606 addresses

Code:

root@DD-WRT:~# ip -6 addr show
1: lo: <LOOPBACK,MULTICAST,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link
       valid_lft forever preferred_lft forever
4: vlan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link
       valid_lft forever preferred_lft forever
5: vlan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link
       valid_lft forever preferred_lft forever
6: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link
       valid_lft forever preferred_lft forever
7: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link
       valid_lft forever preferred_lft forever
10: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2804:XXXX:XXXX:XXXX:XXXX:0/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link
       valid_lft forever preferred_lft forever

root@DD-WRT:~# ip -6 route
XXXX:XXXX:XXXX:XXXX::/64 dev br0  metric 256
fe80::/64 dev eth0  metric 256
fe80::/64 dev br0  metric 256
fe80::/64 dev vlan1  metric 256
fe80::/64 dev eth1  metric 256
fe80::/64 dev eth2  metric 256
fe80::/64 dev vlan2  metric 256
default via fe80::XXXX:XXXX:XXXX:XXXX dev vlan2  metric 1024  expires 1798sec
unreachable default dev lo  metric -1  error -101
ff00::/8 dev eth0  metric 256
ff00::/8 dev br0  metric 256
ff00::/8 dev vlan1  metric 256
ff00::/8 dev eth1  metric 256
ff00::/8 dev eth2  metric 256
ff00::/8 dev vlan2  metric 256
unreachable default dev lo  metric -1  error -101
root@DD-WRT:~# ping6 2001:4860:4860::8888
PING 2001:4860:4860::8888 (2001:4860:4860::8888): 56 data bytes
64 bytes from 2001:4860:4860::8888: seq=0 ttl=59 time=10.660 ms
64 bytes from 2001:4860:4860::8888: seq=1 ttl=59 time=9.954 ms
64 bytes from 2001:4860:4860::8888: seq=2 ttl=59 time=9.764 ms
64 bytes from 2001:4860:4860::8888: seq=3 ttl=59 time=10.297 ms
64 bytes from 2001:4860:4860::8888: seq=4 ttl=59 time=11.033 ms
64 bytes from 2001:4860:4860::8888: seq=5 ttl=59 time=9.541 ms
64 bytes from 2001:4860:4860::8888: seq=6 ttl=59 time=9.732 ms
^C
--- 2001:4860:4860::8888 ping statistics ---
7 packets transmitted, 7 packets received, 0% packet loss
round-trip min/avg/max = 9.541/10.140/11.033 ms
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 297

PostPosted: Sat Apr 20, 2019 21:31    Post subject: Reply with quote
nihilt_ wrote:
Followed this guide https://rsalveti.wordpress.com/2016/07/27/netgear-r7000-dd-wrt-ipv6-and-the-lack-of-a-stable-gateway/ and it worked fine for two days without the need to use rdisc6 workaround...but ICMP started failing 17/20 http://ipv6-test.com/


My usual 19/20 test result started returning 17/20 on my Windows 10 PC when I upgraded to r39572 (ICMP not tested). Disabling the ICMPv6 rule on the Windows 10 firewall caused ICMP not tested to change to ICMP filtered, but simply re-enabling the same firewall rule got me back to 19/20 with no changes to the router.
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Fri Apr 26, 2019 17:37    Post subject: Reply with quote
Looking for help to delegate HE Tunnel /48 into multiple VLANs.

I first tried using DNSMASQ to distribute the /48 I asked for from HE, that failed.

My DNSMASQ:
Code:

interface=br0,br1
enable-ra
ra-param=br0,10,300
ra-param=br1,10,300
dhcp-range=2001:470:f3xx::2,2001:470:f3xx::ffff,constructor:br0,ra-names,64,5m
dhcp-range=2001:470:f3xx:1::2,2001:470:f3xx:1::ffff,constructor:br1,ra-names,64,5m
dhcp-option=option6:br0,dns-server,[::]
dhcp-option=option6:br0,domain-search,main.local
dhcp-option=option6:br1,dns-server,[2620:119:35::35],[2620:119:53::53]
dhcp-option=option6:br1,ntp-server,[2610:20:6f96:96::4]
dhcp-option=option6:br1,domain-search,guest.local



Then I tried using this guide

https://wiki.dd-wrt.com/wiki/index.php/IPv6,_6in4_tunnel_-_GUI_only via dhcp6s & radvd, which gives me the ip6v subnet but It won't route.

dhcp6s:
Code:
option domain-name-servers 2620:0:ccc::2 2620:0:ccd::2;
option refreshtime 900;
interface br0 {
address-pool pool1 3600;
};
pool pool1 {
range 2001:470:fxxx:1::1 to 2001:470:fxxx:1::ffff;
# line above is Assigned/Routed Prefix ::1 to ::ffff
};


radvd:
Code:
interface br0
{
AdvSendAdvert on;
AdvManagedFlag off;
AdvOtherConfigFlag on;
AdvReachableTime 0;
AdvRetransTimer 0;
AdvCurHopLimit 64;
AdvHomeAgentFlag off;
AdvDefaultPreference medium;
AdvSourceLLAddress on;
AdvDefaultLifetime 900;
AdvLinkMTU 1428; # MTU of WAN interface - 20
prefix  2001:470:fxxx:1::/64 { #Assigned/Routed Prefix
AdvValidLifetime 86400;
AdvPreferredLifetime 14400;
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
};


Here is the outputs of ip for addr:
Code:
13: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2001:470:fxxx::/48 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::ae9e:17ff:fea9:c1f4/64 scope link

21: ip6tun@NONE: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1480 state UNKNOWN qlen 1
    inet6 2001:470:c:1xxx::2/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::adc4:dd63/64 scope link
       valid_lft forever preferred_lft forever


Here is the output of ip for route:
Code:

root@ddwrt-ac3200:~# ip -6 route list
2001:470:c:1xxx::/64 dev ip6tun  metric 1024
2001:470:fxxx::/48 dev br0  metric 256
2000::/3 dev ip6tun  metric 1024


so br0 does have the /48 that was assigned to me by HE and the route list looks right.

I can route/ping from the DDWRT router. Local Clients get correct assigned /64 addresses. But I can't route from any of the LAN clients


Any help would be appreciated

NOTE: I haven't added any br1 because I was still testing to get br0 working

_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5219
Location: Akershus, Norway

PostPosted: Fri Apr 26, 2019 20:17    Post subject: Reply with quote
This is how you divide the prefix.

DHCP6C Custom:

interface eth0 {
send ia-pd 0;
send rapid-commit;
request domain-name-servers;
script "/sbin/dhcp6c-state";
};
id-assoc pd 0 {
prefix ::/48 infinity;
prefix-interface br0 {
sla-id 0;
sla-len 16;
};
prefix-interface br1 {
sla-id 1;
sla-len 16;
};
prefix-interface eth1.3 {
sla-id 2;
sla-len 16;
};
};
id-assoc na 0 { };
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Fri Apr 26, 2019 22:11    Post subject: Reply with quote
Per Yngve Berg wrote:
This is how you divide the prefix.

DHCP6C Custom:

interface eth0 {
send ia-pd 0;
send rapid-commit;
request domain-name-servers;
script "/sbin/dhcp6c-state";
};
id-assoc pd 0 {
prefix ::/48 infinity;
prefix-interface br0 {
sla-id 0;
sla-len 16;
};
prefix-interface br1 {
sla-id 1;
sla-len 16;
};
prefix-interface eth1.3 {
sla-id 2;
sla-len 16;
};
};
id-assoc na 0 { };


This will work with Hurricane Electric Tunnel?

Even if it did, how can I control the IPv6 Scope. I got assigned 2001:470:f3xx::/48 from HE.

But I want to SPECIFICALLY use 2001:470:f3xx:1::/64, 2001:470:f3xx:2::/64, and so on. Not whatever it decides it wants to use after 2001:470:f3xx::/48

_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5219
Location: Akershus, Norway

PostPosted: Sat Apr 27, 2019 6:35    Post subject: Reply with quote
Never used a tunnel.

The slaid0, slaid1 is where you delegate to interfsces.
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Mon Apr 29, 2019 19:53    Post subject: Reply with quote
I am using this for dhcp6s custom:

Code:

interface vlan2 {
send ia-pd 0;
send rapid-commit;
request domain-name-servers;
script "/sbin/dhcp6c-state";
};
id-assoc pd 0 {
prefix ::/48 infinity;
prefix-interface br0 {
sla-id 0;
sla-len 16;
};
prefix-interface br1 {
sla-id 1;
sla-len 16;
};
};
id-assoc na 0 { };


and this for radvd.conf custom:
Code:

interface br0
{
AdvSendAdvert on;
AdvManagedFlag off;
AdvOtherConfigFlag on;
AdvReachableTime 0;
AdvRetransTimer 0;
AdvCurHopLimit 64;
AdvHomeAgentFlag off;
AdvDefaultPreference medium;
AdvSourceLLAddress on;
AdvDefaultLifetime 900;
AdvLinkMTU 1428; # MTU of WAN interface - 20
prefix  2001:470:fxxx::/64 { #Assigned/Routed Prefix
AdvValidLifetime 86400;
AdvPreferredLifetime 14400;
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
};
interface br1
{
AdvSendAdvert on;
AdvManagedFlag off;
AdvOtherConfigFlag on;
AdvReachableTime 0;
AdvRetransTimer 0;
AdvCurHopLimit 64;
AdvHomeAgentFlag off;
AdvDefaultPreference medium;
AdvSourceLLAddress on;
AdvDefaultLifetime 900;
AdvLinkMTU 1428; # MTU of WAN interface - 20
prefix  2001:470:fxxx:1::/64 { #Assigned/Routed Prefix
AdvValidLifetime 86400;
AdvPreferredLifetime 14400;
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
};


still the same results

I get the RIGHT subnet assignment IPs but i get NO routes

Question I wonder... if I should be sending that to the ip6tun interface and not the vlan2 Question

****UPDATE: Just tried to turn off radvd and doesn't do anything different

_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Tue Apr 30, 2019 16:36    Post subject: Reply with quote
according to this ddwrt wiki here
https://wiki.dd-wrt.com/wiki/index.php/IPv6,_6in4_tunnel_-_GUI_only

Quote:

If ipv6 only works on router
It seems that the routing is not correctly created when using 6in4.
If you log into the router and pinging ipv6.google.com works but not on other computers in LAN.
Then try run this commands to add routing:
Code:
ip -6 addr add [Assigned / Routed Prefix] dev br0
 ip -6 ro add default via [Tunnel Client IPv6 Address] dev ip6tun

If it works now you can add those lines to startup script under Administration -> Save Firewall.


But when I do that I get this....

Code:
root@ddwrt-ac3200:~# ip -6 addr add 2001:470:fxxx::/48 dev br0
ip: RTNETLINK answers: File exists
root@ddwrt-ac3200:~# ip -6 r add default 2001:470:c:1xxx::2/64 dev ip6tun
ip: either "to" is duplicate, or "2001:470:c:1xxx::2/64" is garbage


which leave me to think I have done everything by that WIKI guide.

How can I contact the author of that guide?

_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5219
Location: Akershus, Norway

PostPosted: Tue Apr 30, 2019 17:48    Post subject: Reply with quote
root@ddwrt-ac3200:~# ip -6 addr add 2001:470:fxxx::/48 dev br0


br0 shall have the first /64 block of the /48 prefix
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Tue Apr 30, 2019 19:56    Post subject: Reply with quote
Per Yngve Berg wrote:
root@ddwrt-ac3200:~# ip -6 addr add 2001:470:fxxx::/48 dev br0


br0 shall have the first /64 block of the /48 prefix


okay so I had to do a
Code:
ip -6 addr del 2001:470:fxxx::/48 dev br0

then it would allow me to add
Code:
ip -6 addr add 2001:470:fxxx::/64 dev br0
ip -6 addr add 2001:470:fxxx:1::/64 dev br1


I am also getting an error when I execute this line as recommend by the DDWRT WIKI:

Code:
root@ddwrt-ac3200:~# ip -6 r add default via 2001:470:c:1xxx::2/64 dev ip6tun
ip: an inet address is expected rather than "2001:470:c:1xxx::2/64"


not sure if this has anything to do with it either from listing the ip route
Code:
unreachable default dev lo  metric -1  error -101


Here are the result:
Code:
13: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2001:470:fxxx::/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::ae9e:17ff:fea9:c1f4/64 scope link
       valid_lft forever preferred_lft forever
14: br1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2001:470:fxxx:1::/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::ac62:3dff:fe3c:2246/64 scope link
       valid_lft forever preferred_lft forever



As good as those outputs looks. My LAN clients STILL can't access anything via IPv6 route. either way with 2001:470:fxxx:1::/64 or 2001:470:fxxx:1::/48 at br0. Nothing gets through... nothing gets through at br1 either.


Just incase I missed something:


_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5219
Location: Akershus, Norway

PostPosted: Wed May 01, 2019 7:45    Post subject: Reply with quote
Quote:
ip -6 addr add 2001:470:fxxx::/64 dev br0
ip -6 addr add 2001:470:fxxx:1::/64 dev br1


You are missing the host portion of the address.


Code:

ip -6 addr add 2001:470:fxxx::1/64 dev br0
ip -6 addr add 2001:470:fxxx:1::1/64 dev br1
mbze430
DD-WRT User


Joined: 14 May 2012
Posts: 239

PostPosted: Wed May 01, 2019 16:31    Post subject: Reply with quote
Per Yngve Berg wrote:
Quote:
ip -6 addr add 2001:470:fxxx::/64 dev br0
ip -6 addr add 2001:470:fxxx:1::/64 dev br1


You are missing the host portion of the address.


Code:

ip -6 addr add 2001:470:fxxx::1/64 dev br0
ip -6 addr add 2001:470:fxxx:1::1/64 dev br1


I added the 'host' address but same.. still can't reach out beyond WAN.

Code:

14: br1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2001:470:fxxx:2::/64 scope global
       valid_lft forever preferred_lft forever
    inet6 2001:470:fxxx:2::1/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::ac62:3dff:fe3c:2246/64 scope link
       valid_lft forever preferred_lft forever


I tried it with and without 2001:470:fxxx:2::/64

I feel like it has to do with the routing. its like it doesn't know it needs to go through interface 'ip6tun'

Code:

2001:470:c:1xxx::/64 dev ip6tun  metric 1024
2001:470:fxxx:2::/64 dev br1  metric 256
2001:470:fxxx::/48 dev br0  metric 256
2000::/3 dev ip6tun  metric 1024
fe80::/64 dev eth0  metric 256
fe80::/64 dev vlan6  metric 256
fe80::/64 dev br1  metric 256
fe80::/64 dev vlan1  metric 256
fe80::/64 dev eth1  metric 256
fe80::/64 dev eth2  metric 256
fe80::/64 dev eth3  metric 256
fe80::/64 dev vlan3  metric 256
fe80::/64 dev vlan2  metric 256
fe80::/64 dev ip6tun  metric 256
fe80::/64 dev wl0.1  metric 256
fe80::/64 dev wl1.1  metric 256
fe80::/64 dev br0  metric 256
unreachable default dev lo  metric -1  error -101
ff00::/8 dev eth0  metric 256
ff00::/8 dev vlan6  metric 256
ff00::/8 dev br1  metric 256
ff00::/8 dev vlan1  metric 256
ff00::/8 dev eth1  metric 256
ff00::/8 dev eth2  metric 256
ff00::/8 dev eth3  metric 256
ff00::/8 dev vlan3  metric 256
ff00::/8 dev vlan2  metric 256
ff00::/8 dev br0  metric 256
ff00::/8 dev ip6tun  metric 256
ff00::/8 dev wl0.1  metric 256
ff00::/8 dev wl1.1  metric 256
unreachable default dev lo  metric -1  error -101



I dont see a 'default via'. When I checked my AC5300 at home running merlin, I do see a 'direct via'. But on the DDWRT I can't add the 'default via' as suggested in the DDWRT HE Wiki here:
https://wiki.dd-wrt.com/wiki/index.php/IPv6,_6in4_tunnel_-_GUI_only

Code:

root@ddwrt-ac3200:~# ip -6 route add default via  2001:470:c:1xxx::2/64 dev ip6tun
ip: an inet address is expected rather than "2001:470:c:1xxx::2/64"
root@ddwrt-ac3200:~# ip -6 route add 2001:470:fxxx:2::/64 via 2001:470:c:1xxx::2/64 dev ip6tun
ip: an inet address is expected rather than "2001:470:c:1xxx::2/64"
root@ddwrt-ac3200:~# ip -6 route add 2001:470:fxxx:2::1/64 via 2001:470:c:1xxx::2/64 dev ip6tun
ip: an inet address is expected rather than "2001:470:c:1xxx::2/64"
root@ddwrt-ac3200:~# ip -6 route add 2001:470:fxxx:2::1 via 2001:470:c:1xxx::2/64 dev ip6tun
ip: an inet address is expected rather than "2001:470:c:1xxx::2/64"
root@ddwrt-ac3200:~# ip -6 route add 2001:470:fxxx:2::1 via 2001:470:c:103f::2 dev ip6tun
ip: RTNETLINK answers: Invalid argument
root@ddwrt-ac3200:~# ip -6 route add 2001:470:fxxx:2::/64 via 2001:470:c:103f::2 dev ip6tun
ip: RTNETLINK answers: Invalid argument
root@ddwrt-ac3200:~# ip -6 route add 2001:470:fxxx:2::1 via 2001:470:c:103f::2 dev ip6tun
ip: RTNETLINK answers: Invalid argument
root@ddwrt-ac3200:~# ip -6 route add default via 2001:470:c:1xxx::2 dev ip6tun
ip: RTNETLINK answers: Invalid argument

_________________
ASUS RT-AC3200 - Deployed Client's site
ASUS RT-AC5200 - Merlin
ASUS RT-AX88U - Merlin


Last edited by mbze430 on Wed May 01, 2019 19:11; edited 1 time in total
Goto page Previous  1, 2, 3 ... , 32, 33, 34  Next Display posts from previous:    Page 33 of 34
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum